Symptoms

Consider the following scenario:

  • You start Windows Media Player 12 on a computer that is running Windows 7.

  • In Windows 7, you set the AutoPlay settings for an Audio CD to Take no action. To do this, click Start, click Control Panel, click Hardware and Sound, and then click AutoPlay.

  • You play a video in Windows Media Player.

  • When the video is playing in Windows Media Player, you insert an Audio CD.


In this scenario, Windows Media Player stops playing the video and plays the Audio CD.

Workaround

To work around this behavior, follow these steps:

  1. In Windows 7, click Start, click Control Panel, click Hardware and Sound, and then click AutoPlay.

  2. In the Audio CD box, select Ask me every time, and then click Save.

  3. Insert an Audio CD.

  4. In the AutoPlay dialog box, click to select the Always do this for Audio CDs check box, and then click View more AutoPlay options in Control Panel.

  5. In the Audio CD box, select Take no action, and then click Save.

  6. Close the AutoPlay dialog box.


More Information

To determine the version of Windows Media Player that is installed on the Windows7-based computer, follow these steps:

  1. Start Windows Media Player. To do this, click Start, type media player in the Search programs and files box, and then press ENTER.

  2. Click Organize, point to Layout, and then click Show menu bar.

  3. Click Help, and then click About Windows Media Player.


References

For more information, visit the following Microsoft websites:

Media Player 12 behavior when inserting audio CD

How to disable AutoPlay in Windows Media Player, normally play FLAC and watch AVI with two or more audio streams

Feedback on Windows Media Player 12

Windows 7 Media Player interrupts playback to change media when disc inserted


Need more help?

Expand your skills
Explore Training
Get new features first
Join Microsoft Insiders

Was this information helpful?

What affected your experience?

Thank you for your feedback!

×