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Symptoms

When you try to install Business Portal in Microsoft Dynamics GP, in Microsoft Business Solutions - Great Plains, in Microsoft Dynamics SL, or in Microsoft Business Solutions - Solomon, the installation is not successful. Additionally, you receive an error message that refers to the MbfPackager.Import.NoMerge.Common.xml file. The MbfPackager.Import.NoMerge.Common.xml file contains the following error message:

Exception: {System.Exception} LoadByObject could not force a web part upgrade. Inner Exception: {System.Net.WebException} The remote server returned an error: (404) Not Found.

Cause

This problem may occur when you restore the system database and the company database to a new server. However, you do not restore the Microsoft Windows SharePoint Services (WSS) content database in which Business Portal was previously installed.

Note If you are using Microsoft Dynamics GP, the system database is named DYNAMICS.

Resolution

To resolve this problem, restore the original SharePoint Services content database, and then remove the new SharePoint Services content database. To do this, follow these steps.

Note The original SharePoint Services content database contains Business Portal objects.

  1. Make sure that the original configuration database, the new configuration database, and the content database display the same version information. To do this, follow these steps:

    1. Verify the version information for the configuration database. To do this, run the following script.

      Select SchemaVersion from Globals
    2. Verify the version information for the content database. To do this, run the following script.

      Select * from SystemVersion
  2. Make sure that the database owner of the original content database on the original computer that is running Microsoft SQL Server is the same database owner on the new computer that is running SQL Server after you restore the content database. To do this, follow these steps:

    1. Verify the database owner on the original computer. To do this, run the following script.

      sp_helpdb
    2. Change the database owner on the new computer. To do this, run the following script. Replace <XXX> with the name of the user whom was returned in step 2a:

      sp_changedbowner <XXX>
  3. Determine the name of the SharePoint Services configuration database. To do this, follow these steps:

    1. Click Start, point to All Programs, click Administrative Tools, and then click SharePoint Central Administration.

    2. In the Server Configuration area, click Set default configuration database.

    3. Note the configuration database name.

  4. Determine the name of the content database. To do this, follow these steps:

    1. In the Virtual Server area, click Configure virtual server settings, and then click the virtual server name that you are using for Business Portal.

    2. In the Virtual Server Management area, click Manage content databases.

    3. Note the content database name.

  5. Re-add the previously used content database. To do this, follow these steps:

    1. Click Start, click Administrative Tools, and then click SharePoint Central Administration.

    2. Click Configure virtual server settings.

    3. Click the virtual server that you are using for Business Portal.

    4. In the Virtual Server Management area, click Manage content databases, and then click Add a content database.

    5. In the Database Information area, click Specify database server settings, and then follow these steps:

      1. In the Database server box, type the name of the computer that is running Microsoft SQL Server or the name of the Microsoft SQL Server Desktop Engine (MSDE) where the content database resides.

      2. In the Database name box, type the name of the SharePoint Services content database.

    6. In the Database Capacity Settings area, follow these steps:

      1. In the Number of sites before a warning event is generated box, type 9000.

      2. In the Maximum number of sites that can be created in this database box, type 15000, and then click OK.

  6. Remove the new content database. To do this, follow these steps:

    1. Click Start, click Administrative Tools, and then click SharePoint Central Administration.

    2. Click Configure virtual server settings.

    3. Click the virtual server that you are using for Business Portal.

    4. Click Manage content databases, and then click the new SharePoint Services content database.

      Note This is the database that does not include the Business Portal objects.

    5. Click Remove Content Database, and then click OK.

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