Symptoms
When you try to modify company data in the Manage Company Setup window, you receive the following error message:
The selected company is being modified by another user
This problem occurs when you use Requisition Management in Business Portal for Microsoft Dynamics GP and for Microsoft Business Solutions - Great Plains.
When this problem occurs, no other users are accessing this company data in Business Portal.
Cause
The error message is caused by a user record that is not being cleared from the MultiUserManager table. The MultiUserManager table is located in the Dynamics database.
Resolution
To resolve this problem, follow these steps:
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Run the following script in SQL Query Analyzer to see which user records are not being cleared in the MultiUserManager table.
SELECT * FROM DYNAMICS..MultiUserManager
Note The MultiUserManager table should be cleared every 20 minutes. However, user records sometimes remain in the table.
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To delete the user record from the table, run the following script.
Note Back up the Dynamics database before you run the script.DELETE DYNAMICS..MultiUserManager WHERE UserID = XXX
Note Replace XXX with the user ID of the user record that was returned in step 1.
More Information
Steps to reproduce the problem
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Start Business Portal.
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Click Sites Settings, point to Application Settings, point to Requisitions, and then click Company Setup.
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Select a company, and then click Modify.