¿Desea organizar los objetos de base de datos de la forma que mejor se adapte a sus necesidades? A continuación, cree categorías y grupos personalizados en el panel de navegación para reorganizar, resaltar e incluso ocultar objetos. También puede ocultar el panel de navegación para proporcionar su propio método de navegación y usar macros para un control más avanzado.
Si busca solo lo básico, consulte Usar el panel de navegación.
Un panel de navegación personalizado organizado por tres funciones empresariales
En este artículo
- Antes de comenzar
- Crear categorías y grupos personalizados
- Organizar objetos en grupos personalizados
- Personalización avanzada
Antes de comenzar
Para ayudar a que las cosas vayan bien: planee su enfoque, proceda en fases y comprenda las implicaciones de seguridad.
Planeación de categorías y grupos personalizados
Cuando planee y diseñe el sistema de navegación de una base de datos, trabaje con las personas que lo usarán. Si eso no es práctico, mantenga sus necesidades en el centro de su proceso de diseño. Dependiendo de sus recursos, considere el uso de grupos focales para planificar y realizar pruebas de usabilidad durante su diseño. En definitiva, céntrate en el usuario.
Por ejemplo, imagine que tiene muchos informes en la base de datos y que ejecuta los informes con frecuencias variables. Puede crear una categoría de informes y, a continuación, crear grupos diarios, semanales, mensuales, trimestrales y anuales. En cada grupo, podría agregar los informes adecuados.
Para obtener muchos ejemplos de personalización del panel de navegación, consulte Plantillas de Access destacadas.
Adoptar un enfoque por fases
Cuando esté listo, cree categorías personalizadas, grupos personalizados dentro de esas categorías y, a continuación, agregue los objetos de base de datos a cada grupo. Para crear y administrar categorías y grupos personalizados, use el cuadro de diálogo Opciones de navegación. El cuadro de diálogo muestra una lista de todas las categorías que se han definido en la base de datos y muestra los grupos de una categoría seleccionada.
Creación de categorías y grupos personalizados
Piense en la creación de categorías y grupos personalizados como el andamiaje para su navegación personalizada.
-
Crear categorías personalizadas Access proporciona una categoría personalizada predefinida llamada Personalizada. Puede cambiar el nombre de esa categoría y, a continuación, agregar o quitar grupos para adaptarlos a sus necesidades. También puedes crear nuevas categorías personalizadas.
Nota Al crear una categoría personalizada, solo se aplica a la base de datos actual. No se pueden transferir categorías y grupos personalizados a otras bases de datos. - Creación de grupos personalizados Después de crear una categoría, puede crear uno o más grupos personalizados para la nueva categoría. Puede crear todos los grupos que necesite.
Al crear una nueva categoría personalizada, se crean los grupos Objetos sin asignar y Grupo personalizado 1 para dicha categoría. De forma predeterminada, Access no coloca ningún objeto en el grupo Objetos sin asignar . En su lugar, todos los objetos de una categoría que no están en un grupo se muestran en el grupo Objetos sin asignar del panel de navegación.
Organización de objetos de base de datos en grupos personalizados
Una vez que haya creado las categorías y los grupos, puede agregar, ocultar o mostrar grupos y objetos que se ajusten a sus necesidades. Es posible agregar o quitar los objetos de un grupo en cualquier momento.
-
Agregar objetos a grupos personalizados En el panel de navegación, puede arrastrar o copiar y pegar los objetos de los objetos sin asignar para asignarlos a un grupo personalizado. Al hacerlo, está agregando un acceso directo a un objeto de base de datos y no moviendo ni copiando el objeto en sí. Los accesos directos pueden identificarse mediante una pequeña flecha situada junto a la esquina inferior izquierda del icono del objeto.
Cada grupo debe tener un solo acceso directo a un objeto de base de datos determinado. Al abrir un acceso directo, se abre su objeto de destino correspondiente.
Nota Las categorías y grupos integrados en el panel de navegación no muestran accesos directos y, en su lugar, muestran objetos de base de datos reales. Estos grupos incluyen todos los grupos de cualquier categoría integrada y el grupo Objetos sin asignar de cualquier categoría personalizada. -
Mostrar u ocultar grupos u objetos Después de rellenar los grupos personalizados, puede ocultar el grupo Objetos sin asignar y cualquier otro grupo que no desee mostrar.
Es posible ocultar algunos o todos los grupos de una categoría personalizada y algunos o todos los objetos de un grupo. Puede usar comandos de clic derecho proporcionados por el panel de navegación o puede elegir una propiedad para cada objeto y ocultarla de todos los grupos y categorías de la base de datos abierta.
Los objetos y grupos ocultos pueden quedar totalmente invisibles, o bien, se pueden mostrar en el panel de navegación como iconos atenuados y no disponibles. Para ello, active o desactive la casilla Mostrar objetos ocultos en el cuadro de diálogo Opciones de navegación. También puede usar esa casilla cuando necesite mostrar un grupo o un objeto.
Importante Aunque puede quitar objetos de una categoría o grupo personalizado, no puede quitar objetos de una categoría o grupo predefinido. Aunque puede eliminar (es decir, quitar permanentemente) grupos predefinidos, no se recomienda hacerlo porque puede causar problemas en la base de datos. Las bases de datos son grupos de componentes que funcionan juntos, y si se borra un objeto de ese grupo de componentes, puede dejar de funcionar parte o toda la funcionalidad de la base de datos.
Personalización avanzada
Hay varias formas avanzadas de personalizar el panel de navegación.
Ocultar el panel de navegación Es posible que prefiera proporcionar su propio método de navegación, como un formulario de centralita o un formulario de navegación.
Deshabilitar la vista Diseño Puede ocultar los objetos de base de datos para ayudar a evitar cambios en el diseño, pero aún así proporcionar accesos directos a ellos en categorías y grupos personalizados.
Macros relacionadas También puede usar acciones de macro para controlar el panel de navegación:
- SetDisplayedCategories Se usa para mostrar u ocultar una categoría independientemente de la configuración en el cuadro de diálogo Opciones de navegación .
- Navegar a Se usa para navegar a una categoría o grupo, o navegar automáticamente a una categoría o grupo cuando se abre la base de datos.
- LockNavigationPane Se usa para evitar que los usuarios agreguen, muevan o eliminen accidentalmente elementos en el panel de navegación. También puede usar RunMenuCommand.
Consideraciones de seguridad
Se pueden omitir las características de facilidad de uso. La personalización del panel de navegación no impide que un usuario malintencionado realice cambios de diseño no deseados en la base de datos ni impide el acceso no autorizado a los datos. Tenga en cuenta lo siguiente:
- Si usa una macro para controlar y bloquear el panel de navegación, los usuarios pueden deshabilitar la macro en el inicio al mantener presionada la tecla Mayús.
- Puede ocultar las categorías y los grupos que contienen objetos de base de datos, y puede ocultar los propios objetos, pero es posible que los usuarios los muestren.
- Bloquear el panel de navegación no impide que los usuarios copien objetos de base de datos en el portapapeles.
Para obtener más información sobre la seguridad de la base de datos, vea Decidir si confiar en una base de datos y cifrar una base de datos con una contraseña de base de datos. Para obtener más información sobre cómo controlar el inicio de la base de datos, vea Establecer las opciones de usuario para la base de datos actual.
Crear categorías y grupos personalizados
Los procedimientos siguientes muestran cómo crear categorías y grupos personalizados y cambiarles el nombre.
Importante Para que funcionen los siguientes procedimientos, el panel de navegación debe estar visible y el comando de menú contextual habilitado. Para obtener más información, vea Personalización avanzada y Establecer opciones de usuario para la base de datos actual.
Crear una categoría personalizada
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- En el cuadro de diálogo Opciones de navegación, en la lista Categorías, haga clic en Agregar elemento. Aparecerá una nueva categoría en la lista.
- Escriba un nombre para la nueva categoría y, a continuación, presione ENTRAR.
Intente crear un nombre que tenga sentido para las personas que usan su base de datos. Después de crear el nombre, observe que el subtítulo de la lista de la derecha cambia para coincidir con ese nombre. Por ejemplo, si denomina a la nueva categoría Mi Centralita, el subtítulo de la lista de la derecha dice Grupos para "Mi Centralita".
Además, observe que la lista de la derecha contiene un grupo llamado Objetos sin asignar. Access crea ese grupo de forma predeterminada. Este grupo contiene todos los objetos de la base de datos y esos objetos se usan para rellenar el grupo personalizado.
Cambiar el nombre de una categoría personalizada
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- En Categorías, haga clic en la categoría personalizada y, a continuación, haga clic en Cambiar nombre de elemento.
- Escriba un nuevo nombre para la categoría y presione ENTRAR.
Crear un grupo personalizado
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- Seleccione la categoría a la que desea agregar uno o más grupos.
- Para cada grupo, en la lista Grupos para <nombre> de grupo, haga clic en Agregar grupo.
- Escriba un nombre para el nuevo grupo y presione ENTRAR.
- Deje seleccionada la casilla situada junto a Objetos no asignados y, después, haga clic en Aceptar. Access cierra el cuadro de diálogo Opciones de navegación y agrega el nuevo grupo personalizado al panel de navegación.
Cambiar el nombre de un grupo personalizado
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- En Grupos para <Nombre> de grupo, haga clic en el grupo personalizado y, a continuación, haga clic en Cambiar nombre de grupo.
- Escriba un nuevo nombre del grupo y presione ENTRAR.
Crear un grupo personalizado a partir de un objeto de base de datos
Con una categoría y un grupo personalizados abiertos en el panel de navegación, haga clic con el botón secundario en el objeto que desee colocar en un grupo nuevo.
Seleccione Agregar al grupo y haga clic en Nuevo grupo.
Aparecerá un nuevo grupo en el panel de navegación.
Escriba un nombre para el nuevo grupo y presione ENTRAR.
Organizar objetos en grupos personalizados
Los procedimientos siguientes muestran cómo organizar los objetos de base de datos en categorías y grupos personalizados.
Importante Para que funcionen los siguientes procedimientos, el panel de navegación debe estar visible y el comando de menú contextual habilitado. Para obtener más información, vea Personalización avanzada y Establecer opciones de usuario para la base de datos actual.
Agregar objetos a un grupo personalizado
Puede agregar accesos directos a objetos a un grupo personalizado de varias formas diferentes.
Haga clic en el menú situado en la parte superior del panel de navegación y, en la sección superior del menú, haga clic en la nueva categoría.
Los grupos que ha creado para la categoría aparecen en la sección inferior del menú, junto con el grupo Objetos sin asignar .En el grupo Objetos no asignados, seleccione los elementos que desee usar en el grupo personalizado y, a continuación, muévalos a ese grupo. Access permite mover los elementos seleccionados de varias formas. Puede:
Arrastrar los elementos individualmente.
Mantener presionada la tecla CTRL y hacer clic en varios elementos y, a continuación, arrastrar los elementos hasta el grupo personalizado.
Hacer clic con el botón secundario del mouse (ratón) en uno de los elementos seleccionados, elegir Agregar al grupo y, a continuación, hacer clic en el nombre del grupo personalizado.
Copiar y pegar:
- En el panel de navegación, haga clic con el botón secundario en el objeto que desee copiar, y, a continuación, haga clic en Copiar.
- Haga clic con el botón secundario en el grupo del panel de navegación donde quiera pegar el objeto y, después, haga clic en Pegar. También puede pegar el objeto en el panel de navegación de otra base de datos que esté abierta en Access.
Cuando termine, puede dejar el grupo Objetos sin asignar visible en el panel de navegación u ocultarlo.
Ocultar el grupo Objetos no asignados
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- En el panel Categorías , seleccione la categoría adecuada.
- En el panel Grupos para <categoría> , desactive la casilla de verificación Objetos no asignados .
Ocultar un grupo
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- En la lista Grupos para <categoría> , desactive la casilla situada junto al grupo que desea ocultar.
También en el panel de navegación, haga clic con el botón secundario en la barra de título del grupo que desea ocultar y, después, haga clic en Ocultar.
Mostrar un grupo
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- En la lista Grupos por <categoría> , active la casilla situada junto al grupo que desea ocultar o mostrar.
Ocultar un objeto
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- En la lista Categorías , seleccione la categoría adecuada.
- En la lista Grupos para <categoría> , seleccione el grupo que contiene el objeto oculto.
Desactive la casilla situada junto al objeto. - Haga clic en Aceptar.
Como alternativa, en el panel de navegación, haga clic con el botón secundario en el objeto y luego haga clic en Ocultar.
Nota No puede ocultar objetos en el grupo Objetos sin asignar de una categoría personalizada en el panel de navegación.
Mostrar un objeto
Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
Bajo Opciones de presentación, active la casilla de verificación Mostrar objetos ocultos.
Haga clic en Aceptar.
En el panel de navegación, aparece un icono atenuado para todos los objetos ocultos.Siga uno de estos procedimientos:
- Si ocultó un acceso directo en un grupo, haga clic con el botón derecho en él y, después, haga clic en Mostrar en este grupo.
- Si ocultó el objeto únicamente de su grupo y categoría primarios, haga clic con el botón secundario del mouse en el objeto y, a continuación, haga clic en Mostrar.
- Si ocultó el objeto de todas las categorías y todos los grupos estableciendo la propiedad Oculto, haga clic con el botón secundario del mouse en el objeto, haga clic en Propiedades de vista y, a continuación, desactive la casilla de verificación Oculto.
Ocultar un objeto de todos los grupos y categorías
- Haga clic con el botón derecho en la parte superior del panel de navegación y, a continuación, seleccione Opciones de navegación.
- Haga clic con el botón secundario en el objeto que desea ocultar y luego haga clic en Propiedades de objeto o (para una tabla) en Propiedades de tabla en el menú contextual.
- Active la casilla de verificación Oculto.
- Haga clic en Aceptar.
Cambiar el nombre de un acceso directo de objeto
Al cambiar el nombre de un acceso directo a un objeto, Access no cambia el nombre del objeto de base de datos al que apunta el acceso directo.
- En el Panel de navegación, haga clic con el botón secundario del mouse en el objeto cuyo nombre desee cambiar y, a continuación, haga clic en Cambiar nombre de acceso directo.
- Escriba el nuevo nombre del acceso directo y, a continuación, presione ENTRAR.
Eliminar un acceso directo de objeto
- En el panel de navegación, haga clic con el botón derecho en el acceso directo que quiera quitar y luego haga clic en Quitar.
Al eliminar un acceso directo a objeto, Access no elimina el objeto de base de datos al que apunta el acceso directo.
Eliminar un objeto
- En el panel de navegación, haga clic con el botón secundario del mouse en el objeto que desee quitar y, a continuación, haga clic en Eliminar.
Importante Si decide eliminar un objeto de un grupo, tenga en cuenta que esto puede provocar problemas. No se recomienda eliminar un objeto porque una base de datos es un conjunto de componentes que trabajan juntos y, si se elimina un objeto de ese conjunto de componentes, puede interrumpir parte o toda la funcionalidad de la base de datos.
Personalización avanzada
Hay formas más avanzadas de personalizar el panel de navegación. Puede ocultar el panel de navegación mediante el cuadro de diálogo Opciones y deshabilitar una vista Diseño de objeto utilizando una propiedad de objeto. También puede usar macros para mostrar u ocultar categorías de forma selectiva, navegar a una categoría o grupo, ocultar el panel de navegación o bloquear el panel de navegación.
Para ejecutar acciones de macro automáticamente cuando se abre una base de datos, coloque las acciones en una macro denominada autoexec. Para obtener más información, vea Crear una macro que se ejecute al abrir una base de datos. Para obtener más información sobre la creación de macros para controlar la interfaz de usuario, consulte Crear una macro de interfaz de usuario (UI).
Ocultar el panel de navegación mediante el cuadro de diálogo Opciones
Puede ocultar el panel de navegación y usar un método alternativo de navegación, como un formulario de centralita, un formulario de navegación o botones y vínculos ubicados estratégicamente en un formulario de inicio (consulte Plantillas de Access destacadas).
- En la base de datos de escritorio abierta, haga clic en la pestaña Archivo y, a continuación, en Opciones.
- Haga clic en la categoría Base de datos activa y, en Navegación, desactive la casilla Mostrar panel de navegación.
- Haga clic en Aceptar.
- Para que esta configuración surta efecto, cierre y vuelva a abrir la base de datos.
Nota Para volver a mostrar el panel de navegación, repita el procedimiento, pero active la casilla.
Deshabilitar la vista Diseño para objetos de base de datos
En el panel de navegación, puede establecer la propiedad Deshabilitar accesos directos de la vista Diseño de un acceso directo (haga clic con el botón derecho en el acceso directo y haga clic en Propiedades de objeto) para controlar si los usuarios pueden usar el acceso directo para abrir el objeto de destino en la vista Diseño o Presentación. Por ejemplo, si habilita esta propiedad para un acceso directo a un formulario, los usuarios no pueden cambiar el diseño o la distribución del formulario mediante el método abreviado.
- En el panel de navegación, haga clic con el botón derecho en el acceso directo para el que desea deshabilitar la vista Diseño y, a continuación, haga clic en Propiedades de objeto o (para una tabla) en Propiedades de tabla.
- En el cuadro de diálogo Propiedades de <nombre> de objeto , active la casilla Deshabilitar accesos directos de vista Diseño .
Usar la macro SetDisplayedCategories para mostrar u ocultar una categoría
Siga uno de estos procedimientos:
- Para crear una macro, en la pestaña Crear , en el grupo Macros & Código , haga clic en Macro.
- Para agregar las acciones a una macro existente, haga clic con el botón derecho en esa macro en el panel de navegación y, a continuación, haga clic en Vista Diseño.
En la pestaña Diseño , en el grupo Mostrar/Ocultar , haga clic en Mostrar todas las acciones.
En el diseñador de macros, seleccione SetDisplayedCategories en la lista desplegable. La acción aparece en el diseñador de macros.
En el cuadro Mostrar , elija una configuración. Elija Sí si desea que la categoría se muestre en el panel de navegación. Elija No si no desea que la categoría se muestre en el panel de navegación.
En el cuadro Categoría , haga clic en el nombre de la categoría que desee mostrar u ocultar.
Repita los pasos del 3 al 5 para cada categoría que desee controlar mediante la macro.
Para obtener más información, vea Acción de macro SetDisplayedCategories.
Usar la macro NavigateTo para navegar a una categoría o grupo
Siga uno de estos procedimientos:
- Para crear una macro, en la pestaña Crear , en el grupo Macros & Código , haga clic en Macro.
- Para agregar la acción a una macro existente, haga clic con el botón derecho en esa macro en el panel de navegación y, a continuación, haga clic en Vista Diseño.
En la pestaña Diseño , en el grupo Mostrar/Ocultar , haga clic en Mostrar todas las acciones.
En el diseñador de macros, seleccione Navegar a la lista desplegable. La acción aparece en el diseñador de macros.
En el cuadro Categoría , haga clic en el nombre de la categoría a la que desea navegar.
Si desea navegar a un grupo específico de la categoría, haga clic en la flecha del cuadro Grupo y, después, haga clic en el nombre del grupo al que desea navegar.
Para obtener más información, consulte Acción de macro Navegar.
Usar la macro LockNavigationPane para bloquear el panel de navegación
Siga uno de estos procedimientos:
- Para crear una macro, en la pestaña Crear , en el grupo Macros & Código , haga clic en Macro.
- Para agregar las acciones a una macro existente, haga clic con el botón derecho en esa macro en el panel de navegación y, a continuación, haga clic en Vista Diseño.
En la pestaña Diseño , en el grupo Mostrar/Ocultar , haga clic en Mostrar todas las acciones.
En el diseñador de macros, seleccione LockNavigationPane en la lista desplegable. La acción aparece en el diseñador de macros.
Especifique un valor para el argumento Lock . Elija Sí para bloquear el panel de navegación.
Para obtener más información, vea Acción de macro LockNavigationPane.
Usar la macro RunMenuCommand para ocultar el panel de navegación
Si prefiere crear su propio sistema de navegación, puede ocultar el panel de navegación mediante la acción de macro RunMenuCommand y el argumento WindowHide .
Siga uno de estos procedimientos:
- Para crear una macro, en la pestaña Crear , en el grupo Macros & Código , haga clic en Macro.
- Para agregar la acción a una macro existente, haga clic con el botón derecho en esa macro en el panel de navegación y, a continuación, haga clic en Vista Diseño.
En la pestaña Diseño , en el grupo Mostrar/Ocultar , haga clic en Mostrar todas las acciones.
En el diseñador de macros, seleccione RunMenuCommand en la lista desplegable. La acción aparece en el diseñador de macros.
En el cuadro de comandos , seleccione WindowHide.
También puede activar o desactivar la visualización del panel de navegación mediante la casilla Mostrar panel de navegación del cuadro de diálogo Opciones de Access . Si usa la acción de macro RunMenuCommand con el argumento WindowHide , se ocultará el panel de navegación independientemente de si la casilla Mostrar panel de navegación está activada o desactivada.
Para obtener más información, vea Acción de macro RunMenuCommand.