Una base de datos bien diseñada no solo ayuda a garantizar la integridad de los datos, sino que es más fácil de mantener y actualizar. Una base de datos de Access no es un archivo en el mismo sentido que un documento de Microsoft Word o un conjunto de diapositivas de Microsoft PowerPoint. En su lugar, es una colección de objetos (tablas, formularios, informes, consultas, etc.) los que deben trabajar juntos para funcionar correctamente.
Los usuarios introducen los datos principalmente a través de controles. Lo que haga con un control determinado dependerá del tipo de datos establecido para el campo de tabla subyacente, las propiedades establecidas para ese campo y las propiedades establecidas para el control. Por último, considere la posibilidad de usar técnicas adicionales de bases de datos, como validación, valores predeterminados, listas y búsquedas, y actualizaciones en cascada.
Para obtener más información sobre la actualización de datos desde el punto de vista del usuario, consulte Formas de agregar, modificar y eliminar registros.
En este artículo
- Cómo afecta el diseño de base de datos a la entrada de datos
- Establecer un valor predeterminado para un campo o control
- Uso de reglas de validación para limitar los datos
- Trabajar con listas de valores y campos de búsqueda
- Eliminar los datos de una lista o campos de búsqueda
- Cómo afectan los tipos de datos a la manera en que se escriben los datos
- Cómo afectan las propiedades de campo de tabla a la forma de escribir datos
- Usar actualizaciones en cascada para cambiar los valores de clave principal y externa
- Por qué los números de identificación a veces parecen omitir un número
- Actualización masiva de datos mediante consultas
Cómo afecta el diseño de base de datos a la entrada de datos
La información que guarda en una base de datos se almacena en tablas, que contienen datos sobre un tema en particular, como activos o contactos. Cada registro de una tabla contiene información sobre un elemento, como un contacto en particular. Un registro se compone de campos, como el nombre, la dirección y el número de teléfono. Un registro se suele denominar fila y un campo se denomina columna. Estos objetos deben cumplir un conjunto de principios de diseño o la base de datos funcionará mal o producirá un error total. A su vez, estos principios de diseño afectan a la forma en que se escriben los datos. Tenga en cuenta lo siguiente:
- Tablas Access almacena todos los datos en una o más tablas. El número de tablas que use dependerá del diseño y la complejidad de la base de datos. Aunque puede ver datos en un formulario, un informe o en los resultados devueltos por una consulta, Access almacena los datos solo en tablas y los demás objetos de la base de datos se generan encima de esas tablas. Cada tabla debe basarse en un tema. Por ejemplo, una tabla de información de contacto de la empresa no debe contener información de ventas. Si lo hace, encontrar y editar la información correcta puede volverse difícil, si no imposible.
-
Tipos de datos Normalmente, cada uno de los campos de una tabla acepta solo un tipo de datos. Por ejemplo, no puede almacenar notas en un campo configurado para aceptar números. Si intenta escribir texto en este campo, Access mostrará un mensaje de error. Sin embargo, esa no es una regla estricta. Por ejemplo, puede almacenar números (como códigos postales) en un campo establecido en el tipo de datos Texto breve, pero no puede realizar cálculos en esos datos porque Access los considera un fragmento de texto.
Con algunas excepciones, los campos de un registro solo deben aceptar un valor. Por ejemplo, no puede escribir más de una dirección en un campo de dirección. Esto contrasta con Microsoft Excel, que le permite introducir cualquier número de nombres, direcciones o imágenes en una sola celda a menos que establezca esa celda para aceptar tipos de datos limitados. - Campos multivalor Access ofrece una característica denominada campo multivalor para adjuntar varios datos en un único registro y crear listas que aceptan varios valores. Siempre puede identificar una lista multivalor porque Access muestra una casilla junto a cada elemento de lista. Por ejemplo, puede adjuntar un conjunto de diapositivas de Microsoft PowerPoint y cualquier número de imágenes a un registro en la base de datos. También puede crear una lista de nombres y seleccionar tantos nombres como sea necesario. Puede parecer que el uso de campos multivalor infringe las reglas del diseño de base de datos, ya que puede almacenar más de un registro por campo de tabla. Pero Access aplica las reglas "entre bastidores", almacenando los datos en tablas especiales ocultas.
- Uso de formularios Por lo general, crea formularios cuando desea facilitar el uso de una base de datos y ayudar a garantizar que los usuarios escriban los datos con precisión. La forma de editar datos en un formulario depende del diseño del formulario. Los formularios pueden contener cualquier número de controles, como listas, cuadros de texto, botones e incluso hojas de datos. A su vez, cada uno de los controles del formulario lee o escribe datos en un campo de tabla subyacente.
Para obtener más información, vea Conceptos básicos del diseño de bases de datos y Crear una tabla y agregar campos.
Establecer un valor predeterminado para un campo o control
Si un gran número de registros comparten el mismo valor para un campo determinado, como una ciudad o un país o región, puede ahorrar tiempo si establece un valor predeterminado para el control enlazado a ese campo o al propio campo. Al abrir el formulario o la tabla para crear un nuevo registro, el valor predeterminado aparece en ese control o campo.
En una tabla
- Abra la tabla en la Vista Diseño.
- Seleccione el campo en la parte superior de la vista.
- En la parte inferior de la vista, seleccione la pestaña General .
- Establezca la propiedad Valor predeterminado en el valor que desee.
En un formulario
- Abra el formulario en la vista Presentación o Diseño.
- Haga clic con el botón secundario en el control con el que desea trabajar y luego haga clic en Propiedades.
- En la pestaña Datos , establezca la propiedad Valor predeterminado en el valor que desee.
Uso de reglas de validación para limitar los datos
Puede validar los datos de las bases de datos de escritorio de Access a medida que los escribe mediante reglas de validación. Puede establecer reglas de validación en la vista de diseño de tabla o en la de hoja de datos de tabla. Hay tres tipos de reglas de reglas de validación en Access:
- Regla de validación de campo Puede usar una regla de validación de campo para especificar un criterio que deben cumplir todos los valores de campo válidos. No debería tener que especificar el campo actual como parte de la regla a no ser que use el campo en una función. Las restricciones sobre los tipos de caracteres que se escriban en un campo pueden aplicarse más fácilmente con una máscara de entrada. Por ejemplo, un campo de fecha podría tener una regla de validación que no permita valores del pasado.
- Regla de validación de registro Puede usar una regla de validación de registro para especificar una condición que deben cumplir todos los registros válidos. Puede comparar valores de distintos campos con una regla de validación de registro. Por ejemplo, un registro con dos campos de fecha puede necesitar que los valores de un campo siempre sean anteriores a los del otro (por ejemplo, que FechaDeInicio sea anterior a FechaDeFinalización).
- Validación en un formulario Puede usar la propiedad Regla de validación de un control en un formulario para especificar un criterio que deben cumplir todos los valores especificados en dicho control. La propiedad de control Regla de validación funciona como una regla de validación de campo. Normalmente, se usa una regla de validación de formulario en lugar de una regla de validación de campo si se trata de una regla específica del formulario y no de la tabla, sin importar donde se use.
Para obtener más información, vea Restringir la entrada de datos mediante reglas de validación.
Trabajar con listas de valores y campos de búsqueda
Hay dos tipos de datos de lista en Access:
- Listas de valores Contienen un conjunto de valores codificados de forma rígida que se introducen manualmente. Los valores residen en la propiedad Origen de fila del campo.
-
Campos de búsqueda Estos usan una consulta para recuperar valores de otra tabla. La propiedad Origen de fila del campo contiene una consulta en lugar de una lista de valores codificada de forma rígida. La consulta recupera valores de una o más tablas de una base de datos. De forma predeterminada, el campo de búsqueda presenta esos valores en forma de lista. Según cómo configure el campo de búsqueda, puede seleccionar uno o varios elementos de esa lista.
Nota Los campos de búsqueda pueden confundir a los nuevos usuarios de Access porque una lista de elementos aparece en una ubicación (la lista que Access crea a partir de los datos del campo de búsqueda), pero los datos pueden residir en otra ubicación (la tabla que contiene los datos).
De forma predeterminada, Access muestra los datos de lista en un control de cuadro combinado, aunque puede especificar un control de cuadro de lista. Se abre un cuadro combinado para presentar la lista y, a continuación, se cierra una vez que realiza una selección. Un cuadro de lista, por el contrario, permanece abierto en todo momento.
Para editar listas, también puede ejecutar el comando Editar elementos de lista o puede editar los datos directamente en la propiedad Origen de fila de la tabla de origen. Al actualizar los datos de un campo de búsqueda, se actualiza la tabla de origen.
Si la propiedad Tipo de origen de fila del cuadro de lista o cuadro combinado se establece en Lista de valores, puede editar la lista de valores mientras el formulario está abierto en la vista Formulario, lo que evita la necesidad de cambiar a la vista Diseño o Presentación, abrir la hoja de propiedades y editar la propiedad Origen de fila para el control cada vez que necesite realizar un cambio en la lista. Para modificar la lista de valores, la propiedad Permitir ediciones de lista de valores del cuadro de lista o del cuadro combinado debe estar establecida en Sí.
Para obtener más información, vea Crear una lista de opciones con un cuadro de lista o un cuadro combinado.
Impedir la modificación de la lista de valores en la vista Formulario
- Haga clic con el botón secundario en el formulario en el panel de navegación y, después, haga clic en Vista Diseño o Vista Presentación.
- Haga clic en el control para seleccionarlo y luego presione F4 para ver la hoja de propiedades.
- En la pestaña Datos de la hoja de propiedades, establezca la propiedad Permitir ediciones de lista de valores como No.
- Haga clic en Archivo y, a continuación, en Guardar, o presione Ctrl+
.
Especificar un formulario distinto para modificar la lista de valores
De forma predeterminada, Access proporciona un formulario integrado para modificar la lista de valores. Si hay otro formulario que hubiera preferido usar para este propósito, puede especificar el nombre del formulario en la propiedad Formulario de edición de elementos de lista, de la siguiente manera:
- Haga clic con el botón secundario en el formulario en el panel de navegación y luego haga clic en Vista Diseño o en Vista Presentación en el menú contextual.
- Haga clic en el control para seleccionarlo y luego presione F4 para ver la hoja de propiedades.
- En la pestaña Datos de la hoja de propiedades, haga clic en la flecha desplegable en el cuadro de la propiedad Formulario de edición de elementos de lista.
- Haga clic en el formulario que quiera usar para modificar la lista de valores.
- Haga clic en el archivo y luego en Guardar, o presione Ctrl+
.
Examinar un campo de búsqueda en un formulario
Abra el formulario en la vista Presentación o Diseño.
Haga clic con el botón secundario en el control cuadro de lista o cuadro combinado y haga clic en Propiedades.
En la hoja de propiedades, haga clic en la pestaña Todos y busque las propiedades Tipo de origen de fila y Origen de fila . La propiedad Tipo de origen de fila debe contener Lista de valores o Tabla o consulta, y la propiedad Origen de fila debe contener una lista de elementos separados por punto y coma o una consulta. Para obtener más espacio, haga clic con el botón derecho en la propiedad y seleccione Zoom o presione Mayús+F2.
Normalmente, las listas de valores usan esta sintaxis básica: "elemento";" artículo";" artículo"
En este caso, la lista es un conjunto de elementos entre comillas dobles y separados por punto y coma.
Las consultas de selección usan esta sintaxis básica: SELECT [table_or_query_name].[ field_name**] FROM [table_or_query_name]**.
En este caso, la consulta contiene dos cláusulas (SELECT y FROM). La primera cláusula hace referencia a una tabla o consulta y a un campo de esa tabla o consulta. La segunda cláusula hace referencia únicamente a la tabla o consulta. Este es un punto clave que debe recordar: las cláusulas SELECT no tienen que contener el nombre de una tabla o consulta, aunque se recomienda, y deben contener el nombre de al menos un campo. Sin embargo, todas las cláusulas FROM deben hacer referencia a una tabla o consulta. Por lo tanto, siempre puede encontrar la tabla de origen o la consulta de origen para un campo de búsqueda leyendo la cláusula FROM.Siga uno de estos procedimientos:
- Si usa una lista de valores, edite los elementos de la lista. Asegúrese de encerrar cada elemento entre comillas dobles y de separarlo con punto y coma.
- Si la consulta de la lista de búsqueda hace referencia a otra consulta, abra esa segunda consulta en la vista Diseño (haga clic con el botón secundario en la consulta en el panel de navegación y haga clic en Vista Diseño). Anote el nombre de la tabla que aparece en la sección superior del diseñador de consultas y, a continuación, vaya al paso siguiente.
De lo contrario, si la consulta del campo Búsqueda hace referencia a una tabla, anote el nombre de la tabla y vaya al paso siguiente.
Abra la tabla en la vista Hoja de datos y, después, edite los elementos de lista según sea necesario.
Examinar un campo de búsqueda en una tabla
Abra la tabla en la Vista Diseño.
En la sección superior de la cuadrícula de diseño de la consulta, en la columna Tipo de datos , haga clic o coloque el foco en cualquier campo de texto, número o Sí/No.
En la sección inferior de la cuadrícula de diseño de la tabla, haga clic en la pestaña Buscar y, a continuación, examine las propiedades Tipo de origen de fila y Origen de fila .
La propiedad Tipo de origen de fila debe ser Lista de valores o Tabla o consulta. La propiedad Origen de fila debe contener una lista de valores o una consulta.
Las listas de valores usan esta sintaxis básica: "elemento";" artículo";" artículo"
En este caso, la lista es un conjunto de elementos entre comillas dobles y separados por punto y coma.
Normalmente, las consultas de selección usan esta sintaxis básica: SELECT [table_or_query_name].[ field_name**] FROM [table_or_query_name]**.
En este caso, la consulta contiene dos cláusulas (SELECT y FROM). La primera cláusula hace referencia a una tabla o consulta y a un campo de esa tabla o consulta. La segunda cláusula hace referencia únicamente a la tabla o consulta. Este es un punto clave que debe recordar: las cláusulas SELECT no tienen que contener el nombre de una tabla o consulta, aunque se recomienda, y deben contener el nombre de al menos un campo. Sin embargo, todas las cláusulas FROM deben hacer referencia a una tabla o consulta. Por lo tanto, siempre puede encontrar la tabla de origen o la consulta de origen para un campo de búsqueda leyendo la cláusula FROM.Siga uno de estos procedimientos:
- Si usa una lista de valores, edite los elementos de la lista. Asegúrese de encerrar cada elemento entre comillas dobles y de separarlo con punto y coma.
- Si la consulta del campo Búsqueda hace referencia a otra consulta, en el panel de navegación, abra esa segunda consulta en la vista Diseño (haga clic con el botón secundario en la consulta y haga clic en Vista Diseño). Anote el nombre de la tabla que aparece en la sección superior del diseñador de consultas y, a continuación, vaya al paso siguiente.
De lo contrario, si la consulta del campo Búsqueda hace referencia a una tabla, anote el nombre de la tabla y vaya al paso siguiente.
Abra la tabla en la vista Hoja de datos y, después, edite los elementos de lista según sea necesario.
Eliminar los datos de una lista de valores o un campo de búsqueda
Los elementos de una lista de valores residen en la misma tabla que los demás valores de un registro. En cambio, los datos de un campo de búsqueda residen en una o más tablas. Para quitar datos de una lista de valores, abra la tabla y edite los elementos.
Eliminar datos de una lista de búsqueda requiere pasos adicionales y estos varían dependiendo de si la consulta para las listas de búsqueda toma sus datos de una tabla o de otra consulta. Si la consulta para la lista de búsqueda se basa en una tabla, identifique esa tabla y el campo que contiene los datos que aparecen en la lista. Después, abra la tabla de origen y modifique los datos de ese campo. Si la consulta para la lista de búsqueda se basa en otra consulta, debe abrir esa segunda consulta, encontrar la tabla de origen y el campo desde el que la segunda consulta toma sus datos y cambiar los valores de esa tabla.
Quitar datos de una lista de valores
- Abra la tabla en la Vista Diseño.
- En la sección superior de la cuadrícula de diseño, seleccione el campo de tabla que contiene la lista de valores.
- En la sección inferior de la cuadrícula, haga clic en la pestaña Búsqueda y después busque la propiedad Origen de la fila.
De forma predeterminada, las comillas dobles rodean los elementos de una lista de valores y los puntos y coma separan cada elemento:"Excellent";"Fair";"Average";"Poor" - Elimine elementos de la lista según sea necesario. Recuerde que debe eliminar las comillas que se encuentran alrededor de cada elemento eliminado. Además, no debe dejar un punto y coma inicial ni pares de punto y coma juntos (;;) y si quita el último elemento de la lista, debe eliminar el punto y coma final.
Importante Si elimina un elemento de una lista de valores y los registros de la tabla ya usan ese elemento eliminado, el elemento eliminado seguirá formando parte del registro hasta que lo cambie. Por ejemplo, supongamos que su empresa tiene un almacén en la ciudad A, pero vende dicho edificio. Si quita "Ciudad A" de la lista de almacenes, verá "Ciudad A" en la tabla hasta que cambie estos valores.
Quitar datos de un campo de búsqueda
Abra la tabla en la Vista Diseño.
En la sección superior de la cuadrícula de diseño, seleccione la lista de búsqueda.
En la sección inferior de la cuadrícula de diseño, haga clic en la pestaña Búsqueda y busque las propiedades Tipo de origen de la fila y Origen de la fila.
La propiedad Tipo de origen de la fila debería mostrar Tabla/consulta y la propiedad Origen de la fila debe contener una consulta que haga referencia a una tabla o a otra consulta. Las consultas de campos de búsqueda siempre comienzan con la palabra SELECCIONAR.
Normalmente (pero no siempre), una consulta de selección usa esta sintaxis básica: SELECT [table_or_query_name].[ field_name*] FROM [table_or_query_name]*.
En este caso, la consulta contiene dos cláusulas (SELECT y FROM). La primera cláusula se refiere a una tabla y a un campo de esa tabla; por el contrario, la segunda cláusula se refiere solo a la tabla. Un punto para recordar: la cláusula FROM siempre le indicará el nombre de la tabla o consulta de origen. Es posible que las cláusulas SELECT no siempre contengan el nombre de una tabla o una consulta, aunque siempre contengan el nombre de al menos un campo. Sin embargo, todas las cláusulas FROM deben hacer referencia a una tabla o consulta.Siga uno de estos pasos:
- Si la consulta del campo Búsqueda hace referencia a otra consulta, haga clic en el botón Crear (en la pestaña Datos de la hoja de propiedades, haga clic en el
siguiente) para abrir la consulta en la vista Diseño. Anote el nombre de la tabla que aparece en la sección superior del Diseñador de consultas y después continúe con el paso 5. - Si la consulta en el campo de búsqueda hace referencia a una tabla, anote el nombre de la tabla y después continúe con el paso 5.
- Si la consulta del campo Búsqueda hace referencia a otra consulta, haga clic en el botón Crear (en la pestaña Datos de la hoja de propiedades, haga clic en el
Abra la tabla de origen en la vista Hoja de datos.
Busque el campo que contiene los datos que se usan en la lista de búsqueda y después edite los datos según sea necesario.
Cómo afectan los tipos de datos a la manera en que se escriben los datos
Al diseñar una tabla de base de datos, seleccione un tipo de datos para cada campo de esa tabla, un proceso que ayuda a garantizar una entrada de datos más precisa.
Ver tipos de datos
Siga uno de estos procedimientos:
Usar la vista Hoja de datos
- Abra la tabla en la Vista Hoja de datos.
- En la pestaña Campos , en el grupo Formato , mire el valor de la lista Tipo de datos. El valor cambia al colocar el cursor en los distintos campos de la tabla:
Usar la vista Diseño
- Abra la tabla en la Vista Diseño.
- Mira la cuadrícula de diseño. La sección superior de la cuadrícula muestra el nombre y el tipo de datos de cada campo de tabla.
Cómo afectan los tipos de datos a la entrada de datos
El tipo de datos que establezca para cada campo de tabla proporciona el primer nivel de control sobre qué tipo de datos se permiten en un campo. En algunos casos, como en un campo de texto largo, puede escribir los datos que desee. En otros casos, como en el campo Autonumeración, la configuración de tipo de datos del campo impide que escriba información alguna. En la tabla siguiente se enumeran los tipos de datos que proporciona Access y cómo afectan a la entrada de datos.
Para obtener más información, vea Tipos de datos para bases de datos de escritorio de Access y Modificar o cambiar la configuración de tipo de datos de un campo.
| Tipo de datos | Efecto en la entrada de datos |
|---|---|
| Texto corto | Los campos de texto corto aceptan caracteres de texto o numéricos, incluidas listas delimitadas de elementos. Un campo de texto acepta un número menor de caracteres que un campo de texto largo, de 0 a 255 caracteres. En algunos casos, puede usar funciones de conversión para realizar cálculos en los datos de un campo de texto corto. |
| Texto largo | Puede introducir grandes cantidades de texto y datos numéricos en este tipo de campo de hasta 64 000 caracteres. Además, establece el campo para que admita el formato de texto enriquecido, puede aplicar los tipos de formato que normalmente encuentra en los programas de procesamiento de texto, como Word. Por ejemplo, puede aplicar fuentes y tamaños de fuente diferentes a caracteres específicos del texto y ponerlos en negrita, cursiva, etc. También puede agregar etiquetas HTML (Lenguaje de marcado de hipertexto) a los datos. Para obtener más información, vea Insertar o agregar un campo de texto enriquecido. Además, los campos de texto largo tienen una propiedad denominada solo anexar. Cuando habilita esa propiedad, puede anexar nuevos datos a un campo de texto largo, pero no puede cambiar los datos existentes. La característica está pensada para su uso en aplicaciones como bases de datos de seguimiento de problemas, donde es posible que deba mantener un registro permanente que permanezca inmutable. Cuando coloca el cursor en un campo de texto largo con la propiedad Anexar solo habilitada, de forma predeterminada, el texto del campo desaparece. No puede aplicar ningún formato ni otros cambios al texto. Al igual que los campos de texto corto, también puede ejecutar funciones de conversión en los datos de un campo de texto largo. |
| Número | Solo puede escribir números en este tipo de campo y puede realizar cálculos en los valores de un campo Número. |
| Número grande Tenga en cuenta que los tipos de datos de Número grande solo están disponibles en la versión de suscripción a Microsoft 365 de Access. |
Solo puede escribir números en este tipo de campo y puede realizar cálculos en los valores de un campo Número grande. Para obtener más información, vea Usar el tipo de datos Número grande. |
| Fecha y hora | Solo puede escribir fechas y horas en este tipo de campo. Puede establecer una máscara de entrada para el campo (una serie de caracteres literales y de marcador de posición que aparecen al seleccionar el campo), debe escribir datos en los espacios y el formato que proporciona la máscara. Por ejemplo, si ve una máscara como MMM_DD_YYYY, debe escribir 11 de octubre de 2017 en los espacios proporcionados. No se puede especificar un nombre de mes completo o un valor de año de dos dígitos. Para obtener más información, consulte Controlar los formatos de entrada de datos con máscaras de entrada. Si no crea una máscara de entrada, puede escribir el valor utilizando cualquier formato de fecha u hora válido. Por ejemplo, puede escribir 11 de octubre de 2017, 10/11/17, 11 de octubre de 2017, etc. También puede aplicar un formato de presentación al campo. En ese caso, si no hay ninguna máscara de entrada, se puede escribir un valor en casi cualquier formato, pero Access muestra las fechas según el formato de visualización. Por ejemplo, puede escribir 11/10/2017, pero el formato de presentación puede establecerse para que muestre el valor como 11-Oct-2017. Para obtener más información, consulte Insertar la fecha del día en día. |
| Moneda | Solo puede introducir valores de moneda en este tipo de campo. Además, no es necesario escribir manualmente un símbolo de moneda. De forma predeterminada, Access aplica el símbolo de moneda (¥, £, $, etc.) especificado en la configuración regional de Windows. Puede cambiar este símbolo de moneda para reflejar una moneda diferente, si es necesario. |
| Autonumeración | No puede introducir ni cambiar los datos de este tipo de campo en ningún momento. Access incrementa los valores de un campo Autonumeración cada vez que se agrega un nuevo registro a una tabla. |
| Calculado | No puede introducir ni cambiar los datos de este tipo de campo en ningún momento. Los resultados de este campo están determinados por una expresión que defina. Access actualiza los valores de un campo calculado cada vez que agrega o modifica un nuevo registro en una tabla. |
| Sí/No | Al hacer clic en un campo establecido en este tipo de datos, Access muestra una casilla o una lista desplegable, según cómo se dé formato al campo. Si da formato al campo para mostrar una lista, puede seleccionar Sí o No, Verdadero o Falso, o Activado o Desactivado en la lista, de nuevo dependiendo del formato aplicado al campo. No puede especificar valores en la lista ni cambiar los valores de la lista directamente desde un formulario o una tabla. |
| Objeto OLE | Use este tipo de campo cuando desee mostrar datos de un archivo creado con otro programa. Por ejemplo, puede mostrar un archivo de texto, un gráfico de Excel o un conjunto de diapositivas de PowerPoint en un campo de objeto OLE. Los datos adjuntos proporcionan una forma más rápida, fácil y flexible de ver los datos de otros programas. |
| Hipervínculo | Puede escribir cualquier dato en este tipo de campo y Access lo ajustará en una dirección web. Por ejemplo, si escribe un valor en el campo, Access delimita el texto con http://www,your_text**.com**. Si escribe una dirección web válida, el vínculo funcionará. De lo contrario, el vínculo mostrará un mensaje de error. Además, la edición de hipervínculos existentes puede ser difícil porque al hacer clic en un campo de hipervínculo con el mouse, se inicia el explorador y se accede al sitio especificado en el vínculo. Para editar un campo de hipervínculo, seleccione un campo adyacente, use la tecla TAB o las teclas de dirección para mover el foco al campo de hipervínculo y, después, presione F2 para habilitar la edición. |
| Datos adjuntos | Puede adjuntar datos de otros programas a este tipo de campo, pero no puede escribir ni escribir texto o datos numéricos. Para obtener más información, consulte Adjuntar archivos y gráficos a los registros de la base de datos. |
| Asistente para búsquedas | El Asistente para búsquedas no es un tipo de datos. En su lugar, utilice el asistente para crear dos tipos de listas desplegables: listas de valores y campos de búsqueda. Una lista de valores utiliza una lista delimitada de elementos que se introducen manualmente al usar el Asistente para búsquedas. Dichos valores pueden ser independientes de cualquier otro dato u objeto de la base de datos. En cambio, un campo de búsqueda usa una consulta para recuperar datos de una o varias de las otras tablas de una base de datos. A continuación, el campo de búsqueda muestra los datos en una lista desplegable. De forma predeterminada, el Asistente para búsquedas establece el campo de tabla en el tipo de datos Número. Puede trabajar con los campos de búsqueda directamente en las tablas, así como en los formularios e informes. De forma predeterminada, los valores de un campo de búsqueda aparecen en un tipo de control de lista denominado cuadro combinado, una lista con una flecha desplegable:
También puede utilizar un cuadro de lista que muestre varios elementos con una barra de desplazamiento para ver más elementos:
Según cómo configure el campo de búsqueda y el cuadro combinado, puede editar los elementos de la lista y agregar elementos a la lista desactivando la propiedad Limitar a lista del campo de búsqueda. Si no puede editar directamente los valores de una lista, tiene que agregar o cambiar los datos de la lista de valores predefinida o de la tabla que sirve de origen al campo de búsqueda. Por último, al crear un campo de búsqueda, puede configurarlo opcionalmente para que admita varios valores. Al hacerlo, la lista resultante muestra una casilla junto a cada elemento de lista y puede activar o borrar tantos elementos como sea necesario. Esta ilustración ilustra una lista típica de varios valores:
Para obtener información sobre cómo crear campos de búsqueda multivalor y usar las listas resultantes, vea Crear o eliminar un campo multivalor. |
Cómo afectan las propiedades de campo de tabla a la forma de escribir datos
Además de los principios de diseño que controlan la estructura de una base de datos y los tipos de datos que controlan lo que puede introducir en un campo determinado, varias propiedades de campo también pueden afectar a la forma en que se escriben datos en una base de datos de Access.
Ver las propiedades de un campo de tabla
Access proporciona dos maneras de ver las propiedades de un campo de tabla.
En la vista Hoja de datos
- Abra la tabla en la Vista Hoja de datos.
- Haga clic en la pestaña Campos y use los controles del grupo Formato para ver las propiedades de cada campo de tabla.
En la vista Diseño
- Abra la tabla en la Vista Diseño.
- En la parte inferior de la cuadrícula, haga clic en la pestaña General , si aún no está seleccionada.
- Para ver las propiedades de un campo de búsqueda, haga clic en la pestaña Búsqueda .
Cómo afectan las propiedades a la entrada de datos
En la tabla siguiente se enumeran las propiedades que tienen el mayor impacto en la entrada de datos y se explica cómo afectan a la entrada de datos.
| Propiedad | Ubicación en la cuadrícula de diseño de la tabla | Posibles valores | Comportamiento al intentar escribir datos |
|---|---|---|---|
| Tamaño de campo | Pestaña General | 0-255 | El límite de caracteres solo se aplica a los campos establecidos en el tipo de datos Texto. Si intenta escribir más caracteres del especificado, el campo los corta. |
| Requerido | Pestaña General | Sí/No | Cuando está activada, esta propiedad le obliga a escribir un valor en un campo y Access no le permitirá guardar ningún dato nuevo hasta que complete un campo obligatorio. Cuando está desactivado, el campo aceptará valores nulos, lo que significa que el campo puede permanecer en blanco. Un valor nulo no es lo mismo que un valor cero. Cero es un dígito y "null" es un valor que falta, no está definido o es desconocido. |
| Permitir cadenas de longitud cero | Pestaña General | Sí/No | Cuando está activada, puede escribir cadenas de longitud cero, cadenas que no contienen caracteres. Para crear una cadena de longitud cero, escriba un par de comillas dobles en el campo (""). |
| Indexado | Pestaña General | Sí/No | Al indexar un campo de tabla, Access evita agregar valores duplicados. También puede crear un índice a partir de más de un campo. Si lo hace, puede duplicar los valores en un campo, pero no en ambos. |
| Máscara de entrada | Pestaña General | Conjuntos predefinidos o personalizados de caracteres literales y de marcador de posición | Una máscara de entrada le obliga a escribir los datos en un formato predefinido. Las máscaras aparecen al seleccionar un campo en una tabla o un control en un formulario. Por ejemplo, supongamos que hace clic en un campo de fecha y ve este conjunto de caracteres: MMM-DD-YYYY. Esa es una máscara de entrada. Le obliga a escribir los valores del mes como abreviaturas de tres letras, como OCT, y el valor del año como cuatro dígitos, por ejemplo, 15-OCT-2017. Las máscaras de entrada solo controlan cómo se escriben los datos, no cómo Access los almacena ni los muestra. Para obtener más información, vea Controlar los formatos de entrada de datos con máscaras de entrada y Dar formato a un campo de fecha y hora. |
| Limitar a lista | Pestaña Búsqueda | Sí/No | Habilita o deshabilita los cambios en los elementos de un campo de búsqueda. En ocasiones, los usuarios intentan cambiar manualmente los elementos de un campo de búsqueda. Cuando Access le impide cambiar los elementos de un campo, esta propiedad se establece en Sí. Si esta propiedad está habilitada y necesita cambiar los elementos de una lista, debe abrir la lista (si desea editar una lista de valores) o la tabla que contiene los datos de origen de la lista (si desea editar un campo de búsqueda) y cambiar los valores allí. |
| Permitir ediciones de listas de valor | Pestaña Búsqueda | Sí/No | Habilita o deshabilita el comando Editar elementos de lista para las listas de valores, pero no para los campos de búsqueda. Para habilitar ese comando para los campos de búsqueda, escriba un nombre de formulario válido en la propiedad Editar formulario de elementos de lista . El comando Permitir ediciones de lista de valores aparece en un menú contextual que se abre haciendo clic con el botón secundario en un cuadro de lista o control de cuadro combinado. Al ejecutar el comando, aparece el cuadro de diálogo Editar elementos de lista . Como alternativa, si especifica el nombre de un formulario en la propiedad Editar formulario de elementos de lista , Access iniciará ese formulario en lugar de mostrar el cuadro de diálogo. Puede ejecutar el comando Editar elementos de lista desde los controles de cuadro de lista y cuadro combinado situados en formularios, así como desde los controles de cuadro combinado situados en tablas y conjuntos de resultados de consulta. Los formularios deben estar abiertos en la vista Diseño o en la vista Examinar; las tablas y los conjuntos de resultados de consulta deben estar abiertos en la vista Hoja de datos. |
| Formulario de edición de elementos de lista | Pestaña Búsqueda | Nombre de un formulario de entrada de datos | Si escribe el nombre de un formulario de entrada de datos como valor en esta propiedad de tabla, ese formulario se abre cuando un usuario ejecuta el comando Editar elementos de lista . De lo contrario, el cuadro de diálogo Editar elementos de lista aparece cuando los usuarios ejecutan el comando. |
Usar actualizaciones en cascada para cambiar los valores de clave principal y externa
A veces es posible que deba actualizar un valor de clave principal. Si usa esa clave principal como una clave externa, puede actualizar automáticamente los cambios en todas las instancias secundarias de la clave externa.
Como recordatorio, una clave principal es un valor que identifica de forma única cada fila (registro) en una tabla de base de datos. Una clave externa es una columna que coincide con la clave principal. Normalmente, las claves externas residen en otras tablas y le permiten crear una relación (un vínculo) entre los datos de las tablas.
Por ejemplo, supongamos que usa un número de identificación de producto como clave principal. Un número de identificación identifica de forma exclusiva un producto. También puede usar ese número de identificador como una clave externa en una tabla de datos de pedidos. De esa manera, puede encontrar todos los pedidos que involucran a cada producto, porque cada vez que alguien realiza un pedido de ese producto, la identificación pasa a formar parte del pedido.
A veces, esos números de Id. (u otros tipos de claves principales) cambian. Cuando lo hagan, puede modificar el valor de la clave principal y hacer que ese cambio se aplique automáticamente en cascada a todos los registros secundarios relacionados. Para habilitar este comportamiento, active la integridad referencial y las actualizaciones en cascada entre las dos tablas.
Recuerde estas importantes reglas:
- Las actualizaciones en cascada solo se pueden habilitar para los campos de clave principal establecidos en los tipos de datos Texto o Número. No se pueden usar actualizaciones en cascada para los campos establecidos en el tipo de datos Autonumeración.
- Puede habilitar las actualizaciones en cascada solo entre tablas con una relación de uno a varios.
Para obtener más información sobre cómo crear relaciones. vea Guía de relaciones de tabla y Crear, editar o eliminar una relación.
Los siguientes procedimientos van de la mano y explican cómo crear primero una relación y, a continuación, habilitar las actualizaciones en cascada para esa relación.
Crear la relación
- En el grupo Mostrar u ocultar de la pestaña Herramientas de base de datos, haga clic en Relaciones.
- En la pestaña Diseño , en el grupo Relaciones , haga clic en Agregar tablas (Mostrar tabla en Access).
- Seleccione la pestaña Tablas , seleccione las tablas que desee cambiar, haga clic en Agregar y, después, haga clic en Cerrar.
Puede presionar Mayús para seleccionar varias tablas o puede agregar cada una de ellas individualmente. Seleccione solo las tablas en los lados "uno" y "varios" de la relación. - En la ventana Relaciones , arrastre la clave principal de la tabla en el lado "uno" de la relación y suéltela en el campo de clave externa de la tabla en el lado "varios" de la relación.
Aparecerá el cuadro de diálogo Modificar relaciones. En la siguiente figura se muestra el cuadro de diálogo:
- Active la casilla Exigir integridad referencial y haga clic en Crear.
Habilitar actualizaciones en cascada en claves principales
- En el grupo Mostrar u ocultar de la pestaña Herramientas de base de datos, haga clic en Relaciones.
- Aparece la ventana Relaciones y muestra las combinaciones (que se muestran como líneas de conexión) entre las tablas de la base de datos. La siguiente figura muestra una relación típica:
- Haga clic con el botón derecho en la línea de combinación entre las tablas principal y secundaria y, después, haga clic en Editar relación.
Aparecerá el cuadro de diálogo Modificar relaciones. En la siguiente figura se muestra el cuadro de diálogo:
- Seleccione Actualizar en cascada los campos relacionados, asegúrese de que la casilla Exigir integridad referencial esté activada y haga clic en Aceptar.
Por qué los números de identificación a veces parecen omitir un número
Cuando se crea un campo con el tipo de datos Autonumeración, Access genera automáticamente un valor para ese campo en cada nuevo registro. El valor se incrementa de forma predeterminada, de modo que cada nuevo registro obtiene el siguiente número secuencial disponible. El propósito del tipo de datos Autonumeración es proporcionar un valor que sea adecuado para su uso como clave principal. Para obtener más información, vea Agregar, establecer, cambiar o quitar la clave principal.
Cuando elimina una fila de una tabla que contiene un campo establecido en el tipo de datos Autonumeración, el valor del campo Autonumeración para esa fila no siempre se reutiliza automáticamente. Por ese motivo, es posible que el número que Access genere no sea el número que espera ver y que aparezcan huecos en la secuencia de números de identificación, esto es así por motivos de diseño. Debe confiar solo en la singularidad de los valores de un campo Autonumeración y no en su secuencia.
Actualización masiva de datos mediante consultas
Las consultas de anexado, actualización y eliminación son formas eficaces de agregar, cambiar o quitar registros en masa. Además, las actualizaciones masivas son más fáciles y eficaces cuando se usan buenos principios de diseño de base de datos. El uso de una consulta de datos anexados, de actualización o de eliminación puede ahorrarle tiempo, ya que también puede reutilizar la consulta.
Importante Realice una copia de seguridad de sus datos antes de usar estas consultas. Tener una copia de seguridad a mano puede ayudarle a corregir rápidamente cualquier error que pueda cometer accidentalmente.
Anexar consultas Se usa para agregar muchos registros a una o más tablas. Uno de los usos más frecuentes de una consulta de datos anexados es agregar un grupo de registros de una o más tablas de una base de datos de origen a una o más tablas de una base de datos de destino. Por ejemplo, supongamos que adquiere algunos clientes nuevos y una base de datos que contiene una tabla de información sobre esos clientes. Para evitar especificar los nuevos datos manualmente, puede anexarlos a la tabla o tablas apropiadas de la base de datos. Para obtener más información, consulte Agregar registros a una tabla mediante una consulta de datos anexados.
Consultas de actualización Se usa para agregar, cambiar o eliminar parte (pero no todos) de muchos registros existentes. Se trata de una especie de cuadro de diálogo Buscar y reemplazar avanzado. Especifique un criterio de selección (el equivalente aproximado de una cadena de búsqueda) y un criterio de actualización (el equivalente aproximado de una cadena de reemplazo). A diferencia del cuadro de diálogo, las consultas de actualización pueden aceptar varios criterios, permiten actualizar un gran número de registros de una sola pasada y permiten cambiar los registros en más de una tabla. Para obtener más información, vea Crear y ejecutar una consulta de actualización.
Eliminar consultas Cuando desea eliminar rápidamente una gran cantidad de datos o eliminar un conjunto de datos de forma periódica, una eliminación es útil porque las consultas permiten especificar criterios para buscar y eliminar rápidamente los datos. Para obtener más información, consulte Formas de agregar, editar y eliminar registros.