Access le proporciona varias herramientas que le ayudan a crear rápidamente informes atractivos y fáciles de leer que presentan los datos de la manera que mejor se adapta a las necesidades de sus usuarios. Puede usar los comandos de la pestaña Crear para crear un informe sencillo con un solo clic. Puede usar el Asistente para informes para crear un informe más complicado, o puede crear un informe agregando todos los datos y elementos de formato usted mismo. Cualquiera que sea el método que elija, probablemente realizará al menos algunos cambios en el diseño del informe para que muestre los datos de la manera que desea. En este artículo se describe el proceso general de diseñar un informe y, después, se muestra cómo agregar elementos de diseño específicos al informe.
En este artículo
- Decida cómo diseñar el informe
- Usar diseños de control para alinear los datos
- Agregar o quitar secciones de encabezado y pie de página o informe
- Sugerencias para dar formato a diferentes tipos de datos
Decida cómo diseñar el informe
Al diseñar un informe, primero debe considerar cómo quiere organizar los datos en la página y cómo se almacenan en la base de datos. Durante el proceso de diseño, es posible que incluso descubra que la disposición de los datos en las tablas no le permitirá crear el informe que desea. Esto puede indicar que las tablas no están normalizadas (esto significa que los datos no se almacenan de la manera más eficaz).
Crear un boceto del informe
Este paso no es necesario: es posible que descubra que el Asistente para informes de Access o la herramienta Informe (ambas disponibles en la pestaña Crear , en el grupo Informes ) proporcionan un diseño inicial suficiente para el informe. Sin embargo, si decide diseñar el informe sin usar estas herramientas, puede resultarle útil hacer un boceto del informe en una hoja de papel dibujando un cuadro donde va cada campo y escribiendo el nombre del campo en cada cuadro. Como alternativa, puede usar programas como Word o Visio para crear una maqueta del informe. Independientemente del método que use, asegúrese de incluir suficientes filas para indicar cómo se repiten los datos.
Por ejemplo, puedes usar una fila para información del producto, después varias filas repetidas para las ventas de ese producto y, por último, una fila de totales de ventas para el producto. A continuación, la secuencia se repite para el siguiente producto y así sucesivamente hasta el final del informe. O tal vez su informe sea una simple lista de los datos de la tabla, en cuyo caso su boceto puede contener solo una serie de filas y columnas.
Nota
Esta técnica también es muy útil si está diseñando un informe para otra persona. En este caso, la otra persona puede dibujar el boceto antes de empezar a trabajar.
Después de crear el boceto, determine qué tabla o tablas contienen los datos que desea mostrar en el informe. Si todos los datos están en una sola tabla, puede basar el informe directamente en esa tabla. Con frecuencia, los datos que desea se almacenan en varias tablas que debe reunir en una consulta antes de que pueda mostrarse en el informe. La consulta se puede incrustar en la propiedad RecordSource del informe, o bien puede crear una consulta independiente guardada y basar el informe en ella.
Decida qué datos incluir en cada sección del informe
Cada informe tiene una o más secciones de informe. La única sección que está presente en cada informe es la sección de detalles. Esta sección se repite una vez para cada registro de la tabla o consulta en la que se basa el informe. Otras secciones son opcionales, se repiten con menos frecuencia y suelen usarse para mostrar información que es común a un grupo de registros, una página del informe o todo el informe.
En la tabla siguiente se describe dónde se encuentra cada sección y cómo se usa normalmente.
| Sección | Ubicación | Contenido típico |
|---|---|---|
| Sección del encabezado del informe | Aparece solo una vez, en la parte superior de la primera página del informe. |
|
| Sección de pie de informe | Aparece después de la última línea de datos, encima de la sección pie de página de la última página del informe. | Totales de informes (sumas, recuentos, promedios, etc.) |
| Sección de encabezado de página | Aparece en la parte superior de cada página del informe. |
|
| Sección de pie de página | Aparece en la parte inferior de cada página del informe. |
|
| Sección de encabezado de grupo | Aparece justo antes de un grupo de registros. | El campo en el que se está agrupando |
| Sección de pie de grupo | Aparece justo después de un grupo de registros. | Totales de grupo (sumas, recuentos, promedios, etc.) |
Para obtener información sobre cómo agregar o quitar secciones de encabezado y pie de página o secciones de encabezado y pie de página, vea la sección Agregar o quitar secciones de encabezado y pie de página de informe de este artículo. Puede agregar secciones de encabezado y pie de página de grupo mediante el panel Agrupación, Orden y Total en las vistas Presentación o Diseño.
Decidir cómo organizar los datos de detalle
La mayoría de los informes se organizan en formato tabular o apilado, pero Access le ofrece la flexibilidad de usar casi cualquier disposición de registros y campos que desee.
Diseño tabular Un diseño tabular es similar a una hoja de cálculo. Las etiquetas están en la parte superior y los datos se alinean en columnas debajo de las etiquetas. Tabular se refiere a la apariencia de tabla de los datos. Este es el tipo de informe que Access crea al hacer clic en Informe en el grupo Informes de la pestaña Crear . El diseño tabular es útil si el informe contiene un número relativamente reducido de campos que desea mostrar en un formato de lista simple. La siguiente ilustración muestra un informe de empleado creado con un diseño tabular.
Diseño apilado Un diseño apilado se asemeja a un formulario que rellena al abrir una cuenta bancaria o realizar una compra en un minorista en línea. Cada dato se etiqueta y los campos se apilan uno encima del otro. Este diseño es adecuado para los informes que contienen demasiados campos como para mostrarlos en formato tabular, es decir, el ancho de las columnas superaría el ancho del informe. La siguiente ilustración muestra un informe de empleado creado con un diseño apilado.
Nota
En el Asistente para informes, este diseño se conoce como diseño de columnas.
Diseño mixto Puede mezclar elementos de diseños tabulares y apilados. Por ejemplo, para cada registro, puede organizar algunos de los campos en una fila horizontal en la parte superior de la sección de Detalles y organizar otros campos del mismo registro en uno o más diseños apilados debajo de la fila superior. La siguiente ilustración muestra un informe de empleado creado con un diseño mixto. Los campos Id., Apellidos y Nombre están organizados en un diseño de control tabular, y los campos Puesto de trabajo y Teléfono profesional están organizados en un diseño apilado. En este ejemplo, las líneas de cuadrícula se usan para proporcionar una separación visual de los campos para cada empleado.
Diseño justificado Si usa el Asistente para informes para crear el informe, puede elegir usar un diseño justificado. Este diseño utiliza todo el ancho de la página para mostrar los registros de la forma más compacta posible. Por supuesto, puede lograr los mismos resultados sin usar el Asistente para informes, pero puede ser un proceso laborioso alinear los campos exactamente. La siguiente ilustración muestra un informe de empleado creado con el diseño justificado del Asistente para informes.
El diseño justificado es un buen diseño para usar si va a mostrar un gran número de campos en el informe. En el ejemplo anterior, si usa un diseño tabular para mostrar los mismos datos, los campos se extienden fuera del borde de la página. Si se usa un diseño apilado, cada registro ocupa mucho más espacio vertical, lo que desperdicia papel y hace que el informe sea más difícil de leer.
Usar diseños de control para alinear los datos
Los diseños de control son guías que puede agregar a un informe mientras está abierto en las vistas Presentación o Diseño. Access agrega diseños de control automáticamente cuando se usa el Asistente para informes para generar un informe, o bien cuando se crea un informe, al hacer clic en Informe en el grupo Informes de la pestaña Crear . Un diseño de control es como una tabla, cada celda de la cual puede contener una etiqueta, un cuadro de texto o cualquier otro tipo de control. En la ilustración siguiente se muestra un diseño de control tabular en un informe.
Las líneas naranjas indican las filas y columnas del diseño de control y solo son visibles cuando el informe está abierto en las vistas Presentación o Diseño. Los diseños de control permiten lograr una alineación uniforme de los datos en las filas y columnas y facilitan la adición, el cambio de tamaño o la eliminación de campos. Mediante el uso de las herramientas de los grupos Tabla y Posición de la pestaña Organizar (disponibles en la vista Presentación o en la vista Diseño), puede cambiar un tipo de diseño de control a otro, así como quitar controles de las presentaciones para poder colocar los controles en el lugar del informe que desee.
Agregar o quitar secciones de encabezado y pie de página o informe
Como se mencionó anteriormente en este artículo, los encabezados y pies de página son secciones del informe que puede usar para mostrar información que es común a todo el informe o a cada página de un informe. Por ejemplo, puede agregar una sección de pie de página para mostrar un número de página en la parte inferior de cada página, o puede agregar una sección de encabezado de informe para mostrar un título para todo el informe.
Agregar secciones de encabezado y pie de página o informe
En el panel de navegación, haga clic con el botón secundario en el informe que quiera cambiar y después haga clic en Vista Diseño en el menú contextual.
Compruebe qué secciones ya están en el informe. Las secciones están separadas por barras horizontales sombreadas denominadas selectores de sección. La etiqueta en cada selector de sección indica cuál es la sección directamente debajo de ella.
Cada informe tiene una sección de detalles y también puede contener secciones de encabezado de informe, encabezado de página, pie de página y pie de página. Además, si hay niveles de agrupación en el informe, es posible que vea encabezados o pies de página de grupo (como el encabezado Archivo como que se muestra en la ilustración anterior). De forma predeterminada, los encabezados y pies de página de grupo se nombran con el nombre de campo o la expresión que es la base del grupo. En este caso, el nombre del campo de agrupación es "Archivo como".Para agregar secciones de encabezado y pie de página o secciones de encabezado y pie de página al informe, haga clic con el botón secundario en cualquier selector de sección y, a continuación, haga clic en Encabezado o pie de página o en Encabezado o pie de página o Pie de página en el menú contextual.
Precaución
Si la sección ya está presente en el informe, Access le advertirá de que eliminará la sección existente y los controles que contiene.
Ahora puede mover los controles existentes o agregar nuevos controles a las secciones nuevas.
Access siempre agrega secciones de encabezado y pie de página e informe en pares. Es decir, no puede agregar una sección de encabezado de página o informe sin agregar también la sección de pie de página correspondiente. Si no necesita ambas secciones, no puede eliminar una sección, pero puede cambiar el tamaño de la sección no utilizada a una altura de cero (0) para evitar agregar espaciado vertical adicional al informe. Coloque el puntero en la parte inferior de la sección sin usar hasta que se convierta en una flecha
de dos puntas y, a continuación, arrastre hacia arriba hasta que la sección quede oculta. Si hay algún control en la sección, debe eliminarlo para poder ocultarla por completo.
Quitar secciones de encabezado y pie de página o informe
- En el panel de navegación, haga clic con el botón secundario en el informe que quiera cambiar y después haga clic en Vista Diseño en el menú contextual.
- Haga clic con el botón secundario en cualquier selector de sección y, después, haga clic en Encabezado o pie de página o en Encabezado o pie de informe en el menú contextual.
Si va a quitar un par de encabezado y pie de página y esas secciones contienen controles, Access le advierte de que al eliminar las secciones también se eliminarán los controles y que no podrá deshacer la acción. Haga clic en Sí para quitar las secciones y eliminar los controles, o haga clic en No para cancelar la operación.
Sugerencias para dar formato a diferentes tipos de datos
Al crear un informe mediante la herramienta Informe (disponible en la pestaña Crear , en el grupo Informes ) o mediante el Asistente para informes, Access agrega los campos al informe por usted y crea el control más adecuado para mostrar cada campo, en función del tipo de datos del campo. Si va a agregar campos a un informe usted mismo, el método preferido es arrastrar cada campo de la lista de campos al informe. Al igual que con el Asistente para informes o la herramienta Informes , Access crea el control más adecuado para cada campo, según el tipo de datos del campo. Para la mayoría de los tipos de datos, el control (predeterminado) más adecuado es el cuadro de texto.
En las secciones siguientes se proporcionan sugerencias sobre cómo dar formato a algunos de los tipos de datos de casos especiales.
Campos multivalor El control predeterminado para un campo multivalor es un cuadro combinado. Esto puede parecer una elección extraña para un control de un informe, ya que no se puede hacer clic en la flecha de un cuadro combinado de un informe. Sin embargo, en el contexto de un informe, un cuadro combinado se comporta como un cuadro de texto. La flecha solo está visible en la vista Diseño.
Si el campo contiene varios valores, estos se separan con comas. Si el cuadro combinado no es lo suficientemente ancho para mostrar todos los valores en una línea y la propiedad CanGrow del cuadro combinado está establecida en Sí, los valores se ajustarán a la línea siguiente. De lo contrario, los valores se truncan. Para establecer la propiedad CanGrow para un control, abra el informe en la vista Diseño o Presentación, haga clic en el control y, después, presione F4 para mostrar la hoja de propiedades del control. La propiedad CanGrow se encuentra tanto en la pestaña Formato como en la pestaña Todos de la hoja de propiedades del control.
Campos de texto enriquecido El control predeterminado para un campo de texto enriquecido es un cuadro de texto. Si el cuadro de texto no es lo suficientemente ancho para mostrar todos los valores en una línea y la propiedad CanGrow del cuadro de texto está establecida en Sí, los valores se ajustarán a la línea siguiente. De lo contrario, los valores se truncan. Para establecer la propiedad CanGrow para un control, abra el informe en la vista Diseño o Presentación, haga clic en el control y, después, presione F4 para mostrar la hoja de propiedades del control. La propiedad CanGrow se encuentra tanto en la pestaña Formato como en la pestaña Todos de la hoja de propiedades del control.
Un campo de texto enriquecido le ayuda a dar formato al texto de varias formas. Por ejemplo, varias palabras de un campo se pueden subrayar y varias otras palabras del mismo campo pueden estar en cursiva. Sin embargo, puede establecer un estilo de formato general para el cuadro de texto que contiene el texto enriquecido. El formato del cuadro de texto solo se aplica al texto al que no se ha aplicado un formato específico con el formato de texto enriquecido.
Establecer estilos de formato para un cuadro de texto que muestra un campo de texto enriquecido
- Haga clic con el botón secundario en el informe en el panel de navegación y, a continuación, haga clic en Vista Presentación en el menú contextual.
- Haga clic en el cuadro de texto que muestra el campo de texto enriquecido y, a continuación, en la pestaña Formato , en el grupo Fuente , haga clic en el estilo de formato que desea aplicar.
Access aplica el formato a todo el texto del campo de texto enriquecido que aún no tenga aplicado ese tipo (pero no valor) de formato en una vista que admita la entrada de datos, como la vista Hoja de datos para una tabla o consulta, o la vista Formulario para un formulario. Por ejemplo, si una parte del texto del campo tiene formato de color de fuente rojo y aplica un color de fuente azul al cuadro de texto, Access convierte todo el texto en azul excepto el que se ha aplicado individualmente a rojo. Como otro ejemplo, si una parte del texto del campo tiene un formato de fuente de 11 puntos y aplica un tamaño de fuente de 14 puntos al cuadro de texto, Access aplica el tamaño de fuente de 14 puntos a todo el texto excepto al que se ha aplicado individualmente a 11 puntos.
Campos de datos adjuntos Los campos de datos adjuntos utilizan un control especial que no se utiliza para ningún otro tipo de datos. Puede adjuntar varios archivos a un registro utilizando un único campo de datos adjuntos, pero el campo solo puede mostrar información sobre los datos adjuntos de uno en uno. De forma predeterminada, el control de datos adjuntos muestra un icono o una imagen, según el tipo de archivo de los datos adjuntos que muestra actualmente el control. Si lo desea, puede establecer las propiedades del control de datos adjuntos para que todos los archivos adjuntos se muestren como iconos o para que el campo muestre simplemente un icono de clip y el número de datos adjuntos. Suponiendo que ya usa un control de datos adjuntos en el informe, puede usar el procedimiento siguiente para ajustar las propiedades del control para distintos usos del control.
Establecer las propiedades de pantalla de un campo de datos adjuntos
Haga clic con el botón secundario en el informe en el panel de navegación y, a continuación, haga clic en Vista Presentación en el menú contextual.
Haga clic en el control de datos adjuntos. Si no se muestra la Hoja de propiedades, presione F4 para mostrarla. En la hoja de propiedades, haga clic en la pestaña Formato .
Use la tabla siguiente como guía para configurar las propiedades del control de datos adjuntos.Propiedad Opción Mostrar como - Imagen/Icono muestra gráficos como imágenes y todos los demás archivos como iconos. Esta es la opción predeterminada.
- El icono muestra todos los archivos como iconos.
- El clip muestra un icono de clip seguido del número de datos adjuntos entre paréntesis.
Imagen predeterminada Para que aparezca una imagen predeterminada en el control de datos adjuntos cuando no haya archivos adjuntos, haga clic en el
en el cuadro de propiedades, busque la imagen que desee y, después, haga clic en Abrir.
Nota: La imagen predeterminada no se muestra si la propiedad Mostrar como está configurada en Clip.Alineación de imagen Seleccione la alineación que desee de la lista. La configuración predeterminada es Centrar. El ajuste de esta configuración puede producir resultados inesperados, en función de la configuración de la propiedad Modo de tamaño de imagen . Modo de tamaño de imagen Esta configuración solo está disponible si la propiedad Mostrar como está establecida en Imagen/Icono. - Clip muestra la imagen en su tamaño real. La imagen se recorta si es demasiado grande para caber dentro del control.
- Expandir estira la imagen para que llene todo el control. A menos que el control de datos adjuntos tenga exactamente el mismo tamaño que la imagen, al usar esta configuración se distorsionará la imagen y se hará que aparezca estirada vertical u horizontalmente.
- El zoom muestra la imagen lo más grande posible sin recortar ni distorsionar la imagen. Esta es la opción predeterminada.
Si usa el control para mostrar gráficos, ajuste el tamaño del control de datos adjuntos para que pueda ver el nivel de detalle que desee.