En este tema, se tratan los escenarios comunes del error #¡VALOR! al trabajar en la función SUMAPRODUCTO.

Problema: Los argumentos de matriz no tienen la misma dimensión

Todos los argumentos de matriz deben tener la misma dimensión. Si no lo están, entonces obtienes la #VALUE. . Por ejemplo, si Matriz 1 hace referencia a un rango de 3 filas y 2 columnas, la matriz 2 también debe corresponder al rango similar.

La fórmula SUMAPRODUCTO que provoca un error es =SUMAPRODUCTO(D2:D13,E2:E10): E10 necesita cambiarse a E13 para que coincida con el primer rango.
  • =SUMAPRODUCTO(D2:D13,E2:E10)

Producirá un error ya que los rangos a los que se hace referencia no tienen el mismo número de filas (13 en el primer rango pero solo 10 en el segundo).

Solución: Cambie la fórmula a:

  • =SUMAPRODUCTO(D2:D13,E2:E13)

De esta manera, los dos rangos tienen el mismo número de filas de inicio y final, y puede volver a probar la fórmula.

Resolver el error #¡VALOR! en los datos para resolver el error de SUMAPRODUCTO

Problema: Una o más celdas del rango contienen texto

Si una o más celdas del rango al que se hace referencia contienen texto o tienen formato de tipo de datos Texto, recibirá la #VALUE! . El texto podría ser el resultado de un cálculo de otra fórmula, o quizás la celda simplemente no tenga el formato correcto.

La fórmula de la celda E15 muestra un error #¡VALOR! porque existe un error #¡VALOR! en la columna E.

Solución: Compruebe todas las celdas que contienen texto o que tienen formato de texto y establezca el tipo de datos correcto.

¿Tiene alguna pregunta sobre una función específica?

Publique una pregunta en el foro de la comunidad de Excel

¿Necesita más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

Vea también

Corregir un error #¡VALOR! error

Función SUMAPRODUCTO

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Detectar errores en fórmulas

Todas las funciones de Excel (orden alfabético)

Todas las funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×