Si PROMEDIO o SUMA hacen referencia a celdas que contienen #VALUE! errores, las fórmulas darán como resultado un #VALUE! .

Error #¡VALOR! en la función PROMEDIO

Para omitir los valores de error, crearemos una fórmula que ignora los errores en el rango de referencia mientras calcula el promedio con los valores "normales" restantes.

Para trabajar en este escenario, usamos una combinación de PROMEDIO junto con SI y ESERROR para determinar si existe un error en el rango especificado. Este escenario concreto necesita una fórmula de matriz:

=PROMEDIO(SI(ESERROR(B2:D2),"",B2:D2))

Esta es una fórmula de matriz. Por lo tanto, debe presionar ENTRAR (solo si usa Microsoft 365 ) o CTRL+MAYÚS+ENTRAR en la fórmula.

Nota: Si tiene una versión actual de Microsoft 365, simplemente puede escribir la fórmula en la celda de salida y, a continuación, presione ENTRAR para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe escribirse como una fórmula de matriz heredada seleccionando primero la celda de salida, especificando la fórmula en la celda de salida y presionando CTRL+MAYÚS+ENTRAR para confirmarla. Excel inserta llaves al principio y al final de la fórmula por usted. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

Función matriz en PROMEDIO para resolver el #VALUE! error

Nota: La función anterior no solo funcionará para el error #¡VALOR!, sino también para #N/A, #NULL y #¡DIV/0! entre otros.

También puede usar SUMA de la misma manera:

=SUMA(SI(ESERROR(B2:D2),"",B2:D2))

¿Tiene alguna pregunta sobre una función específica?

Publique una pregunta en el foro de la comunidad de Excel

¿Necesita más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

Vea también

Corregir un error #¡VALOR! error

Función PROMEDIO

Función SUMA

Información general sobre fórmulas en Excel

Detectar errores en fórmulas

Todas las funciones de Excel (orden alfabéticos)

Todas las funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×