Un escenario es un conjunto de valores que Excel guarda y puede sustituir automáticamente en la hoja de cálculo. Puede crear y guardar diferentes grupos de valores como escenarios y, a continuación, cambiar entre estos escenarios para ver los diferentes resultados.

Si varias personas tienen información específica que desea usar en escenarios, puede recopilar la información en libros independientes y, a continuación, combinar los escenarios de los distintos libros en uno.

Después de tener todos los escenarios que necesita, puede crear un informe de resumen del escenario que incorpore información de todos los escenarios.

Los escenarios se administran con el asistente administrador de escenarios desde el grupo Análisis de hipótesis de la pestaña Datos.

Hay tres tipos de herramientas de What-If de análisis que vienen con Excel: Escenarios,Tablas de datos y Buscar objetivo. Los escenarios y las tablas de datos llevan conjuntos de valores de entrada y proyecto hacia adelante para determinar los posibles resultados. Buscar objetivo difiere de Escenarios y Tablas de datos en que se necesita un resultado y proyectos hacia atrás para determinar los posibles valores de entrada que producen ese resultado.

Cada escenario puede dar cabida a un máximo de 32 valores de variables. Si desea analizar más de 32 valores y los valores representan solo una o dos variables, puede usar tablas de datos. Aunque solo se limita a una o dos variables (una para la celda de entrada de fila y otra para la celda de entrada de columna), una tabla de datos puede incluir tantos valores de variables diferentes como desee. Un escenario puede tener un máximo de 32 valores diferentes, pero puede crear tantos escenarios como desee.

Además de estas tres herramientas, puede instalar complementos que le ayuden a realizar análisis What-If, como el complemento Solver. El complemento Solver es similar a Buscar objetivo, pero puede adaptarse a más variables. También puede crear previsiones mediante el controlador de relleno y diversos comandos integrados en Excel. Para modelos más avanzados, puede usar el complemento Herramientas para análisis.

Supongamos que desea crear un presupuesto, pero no tiene certeza de sus ingresos. Mediante escenarios, puede definir diferentes valores posibles para los ingresos y, a continuación, cambiar entre escenarios para realizar análisis de hipótesis.

Por ejemplo, supongamos que su peor escenario presupuestado es Ingresos brutos de 50.000 $ y Costos de bienes vendidos de 13.200 $, dejando 36.800 $ en el Beneficio bruto. Para definir este conjunto de valores como un escenario, primero escriba los valores en una hoja de cálculo, como se muestra en la siguiente ilustración:

Escenario: configurar un escenario con celdas Cambiar y Resultado

Las celdas Cambiando tienen valores en los que escribe, mientras que la celda Resultado contiene una fórmula basada en las celdas Cambiando (en esta celda de ilustración B4 tiene la fórmula =B2-B3).

A continuación, use el cuadro de diálogo Administrador de escenarios para guardar estos valores como un escenario. Goto la pestaña Datos > What-If Análisis > Escenarios > Agregar.

Obtener acceso al Administrador de escenarios desde Data > Forecast ? What-If análisis

Asistente para el pesebre de escenarios

En el cuadro de diálogo Nombre del escenario, asigne un nombre al escenario Peor de los casos y especifique que las celdas B2 y B3 son los valores que cambian entre escenarios. Si selecciona cambiar celdas en la hoja de cálculo antes de agregar un escenario, el Administrador de escenarios insertará automáticamente las celdas por usted, de lo contrario puede escribirlas a mano o usar el cuadro de diálogo de selección de celdas a la derecha del cuadro de diálogo Cambiar celdas.

Configurar un escenario en el peor de los casos

Nota: Aunque este ejemplo contiene solo dos celdas cambiantes (B2 y B3), un escenario puede contener hasta 32 celdas.

Protección: también puede proteger los escenarios, por lo que en la sección Protección compruebe las opciones que desee o desmarque si no desea ninguna protección.

  • Seleccione Impedir cambios para evitar que se edite el escenario cuando la hoja de cálculo está protegida.

  • Seleccione Oculto para evitar que se muestre el escenario cuando la hoja de cálculo está protegida.

Nota: Estas opciones solo se aplican a hojas de cálculo protegidas. Para obtener más información sobre las hojas de cálculo protegidas, vea Proteger una hoja de cálculo

Ahora supongamos que su escenario presupuestado best case es Ingresos brutos de 150 000 $ y Costos de bienes vendidos de 26 000 $, dejando 124 000 $ en beneficio bruto. Para definir este conjunto de valores como un escenario, cree otro escenario, así como mayúsculas y minúsculas y proporcione valores diferentes para la celda B2 (150 000) y la celda B3 (26 000). Dado que el beneficio bruto (celda B4) es una fórmula (la diferencia entre Ingresos (B2) y Costos (B3), no se cambia la celda B4 para el escenario Mejor caso.

Cambiar entre escenarios

Después de guardar un escenario, estará disponible en la lista de escenarios que puede usar en los análisis de hipótesis. Dados los valores de la ilustración anterior, si opta por mostrar el escenario De mejor caso, los valores de la hoja de cálculo cambiarían para que se parezcan a la ilustración siguiente:

Mejor escenario de caso

Puede haber ocasiones en las que tenga toda la información en una hoja de cálculo o libro necesaria para crear todos los escenarios que desee tener en cuenta. Sin embargo, es posible que desee recopilar información de escenario de otros orígenes. Por ejemplo, supongamos que está intentando crear un presupuesto de la empresa. Es posible que recopile escenarios de diferentes departamentos, como Ventas, Nóminas, Producción, Marketing y Legal, ya que cada una de estas fuentes tiene información diferente para usar en la creación del presupuesto.

Puede recopilar estos escenarios en una hoja de cálculo mediante el comando Combinar. Cada origen puede proporcionar tantos o tan pocos valores de celda cambiantes como desee. Por ejemplo, es posible que desee que cada departamento proporcione proyecciones de gastos, pero solo necesita proyecciones de ingresos de unos pocos.

Cuando elija combinar, el Administrador de escenarios cargará un Asistente para escenarios de combinación,que enumerará todas las hojas de cálculo del libro activo, así como enumerará cualquier otro libro que pueda tener abierto en ese momento. El asistente le dirá cuántos escenarios tiene en cada hoja de cálculo de origen que seleccione.

Cuadro de diálogo Escenarios de combinación

Al recopilar escenarios diferentes de varios orígenes, debe usar la misma estructura de celdas en cada uno de los libros. Por ejemplo, Los ingresos siempre pueden ir en la celda B2 y Los gastos siempre pueden ir en la celda B3. Si usa diferentes estructuras para los escenarios de varios orígenes, puede ser difícil combinar los resultados.

Sugerencia: Considere primero crear un escenario usted mismo y, después, enviar a sus compañeros una copia del libro que contiene ese escenario. Esto hace que sea más fácil asegurarse de que todos los escenarios están estructurados de la misma manera.

Para comparar varios escenarios, puede crear un informe que los resuma en la misma página. El informe puede enumerar los escenarios en paralelo o presentarlos en un informe de tabla dinámica.

Cuadro de diálogo Resumen del escenario

Un informe de resumen de escenario basado en los dos escenarios de ejemplo anteriores tendría un aspecto parecido al siguiente:

Resumen del escenario con referencias de celda

Observará que Excel niveles de agrupación automáticamente, lo que expandirá y contraerá la vista a medida que haga clic en los distintos selectores.

Al final del informe de resumen aparece una nota que explica que la columna Valores actuales representa los valores de cambiar las celdas en el momento en que se creó el informe de resumen del escenario y que las celdas que cambiaron para cada escenario están resaltadas en gris.

Notas: 

  • De forma predeterminada, el informe de resumen usa referencias de celda para identificar las celdas Cambiar celdas y Celdas de resultado. Si crea rangos con nombre para las celdas antes de ejecutar el informe de resumen, el informe contendrá los nombres en lugar de las referencias de celda.

  • Los informes de escenario no se vuelven a calcular automáticamente. Si cambia los valores de un escenario, esos cambios no se mostrarán en un informe de resumen existente, pero se mostrarán si crea un nuevo informe de resumen.

  • No necesita celdas de resultados para generar un informe de resumen de escenario, pero sí las necesita para un informe de tabla dinámica de escenario.

Resumen del escenario con rangos con nombre

Informe de tabla dinámica de escenario

Principio de página

¿Necesita más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

Vea también

Tablas de datos

Búsqueda de objetivos

Introducción al Análisis de hipótesis

Definir y resolver un problema con Solver

Usar las Herramientas para análisis para realizar análisis de datos complejos

Información general sobre fórmulas en Excel

Cómo evitar la ruptura de las fórmulas

Buscar y corregir errores en fórmulas

Métodos abreviados de teclado de Excel

Funciones de Excel (por orden alfabético)

Funciones de Excel (por categoría)

¿Necesita más ayuda?

Ampliar sus conocimientos

Explorar los cursos >

Obtener nuevas características primero

Unirse a Microsoft Insider >

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×