Hemos actualizado Excel para reconocer la nueva era japonesa, que comenzó el 1 de mayo de 2019.  Esto incluye la creación del formato de números Gannen (año 1 en japonés), y ahora puede editar y guardar de forma nativa sus libros de trabajo de Excel con este formato.  

Para aplicar el formato de número Gannen, seleccione la celda o las celdas a las que se aplicará el formato y presione Ctrl + 1 . En el diálogo Formato de celdas, seleccione Fecha en la pestaña Número . Seleccione Japonés de la lista desplegable Configuración regional (ubicación) y El reinado del emperador japonés de la lista desplegable Tipo de calendario . Asegúrese de que la casilla de verificación Usar Gannen para mostrar el primer año esté marcada y, a continuación, pulse Aceptar.

Imagen del diálogo de Formato de celdas en el panel de Números con el formato de fecha Gannen aplicado.

Notas: 

  • Estamos en el proceso de implementar esto para Microsoft 365 usuarios. Para el Excel escritorio, está disponible con la versión 1909 del Canal actual (compilación 12026.20320). Estamos trabajando para habilitar esta función en otros puntos de conexión (Mac, iOS y Android) también en un futuro próximo.

  • Si no está en el Canal actual (Excel 2013, Excel 2016, Excel 2019, canal de Microsoft 365 Semi-Annual Enterprise (vista previa) o canal de Semi-Annual Enterprise Excel), o si tiene una hoja de cálculo con fórmulas, macros o formatos personalizados que dependen de la representación de la era japonesa, puede usar las opciones de formato personalizadas para la presentación de fecha de Gannen que se describe a continuación.

  • Para enviarnos comentarios acerca de lo bien que la experiencia de la era japonesa está trabajando en Excel, o para reportar cualquier problema, vaya a Excel > Archivo > Comentarios y use las opciones de Enviar una aprobación/desaprobación/sugerencia.

Mostrar Gannen con un formato de número personalizado al usar una versión anterior de Excel

  1. Seleccione la celda o rango que requiera la aplicación de formato.

  2. Presione CTRL + 1 para iniciar el diálogo Formato de celdas.

  3. Elija la pestaña Número y, después, seleccione la opción Personalizado de la sección Categoría.

  4. Copie y pegue la siguiente cadena en el cuadro de texto Escribir:

    [<=43585][$-ja-JP]ggge"?"m"?"d"?";[>=43831]ggge"?"m"?"d"?";ggg"??"m"?"d"?"

    Aplicar formato Gannen con un número personalizado desde Ctrl+1 > pestaña Número > Número personalizado.

  5. Presione Aceptar para aplicar el formato a las celdas seleccionadas.

    En el siguiente ejemplo, se puede ver cómo se mostraba la fecha antes de aplicar el formato de número personalizado:

    Imagen con fecha japonés aplicada sin Gannen

    Este es el resultado después de aplicar el formato de número personalizado:

    Imagen con Gannen aplicado

    Tenga en cuenta que el resultado tiene formato personalizado, lo que significa que algunas funciones de texto no funcionarán al hacer referencia a él. Sin embargo, muchas funciones de fecha, como DIAS.LAB(), sí que funcionarán.

Visualización de Gannen con una función de texto

También es posible mostrar el formato de fecha de Gannen con una función de texto.

En el siguiente ejemplo, las celdas A5:A13 contienen valores de fecha y la celda A2 contiene la cadena de formato que se usa en el ejemplo anterior:

[<=43585][$-ja-JP]ggge"?"m"?"d"?";[>=43831]ggge"?"m"?"d"?";ggg"??"m"?"d"?"

La fórmula =TEXTO(A5,$A$2) se ha introducido en la celda C5 y se ha copiado en las celdas C5:C13.

Imagen de la aplicación del formato Gannen con la función TEXTO: =TEXTO(A1,$B$2) donde B2 alberga la cadena de formato Gannen.

Tenga en cuenta que el resultado tiene aplicada la opción de formato General, lo que significa que muchas funciones de texto y de fecha no funcionarán al hacer referencia a esas celdas.

¿Necesita más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×