Puede hacer referencia al contenido de las celdas de otro libro creando una fórmula de referencia externa. Una referencia externa (también denominada vínculo) es una referencia a una celda o rango de una hoja de cálculo en otro libro de Excel o una referencia a un nombre definido en otro libro.

  1. Abra el libro que contendrá la referencia externa (el libro de destino) y el libro que contiene los datos a los que desea vincular (el libro de origen).

  2. Seleccione la celda o celdas donde desea crear la referencia externa.

  3. Tipo = (signo igual).

    Si desea usar una función, como SUMA, escriba el nombre de la función seguido de un paréntesis de apertura. Por ejemplo, =SUMA(.

  4. Cambie al libro de origen y, a continuación, haga clic en la hoja de cálculo que contiene las celdas que desea vincular.

  5. Seleccione la celda o celdas a las que desea vincular y presione Entrar.

    Nota: Si selecciona varias celdas, como =[SourceWorkbook.xlsx]Hoja1!$A$1:$A$10 y tiene una versión actual de Microsoft 365, simplementepuede presionar ENTRAR para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe escribirse como una fórmula de matriz heredada presionando CTRL+MAYÚS+ENTRAR. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

  6. Excel le devolverá al libro de destino y mostrará los valores del libro de origen.

  7. Tenga en cuenta que Excel devolverá el vínculo con referencias absolutas, por lo que si desea copiar la fórmula a otras celdas, deberá quitar los signos de dólar ($):

    =[SourceWorkbook.xlsx]Hoja1! $ A$1

    Si cierra el libro de origen, Excel anexará automáticamente la ruta de acceso del archivo a la fórmula:

    ='C:\Informes\[SourceWorkbook.xlsx]Hoja1'!$A$1

  1. Abra el libro que contendrá la referencia externa (el libro de destino) y el libro que contiene los datos a los que desea vincular (el libro de origen).

  2. Seleccione la celda o celdas donde desea crear la referencia externa.

  3. Tipo = (signo igual).

  4. Cambie al libro de origen y, a continuación, haga clic en la hoja de cálculo que contiene las celdas que desea vincular.

  5. Presione F3, seleccione el nombre al que desea vincular y presione Entrar.

    Nota: Si el rango con nombre hace referencia a varias celdas y tiene una versión actual de Microsoft 365 , simplementepresione ENTRAR para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe escribirse como una fórmula de matriz heredada presionando CTRL+MAYÚS+ENTRAR. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

  6. Excel le devolverá al libro de destino y mostrará los valores del rango con nombre en el libro de origen.

  1. Abra el libro de destino y el libro de origen.

  2. En el libro de destino, vaya a Fórmulas > Nombres definidos > Definir nombre.

    Grupo Nombres definidos en la cinta de opciones

  3. En el cuadro de diálogo Nuevo nombre, en el cuadro Nombre, escriba un nombre para el rango.

  4. En el cuadro Se refiere a, elimine el contenido y, a continuación, mantenga el cursor en el cuadro.

    Si desea que el nombre use una función, escriba el nombre de la función y, a continuación, coloque el cursor donde desee la referencia externa. Por ejemplo, escriba =SUMA()y, a continuación, coloque el cursor entre los paréntesis.

  5. Cambie al libro de origen y, a continuación, haga clic en la hoja de cálculo que contiene las celdas que desea vincular.

  6. Seleccione la celda o rango de celdas que desea vincular y haga clic en Aceptar.

    Agregar un nombre definido a un libro externo desde Fórmulas > nombres definidos > Definir nombre > Nuevo nombre.

Las referencias externas son especialmente útiles cuando no es práctico mantener los modelos de hoja de cálculo grandes juntos en el mismo libro.

  • Combinar datos de varios libros    Puede vincular libros de varios usuarios o departamentos y, a continuación, integrar los datos pertinentes en un libro de resumen. De este modo, cuando se cambien los libros de origen, no tendrá que cambiar manualmente el libro de resumen.

  • Crear diferentes vistas de los datos    Puede escribir todos los datos en uno o varios libros de origen y, a continuación, crear un libro de informe que contenga referencias externas solo a los datos pertinentes.

  • Simplificar modelos grandes y complejos    Al dividir un modelo complicado en una serie de libros interdependientes, puede trabajar en el modelo sin abrir todas sus hojas relacionadas. Los libros más pequeños son más fáciles de cambiar, no requieren tanta memoria y son más rápidos de abrir, guardar y calcular.

Las fórmulas con referencias externas a otros libros se muestran de dos formas, dependiendo de si el libro de origen (el que proporciona datos a una fórmula) está abierto o cerrado.

Cuando el origen está abierto, la referencia externa incluye el nombre del libro entre corchetes ([ ]), seguido del nombre de la hoja de cálculo, un signo de exclamación (! )y las celdas de las que depende la fórmula. Por ejemplo, la siguiente fórmula agrega las celdas C10:C25 del libro denominado Budget.xls.

Referencia externa

=SUMA([Budget.xlsx]Anual! C10:C25)

Cuando el origen no está abierto, la referencia externa incluye toda la ruta de acceso.

Referencia externa

=SUMA('C:\Informes\[Budget.xlsx]Anual'! C10:C25)

Nota: Si el nombre de la otra hoja de cálculo o libro contiene espacios o caracteres no alfabéticos, debe escribir el nombre (o la ruta) entre comillas simples como en el ejemplo anterior. Excel las agregará automáticamente al seleccionar el rango de origen.

Las fórmulas que vinculan a un nombre definido en otro libro usan el nombre del libro seguido de un signo de exclamación (!) y el nombre. Por ejemplo, la siguiente fórmula agrega las celdas del rango denominado Ventas desde el libro denominado Budget.xlsx.

Referencia externa

=SUMA(Budget.xlsx! Ventas)

  1. Seleccione la celda o celdas donde desea crear la referencia externa.

  2. Tipo = (signo igual).

    Si desea usar una función, como SUMA, escriba el nombre de la función seguido de un paréntesis de apertura. Por ejemplo, =SUMA(.

  3. Cambie a la hoja de cálculo que contiene las celdas a las que desea vincular.

  4. Seleccione la celda o celdas a las que desea vincular y presione Entrar.

    Nota: Si selecciona varias celdas (=Hoja1! A1:A10) y tenga una versión actual de Microsoft 365, simplemente presione ENTRAR para confirmar la fórmula como una fórmula de matriz dinámica. En caso contrario, la fórmula debe escribirse como una fórmula de matriz heredada presionando CTRL+MAYÚS+ENTRAR. Para obtener más información sobre las fórmulas de matriz, vea Directrices y ejemplos de fórmulas de matriz.

  5. Excel volverá a la hoja de cálculo original y mostrará los valores de la hoja de cálculo de origen.

Crear una referencia externa entre celdas de diferentes libros

  1. Abra el libro que contendrá la referencia externa (el libro de destino, también denominado libro de fórmulas) y el libro que contiene los datos a los que desea vincular (el libro de origen, también denominado libro de datos).

  2. En el libro de origen, seleccione la celda o celdas que desea vincular.

  3. Presione Ctrl+C o vaya a Inicio> Portapapeles> Copiar.

  4. Cambie al libro de destino y, a continuación, haga clic en la hoja de cálculo donde desea colocar los datos vinculados.

  5. Seleccione la celda donde desea colocar los datos vinculados y, a continuación, vaya a Inicio > Portapapeles > Pegar > Pegar vínculo.

  6. Excel devolverá los datos copiados del libro de origen. Si lo cambia, cambiará automáticamente en el libro de destino al actualizar la ventana del explorador.

  7. Para usar el vínculo en una fórmula, escriba = delante del vínculo, elija una función, escriba (y, a continuación, escriba ) después del vínculo.

Crear un vínculo a una hoja de cálculo en el mismo libro

  1. Seleccione la celda o celdas donde desea crear la referencia externa.

  2. Tipo = (signo igual).

    Si desea usar una función, como SUMA, escriba el nombre de la función seguido de un paréntesis de apertura. Por ejemplo, =SUMA(.

  3. Cambie a la hoja de cálculo que contiene las celdas a las que desea vincular.

  4. Seleccione la celda o celdas a las que desea vincular y presione Entrar.

  5. Excel volverá a la hoja de cálculo original y mostrará los valores de la hoja de cálculo de origen.

¿Necesitas más ayuda?

Siempre puede preguntar a un experto en la Excel Tech Community u obtener soporte técnico en la Comunidad de respuestas.

Vea también

Definir y usar nombres en fórmulas

Buscar vínculos (referencias externas) en un libro

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×