Una consulta es un conjunto de instrucciones que puede usar para trabajar con datos. Ejecute una consulta para realizar estas instrucciones. Además de devolver resultados , que se pueden ordenar, agrupar o filtrar, una consulta también puede crear, copiar, eliminar o cambiar datos.

En este artículo se explica cómo ejecutar consultas y se proporcionan solo breves información general sobre los distintos tipos de consultas. En el artículo también se debatió sobre los mensajes de error que puede encontrar al ejecutar diferentes tipos de consultas y se proporcionan los pasos que puede seguir para corregir o corregir esos errores.

En este artículo no se proporcionan instrucciones paso a paso para crear consultas.

Importante: No puede ejecutar consultas de acción si una base de datos está funcionando en modo Deshabilitado, un modo de funcionalidad reducida que Access usa para ayudar a proteger los datos en determinadas circunstancias. Es posible que vea una advertencia de cuadro de diálogo o que vea una advertencia en la barra de mensajes.

Para obtener más información sobre el modo Deshabilitado y cómo habilitar consultas de acción, vea la sección Ejecutar una consulta de acciones.

¿Qué quiere hacer?

Ejecutar una consulta de selección o de tabla de referencias cruzadas

Use consultas de selección y consultas de tabla de referencias cruzadas para recuperar y presentar datos, así como para proporcionar formularios e informes con datos. Al ejecutar una consulta de selección o de tabla de referencias cruzadas, Access muestra los resultados en Vista de hoja de datos.

Ejecutar la consulta

  1. Busque la consulta en el panel de navegación.

  2. Siga uno de estos procedimientos:

    • Haga doble clic en la consulta que desea ejecutar.

    • Haga clic en la consulta que desea ejecutar y, después, presione ENTRAR.

Si la consulta que desea ejecutar está abierta actualmente en vista Diseño, también puede ejecutarla haciendo clic en Ejecutar en el grupo Resultados de la pestaña Diseño de la cinta de opciones, parte de la interfaz de usuario de Microsoft Office Fluent.

Volver al principio

Ejecutar una consulta de acciones

Hay cuatro tipos de consultas de acción: anexar consultas, eliminar consultas, actualizar consultas y consultas de crear tabla. A excepción de las consultas de creación de tablas (que crean tablas nuevas), las consultas de acción hacen cambios en los datos de las tablas en las que se basan. Estos cambios no se pueden deshacer fácilmente, por ejemplo, presionando CTRL+Z. Si realiza cambios con una consulta de acción que posteriormente decide que no quiere realizar, normalmente tendrá que restaurar los datos de una copia de seguridad. Por este motivo, siempre debe asegurarse de que tiene una copia de seguridad nueva de los datos subyacentes antes de ejecutar una consulta de acciones.

Para mitigar el riesgo de ejecutar una consulta de acciones, primero obtenga una vista previa de los datos sobre los que se actuará. Puede realizar esto de dos maneras:

  • Vea la consulta de acciones en la vista Hoja de datos antes de ejecutarla. Para ello, abra la consulta en la vista Diseño, haga clic en Ver en el barra de estado de Access y, a continuación, haga clic en Vista Hoja de datos en el menú contextual. Para volver a la vista Diseño, haga clic en Ver de nuevo y, a continuación, haga clic en Vista Diseño en el menú contextual.

  • Cambie la consulta a una consulta de selección y, a continuación, ejecutarla.

    Nota: Asegúrese de tener en cuenta el tipo de consulta de acción (anexar, actualizar, crear tabla o eliminar) con la que está empezando, por lo que puede volver a cambiar la consulta a ese tipo después de obtener una vista previa de los datos con este método.

    Ejecutar una consulta de acción como consulta de selección

    1. Abra la consulta de acciones en la vista Diseño.

    2. En la pestaña Diseño, en el grupo Tipo de consulta, haga clic en Seleccionar.

    3. En la pestaña Diseño, en el grupo Resultados, haga clic en Ejecutar.

Ejecutar la consulta

Cuando esté listo para ejecutar una consulta de acciones, haga doble clic en ella en el panel de navegación o haga clic en ella y presione ENTRAR.

Importante: De forma predeterminada, Access deshabilita todas las consultas de acción de una base de datos a menos que indique que confía en la base de datos. Puede indicar que confía en una base de datos mediante la barra de mensajes, justo debajo de la cinta de opciones.

Barra de mensajes

Confiar en una base de datos

  1. En la barra de mensajes, haga clic en Opciones.

    Aparecerá el cuadro de diálogo de Opciones de seguridad de Microsoft Office.

  2. Seleccione Habilitar este contenido y, a continuación, haga clic en Aceptar.

Ejecutar una consulta de parámetros

Una consulta de parámetros le pide un valor al ejecutarlo. Al proporcionar el valor, la consulta de parámetros lo aplica como criterio de campo. El campo al que aplica el criterio se especifica en el diseño de la consulta. Si no proporciona un valor cuando se le solicita, la consulta de parámetros interpreta la entrada como una cadena vacía.

Una consulta de parámetros siempre es otro tipo de consulta. La mayoría de las consultas de parámetros son consultas de selección o consultas de tabla de referencias cruzadas, pero las consultas de anexar, crear tabla y actualizar también pueden ser consultas de parámetros.

Ejecute una consulta de parámetros según su otro tipo de consulta, pero, en general, use el procedimiento siguiente.

Ejecutar la consulta

  1. Busque la consulta en el panel de navegación.

  2. Siga uno de estos procedimientos:

    • Haga doble clic en la consulta que desea ejecutar.

    • Haga clic en la consulta que desea ejecutar y, después, presione ENTRAR.

  3. Cuando aparezca el mensaje de parámetro, escriba un valor para aplicarlo como criterio.

Volver al principio

Ejecutar una consulta SQL específica

Hay tres tipos principales de consulta específica de SQL: consultas de unión, consultas de paso a través y consultas de definición de datos.

Las consultas de unión combinan datos de dos o más tablas, pero no de la misma manera que otras consultas. Mientras que la mayoría de las consultas combinan datos concatenando filas, las consultas de unión combinan datos anexando filas. Las consultas de unión difieren de las consultas de datos anexados en que las consultas de unión no cambian las tablas subyacentes. Las consultas de unión anexan las filas de un conjunto de registros que no persisten después de cerrar la consulta.

El motor de base de datos que viene con Access no procesa las consultas de paso a través; en su lugar, se pasan directamente a un servidor de base de datos remoto que realiza el procesamiento y, a continuación, vuelve a pasar los resultados a Access.

Las consultas de definición de datos son un tipo especial de consulta que no procesa datos; en su lugar, las consultas de definición de datos crean, eliminan o modifican otras objetos de base de datos.

SQL consultas específicas no se pueden abrir en la vista Diseño. Solo se pueden abrir en SQL o ejecutar. A excepción de las consultas de definición de datos, la ejecución de SQL consulta específica se abre en la vista Hoja de datos.

Ejecutar la consulta

  1. Busque la consulta en el panel de navegación.

  2. Siga uno de estos procedimientos:

    • Haga doble clic en la consulta que desea ejecutar.

    • Haga clic en la consulta que desea ejecutar y, después, presione ENTRAR.

Volver al principio

Solucionar un mensaje de error

En la tabla siguiente se muestran algunos mensajes de error comunes que puede encontrar. Estos errores pueden aparecer como un mensaje en una celda (en lugar de un valor esperado) o como un mensaje de error. Las secciones que siguen a la lista incluyen procedimientos que puede usar para resolver estos errores.

Nota: Este contenido de esta tabla no es exhaustivo. Si no incluye el mensaje de error que ha recibido, puede enviar comentarios con el formulario al final de este artículo e incluir información específica sobre el mensaje de error en el cuadro de comentario proporcionado.

Mensaje de error

Problema

Solución

Error de coincidencia de tipo en la expresión

Es posible que la consulta esté uniendo campos con tipos de datos diferentes.

Compruebe el diseño de la consulta y asegúrese de que los campos unidos tienen el mismo tipo de datos. Para obtener instrucciones, vea la sección Comprobar los campos unidos de la consulta.

Registro se elimina

Esto puede ocurrir si el objeto o la base de datos están dañados.

Compactar y reparar la base de datos. Para obtener instrucciones, vea la sección Compactar y reparar la base de datos.

Referencia circular causada por alias

El alias asignado a un campo es el mismo que un componente de la expresión para ese campo.

Un alias es un nombre que se da a cualquier expresión de la fila Campo de la cuadrícula de diseño de la consulta que no es un campo real. Access le asigna el alias si no lo hace usted mismo; por ejemplo, EXPR1. Un alias es inmediatamente seguido de dos puntos (:) y, a continuación, de la expresión. Al ejecutar la consulta, el alias se convierte en el nombre de columna de la hoja de datos.

Cambiar el alias. Para obtener instrucciones, vea la sección Cambiar un alias de campo.

#Error

Este error puede producirse cuando el valor de un campo calculado es mayor que el valor permitido por la configuración de la propiedad FieldSize del campo. Esto también ocurre cuando el denominador de un campo calculado es o se evalúa como cero (0).

Asegúrese de que el denominador del campo calculado no se evalúa como cero (0). Si procede, cambie la propiedad FieldSize.

#Deleted

Se ha eliminado el registro al que se hace referencia.

Si el registro se eliminó accidentalmente, debe restaurarse a partir de una copia de seguridad. Si la eliminación fue intencionada, puede descartar este mensaje de error presionando MAYÚS+F9 para actualizar la consulta.

Comprobar los campos unidos en la consulta

Para comprobar los tipos de datos de los campos de una consulta, mire las tablas de origen en la vista Diseño e inspeccione las propiedades de los campos que está comprobando.

  1. Abra la consulta en la Vista Diseño. Las combinaciones aparecen como líneas que conectan campos en las tablas de origen. Anote los nombres de tabla y campo para cada combinación.

  2. En el panel de navegación, haga clic con el botón derecho en cada tabla que tenga uno o varios campos unidos a la consulta y, a continuación, haga clic en Vista Diseño.

    Campos combinados con diferentes tipos de datos

    1. Campos unidos con diferentes tipos de datos.

    2. Haga clic con el botón derecho en la tabla y, a continuación, haga clic en Vista Diseño.

  3. Para cada combinación, compare los valores de la columna Tipo de datos de la cuadrícula de diseño de tabla para los campos implicados en esa combinación.

    Comprobar el tipo de datos del campo combinado en la vista Diseño de la tabla

    1. Compruebe el tipo de datos de los campos unidos en la vista Diseño de tabla.

  4. Para cambiar a una tabla para que pueda ver sus campos, haga clic en la pestaña con el nombre de esa tabla.

Volver al principio

Compactar y reparar la base de datos

Ejecutar la utilidad Compactar y reparar base de datos en Access puede mejorar el rendimiento de la base de datos. Esta utilidad realiza una copia del archivo de base de datos y, si está fragmentado, reorganiza la forma en que el archivo de base de datos se almacena en el disco. Una vez completado el proceso de compactación y reparación, la base de datos compactada recuperará el espacio desperdiciado y, por lo general, será menor que el original. Al compactar la base de datos con frecuencia, puede ayudar a garantizar un rendimiento óptimo de la aplicación de base de datos y también a resolver los errores que surgen de problemas de hardware, fallos de energía o sobrecargas, y causas similares.

Una vez completada la operación compacta, se mejora la velocidad de la consulta porque los datos subyacentes se han reescrito en las tablas en páginas contiguas. Digitalizar páginas contiguas es mucho más rápido que analizar páginas fragmentadas. Las consultas también se optimizan después de cada compactación de base de datos.

Durante la operación compacta, puede usar el nombre original para el archivo de base de datos compactada o puede usar otro nombre para crear un archivo independiente. Si usa el mismo nombre y la base de datos se compacta correctamente, Access reemplaza automáticamente el archivo original por la versión compactada.

Establecer una opción que automatice este proceso

  1. Haga clic en Archivo > Opciones para abrir el cuadro de diálogo Opciones de Access.

  2. Haga clic en Base de datos actual y, en Opciones de aplicación,active la casilla Compactar al cerrar.

    Esto hace que Access compacte y repare automáticamente la base de datos cada vez que se cierra.

Compactar y reparar manualmente la base de datos

  1. Haga clic en Herramientas de base > base de datos compactar y reparar.

Volver al principio

Cambiar un alias de campo

  1. Abra la consulta en la Vista Diseño.

  2. En la cuadrícula de diseño de la consulta, busque campos con alias. Estos tendrán dos puntos al final del nombre del campo, como en Nombre:.

  3. Compruebe cada alias para asegurarse de que el alias no coincide con el nombre de ningún campo que forma parte de la expresión del alias. Si es así, cambie el alias.

Volver al principio

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Office Usuarios de Insider

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×