Se aplica a
Outlook para Microsoft 365 Outlook.com

PROBLEMA

Al agregar una cuenta de Outlook para Microsoft 365 con un dominio personalizado o una cuenta de Outlook.com con una dirección de correo electrónico personalizada, recibe el siguiente error:

Se ha producido un error al agregar su cuenta de correo electrónico a Outlook.

CAUSA

Este problema se produce porque el proceso de detección automática usado por Outlook recibe un resultado inesperado de un servidor Web de terceros cuando realiza la búsqueda del dominio raíz. Por ejemplo, es posible que Outlook reciba un resultado como https://<RootDomain>/AutoDiscover/AutoDiscover.xml. Por lo general, en este caso, la búsqueda del dominio raíz fallaba y Outlook realizaba una búsqueda de detección automática en https://AutoDiscover. <RootDomain>/AutoDiscover/AutoDiscover.xml. Sin embargo, como Outlook recibe una respuesta correcta de detección automática de la búsqueda del dominio raíz, Outlook intenta autenticarse con los protocolos anunciados, como POP e IMAP, y se produce un error en la operación.

SOLUCIÓN

Póngase en contacto con el proveedor de servicios web o el proveedor de hospedaje web del sitio web de su dominio y asegúrese de que el servidor Web no responde a las solicitudes de detección automática.

SOLUCIÓN ALTERNATIVA

Para evitar este problema si el proveedor de servicios web o el proveedor de hospedaje web no puede resolverlo, realice la siguiente acción:

  • Cree claves de registro de Outlook para excluir la última configuración buena conocida, el dominio raíz HTTPS y el registro SRV como se detalla a continuación. Una vez que las entradas del registro estén en el lugar, reinicie Outlook e intente agregar la cuenta o crear un nuevo perfil.

    • Use ExcludeLastKnownGoodUrl para evitar que Outlook use la última dirección URL de detección automática conocida HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover DWORD: ExcludeLastKnownGoodUrl Valor: 1 O bien HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover DWORD: ExcludeLastKnownGoodUrl Valor: 1

    • Use ExcludeHttpsRootDomain para evitar que Outlook use el dominio raíz https HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover DWORD: ExcludeHttpsRootDomain Valor: 1 O bien HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover DWORD: ExcludeHttpsRootDomain Valor: 1

    • Use ExcludeSrvRecord para evitar que Outlook use el dominio raíz https HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\Autodiscover DWORD: ExcludeSrvRecord Valor: 1 O bien HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Autodiscover DWORD: ExcludeSrvRecord Valor: 1

Notas: 

  • El marcador de posición x. 0 representa su versión de Office (16,0 = Office 2016, Office 365 y Office 2019, 15,0 = Office 2013).

  • Cuando el valor de ExcludeLastKnownGoodUrl se establece en 1, Outlook no usa la última dirección URL de detección automática de trabajo conocida.

Importante: Excluir el dominio raíz HTTPS no es una solución a largo plazo para este problema y no lo recomendamos. Esta solución alternativa se proporciona como alivio inmediato para el problema. Tan pronto como el proveedor de servicios web o el proveedor de hospedaje web resuelve el problema, debe quitarse la clave del registro de Outlook.

Para obtener más información sobre la detección automática y la configuración del registro, vea el comportamiento inesperado de detección automática cuando tiene la configuración del registro en la clave \Autodiscover.

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.