Al escribir una fórmula de matriz,suele usar un rango de celdas en la hoja de cálculo, pero no tiene que hacerlo. También puede usar constantes de matriz, valores que acaba de escribir en la barra de fórmulas entre llaves: {}. A continuación, puede nombrar la constante para que sea más fácil de usar de nuevo.

Puede usar constantes en las fórmulas de matriz o solo.

  1. En la fórmula de matriz, escriba una llave de apertura, los valores que desee y una llave de cierre. Este es un ejemplo: =SUMA(A1:E1*{1,2,3,4,5})

    La constante está dentro de las llaves ({)}, y sí, realmente las escribe manualmente.

  2. Escriba el resto de la fórmula y presione Ctrl+Mayús+Entrar.

    La fórmula tendrá un aspecto parecido a {=SUMA(A1:E1*{1,2,3,4,5})}y los resultados tendrán el siguiente aspecto:


    Una constante de matriz anidada en una fórmula SUMA

    La fórmula multiplicó A1 por 1 y B1 por 2, etc., lo que le ahorra tener que colocar 1,2,3,4,5 en celdas en la hoja de cálculo.

Usar una constante para escribir valores en una columna

Para escribir valores en una sola columna, como 3 celdas en la columna C, debe:

  1. Seleccione las celdas que desea usar.

  2. Escriba un signo igual y la constante. Separe los valores de la constante con punto y coma, no comas y, si escribe texto, rodee con comillas dobles. Por ejemplo: ={"Trimestre 1";" Trimestre2";" Trimestre 3"}

  3. Presione Ctrl+Mayús+Entrar. La constante tiene el siguiente aspecto:

    Constante de matriz vertical que usa texto

    En términos de friki, se trata de una constante vertical unidimensional.

Usar una constante para escribir valores en una fila

Para escribir rápidamente valores en una sola fila, como las celdas F1, G1 y H1, debe:

  1. Seleccione las celdas que desea usar.

  2. Escriba un signo igual y la constante, pero esta vez separa los valores con comas, no punto y coma. Por ejemplo: ={1,2,3,4,5}

  3. Presione Ctrl+Mayús+Entrar y la constante tiene el siguiente aspecto:

    Constante de matriz horizontal unidimensional

    En términos frikis, se trata de una constante horizontal unidimensional.

Usar una constante para escribir valores en varias columnas y filas

  1. Seleccione las celdas que desee.

    Asegúrese de que el número de filas y columnas que seleccione coincida con el número de valores de la constante. Por ejemplo, si la constante escribirá datos en cuatro columnas y tres filas, seleccione esa cantidad de columnas y filas.

  2. Escriba un signo igual y la constante. En este caso, separe los valores de cada fila con comas y use un punto y coma al final de cada fila. Por ejemplo:

    ={1\2\3\4;5\6\7\8;9\10\11\12}

  3. Presione Ctrl+Mayús+Entrar y:

    Constante de matriz bidimensional

    En términos de friki, se trata de una constante bidimensional porque rellena columnas y filas. Si se lo pregunta, no puede crear una constante tridimensional, lo que significa que no puede anidar una constante dentro de otra.

Usar una constante en una fórmula

Ahora que ya está familiarizado con las constantes de matriz, este es un ejemplo de trabajo.

  • En cualquier celda en blanco, escriba (o copie y pegue) esta fórmula y, después, presione Ctrl+Mayús+Entrar:

    =SUMA(A1:E1*{1\2\3\4\5})

    En la celda A3 aparece el valor 85.

    ¿Qué ha ocurrido? Multiplicó el valor de A1 por 1, el valor de la celda B2 por 2, y así sucesivamente, a continuación, la función SUMA agregó esos resultados. También puede escribir la fórmula como =SUMA(A1*1,B1*2,C1*3,D1*4,E1*5)

Si lo desea, puede escribir ambos conjuntos de valores como constantes de matriz:

=SUMA({3\4\5\6\7}*{1\2\3\4\5})

Para probar esto, copie la fórmula, seleccione una celda en blanco y pegue la fórmula en la barra de fórmulas y, después, presione Ctrl+Mayús+Entrar. Verá el mismo resultado.

Notas: Busque estos problemas si las constantes no funcionan:

  • Asegúrese de separar los valores con el carácter adecuado. Si omite una coma o punto y coma, o si coloca una en el lugar incorrecto, es posible que la constante de matriz no tenga el aspecto correcto o que vea un mensaje de advertencia.

  • Es posible que haya seleccionado un rango de celdas que no coincida con el número de elementos de la constante. Por ejemplo, si selecciona una columna de seis celdas para usarla con una constante de cinco celdas, el error #N/A aparece en la celda vacía. Si no selecciona suficientes celdas, Excel omite los valores que no tienen una celda correspondiente.

  • Para obtener más información sobre las fórmulas de matriz:

Principio de página

¿Necesita más ayuda?

Ampliar sus conocimientos
Explorar los cursos
Obtener nuevas características primero
Unirse a Microsoft Insider

¿Le ha sido útil esta información?

¿Cómo de satisfecho está con la calidad de la traducción?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×