En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.
Síntomas
Al imprimir varios informes de clásicos desde el cliente adaptado a roles (RTC) en el Service Pack 1 (SP1) de Microsoft Dynamics NAV 2009, recibirá el siguiente mensaje de error:
No puede utilizar el \AppData\Roaming\fin.zup C:\Users\usuarioarchivo porque ya está en uso.
Este problema se produce si se cumplen las condiciones siguientes:
-
Los informes no tienen un diseño definido. Por lo tanto, los informes se ejecutan en el motor de informes clásicos del RTC.
-
Al menos dos informes se imprimen en una sucesión rápida.
Causa
Este problema se produce porque la RTC iniciar el motor de informes clásico para ejecutar un informe. Cuando se imprime un informe, el motor clásico intenta guardar el archivo .zup. Si se inician varios informes en una sucesión rápida, varios motores clásicos sobrescribirá los demás archivos .zup.
Solución
Información de la revisión
Existe un hotfix disponible desde Microsoft. Hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si tiene un problema al descargar, instalar esta revisión, o si tiene otras preguntas de soporte técnico, póngase en contacto con su socio o si está inscrito en un plan de soporte directamente con Microsoft, puede ponerse en contacto con soporte técnico para Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio web de Microsoft:
https://mbs.microsoft.com/support/newstart.aspxTambién puede comunicarse con soporte técnico para Microsoft Dynamics por teléfono mediante estos vínculos para números de teléfono específico del país. Para ello, visite uno de los siguientes sitios Web de Microsoft: Asociados de negocios
https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+ContactsClientes
https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmEn casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.
Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos
Después de solicitar una revisión de Microsoft Dynamics NAV, se le enviará un hipervínculo en un mensaje de correo.
El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga. Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña. Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico. Si hace clic en Cancelar, se detiene el proceso de descarga.Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización
Las actualizaciones y revisiones de la plataforma Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una revisión de Microsoft Dynamics NAV o una actualización, debe reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes con la revisión o la actualización de los archivos. Para ello, siga estos pasos:
Paso 1: Reemplazar los archivos de la instalación de cliente de Microsoft Dynamics NAV Classic
En la instalación de cliente de Microsoft Dynamics NAV Classic, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Dbm.dll |
6.0.31587.0 |
427,848 |
30-Aug-2010 |
16:28 |
x86 |
Fin.exe |
6.0.31587.0 |
12,632,904 |
30-Aug-2010 |
16:28 |
x86 |
Finhlink.exe |
6.0.31587.0 |
452,432 |
30-Aug-2010 |
16:28 |
x86 |
Finsql.exe |
6.0.31587.0 |
12,754,768 |
30-Aug-2010 |
16:28 |
x86 |
Nc_netb.dll |
6.0.31587.0 |
96,592 |
30-Aug-2010 |
16:28 |
x86 |
Nc_tcp.dll |
6.0.31587.0 |
98,640 |
30-Aug-2010 |
16:28 |
x86 |
Nc_tcps.dll |
6.0.31587.0 |
141,136 |
30-Aug-2010 |
16:28 |
x86 |
Ndbcs.dll |
6.0.31587.0 |
1,350,480 |
30-Aug-2010 |
16:28 |
x86 |
Slave.exe |
6.0.31587.0 |
152,400 |
30-Aug-2010 |
16:28 |
x86 |
Para reemplazar los archivos existentes de Microsoft Dynamics NAV, siga estos pasos:
-
Cierre al cliente para Microsoft Dynamics NAV Classic.
-
Busque el directorio de instalación de cliente de Microsoft Dynamics NAV Classic. El cliente de Microsoft Dynamics NAV Classic normalmente se instala en el directorio siguiente:
C:\Program Files\Microsoft Dynamics NAV\60\Classic
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación de cliente de Microsoft Dynamics NAV Classic.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
Paso 2: Reemplace los archivos de la instalación del cliente de Microsoft Dynamics NAV adaptado a roles
En la instalación del cliente adaptado a roles Microsoft Dynamics NAV, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Microsoft.dynamics.framework.patterns.dll |
1.3.10803.301 |
71,656 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.dll |
1.3.10803.301 |
698,328 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.mapping.dll |
1.3.10803.301 |
104,424 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.navigation.dll |
1.3.10803.301 |
34,800 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.ux2006.dll |
1.3.10803.301 |
88,040 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.ux2006.winforms.dll |
1.3.10803.301 |
63,480 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.windows.dll |
1.3.10803.301 |
83,944 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.winforms.controls.dll |
1.3.10803.301 |
2,115,584 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.framework.ui.winforms.dll |
1.3.10803.301 |
694,248 |
23-Aug-2010 |
06:30 |
x86 |
Microsoft.dynamics.nav.client.builder.dll |
6.0.31587.0 |
198,544 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.client.exe |
6.0.31587.0 |
149,376 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.client.interop.communicator.dll |
1.0.559.183 |
75,688 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.client.serviceconnection.dll |
6.0.31587.0 |
104,352 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.client.ui.dll |
6.0.31587.0 |
509,824 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.client.winforms.dll |
6.0.31587.0 |
341,904 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.client.winforms.tlb |
No aplicable |
2,680 |
30-Aug-2010 |
12:11 |
No aplicable |
Microsoft.dynamics.nav.language.dll |
6.0.31587.0 |
2,000,768 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.types.dll |
6.0.31587.0 |
567,160 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.watson.dll |
6.0.31587.0 |
42,880 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.office.interop.outlook.dll |
10.0.4504.0 |
395,136 |
30-Aug-2010 |
16:28 |
x86 |
Para sustituir estos archivos, siga estos pasos:
-
Cerrar al cliente adaptado a roles Microsoft Dynamics NAV.
-
Busque el directorio de instalación del cliente de Microsoft Dynamics NAV adaptado a roles. El cliente adaptado a roles Microsoft Dynamics NAV se instala normalmente en el directorio siguiente:
C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored cliente
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación del cliente de Microsoft Dynamics NAV adaptado a roles.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
Paso 3: Reemplace los archivos de la instalación de Microsoft Dynamics NAV Server
En la instalación de Microsoft Dynamics NAV Server, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Httpcfg.exe |
5.2.3790.0 |
22,352 |
30-Aug-2010 |
16:28 |
x86 |
Microsoft.dynamics.nav.language.dll |
6.0.31587.0 |
2,000,768 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.ncl.dll |
6.0.31587.0 |
608,120 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.server.exe |
6.0.31587.0 |
141,184 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.service.dll |
6.0.31587.0 |
145,280 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.service.runtime.dll |
6.0.31587.0 |
75,664 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.service.webservices.dll |
6.0.31587.0 |
145,304 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.types.dll |
6.0.31587.0 |
567,160 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.watson.dll |
6.0.31587.0 |
42,880 |
30-Aug-2010 |
16:10 |
x86 |
Nclcsrt.etx |
No aplicable |
89,525 |
30-Aug-2010 |
08:31 |
No aplicable |
Nclcsrt.stx |
No aplicable |
91,724 |
30-Aug-2010 |
08:31 |
No aplicable |
Nclcsrts.dll |
6.0.31587.0 |
1,485,648 |
30-Aug-2010 |
16:27 |
x86 |
Ndbcs.dll |
6.0.31587.0 |
1,350,480 |
30-Aug-2010 |
16:27 |
x86 |
Para sustituir estos archivos, siga estos pasos:
-
Detener el Microsoft Dynamics NAV Server.
-
Busque el directorio de instalación de Microsoft Dynamics NAV Server. La de Microsoft Dynamics NAV Server normalmente se instala en el directorio siguiente:
C:\Program Files\Microsoft Dynamics NAV\60\Service
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Server.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
-
Iniciar el Microsoft Dynamics NAV Server.
Paso 4: Reemplace los archivos de la instalación de Microsoft Dynamics NAV Application Server
Si tiene instalado Microsoft Dynamics NAV Application Server, sustituya los archivos siguientes de la instalación de Microsoft Dynamics NAV Application Server utilizando la revisión o la actualización de los archivos.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Dbm.dll |
6.0.31587.0 |
427,848 |
30-Aug-2010 |
16:28 |
x86 |
Nas.exe |
6.0.31587.0 |
2,271,560 |
30-Aug-2010 |
16:28 |
x86 |
Nassql.exe |
6.0.31587.0 |
2,370,384 |
30-Aug-2010 |
16:28 |
x86 |
Ndbcs.dll |
6.0.31587.0 |
1,350,480 |
30-Aug-2010 |
16:28 |
x86 |
Slave.exe |
6.0.31587.0 |
152,400 |
30-Aug-2010 |
16:28 |
x86 |
Para reemplazar los archivos, siga estos pasos.
-
Detener el servidor de aplicaciones Microsoft Dynamics NAV.
-
Busque el directorio de instalación de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server normalmente se instala en el directorio siguiente:
C:\Program Files\Microsoft Dynamics NAV\60\Application Server
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Application Server.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
-
Inicie Microsoft Dynamics NAV Application Server.
Paso 5: Reemplace los archivos de la instalación del SDK de Microsoft Dynamics NAV
Si tiene instalado de SDK de Microsoft Dynamics NAV, sustituya los archivos siguientes.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Cf.h |
No aplicable |
57,736 |
30-Aug-2010 |
12:11 |
No aplicable |
Cfront.dll |
6.0.31587.0 |
1,577,808 |
30-Aug-2010 |
16:28 |
x86 |
Cfront.ocx |
6.0.31587.0 |
111,952 |
30-Aug-2010 |
16:28 |
x86 |
Cfrontsql.dll |
6.0.31587.0 |
1,787,736 |
30-Aug-2010 |
16:28 |
x86 |
Libload.c |
No aplicable |
31.718 |
30-Aug-2010 |
06:51 |
No aplicable |
Microsoft.dynamics.nav.cfront.cfrontdotnet.dll |
6.0.31587.0 |
182,168 |
30-Aug-2010 |
16:10 |
x86 |
Microsoft.dynamics.nav.cfront.cfrontdotnet.xml |
No aplicable |
442,447 |
30-Aug-2010 |
07:12 |
No aplicable |
Sample.c |
No aplicable |
28,718 |
30-Aug-2010 |
06:51 |
No aplicable |
Sample.exe |
6.0.31587.0 |
152,400 |
30-Aug-2010 |
16:28 |
x86 |
Para reemplazar los archivos, siga estos pasos.
-
Localice los directorios de instalación de SDK de Microsoft Dynamics NAV. El SDK de Microsoft Dynamics NAV se instala normalmente en los siguientes directorios:
C:\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT
C:\Program Files\Microsoft Dynamics NAV\60\SDK\Communication componentes
Componente de C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication
-
Elija el SDK para actualizar, C/Front o componentes de comunicación.
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV SDK adecuado.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
Nota: Si ha descargado una revisión o una actualización para los componentes de comunicación, debe registrar los archivos .dll individualmente.
Paso 6: Reemplace los archivos de la instalación del controlador ODBC de Microsoft Dynamics NAV
Si tiene instalado el controlador ODBC de Microsoft Dynamics NAV, sustituya los archivos siguientes en la instalación del controlador ODBC de Microsoft Dynamics NAV.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Cfront.dll |
6.0.31587.0 |
1,577,808 |
30-Aug-2010 |
16:28 |
x86 |
Dbm.dll |
6.0.31587.0 |
427,848 |
30-Aug-2010 |
16:28 |
x86 |
Nc_netb.dll |
6.0.31587.0 |
96,592 |
30-Aug-2010 |
16:28 |
x86 |
Nc_tcp.dll |
6.0.31587.0 |
98,640 |
30-Aug-2010 |
16:28 |
x86 |
Nc_tcps.dll |
6.0.31587.0 |
141,136 |
30-Aug-2010 |
16:28 |
x86 |
Nodbc.dll |
6.0.31587.0 |
2,141,008 |
30-Aug-2010 |
16:28 |
x86 |
Nodbc.xml |
No aplicable |
1209 |
25-Aug-2009 |
16:43 |
No aplicable |
Nodbccfg.cfg |
6.0.31587.0 |
724,480 |
30-Aug-2010 |
08:05 |
No aplicable |
Nodbccfg.xml |
No aplicable |
2,472 |
25-Aug-2009 |
16:43 |
No aplicable |
Slave.exe |
6.0.31587.0 |
152,400 |
30-Aug-2010 |
16:28 |
x86 |
Para reemplazar los archivos, siga estos pasos.
-
Busque el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV. El controlador ODBC de Microsoft Dynamics NAV se instala normalmente en el directorio siguiente:
C:\Program Files\Microsoft Dynamics NAV\60\ODBC
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV.
-
Haga clic en Sí para sobrescribir los archivos en el directorio.
Requisitos previos
Debe tener Microsoft Dynamics NAV 2009 Service Pack 1 instalado para aplicar esta revisión.
Solución alternativa
Para evitar este problema, definir un diseño para los informes que se ejecutan en una sucesión rápida desde la RTC. Si se define el diseño del informe, la RTC ejecutará el informe utilizando su propio motor de informes. Por lo tanto, la RTC no iniciar varias sesiones del motor de informes clásicos.
Estado
Microsoft ha confirmado que se trata de un error de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft
Nota: Es un artículo "Publicación rápida" creado directamente desde dentro de la organización de soporte técnico de Microsoft. La información contenida en este documento se proporciona como está en respuesta a nuevos problemas. Como consecuencia de la velocidad en la puesta a disposición, los materiales pueden incluir errores tipográficos y podrán revisarse en cualquier momento sin previo aviso. Para obtener información adicional, consulte Condiciones de uso.