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Síntomas

Al configurar AD FS 2.1 con Microsoft Dynamics CRM 2011, un error 404 puede producirse cuando intenta tener acceso el extremo mex. Esto puede ocurrir durante cualquier acción de CRM, sin embargo es más frecuente durante la configuración de Microsoft Dynamics CRM para el cliente de Outlook.

Causa

1. Microsoft Dynamics CRM 2011 Update Rollup 13 o posterior no se aplicó en el servidor de Microsoft Dynamics CRM.

2. AD FS 2.1 tiene un problema conocido de publicación metadatos para mex extremos. Después de configurar notificaciones, basados en la autenticación en Microsoft Dynamics CRM 2011, mex extremos no son accesibles.

Solución

1. aplicar Microsoft Dynamics CRM 2011 acumulativo 13 o posterior.

2. para admitir AD FS 2.1, es necesario ejecutar el siguiente script de PowerShell:

a. Inicie el PowerShell ISE o el editor de texto de la opción

b. crear un archivo llamado UpdateMEXEndpoint.ps1

c. Copie el contenido debajo de en el archivo UpdateMEXEndpoint.ps1

Param
(
#optional params
    [string]$ConfigurationEntityName="FederationProvider",
    [string]$SettingName="ActiveMexEndpoint",
    [object]$SettingValue,
    [Guid]$Id
)
$RemoveSnapInWhenDone = $False

Si (-no (Get-PSSnapin-Name Microsoft.Crm.PowerShell - ErrorAction SilentlyContinue))
{
Add-PSSnapin Microsoft.Crm.PowerShell
    $RemoveSnapInWhenDone = $True
}

$Id = (get-CrmAdvancedSetting - ConfigurationEntityName FederationProvider-configuración ActiveMexEndpoint). Atributos [0]. Valor

$setting = New-Object "Microsoft.Xrm.Sdk.Deployment.ConfigurationEntity"
$setting.LogicalName = $ConfigurationEntityName
if($Id) { $setting.Id = $Id }

$setting. Atributos = New-Object "Microsoft.Xrm.Sdk.Deployment.AttributeCollection"
$keypair = New-Object "System.Collections.Generic.KeyValuePair[String, Object]" ($SettingName, $SettingValue)
$setting.Attributes.Add($keypair)

Set-CrmAdvancedSetting - entidad $setting

if($RemoveSnapInWhenDone)
{
Remove-PSSnapin Microsoft.Crm.PowerShell
}

d. ejecutar la secuencia de comandos anterior de PowerShell utilizando la sintaxis siguiente:

UpdateMEXEndpoint.ps1: ValorConfiguracion "https:// < ADFS STSHOST >/adfs/services/trust/mex"

Example:
Si el STS reside en sts.contoso.com
>
> UpdateMEXEndpoint.ps1 –SettingValue “https://sts.contoso.com/adfs/services/trust/mex”

Esto actualizará su implementación de CRM para conectarse con el extremo proporcionado en el parámetro de valor de configuración de AD FS.

Más información


Equipo ADFS ha sacado un hot fix que se solucionará este problema desde el lado ADFS. La corrección ADFS sana a los metadatos de federación de ADFS y publica los extremos mex falta, con lo que resolver el problema en su raíz.



1. Instale la revisión en http://support.microsoft.com/kb/2827748 en el servidor ADFS.

2. reinicie el servidor de ADFS. En segundo plano, la solución habría permitido ADFS publicar el extremo de \mex en los metadatos de federación de ADFS.

3. Inicie sesión en el servidor CRM.

4. vuelva a ejecutar "el configure notificaciones" y "IFD" asistentes de CRM. Volver a ejecutar esto provocará CRM consumir los metadatos de federación de ADFS cicatrizados y rellenar el valor correcto de \mex en la tabla de base de datos.

 

5. para estar seguro, ejecute el debajo de consulta SQL contra la MSCRM_CONFIG.
 

Seleccione activemexendpoint de federationprovider

Asegúrese de que muestra una dirección URL similar a:

https://<ADFS STSHOST >/adfs/services/trust/mex


6. restablecer IIS en el servidor CRM para destruir la reconstrucción y el contenido de la caché de IIS que se basó en los valores antiguos de DB.

 

7. configurar el cliente de outlook.


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