Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Imagine el siguiente escenario:

  • Tiene un equipo que ejecuta Windows 7, Windows Server 2008 R2, Windows Vista o Windows Server 2008.

  • Habilitar la característica Cambio rápido de usuario o la característica Escritorio remoto en este equipo.

  • Directamente iniciar sesión en el equipo. O bien, utilizar una sesión de escritorio remoto para iniciar sesión en el equipo.

  • Abrir un archivo de imagen mediante el visualizador de fotos de Windows en este equipo.

  • Mientras ha iniciado sesión en el equipo, utilice otra cuenta de usuario para iniciar sesión en el equipo mediante la característica Cambio rápido de usuario o mediante una sesión de escritorio remoto.

  • Intenta iniciar Windows Photo Viewer con esta segunda cuenta de usuario.

En este escenario, no se puede iniciar el Visor de fotos de Windows. Además, recibirá el siguiente mensaje de error si no tiene privilegios de administrador:

Windows no puede obtener acceso el dispositivo especificado, la ruta de acceso o el archivo. No tenga los permisos apropiados para tener acceso al elemento.

Nota: Este problema no ocurre si utiliza otra aplicación para abrir el archivo de imagen, como Microsoft Paint.

Causa

El problema se produce porque utiliza el visualizador de fotos de Windows Microsoft COM + (Dllhost.exe) del proceso de alojamiento. Este proceso está configurado para permitir sólo una instancia de sí mismo para que se ejecute en cada equipo.

Solución

Información de la revisión

Nota: Esta revisión es sólo para Windows 7 y Windows Server 2008 R2. Si está ejecutando Windows Vista o Windows Server 2008, consulte la sección "Solución".

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe estar ejecutando Windows 7 o Windows Server 2008 R2 en el equipo.

Información del registro

Para utilizar este hotfix, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.

Notas sobre la información de archivos de Windows 7 y Windows Server 2008 R2


Importante: Correcciones urgentes de Windows 7 y Windows Server 2008 R2 se incluyen en los mismos paquetes. Sin embargo, las revisiones en la página solicitud de revisión se enumeran en ambos sistemas operativos. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece bajo "Windows 7/Windows Server 2008 R2" en la página. Siempre consulte la sección "Aplicable a" de los artículos para determinar el sistema operativo real a la que se aplica cada revisión.

  • Los archivos MANIFEST (.manifest) y los MUM archivos (.mum) que se instalan para cada entorno están enumerados por separado en la sección "Información para Windows Server 2008 R2 y Windows 7 de archivo adicional". MUM y los archivos MANIFEST y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado del componente actualizado. Los archivos de catálogo de seguridad, para los cuales no se muestran los atributos, están firmados con una firma digital de Microsoft.

Para todas las versiones basadas en x86 compatibles de Windows 7

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Photoviewer.dll

6.1.7600.20645

1,456,128

16-Feb-2010

07:08

x86

Para todas las versiones basadas en x64 de Windows 7 y Windows Server 2008 R2

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Photoviewer.dll

6.1.7600.20645

1,728,000

16-Feb-2010

07:37

x64

Photoviewer.dll

6.1.7600.20645

1,456,128

16-Feb-2010

07:08

x86

Solución alternativa

Para evitar este problema, utilice uno de los métodos siguientes.

Método 1

  1. Haga clic en Inicio, escriba regedit en el cuadro Buscar y, a continuación, haga clic en Regedit en los resultados de la búsqueda.

  2. En el Editor del registro, busque la siguiente subclave del registro:

    HKEY_CLASSES_ROOT\AppID\{76D0CB12-7604-4048-B83C-1005C7DDC503}

  3. Haga clic en la entrada de registro RunAs y, a continuación, haga clic en Eliminar.

Método 2

  1. Haga clic en Inicio, escriba dcomcnfg en el cuadro Buscar y, a continuación, haga clic en .exe dcomcnfgen los resultados de la búsqueda.

  2. En la ventana Servicios de componentes, expanda Servicios de componentes, expanda equiposy, a continuación, expanda Mi PC.

  3. (Ratón) en Aplicaciones COM +, seleccione Very, a continuación, haga clic en estado.

  4. Haga clic derecho en la aplicación COM + que tiene un identificador de aplicación de {76D0CB12-7604-4048-B83C-1005C7DDC503} y, a continuación, haga clic en Propiedades.

  5. En el cuadro de diálogo Propiedades , haga clic en la ficha identidad .

  6. En la ficha identidad , haga clic en el la opción de usuario de puesta a flotey, a continuación, haga clic en Aceptar.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información sobre el usuario cambio compatibilidad servicio rápida, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

294855 descripción del servicio compatibilidad de cambio rápido de usuario

Para obtener más información acerca de la característica Cambio rápido de usuario, visite el siguiente sitio Web de Microsoft:

Cómo ocultar la característica Cambio rápido de usuarioPara obtener más información acerca de la cuenta de usuario interactivo, visite el siguiente sitio Web de Microsoft:

Información general acerca de la cuenta de usuario interactivaPara obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos

Información de archivo adicional para Windows 7 y Windows Server 2008 R2

Archivos adicionales para todas las versiones basadas en x86 compatibles de Windows 7

Nombre del archivo

Update.mum

Versión del archivo

No aplicable

Tamaño de archivo

1,635

Fecha (UTC)

16-Feb-2010

Hora (UTC)

15:30

Plataforma

No aplicable

Nombre del archivo

X86_c76c749764ee75c2445fdfceea66abcb_31bf3856ad364e35_6.1.7600.20645_none_4e01cac8e8cb5db8.manifest

Versión del archivo

No aplicable

Tamaño de archivo

699

Fecha (UTC)

16-Feb-2010

Hora (UTC)

15:30

Plataforma

No aplicable

Nombre del archivo

X86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_dcc9c1a74a08f8f5.manifest

Versión del archivo

No aplicable

Tamaño de archivo

50,296

Fecha (UTC)

16-Feb-2010

Hora (UTC)

07:37

Plataforma

No aplicable

Archivos adicionales para todas las versiones basadas en x64 de Windows 7 y Windows Server 2008 R2

Nombre del archivo

Amd64_c758ef1a37fd7346bbcb0cc1489d847d_31bf3856ad364e35_6.1.7600.20645_none_358bbd4c4e634088.manifest

Versión del archivo

No aplicable

Tamaño de archivo

1,046

Fecha (UTC)

16-Feb-2010

Hora (UTC)

15:30

Plataforma

No aplicable

Nombre del archivo

Amd64_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_38e85d2b02666a2b.manifest

Versión del archivo

No aplicable

Tamaño de archivo

50,300

Fecha (UTC)

16-Feb-2010

Hora (UTC)

08:13

Plataforma

No aplicable

Nombre del archivo

Update.mum

Versión del archivo

No aplicable

Tamaño de archivo

1.850

Fecha (UTC)

16-Feb-2010

Hora (UTC)

15:30

Plataforma

No aplicable

Nombre del archivo

X86_microsoft-windows-photoviewer_31bf3856ad364e35_6.1.7600.20645_none_dcc9c1a74a08f8f5.manifest

Versión del archivo

No aplicable

Tamaño de archivo

50,296

Fecha (UTC)

16-Feb-2010

Hora (UTC)

07:37

Plataforma

No aplicable

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×