Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.

Síntomas

Cuando imprime un informe en el cliente adaptado a roles (RTC) de Microsoft Dynamics NAV 2009, el RTC se bloquea intermitentemente. Además, el mensaje de error siguiente se graba en el registro de aplicación:

Fuente: Microsoft.Dynamics.Nav.Ncl
Tipo: System.Reflection.TargetInvocationException
Mensaje: Se ha producido la excepción en el destino de una invocación.
StackTrace:
en System.RuntimeMethodHandle._InvokeMethodFast (destino de objeto, argumentos de objeto [], SignatureStruct & sig, MethodAttributes methodAttributes, RuntimeTypeHandle typeOwner)

Este problema se produce en los siguientes productos:

  • Microsoft Dynamics NAV 2009 R2

  • Microsoft Dynamics NAV 2009 Service Pack 1

Causa

Este problema se produce debido a una excepción del cliente pueda dañar el servidor. Esto hace que el archivo Microsoft.dynamics.nav.server.exe se bloquea.

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si tiene un problema al descargar, instalar esta revisión, o si tiene otras preguntas de soporte técnico, póngase en contacto con su socio o si está inscrito en un plan de soporte directamente con Microsoft, puede ponerse en contacto con soporte técnico para Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio Web de Microsoft:

https://mbs.microsoft.com/support/newstart.aspxTambién puede comunicarse con soporte técnico para Microsoft Dynamics por teléfono mediante estos vínculos para números de teléfono específico del país. Para ello, visite uno de los siguientes sitios Web de Microsoft:

Asociados de negocios

https://mbs.microsoft.com/partnersource/support/Clientes

https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htmEn casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.

Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos

Después de solicitar una revisión de Microsoft Dynamics NAV, se le enviará un hipervínculo en un mensaje de correo.


El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga.


Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña.


Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico.


Si hace clic en Cancelar, se detiene el proceso de descarga.


Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización

Las actualizaciones y revisiones de la plataforma Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una revisión de Microsoft Dynamics NAV o una actualización, debe reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes con la revisión o la actualización de los archivos. Para ello, siga estos pasos:

Paso 1: Reemplazar los archivos de la instalación de cliente de Microsoft Dynamics NAV Classic

En la instalación de cliente de Microsoft Dynamics NAV Classic, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Dbm.dll

6.0.33433.0

313,544

05-May-2012

04:57

x86

Fin.exe

6.0.33433.0

12,603,080

05-May-2012

04:32

x86

Finhlink.exe

6.0.33433.0

452,824

05-May-2012

04:57

x86

Finsql.exe

6.0.33433.0

12,737,744

05-May-2012

04:32

x86

Microsoft.dynamics.nav.dotnetbridge.dll

6.0.33433.0

208,136

05-May-2012

04:32

x86

Microsoft.dynamics.nav.transformation.reporting.dll

6.0.33433.0

114,472

05-May-2012

04:32

x86

Nc_netb.dll

6.0.33433.0

17,104

05-May-2012

04:57

x86

Nc_tcp.dll

6.0.33433.0

19,152

05-May-2012

04:57

x86

Nc_tcps.dll

6.0.33433.0

25,808

05-May-2012

04:57

x86

Ndbcs.dll

6.0.33433.0

1,138,896

05-May-2012

04:57

x86

Slave.exe

6.0.33433.0

38,608

05-May-2012

04:58

x86

Para reemplazar los archivos existentes de Microsoft Dynamics NAV, siga estos pasos:

  1. Cierre al cliente para Microsoft Dynamics NAV Classic.

  2. Busque el directorio de instalación de cliente de Microsoft Dynamics NAV Classic. El cliente de Microsoft Dynamics NAV Classic normalmente se instala en el directorio siguiente:

    C:\Program Files\Microsoft Dynamics NAV\60\Classic

  3. Copie los archivos que ha descargado.

  4. Pegue los archivos que ha descargado en el directorio de instalación de cliente de Microsoft Dynamics NAV Classic.

  5. Haga clic en para sobrescribir los archivos en el directorio.

Paso 2: Reemplace los archivos de la instalación del cliente de Microsoft Dynamics NAV adaptado a roles

En la instalación del cliente adaptado a roles Microsoft Dynamics NAV, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Microsoft.dynamics.framework.patterns.dll

1.3.10803.900

72,040

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.dll

1.3.10803.900

702,816

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.mapping.dll

1.3.10803.900

104,816

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.navigation.dll

1.3.10803.900

35,184

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.ux2006.dll

1.3.10803.900

92,520

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.ux2006.winforms.dll

1.3.10803.900

67,968

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.windows.dll

1.3.10803.900

84,336

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.winforms.controls.dll

1.3.10803.900

2,222,464

04-May-2012

21:30

x86

Microsoft.dynamics.framework.ui.winforms.dll

1.3.10803.900

1,173,872

04-May-2012

21:30

x86

Microsoft.dynamics.nav.client.builder.dll

6.0.33433.0

211,216

05-May-2012

04:29

x86

Microsoft.dynamics.nav.client.exe

6.0.33433.0

149,760

05-May-2012

04:29

x86

Microsoft.dynamics.nav.client.serviceconnection.dll

6.0.33433.0

112,936

05-May-2012

04:29

x86

Microsoft.dynamics.nav.client.ui.dll

6.0.33433.0

538,888

05-May-2012

04:29

x86

Microsoft.dynamics.nav.client.winforms.dll

6.0.33433.0

358,672

05-May-2012

04:29

x86

Microsoft.dynamics.nav.client.winforms.tlb

No aplicable

2,680

05-May-2012

01:58

No aplicable

Microsoft.dynamics.nav.language.dll

6.0.33433.0

2,021,632

05-May-2012

04:29

x86

Microsoft.dynamics.nav.types.dll

6.0.33433.0

596,224

05-May-2012

04:29

x86

Microsoft.dynamics.nav.watson.dll

6.0.33433.0

43,264

05-May-2012

04:29

x86

Microsoft.office.interop.outlook.dll

10.0.4504.0

395,528

05-May-2012

04:55

x86

Para sustituir estos archivos, siga estos pasos:

  1. Cerrar al cliente adaptado a roles Microsoft Dynamics NAV.

  2. Busque el directorio de instalación del cliente de Microsoft Dynamics NAV adaptado a roles. El cliente adaptado a roles Microsoft Dynamics NAV se instala normalmente en el directorio siguiente:

    C:\Program Files\Microsoft Dynamics NAV\60\RoleTailored cliente

  3. Copie los archivos que ha descargado.

  4. Pegue los archivos que ha descargado en el directorio de instalación del cliente de Microsoft Dynamics NAV adaptado a roles.

  5. Haga clic en para sobrescribir los archivos en el directorio.

Paso 3: Reemplace los archivos de la instalación de Microsoft Dynamics NAV Server

En la instalación de Microsoft Dynamics NAV Server, sustituya los archivos siguientes utilizando el archivo de actualización o la revisión.

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Httpcfg.exe

5.2.3790.0

22,736

05-May-2012

04:54

x86

Microsoft.dynamics.nav.language.dll

6.0.33433.0

2,021,632

05-May-2012

04:30

x86

Microsoft.dynamics.nav.ncl.dll

6.0.33433.0

641,272

05-May-2012

04:30

x86

Microsoft.dynamics.nav.server.exe

6.0.33433.0

141,568

05-May-2012

04:30

x86

Microsoft.dynamics.nav.service.dll

6.0.33433.0

145,664

05-May-2012

04:30

x86

Microsoft.dynamics.nav.service.runtime.dll

6.0.33433.0

76,048

05-May-2012

04:30

x86

Microsoft.dynamics.nav.service.webservices.dll

6.0.33433.0

149,784

05-May-2012

04:30

x86

Microsoft.dynamics.nav.types.dll

6.0.33433.0

596,224

05-May-2012

04:30

x86

Microsoft.dynamics.nav.watson.dll

6.0.33433.0

43,264

05-May-2012

04:30

x86

Nclcsrt.etx

No aplicable

90,329

04-May-2012

22:55

No aplicable

Nclcsrt.stx

No aplicable

92,128

04-May-2012

22:55

No aplicable

Nclcsrts.dll

6.0.33433.0

1,453,272

05-May-2012

04:54

x86

Ndbcs.dll

6.0.33433.0

1,138,896

05-May-2012

04:54

x86

Para sustituir estos archivos, siga estos pasos:

  1. Detener el Microsoft Dynamics NAV Server.

  2. Busque el directorio de instalación de Microsoft Dynamics NAV Server. La de Microsoft Dynamics NAV Server normalmente se instala en el directorio siguiente:

    C:\Program Files\Microsoft Dynamics NAV\60\Service

  3. Copie los archivos que ha descargado.

  4. Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Server.

  5. Haga clic en para sobrescribir los archivos en el directorio.

  6. Iniciar el Microsoft Dynamics NAV Server.

Paso 4: Reemplace los archivos de la instalación de Microsoft Dynamics NAV Application Server

Si tiene instalado Microsoft Dynamics NAV Application Server, sustituya los archivos siguientes de la instalación de Microsoft Dynamics NAV Application Server utilizando la revisión o la actualización de los archivos.

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Dbm.dll

6.0.33433.0

313,544

05-May-2012

04:59

x86

Nas.exe

6.0.33433.0

2,200,776

05-May-2012

04:32

x86

Nassql.exe

6.0.33433.0

2,309,328

05-May-2012

04:32

x86

Ndbcs.dll

6.0.33433.0

1,138,896

05-May-2012

04:59

x86

Slave.exe

6.0.33433.0

38,608

05-May-2012

04:59

x86

Para reemplazar los archivos, siga estos pasos.

  1. Detener el servidor de aplicaciones Microsoft Dynamics NAV.

  2. Busque el directorio de instalación de Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server normalmente se instala en el directorio siguiente:

    C:\Program Files\Microsoft Dynamics NAV\60\Application Server

  3. Copie los archivos que ha descargado.

  4. Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV Application Server.

  5. Haga clic en para sobrescribir los archivos en el directorio.

  6. Inicie Microsoft Dynamics NAV Application Server.

Paso 5: Reemplace los archivos de la instalación del SDK de Microsoft Dynamics NAV

Si tiene instalado de SDK de Microsoft Dynamics NAV, sustituya los archivos siguientes.

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Cf.h

No aplicable

57,950

05-May-2012

01:58

No aplicable

Cfront.dll

6.0.33433.0

1,431,248

05-May-2012

04:58

x86

Cfront.ocx

6.0.33433.0

112,848

05-May-2012

04:58

x86

Cfrontsql.dll

6.0.33433.0

1,644,248

05-May-2012

04:58

x86

Libload.c

No aplicable

31.718

04-May-2012

21:43

No aplicable

Microsoft.dynamics.nav.cfront.cfrontdotnet.dll

6.0.33433.0

182,552

05-May-2012

04:32

x86

Microsoft.dynamics.nav.cfront.cfrontdotnet.xml

No aplicable

443,045

04-May-2012

21:58

No aplicable

Sample.c

No aplicable

28,718

04-May-2012

21:43

No aplicable

Sample.exe

6.0.33433.0

32,976

05-May-2012

04:58

x86

Para reemplazar los archivos, siga estos pasos.

  1. Localice los directorios de instalación de SDK de Microsoft Dynamics NAV. El SDK de Microsoft Dynamics NAV se instala normalmente en los siguientes directorios:

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\CFRONT

    C:\Program Files\Microsoft Dynamics NAV\60\SDK\Communication componentes

    Componente de C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication

  2. Elija el SDK para actualizar, C/Front o componentes de comunicación.

  3. Copie los archivos que ha descargado.

  4. Pegue los archivos que ha descargado en el directorio de instalación de Microsoft Dynamics NAV SDK adecuado.

  5. Haga clic en para sobrescribir los archivos en el directorio.

Nota: Si ha descargado una revisión o una actualización para los componentes de comunicación, debe registrar los archivos .dll individualmente.

Paso 6: Reemplace los archivos de la instalación del controlador ODBC de Microsoft Dynamics NAV

Si tiene instalado el controlador ODBC de Microsoft Dynamics NAV, sustituya los archivos siguientes en la instalación del controlador ODBC de Microsoft Dynamics NAV.

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Cfront.dll

6.0.33433.0

1,431,248

05-May-2012

04:59

x86

Dbm.dll

6.0.33433.0

313,544

05-May-2012

04:55

x86

Nc_netb.dll

6.0.33433.0

17,104

05-May-2012

04:56

x86

Nc_tcp.dll

6.0.33433.0

19,152

05-May-2012

04:55

x86

Nc_tcps.dll

6.0.33433.0

25,808

05-May-2012

04:56

x86

Nodbc.dll

6.0.33433.0

2,144,464

05-May-2012

04:59

x86

Nodbc.xml

No aplicable

1209

29-Mar-2012

22:38

No aplicable

Nodbccfg.cfg

6.0.33433.0

726,016

04-May-2012

22:35

No aplicable

Nodbccfg.xml

No aplicable

2,538

29-Mar-2012

22:38

No aplicable

Slave.exe

6.0.33433.0

38,608

05-May-2012

04:55

x86

Para reemplazar los archivos, siga estos pasos.

  1. Busque el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV. El controlador ODBC de Microsoft Dynamics NAV se instala normalmente en el directorio siguiente:

    C:\Program Files\Microsoft Dynamics NAV\60\ODBC

  2. Copie los archivos que ha descargado.

  3. Pegue los archivos que ha descargado en el directorio de instalación del controlador ODBC de Microsoft Dynamics NAV.

  4. Haga clic en para sobrescribir los archivos en el directorio.

Paso 7: Reemplazar el componente de comunicación


Sustituya los archivos siguientes.

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Msmqbusadapter.dll

6.0.33433.0

283,872

05-May-2012

04:59

x86

Npipebusadapter.dll

6.0.33433.0

257,248

05-May-2012

04:59

x86

Nscomcom2.dll

6.0.33433.0

237,784

05-May-2012

04:59

x86

Socketbusadapter.dll

6.0.33433.0

281,832

05-May-2012

04:59

x86

Para reemplazar los archivos, siga estos pasos.

  1. Busque el directorio de componente de comunicación. El componente de comunicación normalmente se instala en el directorio siguiente:

    Componente de C:\Program Files\Common Files\Microsoft Dynamics NAV\Communication

  2. Copie los archivos que ha descargado.

  3. Pegue los archivos que ha descargado en el directorio de componente de comunicación de Microsoft Dynamics NAV.

  4. Haga clic en para sobrescribir los archivos en el directorio.

Requisitos previos

Debe tener uno de los siguientes productos instalados para aplicar esta revisión:

  • Microsoft Dynamics NAV 2009 R2

  • Microsoft Dynamics NAV 2009 Service Pack 1

Nota especial para Service Pack 1 de Microsoft Dynamics NAV 2009
Antes de aplicar este hotfix en una instalación del Service Pack 1 de Microsoft Dynamics NAV 2009, asegúrese de que la instalación actual de Microsoft Dynamics NAV 2009 SP1 tiene el número de compilación 32074 o una posterior número de compilación. Para obtener más información, visite uno de los siguientes sitios de Microsoft, dependiendo de que sea un socio o un cliente:
Asociado de negocios

Versión combinada de revisión de Microsoft Dynamics NAV 2009 SP1 y Microsoft Dynamics NAV 2009 R2Cliente

Versión combinada de revisión de Microsoft Dynamics NAV 2009 SP1 y Microsoft Dynamics NAV 2009 R2
Si el número de compilación de la instalación del Service Pack 1 de Microsoft Dynamics NAV 2009 actual es inferior a 32074, debe realizar uno de los siguientes pasos antes de instalar este hotfix:

  • Instale la revisión 2496107. Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

    Archivos de recursos de 2496107 plataforma hotfix para el Service Pack 1 de Microsoft Dynamics NAV 2009

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×