Microsoft Business Solutions-Navision y Microsoft Navision forman parte ahora de Microsoft Dynamics NAV. Todas las referencias a Microsoft Business Solutions-Navision o a Microsoft Navision corresponden a Microsoft Dynamics NAV.
En este artículo se aplica a Microsoft Dynamics NAV para todos los países y todas las configuraciones regionales.
Síntomas
Cuando se produce un tiempo de espera de bloqueo en Microsoft Dynamics NAV, Microsoft Dynamics NAV Application Server (NAS) deja de responder a los eventos. Además, cuando el NAS recibe el tiempo de espera de bloqueo, NAS sólo procesa cada segundo mensaje de la cola.
Causa
Este problema se produce porque el servidor NAS trata el tiempo de espera de bloqueo como un error de red. Por lo tanto, el servidor NAS no se desconecta de la base de datos antes de que el NAS intenta volver a conectarse a la base de datos.
Solución
Información de la revisión
Ahora hay una revisión compatible de Microsoft. El hotfix corrige el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.
Para resolver este problema inmediatamente, póngase en contacto con soporte técnico de Microsoft Dynamics y productos relacionados obtener la revisión. Puede iniciar sesión en el sitio de Microsoft Dynamics y crear una nueva solicitud de soporte técnico. Para ello, visite el siguiente sitio web de Microsoft:
https://mbs.microsoft.com/support/newstart.aspxTambién puede comunicarse con soporte técnico de Microsoft Dynamics y productos relacionados llamando por teléfono al (888) 477-7877.
Nota: En casos especiales, los costos derivados normalmente de las llamadas pueden cancelarse si un profesional de soporte técnico de Microsoft Dynamics y productos relacionados de soporte determina que una actualización específica resolverá el problema. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con la actualización en cuestión.
Requisitos previos
Debe tener Microsoft Dynamics NAV 4.0 Service Pack 3 con actualización 6 instalado para poder aplicar este hotfix.
Cómo obtener la revisión de Microsoft Dynamics NAV o actualizar archivos
Después de solicitar una revisión de Microsoft Dynamics NAV o un archivo de actualización del soporte técnico de Microsoft Dynamics, se le enviará un hipervínculo en un mensaje de correo.
El mensaje incluirá un hipervínculo y una contraseña. Puede usar el hipervínculo para descargar la revisión de Microsoft Dynamics NAV o los archivos de actualización. Al hacer clic en el hipervínculo, se abre el cuadro de diálogo Descargar archivo-Advertencia de seguridad . A continuación, deberá ejecutar, guardar o cancelar la descarga.
Si hace clic en Ejecutar, los archivos comienzan la descarga y el proceso de extracción. Debe especificar una carpeta para los archivos nuevos y, a continuación, proporcione la contraseña.
Si hace clic en Guardar, especifique una ruta de acceso para guardar el archivo comprimido. Cuando se abre el archivo que guardó, deberá especificar una ruta para los archivos. A continuación, debe proporcionar la contraseña incluida en el correo electrónico.
Si hace clic en Cancelar, se detiene el proceso de descarga.
Cómo instalar una revisión de Microsoft Dynamics NAV o un archivo de actualización
Las actualizaciones y revisiones de la plataforma Microsoft Dynamics NAV están disponibles como archivos únicos. Para instalar una actualización o una revisión de Microsoft Dynamics NAV, debe reemplazar los archivos de instalación de Microsoft Dynamics NAV existentes con los archivos de revisión o actualización. Para ello, siga estos pasos:
-
Utilice la revisión o la actualización de los archivos para reemplazar los archivos de la instalación del cliente de Microsoft Dynamics NAV que se enumeran en las tablas siguientes:
Microsoft Dynamics NAV 2009
Nombre del archivo
Versión del archivo
Tamaño de archivo
Fecha
Hora
Plataforma
Dbm.dll
6.0.30233.0
444,232
24-Nov-2009
17:09
x86
Fin.exe
6.0.30233.0
12,257,096
24-Nov-2009
17:09
x86
Finhlink.exe
6.0.30233.0
452,432
24-Nov-2009
17:09
x86
Finsql.exe
6.0.30233.0
12,343,120
24-Nov-2009
17:09
x86
Nc_netb.dll
6.0.30233.0
108,368
24-Nov-2009
17:09
x86
Nc_tcp.dll
6.0.30233.0
108,368
24-Nov-2009
17:09
x86
Nc_tcps.dll
6.0.30233.0
153,424
24-Nov-2009
17:09
x86
Ndbcs.dll
6.0.30233.0
1,333,072
24-Nov-2009
17:09
x86
Slave.exe
6.0.30233.0
161,616
24-Nov-2009
17:09
x86
Microsoft Dynamics NAV 2009 SP1
Nombre del archivo
Versión del archivo
Tamaño de archivo
Fecha
Hora
Plataforma
Dbm.dll
6.0.30232.0
427,848
23-Nov-2009
23:16
x86
Fin.exe
6.0.30232.0
12,598,600
23-Nov-2009
23:17
x86
Finhlink.exe
6.0.30232.0
452,432
23-Nov-2009
23:17
x86
Finsql.exe
6.0.30232.0
12,713,808
23-Nov-2009
23:17
x86
Nc_netb.dll
6.0.30232.0
96,592
23-Nov-2009
23:16
x86
Nc_tcp.dll
6.0.30232.0
98,640
23-Nov-2009
23:17
x86
Nc_tcps.dll
6.0.30232.0
141,136
23-Nov-2009
23:16
x86
Ndbcs.dll
6.0.30232.0
1,348,944
23-Nov-2009
23:16
x86
Slave.exe
6.0.30232.0
152,400
23-Nov-2009
23:16
x86
Nota: Normalmente, el cliente de Microsoft Dynamics NAV se instala en la carpeta siguiente:C:\Program Files\Microsoft Business Solutions-Navision\Client\Para reemplazar los archivos existentes, siga estos pasos:
-
Cierre Microsoft Dynamics NAV.
-
Busque la carpeta de instalación del cliente de Microsoft Dynamics NAV.
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en la carpeta de instalación del cliente de Microsoft Dynamics NAV.
-
En el cuadro de diálogo Confirmar el reemplazo de archivos , haga clic en Sí para sobrescribir los archivos en la carpeta de instalación.
-
-
Reemplace los archivos de la instalación de Microsoft Dynamics NAV Application Server que se enumeran en la tabla siguiente:
Microsoft Dynamics NAV 2009
Nombre del archivo
Versión del archivo
Tamaño de archivo
Fecha
Hora
Plataforma
Dbm.dll
6.0.30233.0
444,232
24-Nov-2009
02:13
x86
Nas.exe
6.0.30233.0
2,082,632
24-Nov-2009
02:13
x86
Nassql.exe
6.0.30233.0
2,168,656
24-Nov-2009
02:13
x86
Ndbcs.dll
6.0.30233.0
1,333,072
24-Nov-2009
02:13
x86
Slave.exe
6.0.30233.0
161,616
24-Nov-2009
02:13
x86
Microsoft Dynamics NAV 2009 SP1
Nombre del archivo
Versión del archivo
Tamaño de archivo
Fecha
Hora
Plataforma
Dbm.dll
6.0.30232.0
427,848
23-Nov-2009
23:16
x86
Nas.exe
6.0.30232.0
2,259,784
23-Nov-2009
23:16
x86
Nassql.exe
6.0.30232.0
2,352,464
23-Nov-2009
23:16
x86
Ndbcs.dll
6.0.30232.0
1,348,944
23-Nov-2009
23:16
x86
Slave.exe
6.0.30232.0
152,400
23-Nov-2009
23:16
x86
Para reemplazar los archivos, siga estos pasos.-
Detener el servidor de aplicaciones Microsoft Dynamics NAV.
-
Busque la carpeta de instalación de Microsoft Dynamics NAV Application Server. Normalmente, Microsoft Dynamics NAV Application Server se instala en la carpeta siguiente:
C:\Program Files\Microsoft Business Solutions-Navision\Application Server\
-
Copie los archivos que ha descargado.
-
Pegue los archivos que ha descargado en la carpeta de instalación de Microsoft Dynamics NAV Application Server.
-
Haga clic en Sí para sobrescribir los archivos de la carpeta.
-
Inicie Microsoft Dynamics NAV Application Server.
-
Estado
Microsoft ha confirmado que se trata de un error de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para obtener más información, haga clic en el siguiente número de artículo para verlo en Microsoft Knowledge Base:
824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft