Síntomas
Al intentar actualizar los datos de un libro de Microsoft Excel que tiene un vínculo a una base de datos de Microsoft Access, es posible que reciba el siguiente mensaje de error:
No se pudo encontrar ISAM instalable
Este problema se produce si el libro se ha abierto y actualizado previamente en una versión más reciente de Excel.
Causa
Cuando un libro de Excel vinculado a una base de datos de Access se abre en una versión posterior de Excel, se pueden agregar parámetros a la cadena de conexión. Si la versión anterior de Excel no reconoce estos parámetros, desencadenará el mensaje de error.
Resolución
Para resolver este problema, elimine los nuevos parámetros de la cadena de conexión. Para ello, siga estos pasos:
-
Abra el libro de Excel.
-
En la cinta de opciones datos , haga clic en el botón conexiones .
-
En el cuadro de diálogo conexiones del libro , seleccione la conexión a la base de datos de Access y haga clic en propiedades.
-
En el cuadro de diálogo propiedades de conexión , haga clic en la pestaña definición .
-
Elimine los siguientes parámetros de la cadena de conexión:
Jet OLEDB: omitir la validación del usuario de la UserInfo = false; Jet OLEDB: almacenamiento en caché de base de BD limitado = false; Jet OLEDB: bypass ChoiceField Validation = false
-
En el cuadro de diálogo propiedades de conexión , haga clic en Aceptar. En este punto, deben actualizarse los datos.
-
En el cuadro de diálogo conexiones del libro , haga clic en cerrary, a continuación, guarde el libro actualizado.
Más información
Si actualiza y guarda el libro en una versión más reciente de Excel, el problema se repetirá.