Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

En un entorno de Microsoft Exchange Server de 2016, después de desinstalar Windows PowerShell versión 2.0 e instalar una versión posterior de PowerShell en su lugar, el Shell de administración de Exchange no se puede abrir correctamente y recibe el error siguiente Mensaje:

New-PSSession: [ServerName] procesamiento datos desde un servidor remoto ServerName falló con
el siguiente mensaje de error: [ClientAccessServer =nombreDeServidor, BackEndServer =nombreDeServidor, RequestId =RequestId, TimeStamp =DateTime]
[AuthZRequestId=AuthZRequestId][FailureCategory=AuthZ-SetupVersionInformationCorruptException]
No se puede determinar la versión del archivo instalado desde la clave del registro
'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine'. Para obtener más información, consulte la
tema de Ayuda de about_Remote_Troubleshooting.
En línea: 1 char: 1
+ "$ConnectionUri" new-PSSession - ConnectionURI - ConfigurationName Micr...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo: OpenError: (System.Manageme... RemoteRunspace:RemoteRunspace) [New-PSSession], PSRemotin
gTransportException
+ FullyQualifiedErrorId: IncorrectProtocolVersion, PSSessionOpenFailed

También se registra la siguiente entrada de registro de sucesos:

Nombre de registro: aplicación
Fuente: MSExchange RBAC
Fecha: fecha y hora
Id. de suceso: 258
Categoría de tareas: RBAC
Nivel: Error
Palabras clave: clásico
Usuario: N/D
Equipo: nombreDeEquipo
Descripción:
(Proceso 8820, PID w3wp.exe)"RemotePS Func GetApplicationPrivateData API pública produce Microsoft.Exchange.Diagnostics.SetupVersionInformationCorruptException de la excepción: no se puede determinar la versión del archivo instalado desde la clave del registro ' HKEY_ LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine'.

Causa

Este problema se produce porque se cambia la ruta de acceso del registro de la última versión de PowerShell.

Solución alternativa

Puede agregar el registro de HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\PowerShell\1\PowerShellEngine clave atrás después de desinstalar Windows PowerShell 2.0. La forma más rápida es tomar el registro archivo desde Microsoft TechNet Gallery: https://gallery.technet.microsoft.com/Exchange-2016-CU1-7c843cb0.

Solución

Para corregir este problema, instale actualización acumulativa 9 para Exchange Server 2016 o una posterior actualización acumulativa de 2016 de Exchange Server.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Referencias

Obtenga información acerca de la terminología que utiliza Microsoft para describir las actualizaciones de software.

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×