Síntomas
El proceso de instalación del cliente de Microsoft Dynamics SL se bloquea al instalar los componentes de acceso a datos.
Causa
Causa 1:La versión de MDAC en la estación de trabajo es anterior a la 2,5 y el instalador de Microsoft Dynamics SL está intentando actualizar los componentes de MDAC.
Vea la solución 1.
Causa 2:
Cuando el instalador de Microsoft Dynamics SL que ejecuta Sqlredis. exe para instalar los componentes de conectividad de cliente de SQL Server, el proceso se bloquea en uno de los componentes que se van a instalar.
Vea la solución 2.
Resolución
Solución 1:
Para resolver este problema, ejecute los siguientes pasos: 1. En primer lugar, Compruebe la versión de MDAC que está instalada. Para ello, siga estos pasos: a. Haga clic en Inicio | Ejecutar b. Escriba "regedit" c. En el registro, vaya a HKEY_LOCAL_MACHINE \Software\Microsoft\DataAccess d. Busque la clave "version" (versión). e. Compruebe si esta clave es menor que 2.50.4403.12. f. Si es así, puede intentar instalar manualmente los componentes de MDAC desde el siguiente sitio web: http://www.microsoft.com/downloads/en/details.aspx?FamilyID=6c050fe3-c795-4b7d-b037-185d0506396c&displaylang = enNota:
Si falta la clave, esto podría significar un problema con el sistema operativo y es posible que tenga que reinstalarla. Si la clave está presente y es mayor que 2.50.4403.12, es posible que esta no sea la causa del problema.
Solución 2:
Si Sqlredis. exe o uno de los archivos ejecutables que usa está en fase de bloqueo, puede finalizarlos en el administrador de tareas: 1. Presione Ctrl + Alt + Supr e inicie el administrador de tareas.
2. en la pestaña procesos, busque uno de los siguientes procesos: setupre. exe Sqlredis. exe DaSetup. EXE3. Si alguno de los ejecutables anteriores aparece en la pestaña "procesos", finalizar el proceso. Si se realiza correctamente, el instalador debe continuar con el siguiente paso de la instalación del cliente.