Síntomas
Imagine la siguiente situación:
-
Configurar la dirección de servicios Web externos y la dirección del servidor perimetral de Audio y vídeo en un entorno de Microsoft Lync Server 2010.
-
El servidor DNS no puede resolver la dirección de servicios Web externos o la dirección del servidor perimetral de Audio/vídeo.
-
Utilice una secuencia de comandos de configuración automática de proxy para configurar el servidor proxy en Windows Internet Explorer.
-
Iniciar Microsoft Lync Web App y desea compartir el escritorio o una aplicación.
En este escenario, no puede compartir la aplicación o el escritorio.
Causa
Este problema se produce porque Lync Web App no se conecta al servidor perimetral de Audio y vídeo a través de un servidor proxy. Este comportamiento se produce cuando Internet Explorer está configurado para detectar la configuración del servidor proxy mediante un script de configuración.
Solución
Para resolver este problema, instale la actualización acumulativa siguiente:
2670534 Descripción de la actualización acumulativa de Lync Server 2010, servidor de componentes Web: febrero de 2012 Después de instalar la actualización, utilice uno de los métodos siguientes para resolver el problema.
Método 1
-
En el equipo cliente, abra Opciones de Internet,y, a continuación, borrar el historial de exploraciónen la ficha General .
-
Elimine todos los archivos XAP en la carpeta siguiente:
Archivos de Internet %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary
-
Cierre todas las ventanas de Internet Explorer.
-
Desinstalar Microsoft Lync Web App Plug-in en programas y características.
-
Inicie Lync Web App y desea compartir el escritorio o una aplicación.
-
Instalar el complemento cuando lo solicite la página Web.
Método 2
En el servidor front-end de Lync Server 2010, siga estos pasos:
-
Abra el archivo ReachAppShPluginProperties.xml en la carpeta siguiente:
%ProgramFiles%\Microsoft Lync Server 2010\Web Components\Reach\Int\Client\Plugins
-
Cambio < valor MinSupportedBuildVersion = "4.0.7457.0" / > para < valor MinSupportedBuildVersion = "4.0.7577.380" / >.
-
Abra el archivo ReachAppShPluginProperties.xml en la carpeta siguiente:
%ProgramFiles%\Microsoft Lync Server 2010\Web Components\Reach\Ext\Client\Plugins
-
Cambio < valor MinSupportedBuildVersion = "4.0.7457.0" / > para < valor MinSupportedBuildVersion = "4.0.7577.380" / >.
A continuación, siga estos pasos en los equipos cliente:
-
Abra Opciones de Internet y borrar el historial de exploración en la ficha General .
-
Elimine todos los archivos XAP en la carpeta siguiente:
Archivos de Internet %USERPROFILE%\AppData\Local\Microsoft\Windows\Temporary
-
Próxima vez que inicie Lync Web App en el equipo cliente, solicita la página Web para actualizar el complemento.
Solución alternativa
Para evitar este problema, configure manualmente la configuración de servidor proxy de Internet Explorer.
Más información
Para obtener más información acerca de las características de Lync Web App, visite el siguiente sitio Web de Microsoft:
Información general acerca de las características de Lync Web AppPara obtener más información acerca de cómo utilizar la configuración automática, proxy automático y funciones de detección automática en Internet Explorer, visitan el siguiente sitio Web de Microsoft: