En este artículo se describen las actualizaciones de revisiones 3146717, que está disponible para microsoft .NET Framework 4.5.2, 4.5.1 y 4.5. Para obtener más información sobre los problemas que corrige el paquete acumulativo de revisiones, vea la sección Problemas que corrige este paquete acumulativo de revisiones.

El paquete sin conexión se puede usar cuando el instalador web no se puede usar debido a la falta de conectividad a Internet. Le recomendamos que use el instalador web en lugar del paquete sin conexión siempre que sea posible para obtener una eficiencia y requisitos de ancho de banda óptimos.

Solución

La revisión que corresponde a KB3146717 se ha reemplazado con las últimas actualizaciones de .NET Framework, que contienen todas las correcciones que se incluyeron anteriormente en KB3146717. Se recomienda instalar las actualizaciones más recientes de .NET Framework.

Para obtener más información sobre cómo descargar archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

119591 Cómo obtener archivos de soporte técnico de Microsoft de servicios en línea Microsoft ha digitalizado este archivo en busca de virus. Microsoft usó el software de detección de virus más reciente que había disponible en la fecha en la que se publicó el archivo. El archivo está guardado en servidores de seguridad mejorada que ayudan a prevenir cambios no autorizados del archivo.

Nota Para comprobar la versión de actualización de revisiones, compruebe el valor de la palabra clave Release para determinar la versión instalada. Para ser compatible con el reenvío, puede buscar un valor mayor o igual que el valor que se muestra en la tabla siguiente.
 

Versión del paquete acumulativo de actualizaciones de revisiones

Valor de la versión DWORD

Paquete acumulativo 3146711 revisiones para la versión .NET Framework 4.5 y versiones posteriores

380035

Para obtener más información sobre cómo determinar las .NET Framework, vea Cómo: Determinar qué .NET Framework están instaladas.
 

Más información

Requisitos previos

Para aplicar esta revisión, debe tener las .NET Framework 4.5.2, 4.5.1 o 4.5 instaladas.
 

Requisito de reinicio

Debe reiniciar el equipo después de aplicar esta revisión si se usan archivos afectados. Le recomendamos que cierre todas .NET Framework aplicaciones basadas en aplicaciones antes de aplicar esta revisión.
 

Información de la sustitución de revisión

Este paquete de revisiones no reemplaza un paquete de revisiones publicado anteriormente.

Problemas que corrige este paquete acumulativo de actualizaciones de revisiones

ASP.NET problema

La contención y el mal rendimiento se producen en System.Web.BufferAllocator al ejecutar una aplicación web en equipos con más de 32 núcleos.

Corrección: La contención se ha eliminado quitando el bloqueo global en System.Web.BufferAllocator.

Windows de formularios

Windows la interfaz de usuario de PrintPreviewDialog de formularios se inicializa muy lentamente cuando se cumplen las condiciones siguientes:
 

  • Se usa una impresora de red.

  • Las preferencias de usuario para esta impresora, como la configuración a doble cara, se modifican.

Se ha agregado optimización del rendimiento a este escenario. Si la configuración de página no se modifica para una página específica, la configuración de impresora no se vuelve a aplicar (accediendo a la cola de impresora) para esta página. Si la aplicación modifica la configuración de la impresora mediante el controlador de eventos QueryPageSettings , el rendimiento de generación de la vista previa de impresión para las páginas afectadas no mejorará incluso si se establece la marca de suscripción.

Para participar en esta optimización, se debe agregar la siguiente clave al archivo app.config, según la versión de .NET Framework.

.NET Framework 4.5.2:

<?xml version="1,0" encoding="utf-8"?>
<configuración>
< appSettings >
< key="OptimizePrintPreview" value="true" />
< /appSettings >
</configuration> .NET Framework 4.6 o una versión posterior:

<?xml version="1,0" encoding="utf-8"?>
<configuración>
< runtime>
< AppContextSwitchOverrides = "Switch.System.Drawing.Printing.OptimizePrintPreview=true" />
< /runtime>
</configuration> Si una aplicación puede ejecutarse en cualquiera de las versiones del .NET Framework, use ambos modificadores en el mismo archivo.

Para optar por no participar, quite el modificador o establezca los valores en false.

ClickOnce problema

ClickOnce se ha actualizado para admitir TLS 1.1 y 1.2. ClickOnce detecta automáticamente qué protocolo TLS es necesario en tiempo de ejecución. No se necesitan pasos adicionales en ClickOnce habilitar esta funcionalidad.

Nota ClickOnce continúa siendo compatible con TLS 1.0 para el futuro previsible, aunque ya no se considere compatible con PCI.

¿Necesita más ayuda?

Ampliar sus conocimientos

Explorar los cursos >

Obtener nuevas características primero

Unirse a Microsoft Insider >

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a tu experiencia?

¡Gracias por sus comentarios!

×