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Síntomas

Puede experimentar un comportamiento inesperado cuando Microsoft FRx intenta acceder a uno o varios de los siguientes archivos de base de datos FRx:

  • Frxsys32.mdb

  • Frxque32.mdb

  • Archivos que tienen una extensión de nombre de archivo .f32

Por ejemplo, puede experimentar los siguientes síntomas:

  • Recibe uno de los siguientes mensajes de error.

    Mensaje de error 1

    Error de tiempo de ejecución '-2147467259 (80004005)': Formato de base de datos no reconocido.

    Mensaje de error 2

    Error en tiempo de ejecución '3343': formato de base de datos no reconocido.

    Mensaje de error 3

    Error 3709. La conexión no se puede usar para realizar esta operación. Puede ser cerrado o no válido en este contexto.

  • Es posible que el Diseñador FRx no se inicie. Al intentar iniciar el Diseñador FRx, aparece brevemente la pantalla de inicio. Luego desaparece.

  • Al generar un informe en microsoft FRx Diseñador de informes, recibe el siguiente mensaje de error:

    El motor de base de datos de Microsoft Jet no puede encontrar la tabla de entrada o la consulta "Usuarios activos". Asegúrese de que existe y está escrito correctamente.

Cuando experimentes estos síntomas, ya no puedes usar Microsoft FRx. Después de realizar una operación de compactar y reparar en la base de datos, Microsoft FRx funciona según lo esperado. Sin embargo, es posible que reciba el mismo mensaje de error un poco más tarde.

Causa

Este problema puede ocurrir si las bases de datos de Microsoft Jet usadas por Microsoft FRx están dañadas. Los siguientes problemas pueden provocar daños en la base de datos:

  • Archivos de sistema obsoletos

  • Service Packs de Microsoft FRx que no coinciden

  • Problemas de conectividad de red

  • Problemas con la configuración del entorno

Solución

Para evitar este problema, use uno o varios de los siguientes métodos según corresponda.

Método 1: Realizar regularmente una operación de compactar y reparar en la base de datos

  1. Inicie Microsoft FRx. Puede iniciar Microsoft FRx en una estación de trabajo. O bien, si Microsoft FRx está instalado en un servidor, puede iniciar Microsoft FRx en el servidor.

  2. Haga clic en Archivo, elija Base de datos FRx compacta y, a continuación, haga clic en Base de datos de conjunto de especificaciones actuales.

  3. Haga clic en y, a continuación, haga clic en Aceptar cuando se complete la operación.

  4. Haga clic en Archivo, elija Base de datos FRx compacta y, a continuación, haga clic en Base de datos del sistema FRx.

  5. Haga clic en y, a continuación, haga clic en Aceptar cuando se complete la operación.

  6. Haga clic en Archivo, elija Base de datos FRx compacta y, a continuación, haga clic en Base de datos de cola FRx.

    Nota La base de datos de la cola FRx solo estará disponible si FRx Report Server está instalado.

  7. Haga clic en y, a continuación, haga clic en Aceptar cuando se complete la operación.

Si sigue recibiendo uno de los mensajes de error que se mencionan en la sección "Síntomas", realice el Método 2.

Método 2: Asegurarse de que todas las estaciones de trabajo que tienen FRx Designer instalado están actualizadas

Siga estos pasos en cada estación de trabajo que tenga instalado el Diseñador FRx:

  1. Usa Microsoft Update para instalar el Último Service Pack de Microsoft Windows. Para obtener más información acerca de Microsoft Update, visite el siguiente sitio web de Microsoft:

    http://update.microsoft.com

  2. Obtenga e instale el Último Service Pack de Microsoft Jet. Para obtener los Service Pack de Microsoft Jet, visita el siguiente sitio web de Microsoft:

    http://www.microsoft.com/downloads Para buscar el Último Service Pack de Microsoft Jet, haga clic en Todas las descargas en la lista de búsqueda , escriba Actualizaciones de Jet y, a continuación, haga clic en Ir.

  3. Configura exclusiones en los programas antivirus y antispyware para evitar que estos programas lean la carpeta FRx SysData.

    Para obtener información sobre cómo configurar exclusiones, consulta las instrucciones de configuración del programa antivirus y antispyware.

    Nota Al instalar Microsoft FRx, asegúrate de que los programas antivirus y antispyware estén deshabilitados. Esto evitará que los archivos de instalación se dañen o se bloqueen durante la instalación.

Si sigue recibiendo uno de los mensajes de error que se mencionan en la sección "Síntomas", realice el Método 3.

Método 3: Deshabilitar el bloqueo oportunista en el servidor que hospeda la carpeta FRx SysData

Si experimenta el comportamiento siguiente, el bloqueo oportunista puede estar causando daños en la base de datos de Microsoft Jet:

  • Después de realizar el Método 1 y el Método 2, sigue recibiendo uno de los mensajes de error que se mencionan en la sección "Síntomas".

  • Los archivos que tienen una extensión de nombre de archivo .ldb o .lck permanecen en la carpeta FRx SysData incluso cuando no hay usuarios conectados a FRx.

Este comportamiento puede ocurrir si el servidor que hospeda la carpeta FRx SysData ejecuta cualquiera de los siguientes programas:

  • Microsoft Windows Server 2003 o Windows Server 2003 Terminal Server

  • Microsoft Windows 2000 Server o Windows 2000 Server Terminal Services

  • Citrix Server

Para evitar que el bloqueo oportunista cause daños en la base de datos de Microsoft Jet, instala el Último Service Pack de Windows Server. Sin embargo, si el comportamiento que se menciona en esta sección continúa ocurriendo después de instalar el último Service Pack de Windows Server, deshabilite el bloqueo oportunista. Para obtener más información sobre cómo deshabilitar el bloqueo oportunista, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

296264 Configurar el bloqueo oportunista en Windows

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