Iniciar sesión con Microsoft
Iniciar sesión o crear una cuenta
Hola:
Seleccione una cuenta diferente.
Tiene varias cuentas
Elija la cuenta con la que desea iniciar sesión.

Síntomas

Cuando utiliza el Editor de perfiles de seguimiento (TPE) o la herramienta de BTTDeploy (Bttdeploy.exe) para implementar un perfil de seguimiento grandes (btt) en BizTalk Server 2010, se produce un error en la implementación. Además, recibirá el siguiente mensaje de error:

La transacción ya implícita o explícitamente confirmó o anuló (excepción de HRESULT: 0x8004D00E).


Nota: Este paquete de actualización acumulativa resuelve sólo el problema que se produce al utilizar la herramienta Bttdeploy.exe.

Causa

Este problema se produce porque la transacción de tiempo después de 3 minutos antes de que el perfil de gran tamaño puede implementarse completamente.

Solución

Para resolver este problema, aplique esta revisión. Después de aplicar la revisión, puede ampliar el valor de tiempo de espera predeterminado en un valor mayor que 3 minutos.

Nota: Esta revisión se aplica a la herramienta de línea de comandos BTSDeploy.exe y no a las otras herramientas de supervisión de la actividad económica (SAE).

Para ampliar el valor de tiempo de espera predeterminado, agregue las líneas siguientes al archivo BTSDeploy.exe.config:

<configuration>
  <appSettings>
< Agregar clave = "CommandTimeoutInMinutes" value = "nn" / >
  </appSettings>
</ configuration>
Notas:

  • El marcador de posición de nn representa el número de minutos que desea establecer como el valor de tiempo de espera predeterminado.

  • Si el tiempo de espera llega a 10 minutos o más, también debe tener en cuenta el valor de tiempo de espera predeterminado de.NET Framework en el archivo Machine.config. Este valor debe ser igual o mayor que el valor de tiempo de espera en el archivo BTSDeploy.exe.config.

  • Tenga en cuenta que al aumentar el valor de tiempo de espera puede no resolver completamente el problema. Debido a otros problemas subyacentes también podrían desencadenar este comportamiento, deberá revisar el perfil de seguimiento, BizTalk configuración, Windows Configuración, SQL Server performance, rendimiento de almacenamiento y rendimiento de la red para resolver el problema real.


Información de actualización acumulativa

La revisión que resuelve este problema se incluye en la actualización acumulativa 6 para BizTalk Server 2010.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Solución alternativa

Para evitar este problema, utilice uno de los métodos siguientes:

  • Implementar perfiles de seguimiento de tamaño más pequeño para que la respuesta de transacción no superará los 3 minutos.

  • Optimizar SQL Server para que responda a la transacción en el tiempo de espera de 3 minutos.

¿Necesita más ayuda?

¿Quiere más opciones?

Explore las ventajas de las suscripciones, examine los cursos de aprendizaje, aprenda a proteger su dispositivo y mucho más.

Las comunidades le ayudan a formular y responder preguntas, enviar comentarios y leer a expertos con conocimientos extensos.

¿Le ha sido útil esta información?

¿Cuál es tu grado de satisfacción con la calidad del lenguaje?
¿Qué ha afectado a su experiencia?
Si presiona Enviar, sus comentarios se usarán para mejorar los productos y servicios de Microsoft. El administrador de TI podrá recopilar estos datos. Declaración de privacidad.

¡Gracias por sus comentarios!

×