Síntomas
Utilice el proveedor de Instrumental de administración de Windows (WMI) de Microsoft Host Integration Server para comprobar el estado de los servicios de Host Integration Server. Las consultas WMI pueden dejar de responder después de que las consultas se ejecuten correctamente durante algún tiempo.
Causa
Este problema se produce en determinadas condiciones de temporización cuando la infraestructura (Microsoft Foundation Classes) llama al método ExitInstance desde la función DllMain . Cuando se produce esta situación, el proveedor WMI de Host Integration Server llama a la función CoFreeUnusedLibraries . Esto causa un interbloqueo en el cargador de NTDLL. En este momento, el Host del proveedor de WMI (WmiPrvSE.exe) que aloja el proveedor WMI de Host Integration Server deja de responder.
Solución
Información de la revisión
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.
Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión.
Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
Debe tener el paquete de actualización acumulativa 2 para Microsoft Host Integration Server 2009 instalado para aplicar esta revisión. Para obtener más información acerca de cómo obtener el paquete de actualización acumulativa, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
Paquete 2 de actualización de 2645939 acumulado para Host Integration Server 2009
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Microsoft Host Integration Server 2009, edición de 32 bits
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Wmisna.dll |
8.0.3925.2 |
309,584 |
10-Jan-2012 |
23:48 |
x86 |
Microsoft Host Integration Server 2009, 64-bit Edition
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Wmisna.dll |
8.0.3925.2 |
309,584 |
10-Jan-2012 |
23:48 |
x86 |
Wmisna.dll |
8.0.3925.2 |
580,432 |
10-Jan-2012 |
23:50 |
x64 |
Nota: Debido a la interdependencia entre archivos, la revisión más reciente que contiene estos archivos puede contener también archivos adicionales.
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".