Síntomas
Cuando ejecuta Microsoft BizTalk 2010 Accelerator para SWIFT (A4SWIFT) en un servidor que está ejecutando Microsoft BizTalk Server 2010, los siguientes mensajes de error pueden anotarse en el registro de aplicación:
fecha tiempo Advertencia 5 servicio de SAE EventBus servername.fqdn error de ejecución por lotes. Información de la excepción: TDDS no pudo ejecutar secuencias por lotes. SQLServer: nombre_servidor, base de datos: BAMPrimaryImport.Parameter no es válido.
fechatiempo Error 6 servicio de SAE EventBus servername.fqdn error de evento Execute. Se han producido errores durante la ejecución de eventos, vea TDDS_FailedTrackingData tabla para obtener más detalles. SQLServer: nombre_servidor, base de datos: BAMPrimaryImport.Nota: Este problema se produce durante el procesamiento de una confirmación (ACK) o un mensaje de confirmación negativa (NACK).
Causa
Este problema se produce porque algunos parámetros importantes, como ErrorNack, sesión, TimeSenty la secuencia, no se definen en el archivo de definición de FrrActivities.xml.
Solución
Antes de aplicar esta revisión, debe ejecutar el siguiente comando en un símbolo del sistema con privilegios elevados:
C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" remove-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml
Después de aplicar esta revisión, debe ejecutar el siguiente comando en un símbolo del sistema con privilegios elevados:C:\Program Files (x86)\Microsoft BizTalk Server 2010\Tracking\bm.exe" deploy-all -DefinitionFile:"C:\Program Files (x86)\Microsoft BizTalk Accelerator for SWIFT\BAMTracking\FrrActivities.xml"
Información de la revisión
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplique esta revisión solamente a sistemas que experimenten el problema descripto en este artículo. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la próxima actualización de software que contenga este hotfix.
Si la revisión está disponible para su descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio al cliente de Microsoft y soporte técnico para obtener la revisión. Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de Hotfix disponible" muestra los idiomas para los que el Hotfix está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Requisitos previos
Para aplicar este hotfix, debe tener instalado BizTalk Server 2010.
Información de reinicio
No es necesario que reinicie el equipo después de aplicar este hotfix.
Información de reemplazo
Esta revisión no sustituye cualquier revisión lanzada anteriormente.
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Frractivities.xml |
No aplicable |
10,689 |
18-Jul-2013 |
21:34 |
No aplicable |
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".
Más información
Para obtener más información, consulte soporte técnico información acerca de las revisiones de BizTalk y acumulativos de actualizaciones.