Síntomas
Considere el siguiente escenario. Trabajar con un canal de Windows Communication Foundation (WCF) para WebSphere MQ en un entorno de Microsoft Host Integration Server 2010. El Administrador de cola se detiene por algún motivo, como una conexión de restablecer en el transporte.
En este escenario, no puede volver a conectar el canal WCF. A continuación, se produce un error en cada solicitud de lectura sucesivo y recibirá el código de motivo 6124 como sigue:
Un método falló porque no estaba disponible una conexión a un administrador de cola necesaria y no se puede establecer implícitamente una conexión porque el indicador IMQ_IMPL_CONN del atributo class ImqQueueManagerbehavior es FALSE.
Causa
Este problema se produce porque el error se controla correctamente cuando el Administrador de cola se detiene.
Solución
Información de actualización acumulativa
La revisión que resuelve este problema se incluye en el paquete de actualización acumulativa 8 para Host Integration Server 2010. Para obtener más información acerca de cómo obtener el acumulado paquete de actualización, vea 8 para Host Integration Server 2010 del paquete de actualización acumulativa.
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".