Síntomas
Se supone que usa Microsoft BizTalk Server 2010 o 2013. Cuando se utiliza un componente de canalización personalizado para llamar al servicio de transformación de Bus de servicio empresarial (ESB) para transformar los mensajes en ESB Toolkit 2.1, la propiedad de contexto DocumentSpecName se establece incorrectamente en el mensaje de salida, y recibirá el siguiente mensaje de error:
Nombre de registro: aplicación
Fuente: BizTalk Server
Id. de suceso: 5720
Categoría de tarea: BizTalk Server
Nivel: Error
Descripción: hubo un error al ejecutar la canalización de envío: "ESBTransform.SendPipeline1, ESBTransform, Version = 1.0.0.0, referencia cultural = neutral, PublicKeyToken = ca09cc62b15919a7" origen: "Plana ensamblador de archivo" puerto de envío: "<SendPortName >" URI: "<SendPortURI>" motivo: el tipo de documento "http://ESBTransform.FlatFileSchema1#TargetRoot" no coincide con ninguno de los esquemas determinados.
Causa
El problema se produce porque el servicio de transformación de ESB no establece la propiedad de contexto DocumentSpecName del mensaje de salida es el tipo de esquema de destino después de la transformación.
Solución
Información de la revisión
Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.
Si la revisión está disponible para su descarga, entonces podrá ver una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.
Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.
Información de actualización acumulativa
Este problema se corrigió primero en la actualización acumulativa siguiente de 2013 de BizTalk Server:
Requisitos previos
Para aplicar este hotfix, debe tener instalado de BizTalk ESB Toolkit 2.1.
Requisito de reinicio
No es necesario que reinicie el equipo después de aplicar este hotfix.
Información de reemplazo de revisión
Este hotfix no sustituye a otras revisiones.
Información de archivo
La versión en inglés de esta revisión tiene los atributos de archivo (o atributos del archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en la hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para encontrar la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria en el elemento de Fecha y hora del Panel de control.
Nombre del archivo |
Versión del archivo |
Tamaño de archivo |
Fecha |
Hora |
Plataforma |
---|---|---|---|---|---|
Microsoft.Practices.ESB.Itinerary.Services.dll |
2.1.1.0 |
24576 |
13-Oct-2014 |
13:11 |
x86 |
Más información
Para obtener más información acerca de la terminología de la actualización de software, consulte la Descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft.
Estado
Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".