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Síntomas

Imagine el siguiente escenario:

  • Dispone de un servidor basado en Windows Server 2012 R2 que tiene los servicios de federación de Active Directory (AD FS) 3.0 instalado.

  • Tiene equipos cliente basados en Windows 7 o Windows 8.

  • El valor de la propiedad NtlmOnlySupportedClientAtProxy se establece en TRUE en el servidor.

  • Intente modificar o guardar un documento de Microsoft Office mientras está utilizando un equipo cliente que está fuera de la red corporativa.

En este escenario, se produce un error de autenticación de Microsoft Office 365.

Causa

Este problema se produce porque el código de proxy de AD FS busca un encabezado de "WWWAuthenticate" en los encabezados de respuesta del servicio de Token de seguridad (STS) en lugar de en los encabezados de solicitud.

El componente de autenticación de Office 365 solicita el proxy de AD FS para utilizar "negociar" como mecanismo de autenticación entre los equipos cliente basados en Windows 7 o Windows 8. Un encabezado de WWWAuthenticate se agrega al encabezado de la solicitud. Sin embargo, el código proxy busca el encabezado en los encabezados de respuesta de STS en lugar de en los encabezados de solicitud. Por lo tanto, no se encuentra el encabezado cuando el servidor intenta autenticar el equipo cliente. Equipos cliente basados en Windows 8 y 7 de Windows no pueden realizar la autenticación desafío/respuesta de Windows (NTLM).

Solución

Información de la revisión

Existe un hotfix disponible desde Microsoft. Sin embargo, esta revisión se diseñó para corregir únicamente el problema que se describe en este artículo. Aplíquela sólo a sistemas que experimenten este problema específico.

Si la revisión está disponible para su descarga, entonces podrá ver una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, envíe una solicitud al servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota: Si se producen problemas adicionales o si se requiere cualquier otra solución, será necesario crear una solicitud de revisión independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no califican para esta revisión específica. Para obtener una lista completa de los números de teléfono de servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:

http://support.microsoft.com/contactus/?ws=supportNota: El formulario de "Descarga de revisión disponible" muestra los idiomas para los que la revisión está disponible. Si no ve su idioma, es porque no hay una revisión para ese idioma.

Requisitos previos

Para aplicar esta revisión, debe ejecutar Windows Server R2 de 2012.

Información del registro

Para utilizar la revisión de este paquete, no es necesario realizar ningún cambio en el registro.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información de reemplazo de revisión

Esta revisión no sustituye a ninguna revisión publicada previamente.

La versión global de esta revisión instala archivos que tienen los atributos enumerados en las tablas siguientes. Las fechas y las horas de estos archivos se muestran en la hora Universal coordinada (UTC). Las fechas y las horas de estos archivos en el equipo local se muestran en horario local junto con la diferencia de horario de verano (DST) actual. Además, las fechas y las horas pueden cambiar cuando realiza determinadas operaciones en los archivos.





Notas sobre la información de archivo de Windows Server R2 de 2012Importante: Correcciones urgentes de Windows 8.1 y R2 de Windows Server 2012 se incluyen en los mismos paquetes. Sin embargo, sólo "Windows 8.1" aparece en la página solicitud de revisión. Para solicitar el paquete de revisiones que se aplica a uno o ambos sistemas operativos, seleccione la revisión que aparece en "Windows 8.1" en la página. Siempre consulte la sección "Aplicable a" de los artículos para determinar el sistema operativo real a la que se aplica cada revisión.

  • Los archivos que se aplican a un producto, hito (RTM, SPn) y el servicio (LDR, GDR) se pueden identificar examinando los números de versión de archivo, como se muestra en la siguiente tabla:

    Versión

    Producto

    Hito

    Tipo de servicio

    6.3.960 0,16 xxx

    Windows Server 2012 R2

    RTM

    GDR

  • Los archivos MANIFEST (.manifest) y los MUM archivos (.mum) que se instalan para cada entorno están enumerados por separado en la sección "Información para Windows Server 2012 R2 de archivo adicional". MUM y los archivos de manifiesto y los archivos de catálogo (.cat) de seguridad asociados, son extremadamente importantes para mantener el estado de los componentes actualizados. Los archivos de catálogo de seguridad, para los cuales no se muestran los atributos, están firmados con una firma digital de Microsoft.

Para todas las versiones basadas en x64 compatibles de Windows Server R2 de 2012

Nombre del archivo

Versión del archivo

Tamaño de archivo

Fecha

Hora

Plataforma

Microsoft.identityserver.proxyservice.exe

6.3.9600.16477

63,488

27-Nov-2013

15:33

x86

Microsoft.identityserver.proxyservice.exe.config

No aplicable

1.067

18-Jun-2013

14:55

No aplicable

Microsoft.identityserver.webhost.dll

6.3.9600.16392

172,032

31-Aug-2013

14:23

x86




Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Aplicable a".

Más información

Para obtener más información acerca de la terminología de la actualización de software, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

824684 descripción de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft

Información adicional de archivos para Windows Server R2 de 2012

Archivos adicionales para todas las versiones compatibles basadas en x64 de Windows Server R2 de 2012

Propiedad de archivo

Valor

Nombre del archivo

Amd64_01f5ce74bdcbc4589be5b7ccbd393d70_31bf3856ad364e35_6.3.9600.16477_none_efe8eb19b27435c2.manifest

Versión del archivo

No aplicable

Tamaño de archivo

710

Fecha (UTC)

28-Nov-2013

Hora (UTC)

01:03

Nombre del archivo

Amd64_b08f1d804fb2ba52c1a39f780276f717_31bf3856ad364e35_6.3.9600.16477_none_95426249afcc97f7.manifest

Versión del archivo

No aplicable

Tamaño de archivo

705

Fecha (UTC)

28-Nov-2013

Hora (UTC)

01:03

Nombre del archivo

Msil_microsoft.identityserver.proxyservice_31bf3856ad364e35_6.3.9600.16477_none_46ee2d31e9308eb5.manifest

Versión del archivo

No aplicable

Tamaño de archivo

4,764

Fecha (UTC)

27-Nov-2013

Hora (UTC)

16:14

Nombre del archivo

Msil_microsoft.identityserver.webhost_31bf3856ad364e35_6.3.9600.16477_none_7926ccd9e1870342.manifest

Versión del archivo

No aplicable

Tamaño de archivo

3.334

Fecha (UTC)

28-Nov-2013

Hora (UTC)

01:03


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