Symptoms
When you try to start one of the Microsoft games that are listed in the “Applies to” section, you receive one of the following error messages:
Error message 1
The file d3dx9_25.dll was not found
Error message 2
The file d3dx9_27.dll was not found
Cause
This issue may occur if the Microsoft DirectX file that is mentioned in the error message is corrupted or is not copied correctly.
Resolution
Download and then install the latest version of DirectX
To resolve this problem, download and then install the latest version of DirectX End-User Runtimes Web Installer. To do this, visit the following Microsoft Web site:
http://www.microsoft.com/download/details.aspx?FamilyId=2DA43D38-DB71-4C1B-BC6A-9B6652CD92A3&displaylang=en Note You may receive the following error message during installation:
The software you are installing has not passed Windows Logo testing to verify its compatibility with this version of Windows. (Tell me why this testing is important.)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
822798 You cannot install some updates or programs
Manually copy the file
To resolve this issue, copy the D3dx9_25.dll file or the D3dx9_27.dll file from the disc 1 CD/DVD of the game CD/DVD pack to the corresponding game folder. To do this, follow the appropriate steps for your version of Windows:
Windows 7 or Windows Vista
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Insert the disc 1 CD/DVD for your game into the CD/DVD drive of the computer.
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Click Start , and then click Documents.
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Locate and then click Computer.
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Locate and then click the CD/DVD drive.
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Locate and then click the following folder:
CDDrive:\ DirectX9 Note In this path, CDDriverepresents the drive letter of the CD drive.
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Double-click Apr2005_d3dx9_25_x86.cab, right-click d3dx9_25.dll, and then click Copy.
Note Use the Apr2005_d3dx9_25_x64.cab file for the x64-based version of the Windows operating system.
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Locate the following folder for your game:
Drive:\Program Files\Microsoft Games\Game Title Note In this path, Driverepresents the drive letter on which the game is installed, and Game Title represents the game that you want to repair.
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Right-click the game folder that corresponds to the game that is installed on the computer, and then click Paste.
Note If you have installed more than one game on the computer, repeat steps 7and 8 for the other games.
Windows XP
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Insert the disc 1 CD/DVD for your game into the CD/DVD drive of the computer.
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Click Start, point to Programs, point to Accessories, and then click Windows Explorer.
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Locate and then click the following folder:
CDDrive:\ DirectX9 Note In this path, CDDriverepresents the drive letter of the CD drive.
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Double-click Apr2005_d3dx9_25_x86.cab, right-click d3dx9_25.dll, and then click Copy.
Note Use the Apr2005_d3dx9_25_x64.cab file for the x64-based version of the Microsoft Windows operating system.
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Locate the following folder for your game:
Drive:\Program Files\Microsoft Games\Game Title
Note In this path, Drive represents the drive letter of the drive on which the game is installed, and Game Title represents the game that you want to repair.
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Right-click the game folder that corresponds to the game that is installed on the computer, and then click Paste.
Note If you have installed more than one game on the computer, repeat steps 5 and 6 for the other games.
Next steps
If you need more help, visit the Microsoft Customer Support Services Web site to find other solutions. This Web site provides the following services:
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http://answers.microsoft.com/en-us/windows/default.aspx): Interact with peers and with Microsoft Most Valuable Professionals (MVPs).
Microsoft Community( -
Solution Centers (http://support.microsoft.com/select/?target=hub): View product-specific frequently asked questions (FAQ) and support highlights.
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Searchable Knowledge Base (http://support.microsoft.com/search/?adv=1): Search technical support information and self-help tools for Microsoft products.
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Other Support Options (http://support.microsoft.com/default.aspx?pr=csshome): Use the Web to ask a question, to contact Microsoft Customer Support Services, or to provide feedback.