Sümptomid

Kui proovite installida Microsoft .NET Frameworki 4.7 arvutis, milles töötab Windows 7 Service Pack 1 (SP1), Windows Server 2008 R2 hoolduspaketi SP1 või Windows Server 2012 setup on blokeeritud ja ei saa jätkata.

.netFramework

See probleem ilmneb siis, kui arvutisse installitud D3DComplier värskendus (D3DCompiler_47.dll) installitud.

Põhjus

Windows 7 SP1, Windows Server 2008 R2 hoolduspaketi SP1 ja Windows Server 2012 on .NET Framework 4.7 on uus sõltuvus %windir%\system32\D3DCompiler_47.dll faili jaoks WPF-i. See fail peab olema installitud enne, kui .NET Frameworki 4.7 toote saab installida.

Lahendus

Selle probleemi lahendamiseks, manstalli ning d3dcompiler värskenduse üks järgmistest lingid enne installimist .NET Frameworki 4.7. See värskendus on saadaval Windows Update'i kaudu ja Microsofti värskenduste kataloogist ka.

  • Windows 7 SP1 x 86, kasutage seda linki.

  • Windows 7 hoolduspaketi SP1 või Windows Server 2008 R2 x64, kasutage seda linki.

  • Windows Server 2012 x64, kasutage seda linki.

Olek

Microsoft on kinnitanud, et see on küsimus jaotises "Kehtib järgmiste toodete kohta" loetletud Microsofti toodetel.

Kas vajate veel abi?

Täiendage oma oskusi
Tutvuge koolitusmaterjalidega
Kasutage uusi funktsioone enne teisi
Liitu Microsofti Insideri programmis osalejad

Kas sellest teabest oli abi?

Kui rahul te keelekvaliteediga olete?
Mis mõjutas teie hinnangut?

Täname tagasiside eest!

×