Kirjaudu sisään Microsoft-tilillä
Kirjaudu sisään tai luo tili.
Hei
Valitse toinen tili.
Sinulla on useita tilejä
Valitse tili, jolla haluat kirjautua sisään.

Kun alat luoda kaavoja, muista seuraavat parhaat käytännöt. On myös hyvä tiedostaa yleiset virheet, jotka voit tehdä kaavoja luodessa.

Kaavojen luomisen parhaat käytännöt

Seuraavassa taulukossa on yhteenveto kaavojen kirjoittamisen parhaista käytännöistä.

Noudata tätä parasta käytäntöä

Toimimalla seuraavasti:

Viittauksen tyypin muuttaminen helposti        

Huomautus: Tämä ei koske Excelin verkkoversio.

Voit vaihtaa suhteellisten, absoluuttisten ja sekaviittausten välillä:

  1. Valitse kaavan sisältävä solu.

  2. Valitse kohdasta kaavarivi Painikkeen kuvasoluviittaus, jota haluat muuttaa.

  3. Vaihda viittaustyyppien välillä painamalla F4-näppäintä.

Kaavojen kopioiminen nopeasti   

Jos haluat kirjoittaa saman kaavan nopeasti solualueeseen, valitse laskettava alue, kirjoita kaava ja paina näppäinyhdistelmää Ctrl+Enter. Jos esimerkiksi kirjoitat =SUMMA(A1:B1) alueelle C1:C5 ja painat sitten näppäinyhdistelmää Ctrl+Enter, Excel kirjoittaa kaavan alueen jokaiseen soluun käyttämällä A1:tä suhteellisena viittauksena.

Kaavojen automaattisen täydennyksen käyttö    

Voit helpottaa kaavojen muodostamista ja muokkaamista sekä vähentää kirjoitus- ja syntaksivirheitä käyttämällä kaavojen automaattista täydennystä. Kun kirjoitat = (yhtäläisyysmerkki) ja alkukirjaimet (alkukirjaimet toimivat näyttösyistä), Excel näyttää dynaamisen luettelon kelvollisia funktioita ja nimiä solun alapuolella. Kun olet lisännyt funktion tai nimen kaavaan insert-käynnistimen avulla (painamalla SARKAINTA tai kaksoisnapsauttamalla kohdetta luettelossa), Excel sopivat argumentit. Kun täytät kaavaa, pilkku voi myös toimia näyttö käynnistimenä , Excel voi näyttää lisää argumentteja. Voit lisätä kaavaan muita funktioita tai nimiä, sillä Excel näyttää uudelleen dynaamisen luettelon, kun kirjoitat näiden funktioiden tai nimien ensimmäiset kirjaimet.

Funktioiden kohdeohjeiden käyttäminen   

Jos funktion argumentit eivät ole sinulle tuttuja, voit käyttää funktion kohdeohjetta, joka tulee näkyviin, kun kirjoitat funktion nimen ja alkusulkeen. Napsauttamalla funktion nimeä saat näkyviin funktion ohjeaiheen, ja argumentin nimeä napsauttamalla voit valita vastaavan argumentin kaavaasi.

Kaavoissa esiintyvien virheiden etsiminen

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Office Insidersiin

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteesta!

×