TULOJEN.SUMMA (TULOJEN.SUMMA-funktio)

TULOJEN.SUMMA-funktio palauttaa vastaavien matriisien tai matriisien tulojen summan. Oletustoiminto on kertolasku, mutta myös lisäys, vähennyslasku ja jako ovat mahdollisia.

Tässä esimerkissä käytämme TULOJEN.SUMMA-funktiota tietyn kohteen ja koon kokonaismyynnin palauttamiseen:

Esimerkki TULOJEN.SUMMA-funktion käyttämisestä kokonaismyynnin palauttamiseen, kun kullekin annetaan tuotteen nimi, koko ja yksittäiset myyntiarvot.

TULOJEN.SUMMA vastaa kohteen Y/Koko M kaikkia esiintymät ja summaa ne, joten tässä esimerkissä 21 ja 41 on yhtä suuri kuin 62.

Syntaksi

Oletustoiminnon (kertolaskun) käyttö:

=TULOJEN.SUMMA(matriisi1; [matriisi2]; [matriisi3]; ...)

TULOJEN.SUMMA-funktion syntaksissa on seuraava argumentti:

Argumentti

Kuvaus

matriisi1   

Pakollinen

Ensimmäinen matriisiargumentti, jonka osat halutaan kertoa ja laskea sitten yhteen.

[matriisi2], [matriisi3],...    

Valinnainen

Matriisiargumentit 2–255, joiden osat halutaan kertoa ja laskea sitten yhteen.

Muiden aritmeettisten toimintojen suorittamiseen

Käytä TULOJEN.SUMMA-funktiota tavalliseen tapaan, mutta korvaa matriisiargumentit haluamallasi aritmeettisilla operaattoreilla (*, /, +, -). Kun kaikki toiminnot on suoritettu, tulokset lasketaan yhteen tavalliseen tapaan.

Huomautus: Jos käytät aritmeettisia operaattoreita, matriisiargumentit kannattaa ehkä menettää sulkeissa ja matriisiargumentit kannattaa ryhmitellä sulkeiden avulla aritmeettisten toimintojen järjestyksen hallitsemista varten.

Huomautuksia

  • Argumentteina olevien matriisien on oltava samankokoisia. Muuten TULOJEN.SUMMA palauttaa #ARVO! ‑virhearvon. Esimerkiksi =TULOJEN.SUMMA(C2:C10;D2:D5) palauttaa virheen, koska alueet eivät ole samankokoisia.

  • TULOJEN.SUMMA käsittelee ei-numeerisia matriisimerkintöjä nollina.

  • TULOJEN.SUMMA-funktiota ei tule käyttää kokonaisten sarakeviittausten kanssa, mikä parantaa suorituskykyä. Harkitse = TULOJEN.SUMMA(A:A,B:B), tässä funktio kertoo sarakkeen A 1 048 576 solua 1 048 576 solulla ennen niiden lisäämistä sarakkeeseen B. 

Esimerkki 1

Esimerkki TULOJEN.SUMMA-funktiosta, jonka avulla voidaan palauttaa myytyjen tuotteiden summa, kun annetaan yksikkökustannuksia ja määrää.

Jos haluat luoda kaavan edellä olevasta esimerkkiluettelosta, kirjoita =TULOJEN.SUMMA(C2:C5,D2:D5) ja paina Enter-näppäintä. Jokainen sarakkeen C solu kerrotaan sen vastaavalla solulla samalla rivillä sarakkeessa D, ja tulokset lisätään. Ruokaostoksien summa on 78,97 $.

Jos haluat kirjoittaa pidemmän kaavan, joka antaa saman tuloksen, kirjoita =C2*D2+C3*D3+C4*D4+C5*D5 ja paina Enter-näppäintä. Kun olet painanut Enter-näppäintä, tulos on sama: 78,97 $. Solu C2 kerrotaan solulla D2, ja sen tulos lisätään solun C3 soluun D3 ja niin edelleen.

Esimerkki 2

Seuraavassa esimerkissä TULOJEN.SUMMA-funktiota käytetään myyntiedustajan kokonaismyynnin palauttamiseen, ja myyntiedustajan kokonaismyynti on sekä kokonaismyynti että kulut edustajalta. Tässä tapauksessa käytetään Excel-taulukkoa, jossa käytetään rakenteellisiaviittauksia Excelin vakioalueiden sijaan. Tässä näet, että Myynti-, Kulut- ja Edustaja-alueet on viitattu nimellä.

Esimerkki TULOJEN.SUMMA-funktiosta, joka palauttaa myyntiedustajan kokonaismyynnin, kun se sisältää kunkin myyntisumman ja kulut.

Kaava on: =TULOJEN.SUMMA(((Taulukko1[Myynti])+(Taulukko1[Kulut]))*(Taulukko1[Edustaja]=B8)), ja se palauttaa solussa B8 luetellun tukiedustajan myynnin ja kulujen summan.

Esimerkki 3

Tässä esimerkissä haluamme palauttaa tietyn alueen myymisen kokonaiskohteen. Tässä tapauksessa, kuinka monta kirsikoita itäinen alue myi?

Koe, jossa käytetään TULOJEN.SUMMA-funktiota, joka palauttaa kohteiden summan alueittain. Tässä tapauksessa itäalueella myytyjen kirsikoiden määrä.

Tässä kaava on: =TULOJEN.SUMMA((B2:B9=B12)*(C2:C9=C12)*D2:D9). Se kertoo ensin itäisten esiintymien määrän samannimisten kirsikoiden esiintymiskerran kertymällä. Lopuksi se summaa Myynti-sarakkeen vastaavien rivien arvot. Jos haluat nähdä, miten Excel laskee tämän, valitse kaavan solu ja siirry sitten kaavaan, >kaavan laskeminen > laskeminen.

Tarvitsetko lisätietoja?

Voit aina kysyä neuvoa Excel Tech Community -yhteisön asiantuntijalta tai saada tukea yhteisön vastauksista.

Katso myös

Ehdollisten laskutoimitusten suoristaminen solualueissa

Summa useiden ehtojen perusteella SUMMA.JOS.SUMMA-funktiolla

Laskeminen useiden ehtojen perusteella LASKE.JOS.MÄÄRÄ-lla

Keskiarvo useiden ehtojen perusteella KESKIARVO.JOS.S-lla

Tarvitsetko lisäohjeita?

Kehitä Office-taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Office Insider -käyttäjiin

Oliko näistä tiedoista hyötyä?

Kiitos palautteesta!

Kiitos palautteestasi! Näyttää siltä, että Office-tukiedustajamme avusta voi olla sinulle hyötyä.

×