Sign in with Microsoft
New to Microsoft? Create an account.

Tässä artikkelissa kuvataan Microsoft Excelin VIRHEEN.LAJI-funktion kaavasyntaksi ja käyttö.

Kuvaus

Palauttaa Microsoft Excelin sisäistä virhearvoa vastaavan luvun tai palauttaa virhearvon #PUUTTUU!, ellei virhettä ole. Voit käyttää VIRHEEN.LAJI-funktiota JOS-funktiossa, kun haluat testata virhearvon ja palauttaa merkkijonon, kuten sanoman, virhearvon sijasta.

Syntaksi

VIRHEEN.LAJI(virhearvo)

VIRHEEN.LAJI-funktion syntaksissa on seuraavat argumentit:

  • Virhearvo Pakollinen. Virhearvo, jonka tunnusluku halutaan etsiä. Vaikka virhearvo voi olla tosiasiallinen virhearvo, se on usein viittaus sellaisen kaavan sisältävään soluun, joka halutaan testata.

Jos virhearvo on:

VIRHEEN.LAJI palauttaa:

#TYHJÄ!

1

#JAKO/0!

2

#ARVO!

3

#VIITTAUS!

4

#NIMI?

5

#LUKU!

6

#PUUTTUU!

7

#HAETAAN_TIETOJA

8

Jokin muu

#PUUTTUU!

Esimerkki

Kopioi esimerkkitiedot seuraavaan taulukkoon ja lisää se uuden Excel-laskentataulukon soluun A1. Kaavat näyttävät tuloksia, kun valitset ne, painat F2-näppäintä ja sitten Enter-näppäintä. Voit säätää sarakkeiden leveyttä, että näet kaikki tiedot.

Tiedot

#TYHJÄ!

#JAKO/0!

Kaava

Kuvaus

Tulos

=VIRHEEN.LAJI(A2)

Virheen #TYHJÄ! numero(1).

1

=JOS(VIRHEEN.LAJI(A3)<3,VALITSE.INDEKSI(VIRHEEN.LAJI(A3),"Alueet eivät leikkaa","Jakaja on nolla"))

Tarkistaa solusta A3 sisältääkö solu joko virhearvon #TYHJÄ! tai #JAKO/0! ‑virhearvon. Jos sisältää, virhearvon numeroa käytetään laskentataulukon funktiossa VALITSE.INDEKSI esittämään jompikumpi viesti; muussa tapauksessa palautuu virhearvo #PUUTTUU.

Jakajana on nolla

Tarvitsetko lisäohjeita?

Kehitä taitojasi
Tutustu koulutusmateriaaliin
Saat uudet ominaisuudet ensimmäisten joukossa
Liity Microsoft Office Insidersiin

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?

Kiitos palautteesta!

×