Kirjaudu sisään Microsoft-tilillä
Kirjaudu sisään tai luo tili.
Hei,
Käytä toista tiliä.
Sinulla on useita tilejä
Valitse tili, jolla haluat kirjautua sisään.

Oireet

Kun yrität asentaa, päivittää tai käynnistää ohjelman tai tiedoston, näkyviin tulee seuraava virhesanoma:

Virhe: Windows ei voi käyttää määritettyä laitetta, polkua tai tiedostoa. Sinulla ei ehkä ole tarvittavia käyttöoikeuksia.

Ratkaisu

Voit ratkaista tämän ongelman tekemällä alla olevien ratkaisutapojen vaiheet alkaen tavasta 1. Jos se ei korjaa ongelmaa, kokeile seuraavaa tapaa:

Tapa 1: Tarkista tiedoston tai kansion käyttöoikeudet.

Huomautus Varmista, että olet järjestelmänvalvoja tai että kuulut Toimialueen valvojat -ryhmään, jos olet toimialueessa.

Käyttöoikeudet ovat tiedostoihin liittyviä sääntöjä, jotka määräävät, voitko käyttää tiedostoa ja mitä voit tehdä sillä. Voit tarkistaa tiedoston tai kansion käyttöoikeudet seuraavasti:

  1. Napsauta tiedostoa tai kansiota hiiren kakkospainikkeella ja valitse Ominaisuudet.

  2. Valitse Suojaus-välilehti.

  3. Käyttöoikeutesi tulevat näkyviin, kun valitset nimesi Ryhmä- tai käyttäjänimet -kohdassa. (Tämän vaiheen näyttökuva on alla).
    The screen shot for this step

  4. Valitse Muokkaa, valitse tarvitsemiesi käyttöoikeuksien valintaruudut ja valitse OK. (Tämän vaiheen näyttökuva on alla).
    The screen shot for this step


Lisätietoja käyttöoikeuksista on kohdassa Mitä ovat käyttöoikeudet?

Tapa 2: Tarkista tiedoston sijainti.

Virheen syynä voi olla, se, että oikopolku tai asennus yrittää käyttää sijaintia, joka ei ole saatavilla (esimerkiksi verkkoasemaa tai siirrettävää asemaa). Tarkista sen tiedoston polku, jota Windows ei voi käyttää, ja varmista, että kyseinen sijainti on käytettävissä. (Tämän vaiheen näyttökuva on alla).
The screen shot for this step

Tapa 3: Varmista, ettei tiedostoa ole siirretty tai poistettu.

Voit saada tämän virheen myös siinä tapauksessa, että tiedosto on siirretty tai poistettu. Siirry tiedoston sijaintiin ja varmista, että tiedosto löytyy sieltä.

Tapa 4: Tarkista, ettei oikopolku ole vaurioitunut, luomalla se uudelleen.

Voit saada tämän virheen myös siinä tapauksessa, että oikopolku tai muun tyyppinen tiedosto on vaurioitunut. Voit tarkistaa, ettei oikopolku ole vaurioitunut, luomalla sen uudelleen. Saat lisätietoja ohjeartikkelista Oikopolun luominen tai poistaminen.

Jos sovellus tai muun tyyppinen tiedosto on vaurioitunut, kyseinen sovellus on ehkä korjattava ongelman ratkaisemiseksi.

Tapa 5: Poista tiedoston esto.

Joissakin tapauksissa voi olla, että Windows on estänyt tiedoston käytön. Tarkista löytyykö tiedoston ominaisuuksista seuraava tieto: Tämä tiedosto on peräisin toisesta tietokoneesta, ja se on estetty tietokoneen suojaamiseksi. Voit tarkistaa tiedoston ja poistaa sen eston toimimalla seuraavasti:

  1. Napsauta estettyä tiedostoa hiiren kakkospainikkeella ja valitse sitten Ominaisuudet.

  2. Valitse Yleiset-välilehdestä Poista esto -toiminto, jos se on käytettävissä.

Tapa 6: Tarkista, estääkö virustorjuntaohjelmisto tiedoston käytön.

Voit tarkistaa, estääkö virustorjuntaohjelmisto tiedoston käytön, poistamalla ohjelmiston tilapäisesti käytöstä ja yrittämällä sitten avata tiedoston. Jos sinun on poistettava virustorjuntaohjelmisto tilapäisesti käytöstä, se kannattaa ottaa uudelleen käyttöön heti, kun olet valmis. Jos olet yhteydessä Internetiin silloin, kun virustorjuntaohjelmisto on poissa käytöstä, tietokoneesi on alttiina hyökkäyksille.

Tärkeä: Virustorjuntaohjelmiston poistaminen käytöstä tai sen asetusten muuttaminen saattaa altistaa tietokoneen viruksia sisältäville, petollisille tai haitallisille hyökkäyksille. Microsoft ei suosittele virustorjuntaohjelmiston poistamista käytöstä tai sen asetusten muuttamista.  Jos sinun on poistettava virustorjuntaohjelmisto tilapäisesti käytöstä, se kannattaa ottaa uudelleen käyttöön heti, kun olet valmis. Tämän vaihtoehdon käyttö tapahtuu omalla vastuullasi. Ohjeet virustorjuntaohjelmiston tilapäiseen käytöstä poistoon löytyvät ohjeartikkelista Virustorjuntaohjelmiston poistaminen käytöstä.

Syy

Tämä ongelma voi ilmetä, jos tietokoneessa vallitsee jokin seuraavista tilanteista.

  • Sinulla ei ole tiedoston tai tiedostosijainnin käyttöoikeuksia.

  • Tiedosto sijaitsee sijainnissa, joka ei ole tällöin käytettävissä (esimerkiksi verkkosijainti tai ulkoinen asema, joka ei ole parhaillaan kytkettynä tietokoneeseen).

  • Tiedosto on siirretty tai poistettu.

  • Tiedosto tai oikopolku on vaurioitunut.

  • Windows on saattanut estää tiedoston käytön.

  • Virustorjuntaohjelmisto saattaa estää tiedoston käytön.

Lisätietoja

Lisätietoja tiedostojen tai kansioitten käyttövirheistä Windowsissa on ohjeartikkelissa "Käyttö estetty" tai muut tiedostojen ja kansioitten käyttö virheet Windowsissa.

Tarvitsetko lisäohjeita?

Haluatko lisää vaihtoehtoja?

Tutustu tilausetuihin, selaa harjoituskursseja, opi suojaamaan laitteesi ja paljon muuta.

Osallistumalla yhteisöihin voit kysyä kysymyksiä ja vastata niihin, antaa palautetta sekä kuulla lisää asiantuntijoilta, joilla on runsaasti tietoa.

Oliko näistä tiedoista hyötyä?

Kuinka tyytyväinen olet käännöksen laatuun?
Mikä vaikutti kokemukseesi?
Kun valitset Lähetä, palautettasi käytetään Microsoftin tuotteiden ja palveluiden parantamiseen. IT-järjestelmänvalvojasi voi kerätä nämä tiedot. Tietosuojatiedot.

Kiitos palautteesta!

×