Considérations de conception pour la mise à jour des données

S’applique à
Access pour Microsoft 365 Access 2024 Access 2021 Access 2019 Access 2016

Une base de données bien conçue permet non seulement d’assurer l’intégrité des données, mais elle est également plus facile à gérer et à mettre à jour. Une base de données Access n’est pas un fichier au même sens qu’un document Microsoft Word ou une présentation de diapositives Microsoft PowerPoint. Il s’agit plutôt d’une collection d’objets (tables, formulaires, états, requêtes, etc.) qui doivent fonctionner ensemble pour fonctionner correctement.

Les utilisateurs entrent des données principalement par le biais de contrôles. L’utilisation d’un contrôle donné dépend du type de données défini pour le champ de table sous-jacent, des propriétés définies pour ce champ et des propriétés définies pour le contrôle. Enfin, envisagez d’utiliser des techniques de base de données supplémentaires telles que la validation, les valeurs par défaut, les listes et les recherches, ainsi que les mises à jour en cascade.

Pour plus d’informations sur la mise à jour des données du point de vue de l’utilisateur, voir Méthodes d’ajout, de modification et de suppression d’enregistrements.

Contenu de cet article

Comment la conception de base de données affecte la saisie de données

Les informations que vous conservez dans une base de données sont stockées dans des tables contenant des données relatives à un sujet spécifique, comme des ressources ou des contacts. Chaque enregistrement d’une table contient des informations sur un élément, tel qu’un contact particulier. Un enregistrement est composé de champs, tels que le nom, l’adresse et le numéro de téléphone. Un enregistrement est communément appelé une ligne et un champ est communément appelé une colonne. Ces objets doivent respecter un ensemble de principes de conception, sinon la base de données fonctionnera mal ou échouera complètement. À leur tour, ces principes de conception affectent la façon dont vous entrez des données. Prenez en compte les éléments suivants :

  • Tables Access stocke toutes les données dans une ou plusieurs tables. Le nombre de tables que vous utilisez dépend de la conception et de la complexité de la base de données. Bien que vous puissiez afficher les données dans un formulaire, un rapport ou les résultats renvoyés par une requête, Access stocke les données uniquement dans des tables et les autres objets de la base de données sont basés sur ces tables. Chaque tableau doit être basé sur un sujet. Par exemple, un tableau d’informations de contacts professionnels ne doit pas contenir d’informations sur les ventes. Si c’est le cas, trouver et corriger les informations correctes peut devenir difficile, voire impossible.
  • Types de données En règle générale, chacun des champs d’une table accepte un seul type de données. Par exemple, vous ne pouvez pas stocker de notes dans un champ défini de manière à accepter des nombres. Si vous essayez d’entrer du texte dans un tel champ, Access affiche un message d’erreur. Cependant, ce n’est pas une règle absolue. Par exemple, vous pouvez stocker des nombres (tels que des codes postaux) dans un champ défini sur le type de données Texte abrégé, mais vous ne pouvez pas effectuer de calculs sur ces données étant donné qu’Access considère qu’il s’agit d’un morceau de texte.
    Sauf exceptions, les champs d’un enregistrement ne doivent accepter qu’une seule valeur. Par exemple, vous ne pouvez pas entrer plus d’une adresse dans un champ d’adresse. Cela contraste avec Microsoft Excel qui vous permet d’entrer un nombre quelconque de noms, d’adresses ou d’images dans une seule cellule, sauf si vous configurez cette cellule pour accepter des types de données limités.
  • Champs à plusieurs valeurs Access offre une fonctionnalité appelée champ à plusieurs valeurs qui permet d’attacher plusieurs données à un même enregistrement et de créer des listes acceptant plusieurs valeurs. Vous pouvez toujours identifier une liste à plusieurs valeurs car Access affiche une case activée en regard de chaque élément de liste. Par exemple, vous pouvez joindre une série de diapositives Microsoft PowerPoint et un nombre quelconque d’images à un enregistrement dans votre base de données. Vous pouvez également créer une liste de noms et en sélectionner autant que nécessaire. L’utilisation de champs à plusieurs valeurs peut sembler aller à l’encontre des règles de conception d’une base de données, car vous pouvez stocker plusieurs enregistrements par champ de table. Toutefois, Access applique les règles « en arrière-plan » en stockant les données dans des tables spéciales et masquées.
  • Utilisation de formulaires En général, vous créez des formulaires pour simplifier l’utilisation d’une base de données et vous assurer que les utilisateurs entrent des données avec précision. L’utilisation d’un formulaire pour modifier des données dépend de la conception du formulaire. Les formulaires peuvent contenir un nombre indéfini de contrôles, tels que des listes, des zones de texte, des boutons et même des feuilles de données. Par ailleurs, chacun des contrôles figurant sur le formulaire lit des données à partir d’un champ de table sous-jacent ou écrit des données dans un tel champ.

Pour plus d’informations, voir Principes de base de la conception d’une base de données et Créer une table et ajouter des champs.

Haut de la page

Définir une valeur par défaut pour un champ ou un contrôle

Si un grand nombre d’enregistrements partagent la même valeur pour un champ donné, tel qu’une ville ou un pays/région, vous pouvez gagner du temps en définissant une valeur par défaut pour le contrôle lié à ce champ ou pour le champ lui-même. Lorsque vous ouvrez le formulaire ou la table pour créer un enregistrement, votre valeur par défaut apparaît dans ce contrôle ou ce champ.

Dans un tableau

  1. Ouvrez le tableau en mode Création.
  2. En haut de la vue, sélectionnez le champ.
  3. En bas de la vue, sélectionnez l’onglet Général .
  4. Définissez la propriété Valeur par défaut sur la valeur souhaitée.

Dans un formulaire

  1. Ouvrez le formulaire en mode Page ou Création.
  2. Cliquez avec le bouton droit sur le contrôle que vous souhaitez utiliser, puis cliquez sur Propriétés.
  3. Sous l’onglet Données , définissez la propriété Valeur par défaut sur la valeur souhaitée.

Haut de la page

Utilisation de règles de validation pour limiter les données

Vous pouvez valider des données dans des bases de données Access de bureau au fur et à mesure que vous les entrez en utilisant des règles de validation. Les règles de validation peuvent être définies en mode Création de table ou Feuille de données de table. Il existe trois types de règles de validation dans Access :

  • Règle de validation de champ Vous pouvez utiliser une règle de validation de champ pour spécifier un critère sur toutes les valeurs de champ valides. Vous ne devez pas spécifier le champ actif comme faisant partie de la règle, sauf si vous l’utilisez dans une fonction. Il peut être plus facile d’appliquer les restrictions relatives aux types de caractères pouvant être entrés dans un champ avec un Masque de saisie. Par exemple, un champ de date peut avoir une règle de validation interdisant des valeurs passées.
  • Règle de validation d’enregistrement Vous pouvez utiliser une règle de validation d’enregistrement pour spécifier une condition que tous les enregistrements doivent respecter pour être valides. Vous pouvez comparer des valeurs de différents champs à l’aide d’une règle de validation d’enregistrement. Par exemple, un enregistrement comportant deux champs de date peut exiger que les valeurs d’un champ précèdent toujours celles de l’autre (par exemple, DateDébut avant DateFin).
  • Validation d’un formulaire Vous pouvez utiliser la propriété Valide si d’un contrôle figurant sur un formulaire pour spécifier un critère que doivent remplir toutes les valeurs entrées dans ce contrôle. La propriété de contrôle Valide si fonctionne comme une règle de validation de champ. En général, vous utilisez une règle de validation de formulaire au lieu d’une règle de validation de champ si la règle est spécifique du formulaire et non de la table, quel que soit l’endroit où elle est utilisée.

Pour plus d’informations, voir Restreindre l’entrée de données à l’aide de règles de validation.

Haut de la page

Utilisation de listes de valeurs et de champs Liste de choix

Il existe deux types de données de liste dans Access :

  • Listes de valeurs Il s’agit d’un ensemble de valeurs codées en dur que vous pouvez entrer manuellement. Les valeurs résident dans la propriété Source de ligne du champ.
  • Champs Liste de choix Celles-ci utilisent une requête pour récupérer des valeurs à partir d’une autre table. La propriété Source de ligne du champ contient une requête au lieu d’une liste de valeurs codées en dur. La requête extrait des valeurs dans une ou plusieurs tables d’une base de données. Par défaut, le champ Liste de choix vous présente ces valeurs sous la forme d’une liste. Selon la manière dont vous définissez le champ Liste de choix, vous pouvez sélectionner un ou plusieurs éléments dans cette liste.
    Remarque Les champs Liste de choix peuvent induire la confusion chez les nouveaux utilisateurs d’Access, car une liste d’éléments apparaît à un emplacement (la liste créée par Access à partir des données du champ Liste de choix), mais les données peuvent se situer à un autre emplacement (la table qui contient les données).

Par défaut, Access affiche des données de liste dans un contrôle de zone de liste modifiable, bien que vous puissiez spécifier un contrôle de zone de liste. Une zone de liste modifiable s’ouvre pour présenter la liste, puis se ferme une fois que vous avez effectué une sélection. Une zone de liste, en revanche, reste ouverte à tout moment.

Pour modifier des listes, vous pouvez aussi exécuter la commande Modifier les éléments de liste ou modifier les données directement dans la propriété Source de ligne de la table source. Lorsque vous mettez à jour les données d’un champ Liste de choix, vous mettez à jour la table source.

Si la propriété Type de source de ligne de votre zone de liste ou zone de liste déroulante est définie sur Liste de valeurs, vous pouvez modifier la liste de valeurs lorsque le formulaire est ouvert en mode Formulaire, en évitant de devoir basculer en mode Création ou en mode Page, d’ouvrir la feuille de propriétés et de modifier la propriété Source de ligne du contrôle chaque fois que vous devez apporter une modification à la liste. Pour modifier la liste des valeurs, la propriété Autoriser les modifications de la liste de valeurs associée à la zone de liste ou à la zone de liste déroulante doit être définie sur Oui.

Pour plus d’informations, voir Créer une liste de choix à l’aide d’une zone de liste ou d’une zone de liste modifiable.

Empêcher la modification de la liste de valeurs en mode Formulaire

  1. Dans le volet de navigation, cliquez avec le bouton droit sur le formulaire, puis cliquez sur Mode Création ou sur Mode Page.
  2. Cliquez sur le contrôle pour le sélectionner, puis appuyez sur F4 pour afficher la feuille de propriétés.
  3. Sous l’onglet Données de la feuille de propriétés, définissez la propriété Autoriser les modifications de la liste de valeurs sur Non.
  4. Cliquez sur Fichier, puis sur Enregistrer, ou appuyez sur Ctrl+S Bouton Image .

Spécifier un autre formulaire pour modifier la liste de valeurs

Par défaut, Access fournit un formulaire intégré à des fins d’édition de la liste de valeurs. Si vous disposez d’un autre formulaire que vous préférez utiliser à cette fin, vous pouvez entrer le nom du formulaire dans la propriété Formulaire Modifier les éléments de liste, comme suit :

  1. Dans le volet de navigation, cliquez avec le bouton droit sur le formulaire, puis cliquez sur Mode Création ou sur Mode Page dans le menu contextuel.
  2. Cliquez sur le contrôle pour le sélectionner, puis appuyez sur F4 pour afficher la feuille de propriétés.
  3. Sous l’onglet Données de la feuille de propriétés, cliquez sur la flèche de déroulement dans la zone de propriété Formulaire Modifier les éléments de liste.
  4. Cliquez sur le formulaire à utiliser pour modifier la liste de valeurs
  5. Cliquez sur le fichier, puis sur Enregistrer, ou appuyez sur Ctrl+S Bouton Image .

Examiner un champ Liste de choix dans un formulaire

  1. Ouvrez le formulaire en mode Page ou Création.

  2. Cliquez avec le bouton droit sur le contrôle de zone de liste ou de zone de liste modifiable, puis cliquez sur Propriétés.

  3. Dans la feuille de propriétés, cliquez sur l’onglet Tout et recherchez les propriétés Type de source de ligne et Source de ligne . La propriété Type de source de ligne doit contenir une liste de valeurs ou une table/requête, et la propriété Source de ligne doit contenir une liste d’éléments séparés par des points-virgules ou une requête. Pour plus d’espace, cliquez avec le bouton droit sur la propriété, puis sélectionnez Zoom ou appuyez sur Maj+F2.
    En règle générale, les listes de valeurs utilisent cette syntaxe de base : « élément » ; objet » ; » objet »
    Dans ce cas, la liste est un ensemble d’éléments entourés de guillemets doubles et séparés par des points-virgules.
    Les requêtes Select utilisent cette syntaxe de base : SELECT [table_or_query_name].[ field_name**] FROM [table_or_query_name]**.
    Dans ce cas, la requête contient deux clauses (SELECT et FROM). La première clause fait référence à une table ou requête et à un champ de cette table ou requête. La deuxième clause fait uniquement référence à la table ou à la requête. Voici un point clé à retenir : les clauses SELECT n’ont pas besoin de contenir le nom d’une table ou d’une requête, bien que cela soit recommandé, et elles doivent contenir le nom d’au moins un champ. Toutefois, toutes les clauses FROM doivent faire référence à une table ou à une requête. Ainsi, vous pouvez toujours rechercher la table source ou la requête source d’un champ de liste de choix en lisant la clause DE.

  4. Effectuez l’une des opérations suivantes :

    • Si vous utilisez une liste de valeurs, modifiez les éléments de la liste. Veillez à entourer chaque élément de guillemets doubles et à séparer chaque élément par un point-virgule.
    • Si la requête de la liste de choix fait référence à une autre requête, ouvrez cette seconde requête en mode Création (cliquez avec le bouton droit sur la requête dans le volet de navigation, puis cliquez sur Mode Création). Notez le nom de la table qui apparaît dans la section supérieure du concepteur de requêtes, puis passez à l’étape suivante.
      Sinon, si la requête du champ Liste de choix fait référence à une table, notez le nom de la table et passez à l’étape suivante.
  5. Ouvrez la table en mode Feuille de données, puis modifiez les éléments de liste si nécessaire.

Examiner un champ Liste de choix dans une table

  1. Ouvrez le tableau en mode Création.

  2. Dans la section supérieure de la grille de création de requête, dans la colonne Type de données , cliquez ou placez le focus sur un champ Texte, Nombre ou Oui/Non.

  3. Dans la partie inférieure de la grille de création de table, cliquez sur l’onglet Liste de choix , puis examinez les propriétés Type de source de ligne et Source de ligne .
    La propriété Type de source de ligne doit lire Liste de valeurs ou Table/requête. La propriété Source de ligne doit contenir une liste de valeurs ou une requête.
    Les listes de valeurs utilisent la syntaxe de base suivante : « élément » ; objet » ; » objet »
    Dans ce cas, la liste est un ensemble d’éléments entourés de guillemets doubles et séparés par des points-virgules.
    En règle générale, les requêtes SELECT utilisent cette syntaxe de base : SELECT [table_or_query_name].[ field_name**] FROM [table_or_query_name]**.
    Dans ce cas, la requête contient deux clauses (SELECT et FROM). La première clause fait référence à une table ou requête et à un champ de cette table ou requête. La deuxième clause fait uniquement référence à la table ou à la requête. Voici un point clé à retenir : les clauses SELECT n’ont pas besoin de contenir le nom d’une table ou d’une requête, bien que cela soit recommandé, et elles doivent contenir le nom d’au moins un champ. Toutefois, toutes les clauses FROM doivent faire référence à une table ou à une requête. Ainsi, vous pouvez toujours rechercher la table source ou la requête source d’un champ de liste de choix en lisant la clause DE.

  4. Effectuez l’une des opérations suivantes :

    • Si vous utilisez une liste de valeurs, modifiez les éléments de la liste. Veillez à entourer chaque élément de guillemets doubles et à séparer chaque élément par un point-virgule.
    • Si la requête du champ Liste de choix fait référence à une autre requête, dans le volet de navigation, ouvrez cette deuxième requête en mode Création (cliquez avec le bouton droit sur la requête, puis cliquez sur Mode Création). Notez le nom de la table qui apparaît dans la section supérieure du concepteur de requêtes, puis passez à l’étape suivante.
      Sinon, si la requête du champ Liste de choix fait référence à une table, notez le nom de la table et passez à l’étape suivante.
  5. Ouvrez la table en mode Feuille de données, puis modifiez les éléments de liste si nécessaire.

Haut de la page

Suppression des données d’une liste de valeurs ou d’un champ Liste de choix

Les éléments composant une liste de valeurs résident dans la même table que les autres valeurs d’un enregistrement. En revanche, les données d’un champ Liste de choix résident dans une ou plusieurs autres tables. Pour supprimer des données d’une liste de valeurs, ouvrez la table, puis modifiez les éléments.

La suppression des données d’une liste de recherche nécessite des étapes supplémentaires, lesquelles diffèrent si la requête associée aux listes de recherche récupère ses données dans une table ou une autre requête. Si la requête associée à la liste de recherche est basée sur une table, vous devez identifier cette table ainsi que le champ qui contient les données qui s’affichent dans la liste. Vous devez ensuite ouvrir la table source et modifier les données dans ce champ. Si la requête associée à la liste de recherche est basée sur une autre requête, vous devez ouvrir cette deuxième requête, rechercher la table source et le champ à partir desquels la deuxième requête récupère ses données, puis modifier les valeurs dans cette table.

Supprimer des données dans une liste de valeurs

  1. Ouvrez le tableau en mode Création.
  2. Dans la partie supérieure de la grille de création, sélectionnez le champ de table qui contient la liste de valeurs.
  3. Dans la partie inférieure de la grille, cliquez sur l’onglet Rechercher, puis recherchez la propriété Contenu.
    Par défaut, les éléments d’une liste de valeurs sont encadrés par des guillemets doubles et des points-virgules séparent chaque élément : "Excellent";"Fair";"Average";"Poor"
  4. Le cas échéant, supprimez les éléments de la liste. N’oubliez pas de supprimer les guillemets qui entourent chaque élément supprimé. De même, ne laissez pas de point-virgule de début, ne laissez pas de paires de points-virgules ensemble ( ;;), et si vous supprimez le dernier élément de la liste, supprimez le dernier point-virgule.
    Important Si vous supprimez un élément d’une liste de valeurs et que les enregistrements de la table utilisent déjà cet élément supprimé, l’élément supprimé reste dans l’enregistrement jusqu’à ce que vous le modifiiez. Par exemple, supposons que votre entreprise dispose d’un entrepôt dans une ville A et qu’elle vend ce bâtiment. Si vous supprimez « Ville A » de la liste des entrepôts, « Ville A » restera dans votre table tant que vous n’aurez pas modifié ces valeurs.

Supprimer des données d’un champ Liste de choix

  1. Ouvrez le tableau en mode Création.

  2. Dans la partie supérieure de la grille de création, sélectionnez le champ de recherche.

  3. Dans la partie inférieure de la grille de création, cliquez sur l’onglet Rechercher, puis recherchez les propriétés Origine source et Contenu.
    La propriété Origine source devrait afficher Table/Requête et la propriété Contenu doit contenir une requête qui fait référence à une table ou à une autre requête. Les requêtes pour les champs Liste de choix commencent toujours par le mot SÉLECTIONNER.
    Typiquement (mais pas toujours), une requête SELECT utilise cette syntaxe de base : SELECT [table_or_query_name].[ field_name*] FROM [table_or_query_name]*.
    Dans ce cas, la requête contient deux clauses (SELECT et FROM). La première clause fait référence à une table et à un champ dans cette table ; inversement, la deuxième clause fait uniquement référence à la table. N’oubliez pas le point suivant : La clause FROM indique toujours le nom de la table ou requête source. Les clauses SELECT ne contiennent pas toujours le nom d’une table ou d’une requête, bien qu’elles contiennent toujours le nom d’au moins un champ. Toutefois, toutes les clauses FROM doivent faire référence à une table ou à une requête.

  4. Effectuez l’une des opérations suivantes :

    • Si la requête incluse dans le champ Liste de choix fait référence à une autre requête, cliquez sur le bouton Créer (dans l’onglet Données de la feuille de propriétés, cliquez sur le bouton Générateur suivant) pour ouvrir la requête en mode Création. Notez le nom de la table qui s’affiche dans la section supérieure du générateur de requêtes, puis passez à l’étape 5.
    • Si la requête dans le champ Liste de choix fait référence à une table, notez le nom de la table, puis passez à l’étape 5.
  5. Ouvrez la table source en mode Feuille de données.

  6. Recherchez le champ qui contient les données utilisées dans la liste de recherche, puis modifiez les données au besoin.

Haut de la page

Comment les types de données affectent la façon dont vous saisissez les données

Lorsque vous concevez une table de base de données, vous sélectionnez un type de données pour chaque champ de cette table, ce processus qui permet de garantir une entrée de données plus précise.

Afficher les types de données

Effectuez l’une des opérations suivantes :

Utiliser le mode Feuille de données

  1. Ouvrez le tableau en modeAffichage Feuille de données.
  2. Sous l’onglet Champs , dans le groupe Mise en forme, examinez la valeur dans la liste Type de données. La valeur change lorsque vous placez le curseur dans les différents champs de votre table :
    Liste Type de données

Utiliser le mode Création

  1. Ouvrez le tableau en mode Création.
  2. Regardez la grille de conception. La partie supérieure de la grille affiche le nom et le type de données de chaque champ de table.
    Champs en mode Création

Comment les types de données affectent la saisie de données

Le type de données que vous définissez pour chaque champ de table fournit le premier niveau de contrôle sur le type de données autorisées dans un champ. Dans certains cas, comme dans un champ Texte long, vous pouvez entrer les données souhaitées. Dans d’autres cas, par exemple dans le cas d’un champ NuméroAuto, le type de données associé à ce champ empêche la saisie d’informations. Le tableau suivant répertorie les types de données fournis par Access et décrit comment ils affectent la saisie de données.

Pour plus d’informations, consultez Types de données pour les bases de données de bureau Access et Modifier ou changer le paramètre de type de données d’un champ.

Type de données Effet sur la saisie de données
Texte court Les champs Texte court acceptent du texte ou des caractères numériques, y compris des listes délimitées d’éléments. Un champ de texte accepte un plus petit nombre de caractères qu’un champ de texte long (de 0 à 255 caractères). Dans certains cas, vous pouvez utiliser des fonctions de conversion pour effectuer des calculs sur les données d’un champ Texte court.
Texte long Dans ce type de champ, vous pouvez entrer de grandes quantités de texte et de données numériques, jusqu’à 64 000 caractères. De plus, vous définissez le champ pour qu’il prenne en charge la mise en forme de texte enrichi. Vous pouvez appliquer les types de mise en forme que vous trouvez normalement dans les programmes de traitement de texte, tels que Word. Par exemple, vous pouvez appliquer différentes polices et tailles de police à des caractères spécifiques de votre texte, les mettre en gras ou en italique, etc. Vous pouvez également ajouter des balises HTML (Hypertext Markup Language) aux données. Pour plus d’informations, voir Insérer ou ajouter un champ RTF.
De plus, les champs Texte long ont une propriété appelée Ajouter uniquement. Lorsque vous activez cette propriété, vous pouvez ajouter de nouvelles données à un champ de texte long, mais vous ne pouvez pas modifier les données existantes. Cette fonctionnalité est destinée à être utilisée dans des applications telles que les bases de données de suivi des problèmes, où vous devrez peut-être conserver un enregistrement permanent qui reste immuable. Lorsque vous placez le curseur dans un champ de texte long avec la propriété Ajouter uniquement activée, par défaut, le texte du champ disparaît. Vous ne pouvez pas appliquer de mise en forme ou d’autres modifications au texte.
Comme pour les champs Texte court, vous pouvez également exécuter des fonctions de conversion sur les données d’un champ Texte long.
Nombre Vous ne pouvez entrer que des nombres dans ce type de champ, et vous pouvez effectuer des calculs sur les valeurs d’un champ numérique.
Grand numéro
Notez que les types de données Grand nombre sont disponibles uniquement dans la version d’abonnement Microsoft 365 d’Access.
Vous ne pouvez entrer que des nombres dans ce type de champ, et vous pouvez effectuer des calculs sur les valeurs d’un champ Grand nombre.
Pour plus d’informations, voir Utilisation du type de données Grand nombre.
Date et heure Vous ne pouvez entrer que des dates et des heures dans ce type de champ.
Vous pouvez définir un masque de saisie pour le champ (une série de caractères littéraux et d’espaces réservés qui apparaissent lorsque vous sélectionnez le champ). Vous devez entrer des données dans les espaces et le format fournis par le masque. Par exemple, si vous voyez un masque tel que MMM_DD_YYYY, vous devez taper Oct 11 2017 dans les espaces prévus à cet effet. Vous ne pouvez pas entrer un nom de mois complet ou une valeur d’année à deux chiffres. Pour plus d’informations, voir Contrôler les formats de saisie de données à l’aide de masques de saisie.
Si vous ne créez pas de masque de saisie, vous pouvez entrer la valeur au format de date ou d’heure valide. Par exemple, vous pouvez taper 11 octobre 2017, 11/10/17, 11 octobre 2017, etc.
Vous pouvez également appliquer un format d’affichage au champ. Dans ce cas, en l’absence de masque de saisie, vous pouvez entrer une valeur dans presque n’importe quel format, mais Access affiche les dates conformément au format d’affichage. Par exemple, vous pouvez entrer 10/11/2017, mais le format d’affichage peut être défini de sorte qu’il affiche la valeur sous la forme 11-Oct-2017.
Pour plus d’informations, voir Insérer la date du jour.
Devise Vous ne pouvez entrer que des valeurs monétaires dans ce type de champ. De plus, vous n’avez pas besoin de saisir manuellement un symbole monétaire. Par défaut, Access applique le symbole de devise (¥, £, $, etc.) spécifié dans vos paramètres régionaux Windows. Vous pouvez modifier ce symbole de devise pour refléter une autre devise, si nécessaire.
NuméroAuto Vous ne pouvez à aucun moment entrer ou modifier les données de ce type de champ. Access incrémente les valeurs d’un champ NuméroAuto chaque fois que vous ajoutez un nouvel enregistrement à une table.
Calculé Vous ne pouvez à aucun moment entrer ou modifier les données de ce type de champ. Les résultats de ce champ sont déterminés par une expression que vous définissez. Access met à jour les valeurs d’un champ Calculé chaque fois que vous ajoutez ou modifiez un nouvel enregistrement dans une table.
Oui/non Lorsque vous cliquez sur un champ défini sur ce type de données, Access affiche une zone à case activée ou une liste déroulante, selon la façon dont vous mettez en forme le champ. Si vous mettez en forme le champ pour afficher une liste, vous pouvez sélectionner Oui ou Non, Vrai ou Faux, ou Activé ou Désactivé dans la liste, toujours selon le format appliqué au champ. Vous ne pouvez pas entrer de valeurs dans la liste ou modifier les valeurs de la liste directement à partir d’un formulaire ou d’une table.
Objet OLE Vous utilisez ce type de champ lorsque vous souhaitez afficher des données à partir d’un fichier créé avec un autre programme. Par exemple, vous pouvez afficher un fichier texte, un graphique Excel ou une présentation de diapositives PowerPoint dans un champ d’objet OLE.
Les pièces jointes offrent un moyen plus rapide, plus facile et plus flexible d’afficher les données d’autres programmes.
Lien hypertexte Vous pouvez entrer n’importe quelle donnée dans ce type de champ, et Access les intègre dans une adresse web. Par exemple, si vous entrez une valeur dans ce champ, Access met votre texte entre http://www,your_text**.com**. Si vous entrez une adresse Web valide, votre lien fonctionnera. Dans le cas contraire, votre lien entraînera un message d’erreur.
En outre, la modification de liens hypertexte existants peut être difficile, car en cliquant sur un champ de lien hypertexte avec votre souris, vous démarrez votre navigateur et vous accédez au site spécifié dans le lien. Pour modifier un champ de lien hypertexte, sélectionnez un champ adjacent, utilisez la touche TAB ou les touches de direction pour déplacer le focus sur le champ de lien hypertexte, puis appuyez sur F2 pour activer la modification.
Pièce jointe Vous pouvez joindre des données d’autres programmes à ce type de champ, mais vous ne pouvez pas taper ou entrer du texte ou des données numériques.
Pour plus d’informations, voir Joindre des fichiers et des graphiques aux enregistrements de votre base de données.
Assistant Liste de choix L’Assistant Liste de choix n’est pas un type de données. L’Assistant vous permet de créer deux types de listes déroulantes : les listes de valeurs et les champs Liste de choix. Une liste de valeurs utilise une liste délimitée d’éléments que vous entrez manuellement lorsque vous utilisez l’Assistant Liste de choix. Ces valeurs peuvent être indépendantes de toute autre donnée ou objet de votre base de données.
En revanche, un champ Liste de choix utilise une requête pour extraire des données d’une ou de plusieurs autres tables d’une base de données. Le champ Liste de choix affiche ensuite les données dans une liste déroulante. Par défaut, l’Assistant Liste de choix définit le type de données Nombre dans le champ de table.
Vous pouvez utiliser les champs Liste de choix directement dans les tables, ainsi que dans les formulaires et états. Par défaut, les valeurs d’un champ Liste de choix apparaissent dans un type de contrôle de liste appelé zone de liste modifiable, une liste dotée d’une flèche déroulante :
Liste de recherche vide
Vous pouvez également utiliser une zone de liste qui affiche plusieurs éléments avec une barre de défilement pour voir plus d’éléments :
Contrôle de zone de liste simple dans un formulaire
Selon la manière dont vous définissez le champ Liste de choix et la zone de liste modifiable, vous pouvez modifier les éléments de la liste et ajouter des éléments à la liste en désactivant la propriété Limiter à la liste du champ Liste de choix.
Si vous ne pouvez pas modifier directement les valeurs d’une liste, vous devez ajouter ou modifier les données de votre liste de valeurs prédéfinie ou de la table qui sert de source pour le champ Liste de choix.
Enfin, lorsque vous créez un champ Liste de choix, vous pouvez définir qu’il prenne en charge plusieurs valeurs. Dans ce cas, la liste résultante affiche une zone case activée en regard de chaque élément de liste, et vous pouvez sélectionner ou effacer autant d’éléments que nécessaire. Cette figure illustre une liste à plusieurs valeurs classique :
Liste Case à cocher
Pour plus d’informations sur la création de champs Liste de choix à plusieurs valeurs et l’utilisation des listes résultantes, voir Créer ou supprimer un champ à plusieurs valeurs.

Haut de la page

Comment les propriétés d’un champ de table affectent la manière dont vous entrez des données ?

Outre les principes de conception qui contrôlent la structure d’une base de données et les types de données qui contrôlent ce que vous pouvez entrer dans un champ donné, plusieurs propriétés de champ peuvent également affecter la façon dont vous entrez des données dans une base de données Access.

Afficher les propriétés d’un champ de table

Access propose deux façons d’afficher les propriétés d’un champ de table.

En mode Feuille de données

  1. Ouvrez le tableau en modeAffichage Feuille de données.
  2. Cliquez sur l’onglet Champs et utilisez les commandes du groupe Mise en forme pour afficher les propriétés de chaque champ de table.

En mode Création

  1. Ouvrez le tableau en mode Création.
  2. Dans la partie inférieure de la grille, cliquez sur l’onglet Général , s’il n’est pas déjà sélectionné.
  3. Pour afficher les propriétés d’un champ Liste de choix, cliquez sur l’onglet Liste de choix .

Impact des propriétés sur la saisie de données

Le tableau suivant répertorie les propriétés qui ont le plus d’impact sur la saisie de données et explique comment elles affectent la saisie de données.

Propriété Emplacement dans la grille de création de table Valeurs possibles Comportement lorsque vous essayez d’entrer des données
Taille du champ Onglet Général 0-255 La limite de caractères s’applique uniquement aux champs définis pour le type de données Texte. Si vous essayez d’entrer plus de caractères que le nombre spécifié, le champ les coupe.
Obligatoire Onglet Général Oui/non Lorsqu’elle est activée, cette propriété vous oblige à entrer une valeur dans un champ et Access ne vous permet pas d’enregistrer de nouvelles données tant que vous n’avez pas rempli un champ obligatoire. Lorsqu’il est désactivé, le champ accepte les valeurs Null, ce qui signifie que le champ peut rester vide.
Une valeur nulle n’est pas la même chose qu’une valeur nulle. zéro est un chiffre et « null » une valeur manquante, indéfinie ou inconnue.
Autoriser les chaînes vides Onglet Général Oui/non Lorsqu’il est activé, vous pouvez entrer des chaînes nulles, c’est-à-dire des chaînes qui ne contiennent aucun caractère. Pour créer une chaîne nulle, vous devez entrer une paire de guillemets doubles dans le champ («  »).
Indexé Onglet Général Oui/non Lorsque vous indexez un champ de table, Access vous empêche d’ajouter des valeurs en double. Vous pouvez également créer un index à partir de plusieurs champs. Dans ce cas, vous pouvez dupliquer les valeurs dans un champ, mais pas dans les deux.
Masque de saisie Onglet Général Jeux prédéfinis ou personnalisés de caractères littéraux et d’espace réservé Un masque de saisie vous oblige à entrer des données dans un format prédéfini. Les masques apparaissent lorsque vous sélectionnez un champ dans une table ou un contrôle dans un formulaire. Par exemple, supposons que vous cliquez sur un champ Date et que vous voyez cet ensemble de caractères : JJ-MMM-AAAA. Il s’agit d’un masque de saisie. Elle vous oblige à entrer les valeurs du mois sous forme d’abréviations à trois lettres, telles que OCT, et la valeur de l’année sous forme de quatre chiffres (par exemple, OCT-15-2017).
Les masques de saisie contrôlent uniquement la façon dont vous entrez des données, et non la façon dont Access les stocke ou les affiche.
Pour plus d’informations, voir Contrôler les formats de saisie de données à l’aide de masques de saisie et Mettre en forme un champ de date et d’heure.
Limiter à la liste Onglet Liste de choix Oui/non Active ou désactive les modifications apportées aux éléments d’un champ Liste de choix. Les utilisateurs essaient parfois de modifier manuellement les éléments d’un champ Liste de choix. Lorsque Access vous empêche de modifier les éléments d’un champ, cette propriété est définie sur Oui. Si cette propriété est activée et que vous devez modifier les éléments d’une liste, vous devez ouvrir la liste (si vous voulez modifier une liste de valeurs) ou la table qui contient les données sources de la liste (si vous voulez modifier un champ Liste de choix) et y modifier les valeurs.
Autoriser les modifications de la liste de valeurs Onglet Liste de choix Oui/non Active ou désactive la commande Modifier les éléments de liste pour les listes de valeurs, mais pas pour les champs Liste de choix. Pour activer cette commande pour les champs Liste de choix, entrez un nom de formulaire valide dans la propriété Modifier le formulaire Éléments de liste . La commande Autoriser les modifications de liste de valeurs apparaît dans un menu contextuel que vous ouvrez en cliquant avec le bouton droit sur une zone de liste ou un contrôle de zone de liste déroulante. Lorsque vous exécutez la commande, la boîte de dialogue Modifier les éléments de liste s’affiche. Si vous spécifiez le nom d’un formulaire dans la propriété Éléments de liste Modifier le formulaire , Access démarre ce formulaire au lieu d’afficher la boîte de dialogue.
Vous pouvez exécuter la commande Modifier des éléments de liste à partir des contrôles de zone de liste et de zone de liste déroulante situés dans les formulaires, ainsi que des contrôles de zone de liste déroulante situés dans les tables et les jeux de résultats de requête. Les formulaires doivent être ouverts en mode Création ou en mode Parcourir ; Les tables et les jeux de résultats de requête doivent être ouverts en mode Feuille de données.
Formulaire Modifier les éléments de liste Onglet Liste de choix Nom d’un formulaire de saisie de données Si vous entrez le nom d’un formulaire d’entrée de données comme valeur dans cette propriété de table, ce formulaire s’ouvre lorsqu’un utilisateur exécute la commande Modifier les éléments de liste . Sinon, la boîte de dialogue Modifier les éléments de la liste s’affiche lorsque les utilisateurs exécutent la commande.

Haut de la page

Utiliser des mises à jour en cascade pour modifier les valeurs de clé primaire et étrangère

Il peut parfois s’avérer nécessaire de mettre à jour une valeur de clé primaire. Si vous utilisez cette clé primaire comme clé étrangère, vous pouvez automatiquement mettre à jour vos modifications dans toutes les instances enfants de la clé étrangère.

Pour rappel, une clé primaire est une valeur qui identifie de manière unique chaque ligne (enregistrement) d’une table de base de données. Une clé étrangère est une colonne qui correspond à la clé primaire. En règle générale, les clés étrangères résident dans d’autres tables et vous permettent de créer une relation (un lien) entre les données des tables.

Supposons, par exemple, que vous utilisiez un numéro d’ID de produit comme clé primaire. Un numéro d’identification identifie de manière unique un produit. Vous utilisez également ce numéro d’ID comme clé étrangère dans une table de données de commande. De cette façon, vous pouvez trouver toutes les commandes qui impliquent chaque produit, car chaque fois que quelqu’un passe une commande pour ce produit, l’ID fait partie de la commande.

Parfois, ces numéros d’identification (ou d’autres types de clés primaires) changent. Dans ce cas, vous pouvez modifier la valeur de votre clé primaire et faire en sorte que cette modification soit automatiquement répercutée sur tous les enregistrements enfants associés. Vous activez ce comportement en activant l’intégrité référentielle et en mettant à jour en cascade entre les deux tables.

N’oubliez pas ces règles importantes :

  • Vous pouvez activer les mises à jour en cascade uniquement pour les champs de clé primaire définis sur les types de données Texte ou Nombre. Vous ne pouvez pas utiliser de mises à jour en cascade pour les champs définis sur le type de données NuméroAuto.
  • Vous ne pouvez activer les mises à jour en cascade qu’entre les tables ayant une relation un-à-plusieurs.

Pour plus d’informations sur la création de relations. Voir Guide des relations entre tables et Créer, modifier ou supprimer une relation.

Les procédures suivantes vont de pair et expliquent comment créer d’abord une relation, puis activer des mises à jour en cascade pour cette relation.

Créer la relation

  1. Sous l’onglet Outils de base de données, dans le groupe Afficher/Masquer, cliquez sur Relations.
  2. Sous l’onglet Création , dans le groupe Relations , cliquez sur Ajouter des tables (Afficher la table dans Access).
  3. Sélectionnez l’onglet Tableaux , sélectionnez les tables que vous souhaitez modifier, cliquez sur Ajouter, puis sur Fermer.
    Vous pouvez appuyer sur Maj pour sélectionner plusieurs tables ou ajouter chaque table individuellement. Sélectionnez uniquement les tables sur les côtés « un » et « plusieurs » de la relation.
  4. Dans la fenêtre Relations , faites glisser la clé primaire de la table du côté « un » de la relation et déposez-la dans le champ Clé étrangère de la table, du côté « plusieurs » de la relation.
    La boîte de dialogue Modifier des relations apparaît. La figure suivante montre la boîte de dialogue :
    Boîte de dialogue Modifier les relations avec une relation existante
  5. Activez la case à case activée Appliquer l’intégrité référentielle, puis cliquez sur Créer.

Activer les mises à jour en cascade dans les clés primaires

  1. Sous l’onglet Outils de base de données, dans le groupe Afficher/Masquer, cliquez sur Relations.
  2. La fenêtre Relations s’affiche et affiche les jointures (affichées sous forme de lignes de connexion) entre les tables de la base de données. La figure suivante illustre une relation typique :
  3. Cliquez avec le bouton droit sur la ligne de jointure entre les tables parent et enfant, puis cliquez sur Modifier la relation.
    Relation entre deux tables
    La boîte de dialogue Modifier des relations apparaît. La figure suivante montre la boîte de dialogue :
    Boîte de dialogue Modifier les relations
  4. Sélectionnez Mettre à jour en cascade les champs associés, vérifiez que la case Appliquer l’intégrité référentielle case activée est activée, puis cliquez sur OK.

Haut de la page

Pourquoi les numéros d’identification semblent parfois ignorer un numéro

Lorsque vous créez un champ défini sur le type de données NuméroAuto, Access génère automatiquement une valeur pour ce champ dans chaque nouvel enregistrement. La valeur est incrémentée par défaut, de sorte que chaque nouvel enregistrement reçoive le prochain numéro séquentiel disponible. Le type de données NuméroAuto sert à fournir une valeur qui peut être utilisée comme clé primaire. Pour plus d’informations, voir Ajouter, définir, modifier ou supprimer la clé primaire.

Lorsque vous supprimez une ligne d’une table contenant un champ défini sur le type de données NuméroAuto, la valeur du champ NuméroAuto correspondant à cette ligne n’est pas toujours automatiquement réutilisée. C’est pourquoi le numéro généré par Access peut ne pas être celui que vous vous attendez à voir, et des espaces peuvent apparaître dans la séquence des numéros d’ID, ce comportement est voulu par la conception même du produit. Vous devez vous fier uniquement au caractère unique des valeurs d’un champ NuméroAuto, et non à leur séquence.

Haut de la page

Mise à jour en bloc des données à l’aide de requêtes

Les requêtes Ajouter, Mettre à jour et Supprimer sont des moyens puissants d’ajouter, de modifier ou de supprimer des enregistrements en bloc. En outre, les mises à jour en bloc sont plus faciles et plus efficaces à effectuer lorsque vous utilisez de bons principes de conception de base de données. L’utilisation d’une requête d’ajout, de mise à jour ou de suppression peut vous faire gagner du temps, car vous pouvez également réutiliser la requête.

Important Sauvegardez vos données avant d’utiliser ces requêtes. Avoir une sauvegarde à portée de main peut vous aider à corriger rapidement les erreurs que vous pourriez commettre par inadvertance.

Ajouter des requêtes Permet d’ajouter de nombreux enregistrements à une ou plusieurs tables. Une requête Ajout permet d’ajouter un groupe d’enregistrements d’une ou plusieurs tables d’une base de données source à une ou plusieurs tables d’une base de données de destination. Supposons, par exemple, que vous acquériez de nouveaux clients et une base de données contenant un tableau d’informations sur ces clients. Pour éviter d’entrer ces nouvelles données manuellement, vous pouvez les ajouter à la ou aux tables appropriées de votre base de données. Pour plus d’informations, voir Ajouter des enregistrements à une table à l’aide d’une requête Ajout.

Requêtes Mise à jour Permet d’ajouter, de modifier ou de supprimer une partie (mais pas la totalité) de nombreux enregistrements existants. Les requêtes Mise à jour peuvent être considérées comme une forme plus puissante de la boîte de dialogue Rechercher et remplacer. Vous entrez un critère de sélection (l’équivalent approximatif d’une chaîne de recherche) et un critère de mise à jour (l’équivalent approximatif d’une chaîne de remplacement). Contrairement à la boîte de dialogue, les requêtes de mise à jour peuvent accepter plusieurs critères, vous permettent de mettre à jour un grand nombre d’enregistrements en une seule fois et de modifier des enregistrements dans plusieurs tables. Pour plus d’informations, voir Créer et exécuter une requête Mise à jour.

Supprimer des requêtes Lorsque vous souhaitez supprimer rapidement un grand nombre de données ou supprimer un ensemble de données de manière régulière, une suppression est utile car les requêtes permettent de spécifier des critères pour trouver et supprimer rapidement les données. Pour plus d’informations, voir Méthodes d’ajout, de modification et de suppression d’enregistrements.

Haut de la page