Lorsque vous créez des références externes à d’autres livres (également appelés liens), vous pouvez contrôler si et quand elles sont mises à jour. Ceci est important, car si quelqu’un d’autre modifie la valeur d’une cellule liée, Excel ne met pas à jour le lien et n’affiche la nouvelle valeur que si vous ne le lui indiquez pas.

Le workbook qui contient les liens est appelé le workbook de destination, et le workbook avec qui il est lié est appelé le workbook source. Vous pouvez lier plusieurs workbooks sources à un seul et unique workbook de destination.

Classeur contenant des liens

1. Le workbook de destination contient la référence externe (lien).

2. La référence externe (ou lien) est une référence à une cellule ou plage du workbook source.

3. Le workbook source contient la cellule ou plage liée ainsi que la valeur réelle renvoyée au workbook de destination.

Remarque : Bien qu’il n’y a pas de limite au nombre de livres que vous pouvez lier, il est généralement important de lier le plus petit nombre possible de ces derniers. Dans le cas contraire, vous risquez de faire face à des problèmes de performances lors du recalcul des formules. Il est également possible d’associer des liens entre des workbooks, où chacun agit comme source et destination, mais cela peut prêter à confusion et rendre la gestion plus difficile.

Lorsque les manuels source et de destination sont ouverts sur le même ordinateur, les liens sont automatiquement mis à jour. Lorsque vous ouvrez un classeur de destination et que le classeur source n’est pas ouvert, la barre de confidentialité peut vous demander si vous voulez mettre à jour les liens. Vous pouvez contrôler son affichage et la mise à jour des liens lorsque l’alerte ne s’affiche pas. Vous pouvez également choisir de mettre à jour uniquement certains liens si le workbook en contient plusieurs.

Dans les sections suivantes, nous allons passer en revue les options les plus courantes de gestion de la mise à jour des liens.

  1. Fermez tous les workbooks sources. Si un classeur source est ouvert et tous les autres fermés, la mise à jour ne sera pas uniforme.

  2. Ouvrez le classeur de destination.

  3. Pour mettre à jour les liens, dans la barre de confiance, cliquez sur Mettre à jour. Fermez la barre de confiance si vous ne voulez pas mettre à jour les liens (recherchez le X sur le côté droit).

  1. Ouvrez le classeur contenant les liens.

  2. Go to Data > Queries & Connections > Edit Links.

    Connexions de données

  3. Dans la liste Source, cliquez sur l’objet lié à mettre à jour.

    Vous pouvez sélectionner des livres individuels en Ctrl+clic,ou tous avec Ctrl+A.

  4. Cliquez sur Mettre à jour les valeurs.

    Excel boîte de dialogue Modifier les liens à partir des requêtes > données et & connexions et > modifier les liens

  1. Recherchez le document que vous voulez utiliser comme nouvelle source pour la référence externe, puis notez son emplacement.

  2. Dans le workbook de destination, sélectionnez la cellule avec la référence externe à modifier.

  3. Dans la barre de formule Image du bouton, recherchez une référence à un autre document (par exemple, C:\Reports\[Budget.xlsx] et remplacez cette référence par l’emplacement du nouveau document source.

Vous pouvez décider si les liens de ce classeux sont mis à jour lors de l’ouverture du fichier en fonction des paramètres de l’utilisateur, non mis à jour lors de l’ouverture du fichier, ou mis à jour automatiquement sans demander l’utilisateur.

Avertissement : Cette option affecte tous les utilisateurs du classeur. Si vous choisissez de ne pas mettre à jour les liens et si vous demandez à l’application de ne pas afficher d’invite, les utilisateurs du classeur ne sauront pas que les données sont obsolètes.

  1. Go to Data > Queries & Connections > Edit Links.

  2. Cliquez sur Invite de démarrage.

  3. Sélectionnez l’une des trois options suivantes :

  • Laisser les utilisateurs choisir d’afficher ou non l’alerte

  • Ne pas afficher l’alerte et ne pas mettre à jour les liens automatiques

  • N’affichez pas les liens d’alerte et de mise à jour.

Remarques : 

  • Options de mise à jour automatique et manuelle - Les liens de formule sont toujours réglés sur Automatique.

  • Même si vous spécifiez Excel ne devez pas vous demander de mettre à jour les liens, vous serez averti s’il existe des liensrompus.

Lorsque vous ouvrez la boîte de dialogue Modifier les liens(Requêtes > de données & Connexions > Modifier les liens),plusieurs options s’offrent à vous pour gérer les liens existants. Vous pouvez sélectionner des livres individuels en Ctrl+clic,ou tous avec Ctrl+A.

Excel boîte de dialogue Modifier les liens à partir des requêtes > données et & connexions et > modifier les liens
  • Mettre à jour les valeurs

    Cela permet de mettre à jour tous les livres sélectionnés.

  • Modifier la source

    Cette option est utile lorsque vous voulez pointer des liens existants vers une autre source. Par exemple, vous avez peut-être un modèle d’année antérieure et vous devez pointer vers un nouveau workbook lorsqu’une nouvelle année commence. La sélection de la source de modification a pour effet de lancer une boîte de dialogue de l’Explorateur de fichiers dans laquelle vous pouvez rechercher le nouveau classeur source. Si le feuille de calcul a plusieurs feuilles de calcul, vous êtes invité à spécifier celle vers laquelle établir un lien. Il vous suffit de cliquer sur la feuille de calcul de votre souhaitez, puis sur OK.

    Remarque : Il est possible de pointer sur lui-même un tel livre en le sélectionnant dans la boîte de dialogue Modifier la source. Cette opération permet de couper toute liaison de formule au workbook source lié à l’origine.

  • Open Source

    Le workbook source s’ouvre alors.

  • Rompre la liaison

    Important : Lorsque vous rompez une liaison à une source, toutes les formules qui utilisent la source sont converties en valeur actuelle. Par exemple, le lien =SOMME([Budget.xlsx]Annuel! C10:C25) serait convertie en la somme des valeurs du workbook source. Étant donné que cette action ne peut pas être annulée, vous souhaitez peut-être enregistrer tout d’abord une version du fichier.

    1. Sous l’onglet Données, dans le groupe Requêtes & Connexions, cliquez sur Modifier les liens.

    2. Dans la liste Source, cliquez sur la liaison que vous voulez rompre.

      Vous pouvez sélectionner des livres individuels en Ctrl+clic,ou tous avec Ctrl+A.

    3. Cliquez sur Rompre la liaison.

      Remarques : 

      • Si le lien utilise un nom défini, il n’est pas supprimé automatiquement. Vous pouvez donc également supprimer le nom.

      • Pour supprimer un nom :

      • Si vous utilisez une plage de données externe, un paramètre d’une requête peut également utiliser les données d’un autre workbook. Vous pouvez rechercher et supprimer tous ces types de liens.

      • Sous l’onglet Formules, dans le groupe Noms définis, cliquez sur Gestionnaire de noms.

      • Dans la colonne Nom, cliquez sur le nom à supprimer, puis sur Supprimer.

  • Vérifier l’état

    Ceci affiche simplement une notification dans le volet Modifier les liens si un workbook lié est toujours une source valide. Il doit afficher OK,mais si ce n’est pas le cas, vous devez vérifier le workbook source. Dans de nombreux cas, un fichier de travail source peut avoir été déplacé ou supprimé, coupant ainsi le lien. Si le manuel existe toujours, vous pouvez utiliser l’option Modifier la source pour liez de façon réliens le manuel.

  • Puis-je remplacer une seule formule par sa valeur calculée ?

    Oui. Lorsque vous remplacez une formule par sa valeur, Excel supprime définitivement la formule. Si vous remplacez accidentellement une formule par une valeur et que vous souhaitez restaurer la formule, cliquez sur Annuler Bouton Annuler après avoir entré ou collé la valeur.

    1. Appuyez sur Ctrl+C pour copier la formule.

    2. Appuyez sur Alt+E+S+V pour coller la formule comme valeur, ou allez dans Le Presse-papiers>'> coller > coller des valeurs.

  • Que se passe-t-il si je ne suis pas connecté à la source ?

    Cliquez sur Ne pas mettre à jour. Excel ne peut pas effectuer la mise à jour à partir d’une source qui n’est pas connectée. Par exemple, la source peut se trouver sur un réseau auquel vous n’êtes pas connecté.

  • Je ne souhaite pas que mes données actuelles sont remplacées par de nouvelles données

    Cliquez sur Ne pas mettre à jour.

  • J’ai essayé de mettre à jour la dernière fois, mais cela a pris trop de temps

    Cliquez sur Ne pas mettre à jour. Si les données ne doivent pas nécessairement être les plus récentes, vous pouvez gagner du temps en ne mettant pas à jour tous les liens. Après avoir ouvert le manuel, sous l’onglet Données, dans le groupe Connexions, cliquez sur Modifier les liens,puis mettez à jour les liens uniquement à partir des sources dont vous avez besoin.

  • Quelqu’un d’autre a créé le manuel et je ne sais pas pourquoi cette invite s’invite

    Cliquez sur Ne pas mettre àjour et contactez le propriétaire du groupe. Vous pouvez également rechercher les liens dans le workbook. Sous l’onglet Données, dans le groupe Requêtes & Connexions, cliquez sur Modifier les liens.

  • Je réponds à l’invite de la même façon à chaque fois, et je ne souhaite plus la voir.

    Vous pouvez répondre au message d’invite de démarrage de façon cohérente et éviter qu’il s’affiche pour ce classeur.

    • Ne pas demander si les liens doivent être mis à jour à l’ouverture d’un classeur. Mettre automatiquement à jour les liens     

      Cette option affecte chaque classeur ouvert sur l’ordinateur. Les utilisateurs qui ouvrent le classeur sur un autre ordinateur ne sont pas concernés.

      1. Accédez à Fichier > Options > Options avancées.

      2. Sous Général, désactivez la case à cocher Confirmation de la mise à jour automatique des liens. Si cette case est désactivée, les liens sont automatiquement mis à jour ; aucune invite ne s’affiche.

    • Invite identique pour chaque utilisateur de ce classeur    

      Avertissement : Cette option affecte tous les utilisateurs du classeur. Si vous choisissez de ne pas mettre à jour les liens et si vous demandez à l’application de ne pas afficher d’invite, les utilisateurs du classeur ne sauront pas que les données sont obsolètes.

      Sélectionnez l’option > l’option De votre choix & l’option Modifier > liens > invite de démarrage.

      Remarque : Vous serez toujours averti si certains liens sont rompus.

  • Que se passe-t-il si j’utilise une requête Paramètre ?

    1. Cliquez sur Ne pas mettre à jour.

    2. Fermez le classeur de destination.

    3. Ouvrez le classeur source.

    4. Ouvrez le classeur de destination.

    5. Cliquez sur Mettre à jour.

    Pour mettre à jour un lien avec une requête paramétrée, le classeur source doit obligatoirement être ouvert.

  • Pourquoi ne puis-je pas choisir « Manuel » comme option de mise à jour pour un lien externe spécifique ?

    Les liens de formule sont toujours réglés sur Automatique.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×