Correction d’une erreur #VALEUR! dans la fonction NB.SI/NB.SI.ENS

Cette rubrique répertorie les causes les plus courantes de l’erreur #VALEUR! dans les fonctions NB.SI et NB.SI.ENS.

Problème : La formule fait référence à des cellules figurant dans un classeur fermé

Les fonctions COUNTIF/COUNTIFS qui font référence à une cellule ou à une plage dans un workbook fermé entraînent une #VALUE! comme erreur.

Remarque : Il s’agit d’un problème connu avec plusieurs autres fonctions Excel telles que SOMME.SI, SOMME.SI.ENS, COUNTBLANK, entre autres. Pour plus d'#VALUE les fonctions SOMME.SI, COUNTIF et COUNTBLANK .

Solution : Ouvrez le classeur lié indiqué dans la formule et appuyez sur F9 pour actualiser celle-ci.

Vous pouvez également contourner ce problème en utilisant ensemble les fonctions SOMME et SI dans une formule de tableau. Pour plus d'#VALUE les fonctions SOMME.SI, COUNTIF et COUNTBLANK .

Problème : La chaîne dépasse les 255 caractères

Solution : Si possible, raccourcissez la chaîne. Si vous ne pouvez pas la raccourcir, utilisez la fonction CONCATENER ou l’opérateur esperluette (&) pour décomposer la valeur en plusieurs chaînes. Par exemple,

  • =NB.SI(B2:B12;"chaîne longue"&"autre chaîne longue")

Vous avez une question sur une fonction en particulier ?

Posez une question sur le forum de la communauté Excel

Contribuer à l’amélioration d’Excel

Avez-vous des suggestions sur la manière dont nous pouvons améliorer la prochaine version d’Excel ? Si c’est le cas, consultez les rubriques du forum User Voice sur Excel.

Voir aussi

Corriger une erreur #VALEUR! erreur

NB.SI

NB.SI.ENS

Fonction SI – Utiliser des formules imbriquées et éviter les pièges

Regardez une vidéo sur les fonctions SI avancées

Vue d’ensemble des formules dans Excel

Comment éviter les formules incorrectes

Détecter les erreurs dans les formules

Toutes les fonctions Excel (par ordre alphabétique)

Toutes les fonctions Excel (par catégorie)

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×