Cellules

Importer ou exporter des fichiers texte (.txt ou .csv)

Importer ou exporter des fichiers texte (.txt ou .csv)

Il existe deux façons d’importer des données à partir d’un fichier texte avec Excel : vous pouvez les ouvrir dans Excel ou les importer en tant qu' plage de données externes. Pour exporter des données d’Excel vers un fichier texte, utilisez la commande Enregistrer sous et modifiez le type de fichier dans le menu déroulant.

Il existe deux formats de fichiers texte couramment utilisés :

  • Fichiers texte délimités (.txt), dans lesquels le caractère TAB (code de caractère ASCII 009) sépare généralement chaque champ de texte.

  • Fichiers texte de valeurs séparées par des virgules (.csv), dans lequel le caractère virgule (,) sépare généralement chaque champ de texte.

Vous pouvez modifier le caractère de séparation utilisé dans les fichiers texte délimités et .csv. Cette opération peut être nécessaire pour vous assurer que l’opération d’importation ou d’exportation fonctionne comme vous le souhaitez.

Remarque : Vous pouvez importer ou exporter jusqu’à 1 048 576 lignes et 16 384 colonnes.

Importer un fichier texte en l’ouvrant dans Excel

Vous pouvez ouvrir un fichier texte que vous avez créé dans un autre programme en tant que classeur Excel à l’aide de la commande Ouvrir. L’ouverture d’un fichier texte dans Excel ne modifie pas son format. Vous pouvez le voir dans la barre de titre d’Excel, où le nom du fichier conserve l’extension de nom de fichier texte (par exemple, .txt ou .csv).

  1. Accédez à Fichier > Ouvrir et accédez à l’emplacement qui contient le fichier texte.

  2. Sélectionnez Fichiers texte dans la liste type de fichier de la boîte de dialogue Ouvrir.

  3. Localisez et double-cliquez sur le fichier texte que vous voulez ouvrir.

    • Si le fichier est un fichier texte (.txt), Excel démarre l’Assistant Importation de texte. Lorsque vous avez terminé les étapes, cliquez sur Terminer pour terminer l’importation. Pour plus d’informations sur les délimiteurs et les options avancées, voir l’Assistant Importation de texte.

    • Si le fichier est un fichier .csv, Excel ouvre automatiquement le fichier texte et affiche les données dans un nouveau classeur.

      Remarque : Lorsqu’Excel ouvre un fichier .csv, il utilise les paramètres actuels de format de données par défaut pour interpréter l’importation de chaque colonne de données. Si vous souhaitez plus de flexibilité dans la conversion des colonnes dans différents formats de données, vous pouvez utiliser l’Assistant Importation de texte. Par exemple, le format d’une colonne de données dans le fichier .csv peut être MDY, mais le format de données Par défaut d’Excel est YMD, ou vous voulez convertir une colonne de nombres contenant des zéros non responsables en texte afin de conserver les zéros non sérieux. Pour forcer Excel à exécuter l’Assistant Importation de texte, vous pouvez modifier l’extension de nom de fichier de .csv en .txt avant de l’ouvrir, ou vous pouvez importer un fichier texte en vous y connectant (pour plus d’informations, voir la section suivante).

Importer un fichier texte en le connectant (Power Query)

Vous pouvez importer des données à partir d’un fichier texte dans une feuille de calcul existante.

  1. Sous l’onglet Données, dans le groupe Récupérer & transformer les données, cliquez sur Texte/CSV.

  2. Dans la boîte de dialogue Importer des données, localisez et double-cliquez sur le fichier texte à importer, puis cliquez sur Importer.

  3. Dans la boîte de dialogue Aperçu, plusieurs options s’offrent à vous :

    • Sélectionnez Charger si vous voulez charger les données directement dans une nouvelle feuille de calcul.

    • Vous pouvez également sélectionner Charger si vous voulez charger les données dans un tableau, un tableau croisé dynamique ou un rapport croisé dynamique, une feuille de calcul Excel existante/nouvelle, ou simplement créer une connexion. Vous avez également la choix d’ajouter vos données au modèle de données.

    • Sélectionnez Transformer les données si vous voulez charger les données dans Power Query et modifiez-les avant de les apporter à Excel.

Si Excel ne convertit pas une colonne de données spécifique au format voulu, vous pouvez convertir les données après les avoir importées. Pour plus d’informations, voir Convertir les nombres stockés en tant que texte en nombres et convertir les dates stockées entant que texte en dates.

Exporter des données vers un fichier texte en l’enregistrer

Vous pouvez convertir une feuille de calcul Excel en fichier texte à l’aide de la commande Enregistrer sous.

  1. Accédez à Fichier > Enregistrer sous.

  2. Cliquez sur Parcourir.

  3. Dans la boîte de dialogue Enregistrer sous, sous La zone Type de fichier, sélectionnez le format de fichier texte pour la feuille de calcul. Par exemple, cliquez sur Texte (délimité par des tabulations) ou CSV (délimitépar des virgules).

    Remarque : Les différents formats présentent différents ensembles de fonctionnalités. Pour plus d’informations sur les ensembles de fonctionnalités pris en charge par les différents formats de fichiers texte, voir Les formats de fichier pris en charge dans Excel.

  4. Accédez à l’emplacement où vous souhaitez enregistrer le nouveau fichier texte, puis cliquez sur Enregistrer.

  5. Une boîte de dialogue s’affiche pour vous rappeler que seule la feuille de calcul actuelle est enregistrée dans le nouveau fichier. Si vous êtes certain que la feuille de calcul actuelle est celle que vous voulez enregistrer en tant que fichier texte, cliquez sur OK. Vous pouvez enregistrer d’autres feuilles de calcul en tant que fichiers texte distincts en répétant cette procédure pour chaque feuille de calcul.

    Une alerte peut également s’avertir sous le ruban que certaines fonctionnalités risquent d’être perdues si vous enregistrez le fichier au format CSV.

Pour plus d’informations sur l’enregistrement de fichiers dans d’autres formats, voir Enregistrer un classez dans un autre format de fichier.

Importer un fichier texte en le connectant

Vous pouvez importer des données à partir d’un fichier texte dans une feuille de calcul existante.

  1. Cliquez sur la cellule dans laquelle vous voulez placer les données du fichier texte.

  2. Sous l’onglet Données, dans le groupe Données externes, cliquez sur À partir du texte.

  3. Dans la boîte de dialogue Importer des données, localisez et double-cliquez sur le fichier texte à importer, puis cliquez sur Importer.

    Suivez les instructions de l’Assistant Importation de texte. Cliquez sur Aide Bouton n’importe quelle page de l’Assistant Importation de texte pour plus d’informations sur l’utilisation de l’Assistant. Lorsque vous avez terminé les étapes de l’Assistant, cliquez sur Terminer pour terminer l’opération d’importation.

  4. Dans la boîte de dialogue Importer des données, vous pouvez :

    1. Sous Où voulez-vous placer les données ?Faites l’une des choses suivantes :

      • Pour renvoyer les données à l’emplacement que vous avez sélectionné, cliquez sur Feuille de calcul existante.

      • Pour renvoyer les données dans le coin supérieur gauche d’une nouvelle feuille de calcul, cliquez sur Nouvelle feuille de calcul.

    2. Vous pouvez également cliquer sur Propriétés pour définir les options d’actualisation, de mise en forme et de mise en page pour les données importées.

    3. Cliquez sur OK.

      Excel place la plage de données externes à l’emplacement que vous spécifiez.

Si Excel ne convertit pas une colonne de données au format voulu, vous pouvez convertir les données après les avoir importées. Pour plus d’informations, voir Convertir les nombres stockés en tant que texte en nombres et convertir les dates stockées entant que texte en dates.

Exporter des données vers un fichier texte en l’enregistrer

Vous pouvez convertir une feuille de calcul Excel en fichier texte à l’aide de la commande Enregistrer sous.

  1. Accédez à Fichier > Enregistrer sous.

  2. La boîte de dialogue Enregistrer sous s’affiche.

  3. Dans la zone Type de fichier, sélectionnez le format de fichier texte pour la feuille de calcul.

    • Par exemple, cliquez sur Texte (délimité par des tabulations) ou CSV (délimitépar des virgules).

    • Remarque : Les différents formats présentent différents ensembles de fonctionnalités. Pour plus d’informations sur les ensembles de fonctionnalités pris en charge par les différents formats de fichiers texte, voir Les formats de fichier pris en charge dans Excel.

  4. Accédez à l’emplacement où vous souhaitez enregistrer le nouveau fichier texte, puis cliquez sur Enregistrer.

  5. Une boîte de dialogue s’affiche pour vous rappeler que seule la feuille de calcul actuelle est enregistrée dans le nouveau fichier. Si vous êtes certain que la feuille de calcul actuelle est celle que vous voulez enregistrer en tant que fichier texte, cliquez sur OK. Vous pouvez enregistrer d’autres feuilles de calcul en tant que fichiers texte distincts en répétant cette procédure pour chaque feuille de calcul.

  6. Une deuxième boîte de dialogue s’affiche pour vous rappeler que votre feuille de calcul peut contenir des fonctionnalités non prise en charge par les formats de fichier texte. Si vous souhaitez enregistrer uniquement les données de la feuille de calcul dans le nouveau fichier texte, cliquez sur Oui. Si vous n’êtes pas certain et souhaitez en savoir plus sur les fonctionnalités Excel qui ne sont pas pris en charge par les formats de fichier texte, cliquez sur Aide pour plus d’informations.

Pour plus d’informations sur l’enregistrement de fichiers dans d’autres formats, voir Enregistrer un classez dans un autre format de fichier.

La façon dont vous modifiez le délimiteur lors de l’importation varie selon la façon dont vous importez le texte.

  • Si vous utilisez la & Transformer les données > À partir d’un texte/CSV,après avoir choisi le fichier texte et cliqué sur Importer,sélectionnez un caractère à utiliser dans la liste sous Délimiteur. Vous pouvez voir l’effet de votre nouveau choix immédiatement dans l’aperçu des données, de sorte que vous pouvez vous assurer de faire le choix voulu avant de continuer.

  • Si vous utilisez l’Assistant Importation de texte pour importer un fichier texte, vous pouvez modifier le délimiteur utilisé pour l’opération d’importation à l’étape 2 de l’Assistant Importation de texte. Dans cette étape, vous pouvez également modifier la façon dont les délimiteur consécutifs, tels que les guillemets consécutifs, sont gérés.

    Pour plus d’informations sur les délimiteurs et les options avancées, voir l’Assistant Importation de texte.

Si vous souhaitez utiliser un point-virgule comme séparateur de liste par défaut lorsque vous enregistrez sous .csv, mais que vous devez limiter la modification à Excel, envisagez de changer le séparateur décimal par défaut en virgule . Cela oblige Excel à utiliser un point-virgule pour le séparateur de liste. Bien évidemment, cela change également la façon dont les nombres décimaux s’affichent, aussi envisagez-vous de modifier le séparateur des milliers pour limiter toute confusion.

  1. Clear Excel Options> Advanced> Editing options> Use system separators.

  2. Définissez le séparateur décimal sur , (une virgule).

  3. Définissez le séparateur des milliers sur . (a point).

Lorsque vous enregistrez un classeur en tant que fichier .csv, le séparateur de liste par défaut est une virgule. Vous pouvez changer ce caractère de séparation à l’aide des paramètres de région Windows. 

Attention : La modification du paramètre Windows entraîne un changement global sur votre ordinateur et affecte toutes les applications. Pour modifier uniquement le séparateur de liste pour Excel, voir Modifier le séparateur de liste par défaut pour l’enregistrement des fichiers au moyen de texte (.csv) dans Excel.

  1. Dans Microsoft Windows 10, cliquez avec le bouton droit sur le bouton Démarrer, puis cliquez sur Paramètres.

  2. Cliquez sur & langue,puis sur Région dans le panneau de gauche.

  3. Dans le panneau principal, sous Paramètres régionaux,cliquez sur Date, heure et paramètres régionaux supplémentaires.

  4. Sous Région,cliquez sur Modifier les formats de date, d’heure ou de nombre.

  5. Dans la boîte de dialogue Région, sous l’onglet Format, cliquez sur Paramètres supplémentaires.

  6. Dans la boîte de dialogue Personnaliser le format, sous l’onglet Nombres, tapez un caractère à utiliser comme nouveau séparateur dans la zone Séparateur de liste.

  7. Cliquez deux fois sur OK.

  1. Dans Microsoft Windows, cliquez sur le bouton Démarrer, puis sur Panneau de configuration.

  2. Sous Horloge, langue et région, cliquez sur Modifier les formats de date, d’heure ou de nombre.

  3. Dans la boîte de dialogue Région, sous l’onglet Format, cliquez sur Paramètres supplémentaires.

  4. Dans la boîte de dialogue Personnaliser le format, sous l’onglet Nombres, tapez un caractère à utiliser comme nouveau séparateur dans la zone Séparateur de liste.

  5. Cliquez deux fois sur OK.

Remarque :  Après avoir changé le caractère séparateur de liste de votre ordinateur, tous les programmes utilisent le nouveau caractère comme séparateur de liste. Vous pouvez revenir au caractère par défaut en suivant la même procédure.

Besoin d’aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Importer des données à partir de sources de données externes (Power Query)

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×