Si vous avez une liste de données que vous voulez grouper et synthétiser, vous pouvez créer un plan de huit niveaux au plus. Chaque niveau interne, représenté par un numéro plus élevé dans les symboles du plan affiche les données de détails du niveau externe précédent, représenté par un numéro moins élevé. Un plan vous permet d’afficher rapidement les lignes ou les colonnes de synthèse ou de révéler les détails de chaque groupe. Vous pouvez créer un plan de lignes (comme dans l’exemple ci-après), un plan de colonnes ou un plan de lignes et de colonnes.

Données avec un plan à trois niveaux

1. Pour afficher les lignes pour un niveau, cliquez sur le plan approprié un deux trois les symboles du plan.

2.  Le niveau 1 contient le total des ventes pour toutes les lignes de détail.

3.  Le niveau 2 contient le total des ventes par mois et par région.

4. Le niveau 3 contient les lignes de détail (en l'occurrence, les lignes 17 à 20).

5. Pour développer ou réduire les données dans votre plan, cliquez sur les symboles de plan case plus et moins ou appuyez sur Alt+Shift+= pour développer et Alt+Shift+- pour réduire.

  1. Assurez-vous que chaque colonne des données à présenter en mode Plan est étiquetée dans la première ligne (par exemple Région), contient des faits similaires dans chaque colonne et que la plage que vous voulez définir en mode Plan ne comporte aucune ligne ou colonne vide.

  2. Si vous le souhaitez, vos lignes de détail groupées peuvent avoir une ligne de synthèse correspondante (un sous-totaux). Pour créer ces éléments, vous pouvez :

    • Insérer des lignes de synthèse à l’aide de la commande Sous-total    

      Utilisez la commande Sous-total qui insère la fonction SOUS.TOTAL immédiatement en dessous ou au-dessus de chaque groupe de lignes de détails et qui crée automatiquement le plan. Pour plus d’informations sur l’utilisation de la fonction Sous-total, voir SOUS.TOTAL, fonction.

    • Insérer des lignes de synthèse    

      Insérez vos propres lignes de synthèse avec des formules immédiatement en dessous ou au-dessus de chaque groupe de lignes de détails. Par exemple, sous (ou au-dessus) de la ligne des données de vente pour mars et avril, utilisez la fonction SOMME pour calculer le sous-total des ventes pour ces mois. Le tableau ci-après vous montre cet exemple.

  3. Par défaut, Excel recherche les lignes de synthèse sous les détails qu'ils synthétiser, mais il est possible de les créer au-dessus des lignes de détail. Si vous avez créé les lignes de synthèse sous les détails, passez à l'étape suivante (étape 4). Si vous avez créé vos lignes de synthèse au-dessus de vos lignes de détail, sous l'onglet Données, dans le groupe Plan, cliquez sur le lanceur de boîte de dialogue.

    Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

    La boîte de dialogue Paramètres s'ouvre.

    Boîte de dialogue Paramètres pour les plan

    Dans la boîte de dialogue Paramètres, videz les lignes de synthèse sous la case à cocher détaillée, puis cliquez sur OK.

  4. Affichez vos données en mode plan. Effectuez l’une des actions suivantes :

    Créer automatiquement un plan des données

    1. Sélectionnez une cellule dans la plage de cellules que vous voulez mettre en plan.

    2. Sous l’onglet Données, dans le groupe Plan, cliquez sur la flèche sous Grouper, puis cliquez sur Plan automatique.

      Cliquez sur la flèche sous Groupe, puis cliquez sur Plan automatique

    Créer manuellement un plan des données

    Important : Lorsque vous groupez manuellement des niveaux du plan, veillez à ce que toutes les données soient affichées pour éviter de grouper incorrectement les lignes.

    1. Pour présenter le groupe externe en plan (niveau 1), sélectionnez toutes les lignes que contiendra le groupe externe (c'est-à-dire, les lignes de détail et, si vous les avez ajoutées, leurs lignes de synthèse).

      Sélection de données prête pour la création d’un groupe externe

      1. La première ligne contient des étiquettes et n'est pas sélectionnée.

      2. Étant donné qu'il s'agit du groupe externe, sélectionnez toutes les lignes avec des sous-totaux et des détails.

      3. Ne sélectionnez pas le total global.

    2. Dans l’onglet Données, dans le groupe Plan, cliquez sur Grouper. Dans la boîte de dialogue Grouper, cliquez sur Lignes,puis sur OK.

      Conseil : Si vous sélectionnez des lignes entières au lieu de n'en sélectionner que les cellules, Excel effectue automatiquement un regroupement par ligne. La boîte de dialogue Grouper ne s'ouvre même pas.

      Cliquez sur Lignes, puis sur OK.

      Les symboles du plan s’affichent à côté du groupe à l’écran.

    3. (Facultatif) Présentez en mode plan un groupe imbriqué interne (lignes de détail pour une section donnée de vos données).

      Remarque : Si vous n'avez pas besoin de créer de groupes internes, passez à l'étape f, ci-dessous.

      Pour chaque groupe imbriqué interne, sélectionnez les lignes de détails adjacentes à la ligne qui contient la ligne de synthèse.

      Données sélectionnées pour le regroupement au niveau 2 dans une hiérarchie.

      1. Vous pouvez créer plusieurs groupes à chaque niveau interne. Ici, deux sections sont déjà regroupées au niveau 2.

      2. Cette section est sélectionnée et prête à être regroupée.

      3. Ne sélectionnez pas la ligne de synthèse pour les données que vous groupez.

    4. Dans l’onglet Données, dans le groupe Plan, cliquez sur Grouper.

      Cliquez sur Groupe sous l’onglet Données

      Dans la boîte de dialogue Grouper, cliquez sur Lignes,puis sur OK. Les symboles du plan s’affichent à côté du groupe à l’écran.

      Conseil : Si vous sélectionnez des lignes entières au lieu de n'en sélectionner que les cellules, Excel effectue automatiquement un regroupement par ligne. La boîte de dialogue Grouper ne s'ouvre même pas.

    5. Continuez à sélectionner et à grouper les lignes internes jusqu’à ce que vous ayez créé tous les niveaux souhaités dans le plan.

    6. Si vous souhaitez dissocier des lignes, sélectionnez-les, puis, dans le groupe Plan de l’onglet Données, cliquez sur Dissocier.

      Vous pouvez également dégrouper des sections du plan sans supprimer le niveau entier. Maintenez la souris Ct vers le bas tout en cliquant sur la case plus ou la case moins du groupe, puis sous l'onglet Données, dans le groupe Plan, cliquez sur Grouper.

      Important : Si vous dissociez des sections du plan alors que les données de détail sont masquées, les lignes de détail peuvent rester masquées. Pour afficher les données, faites glisser le pointeur sur les numéros des lignes visibles adjacentes aux lignes masquées. Dans l'onglet Accueil, dans le groupe Cellules, cliquez sur Format,pointez sur Masquer &, puis cliquez sur Masquer les lignes.

  1. Chaque ligne de données à afficher en mode Plan doit comporter une étiquette dans la première colonne et contenir des informations similaires et aucune ligne ou colonne de la plage de cellules ne doit être vide.

  2. Insérez vos propres colonnes de synthèse avec les formules immédiatement à droite ou à gauche de chaque groupe de colonnes de détails. Le tableau indiqué à l’étape 4 ci-dessous montre cet exemple.

    Remarque :  Pour afficher les données par colonne en mode plan, les colonnes de synthèse doivent contenir des formules qui font référence aux cellules de chaque colonne de détails pour le groupe.

  3. Si votre colonne de synthèse se trouve à gauche des colonnes de détail, sous l'onglet Données, dans le groupe Plan, cliquez sur le lanceur de boîte de dialogue.

    Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

    La boîte de dialogue Paramètres s'ouvre.

    Boîte de dialogue Paramètres pour les plan

    Dans la boîte de dialogue Paramètres, cochez les colonnes de synthèse à droite de la case à cocher détaillée, puis cliquez sur OK.

  4. Pour afficher les données en mode Plan, effectuez l’une des actions suivantes :

    Créer automatiquement un plan des données

    1. Sélectionnez une cellule dans la plage.

    2. Sous l’onglet Données, dans le groupe Plan, cliquez sur la flèche sous Grouper, puis cliquez sur Plan automatique.

    Créer manuellement un plan des données

    Important :  Lorsque vous groupez manuellement des niveaux du plan, veillez à ce que toutes les données soient affichées pour éviter de grouper incorrectement les colonnes.

    1. Pour présenter le groupe externe en plan (niveau 1), sélectionnez toutes les colonnes de synthèse subordonnées, ainsi que les données de détail qui leur sont associées.

      Données organisées en colonnes pour être regroupées

      1. La colonne A contient des étiquettes.

      2. Sélectionnez toutes les colonnes de détail et de sous-total. Notez que si vous ne sélectionnez pas des colonnes entières, lorsque vous cliquez sur Groupe (sous l'onglet Données du groupe Plan), la boîte de dialogue Groupe s'ouvre et vous demande de choisir Lignes ou Colonnes.

      3. Ne sélectionnez pas la colonne de total global.

    2. Dans l’onglet Données, dans le groupe Plan, cliquez sur Grouper.

      Cliquez sur Groupe sous l’onglet Données

      Le symbole du plan s'affiche au-dessus du groupe.

    3. Pour présenter en plan un groupe imbrmbré interne de colonnes de détail (niveau 2 ou supérieur), sélectionnez les colonnes de détail adjacentes à la colonne qui contient la colonne de synthèse.

      Données regroupées en colonnes

      1. Vous pouvez créer plusieurs groupes à chaque niveau interne. Ici, deux sections sont déjà regroupées au niveau 2.

      2. Ces colonnes sont sélectionnées et prêtes à être regroupées. Notez que si vous ne sélectionnez pas des colonnes entières, lorsque vous cliquez sur Groupe (sous l'onglet Données du groupe Plan), la boîte de dialogue Groupe s'ouvre et vous demande de choisir Lignes ou Colonnes.

      3. Ne sélectionnez pas la colonne de synthèse pour les données que vous groupez.

    4. Dans l’onglet Données, dans le groupe Plan, cliquez sur Grouper.

      Cliquez sur Groupe sous l’onglet Données

      Les symboles du plan s’affichent à côté du groupe à l’écran.

  5. Continuez à sélectionner et à grouper les colonnes internes jusqu’à ce que vous ayez créé tous les niveaux que vous souhaitez dans le plan.

  6. Si vous souhaitez dissocier des colonnes, sélectionnez-les, puis, dans le groupe Plan de l’onglet Données, cliquez sur Dissocier.

Sous l’onglet Données, cliquez sur Dissocier

Vous pouvez également dégrouper des sections du plan sans supprimer le niveau entier. Maintenez la souris Ct vers le bas tout en cliquant sur la case plus ou la case moins du groupe, puis sous l'onglet Données, dans le groupe Plan, cliquez sur Grouper.

Si vous dissociez des sections du plan alors que les données de détail sont masquées, les colonnes de détail peuvent rester masquées. Pour afficher les données, faites glisser le pointeur sur les lettres des colonnes visibles adjacentes aux colonnes masquées. Dans le groupe Cellules de l’onglet Accueil, cliquez sur Format, pointez sur Masquer et afficher, puis cliquez sur Masquer les colonnes.

  1. Si vous ne voyez pas les symboles du plan un deux trois, case pluset moins, sélectionnez Fichier >Options> Avancées,puis sous la section Options d'affichage de cette feuille de calcul, sélectionnez la case à cocher Afficher les symboles du plan si un plan est appliqué, puis cliquez sur OK.

  2. Effectuez au moins l’une des opérations suivantes :

    • Afficher ou masquer les données de détail pour un groupe    

      Pour afficher les données de détail dans un groupe, cliquez sur le case plus du groupe ou appuyez sur Alt+Shift+=.

    • Pour masquer les données de détail d'un groupe, cliquez sur le moins du groupe ou appuyez sur Alt+Shift+-.

    • Développer ou réduire la totalité d’un plan à un niveau particulier    

      Dans les un deux trois du plan, cliquez sur le numéro du niveau de votre souhaitez. Les données de détail des niveaux inférieurs sont alors masquées.

      Par exemple, si un plan comporte quatre niveaux, vous pouvez masquer le quatrième niveau tout en affichant les autres niveaux, en cliquant sur trois.

    • Afficher ou masquer toutes les données de détail en mode plan    

      Pour afficher toutes les données de détail, cliquez sur le niveau le plus bas dans les un deux trois du plan. Si, par exemple, il existe trois niveaux, cliquez sur trois.

    • Pour masquer toutes les données de détail, cliquez sur un.

Pour les lignes du plan, Microsoft Excel utilise des styles, tels que NiveauLigne_1 et NiveauLigne_2. Pour les colonnes du plan, Excel utilise des styles tels que NiveauColonne_1 et NiveauColonne_2. Ces styles utilisent la mise en forme gras, italique et d’autres mises en forme pour différencier les lignes ou les colonnes de synthèse dans les données. En changeant la façon dont chaque style est défini, vous pouvez appliquer différentes mises en forme de texte et de cellule afin de personnaliser l’apparence de votre plan. Vous pouvez appliquer un style à un plan à sa création ou ultérieurement.

Effectuez au moins l’une des opérations suivantes :

Appliquer automatiquement un style aux nouvelles lignes ou colonnes de synthèse    

  1. Sous l'onglet Données, dans le groupe Plan, cliquez sur le lanceur de boîte de dialogue.

    Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

    La boîte de dialogue Paramètres s'ouvre.

    Boîte de dialogue Paramètres pour les plan

  2. Activez la case à cocher Styles automatiques.

Appliquer un style à une ligne ou une colonne existante    

  1. Sélectionnez les cellules à lesquelles vous voulez appliquer un style.

  2. Sous l'onglet Données, dans le groupe Plan, cliquez sur le lanceur de boîte de dialogue.

    Dans le groupe Plan, cliquez sur le lanceur de la boîte de dialogue

    La boîte de dialogue Paramètres s'ouvre.

    Boîte de dialogue Paramètres pour les plan

  3. Cochez la case Styles automatiques, puis cliquez sur Appliquer les styles.

    Boîte de dialogue Paramètres avec Styles automatiques sélectionné

Vous pouvez également utiliser les mises en forme automatiques pour mettre en forme les données du plan.

  1. Si vous ne voyez pas les symboles du plan un deux trois, case pluset moins, sélectionnez Fichier >Options> Avancées,puis sous la section Afficher les options pour cette feuille de calcul, cochez la case Afficher les symboles du plan si un plan est appliqué.

  2. Utilisez les symboles du un deux trois, moinset case plus pour masquer les données de détail que vous ne voulez pas copier.

    Pour plus d’informations, voir Afficher ou masquer des données affichées en mode plan.

  3. Sélectionnez la plage de lignes de synthèse.

  4. Dans l’onglet Accueil, dans le groupe Édition, cliquez sur Rechercher et sélectionner, puis sur Atteindre.

    Cliquez sur Rechercher et sélectionner, puis sur Atteindre

  5. Cliquez sur Sélectionner les cellules.

  6. Cliquez sur Cellules visibles seulement.

  7. Cliquez sur OK, puis copiez les données.

Remarque : Aucune donnée n’est supprimée lorsque vous masquez ou supprimez un plan.

Masquer un plan

  • Dans Fichier >Options > Avancées,puis sous la section Options d'affichage de cette feuille de calcul, décochez la case Afficher les symboles du plan si un plan est appliqué.

Supprimer un plan

  1. Cliquez sur la feuille de calcul.

  2. Sous l’onglet Données, dans le groupe Plan, cliquez sur Dissocier, puis sur Effacer le plan.

    Cliquez sur Dissocier, puis sur Effacer le plan

    Important : Si vous supprimez un plan alors que les données de détail sont masquées, les lignes ou les colonnes de détail peuvent rester masquées. Pour afficher les données, faites glisser le pointeur sur les numéros des lignes ou les lettres des colonnes visibles et adjacentes aux lignes et aux colonnes masquées. Dans le groupe Cellules de l’onglet Accueil, cliquez sur Format, pointez sur Masquer et afficher, puis sur Afficher les lignes ou sur Afficher les colonnes.

Supposons que vous vouliez créer un rapport de synthèse de vos données qui n’affiche que les totaux accompagnés d’un graphique. En général, la procédure est la suivante :

  1. Créer un rapport de synthèse

    1. Affichez vos données en mode plan.

      Pour plus d’informations, voir Créer un plan de lignes ou Créer un plan de colonnes.

    2. Masquez les détails en cliquant sur les symboles de plan un deux trois, case pluset moins pour afficher uniquement les totaux, comme illustré dans l'exemple suivant de plan de ligne :

      Liste sous forme de plan affichant uniquement les lignes de totaux

    3. Pour plus d’informations, voir Afficher ou masquer des données affichées en mode plan.

  2. Tracer le rapport de synthèse

    1. Sélectionnez les données de synthèse que vous voulez représenter graphiquement.

      Par exemple, pour ne graphiquer que les totaux pour Buchanan et Davolio, mais pas les totaux grands, sélectionnez les cellules A1 à C19, comme illustré dans l'exemple ci-dessus.

    2. Cliquez sur Insérer > graphiques > les graphiquesrecommandés, puis cliquez sur l'onglet Tous les graphiques et choisissez votre type de graphique.

      Boîte de dialogue Insérer un graphique

      Par exemple, si vous avez choisi l'option Colonne groupée, votre graphique se présente comme ceci :

      Graphique créé à partir des données de sous-totaux

      Si vous affichez ou masquez des détails dans la liste de données sous forme de plan, le graphique est également mis à jour pour afficher ou masquer les données en conséquence.

Vous pouvez grouper (ou présenter en plan) des lignes et des colonnes Excel pour le web.

Remarque : Bien que vous pouvez ajouter des lignes ou des colonnes de synthèse à vos données (à l'aide de fonctions telles que SOMME ou SOUS.TOTAL), vous ne pouvez pas appliquer de styles ou définir une position pour les lignes et colonnes de synthèse dans Excel pour le web.

Créer un plan de lignes ou de colonnes

Plan de lignes dans Excel Online

Plan des colonnes dans Excel Online

Plan de lignes dans Excel Online

  1. La première colonne contient des étiquettes.

  2. Les lignes de détail et les lignes de synthèse sont regroupées dans le plan.

  3. Le total global n'est pas regroupé dans le plan.

Plan des colonnes dans Excel Online

  1. La première ligne contient des étiquettes.

  2. Les colonnes de détail et les colonnes de synthèse sont regroupées dans le plan.

  3. Le total global n'est pas regroupé dans le plan.

  1. Assurez-vous que chaque colonne (ou ligne) des données à présenter en mode Plan est étiquetée dans la première ligne (ou colonne), contient des faits similaires dans chaque colonne (ou ligne) et que la plage ne contient aucune ligne ou colonne vide.

  2. Sélectionnez les données (y compris les lignes ou colonnes de synthèse).

  3. Sous l'onglet Données, dans le groupe Plan, cliquez sur Grouper > grouper les lignes ou les colonnes du groupe.

  4. Si vous souhaitez présenter un groupe imbrmbré interne en plan, vous pouvez sélectionner les lignes ou les colonnes dans la plage de données en plan et répéter l'étape 3.

  5. Continuez à sélectionner et à grouper les lignes ou colonnes internes jusqu'à avoir créé tous les niveaux que vous souhaitez dans le plan.

Dégrouper des lignes ou des colonnes

  • Pour dégrouper, sélectionnez les lignes ou les colonnes, puis sous l'onglet Données, dans le groupe Plan, cliquez sur Ungrouper, puis sélectionnez Ungroup Rows ou Ungroup Columns.

Afficher ou masquer des données affichées en mode plan

Effectuez au moins l’une des opérations suivantes :

Afficher ou masquer les données de détail pour un groupe    

  • Pour afficher les données de détail dans un groupe, cliquez sur la case plus du groupe, ou appuyez sur Alt+Shift+=.

  • Pour masquer les données de détail d'un groupe, cliquez sur la moins du groupe, ou appuyez sur Alt+Shift+-.

Développer ou réduire la totalité d’un plan à un niveau particulier    

  • Dans les un deux trois du plan, cliquez sur le numéro du niveau de votre souhaitez. Les données de détail des niveaux inférieurs sont alors masquées.

  • Par exemple, si un plan comporte quatre niveaux, vous pouvez masquer le quatrième niveau tout en affichant les autres niveaux, en cliquant sur trois.

Afficher ou masquer toutes les données de détail en mode plan    

  • Pour afficher toutes les données de détail, cliquez sur le niveau le plus bas dans les un deux trois du plan. Si, par exemple, il existe trois niveaux, cliquez sur trois.

  • Pour masquer toutes les données de détail, cliquez sur un.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel ou obtenir une assistance dans la communauté Answers.

Voir aussi

Regrouper ou dissocier des données dans un tableau croisé dynamique

Besoin d’aide ?

Développez vos compétences
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoindre Microsoft Insider

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la traduction ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions pour vos commentaires.

×