L’utilisation de formules dans des colonnes calculées dans des listes peut vous aider à ajouter des colonnes existantes, par exemple, au calcul de taxes sur un prix. Ces éléments peuvent être combinés pour valider des données par programme. Pour ajouter une colonne calculée, cliquez sur +ajouterune colonne, puis sélectionnez Autres. 

Remarque : Les champs calculés fonctionnent uniquement sur leur propre ligne. Vous ne pouvez donc pas faire référence à une valeur d’une autre ligne ou à des colonnes contenues dans une autre liste ou bibliothèque. Les champs De recherche ne sont pas pris en charge dans une formule et l’ID d’une ligne nouvellement insérée ne peut pas être utilisé, car l’ID n’existe pas lors du traitement de la formule.

Lors de la saisie de formules, sauf indication contraire, il n’y a pas d’espace entre les mots clés et les opérateurs. La liste suivante n’est pas exhaustive. Pour afficher toutes les formules, consultez la liste alphabétique à la fin de cet article.

Remarque : Les champs calculés fonctionnent uniquement sur leur propre ligne. Vous ne pouvez donc pas faire référence à une valeur d’une autre ligne ou à des colonnes contenues dans une autre liste ou bibliothèque. Les champs De recherche ne sont pas pris en charge dans une formule et l’ID d’une ligne nouvellement insérée ne peut pas être utilisé, car l’ID n’existe pas lors du traitement de la formule.

Sélectionnez un titre ci-dessous pour l’ouvrir et voir les instructions détaillées. 

Vous pouvez utiliser les formules suivantes pour tester la condition d’une instruction et renvoyer une valeur Oui ou Non, pour tester une valeur de remplacement telle que OK ou Pas OK, ou pour renvoyer une valeur vide ou un tiret pour représenter une valeur Null.

Vérifier si un nombre est supérieur ou inférieur à un autre

Utilisez la fonction SI pour effectuer cette comparaison.

Colonne1

Colonne2

Formule

Description (résultat possible)

15000

9 000

=[Colonne1]>[Colonne2]

Colonne1 est-elle supérieure à Colonne2 ? (Oui)

15000

9 000

=SI([Colonne1]<=[Colonne2], « OK », « Pas OK »)

Colonne1 est-elle inférieure ou égale à Colonne2 ? (Pas OK)

Renvoyer une valeur logique après comparaison du contenu des colonnes

Pour un résultat qui est une valeur logique (Oui ou Non), utilisez les fonctions ET,OUet NON.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 et inférieur à 8 ? (Non)

15

9

8

=OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3])

15 est-il supérieur à 9 ou inférieur à 8 ? (Oui)

15

9

8

=NON([Colonne1]+[Colonne2]=24)

15 plus 9 n’est-il pas égal à 24 ? (Non)

Pour un résultat qui est un autre calcul ou toute autre valeur autre que Oui ou Non, utilisez les fonctions SI, ETet OU.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat possible)

15

9

8

=SI([Colonne1]=15, « OK », « Pas OK »)

Si la valeur dans Colonne1 est égale à 15, renvoyer « OK ». (OK)

15

9

8

=SI(ET([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), « OK », « Pas OK »)

Si 15 est supérieur à 9 et inférieur à 8, renvoyer « OK ». (Pas OK)

15

9

8

=SI(OU([Colonne1]>[Colonne2], [Colonne1]<[Colonne3]), « OK », « Pas OK »)

Si 15 est supérieur à 9 ou inférieur à 8, renvoyer « OK ». (OK)

Afficher les zéros sous la mesure d’espaces ou de tirets

Pour afficher un zéro, effectuez un calcul simple. Pour afficher un vide ou un tiret, utilisez la fonction SI.

Colonne1

Colonne2

Formule

Description (résultat possible)

10

10

=[Colonne1]-[Colonne2]

Deuxième nombre soustrait du premier (0)

15

9

=SI([Colonne1]-[Colonne2], »-« ,[Colonne1]-[Colonne2])

Renvoie un tiret lorsque la valeur est zéro (-)

Masquer les valeurs d’erreur dans les colonnes

Pour afficher un tiret, #N/A ou NA à la place d’une valeur d’erreur, utilisez la fonction ESTERREUR.

Colonne1

Colonne2

Formule

Description (résultat possible)

10

0

=[Colonne1]/[Colonne2]

Entraîne une erreur (#DIV/0)

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]),"NA »,[Colonne1]/[Colonne2])

Renvoie NA lorsque la valeur est une erreur

10

0

=SI(ESTERREUR([Colonne1]/[Colonne2]), »-« ,[Colonne1]/[Colonne2])

renvoie un tiret lorsque la valeur est une erreur.

Vérifier la recherche de champs vides

Vous pouvez utiliser la formule ESTBLANK pour rechercher des champs vides.

Colonne1

Formule

Description (résultat possible)

« Jelly beans »

=ESTBLANK([Colonne1]

Renvoie Oui ou Non s’il est vide ou non.

« Steel »

=SI(ESTBLANK([Colonne1]), « Pas OK », « OK »)

Remplissez vos propres choix : d’abord s’il est vide, deuxième si ce n’est pas le cas

Pour plus d’informations sur les fonctions EST, voir les fonctions EST.

Vous pouvez utiliser les formules suivantes pour effectuer des calculs basés sur des dates et des heures, comme l’ajout d’un nombre de jours, de mois ou d’années à une date, le calcul de la différence entre deux dates et la conversion d’heures en valeur décimale.

Ajouter des dates

Pour ajouter un nombre de jours à une date, utilisez l’opérateur d’ajout (+).

Remarque : Lorsque vous manipulez des dates, le type de retour de la colonne calculée doit être réglé sur Date et heure.

Colonne1

Colonne2

Formule

Description (résultat)

6/9/2007

3

=[Colonne1]+[Colonne2]

Ajoute 3 jours au 09/06/2007 (12/06/2007)

12/10/2008

54

=[Colonne1]+[Colonne2]

Ajoute 54 jours au 10/12/2008 (02/02/2009)

Pour ajouter un nombre de mois à une date, utilisez les fonctions DATE,ANNÉE,MOISet JOUR.

Colonne1

Colonne2

Formule

Description (résultat)

6/9/2007

3

=DATE(ANNÉE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 3 mois au 09/06/2007 (09/09/2007)

12/10/2008

25

=DATE(ANNÉE([Colonne1]),MOIS([Colonne1])+[Colonne2],JOUR([Colonne1]))

Ajoute 25 mois au 10/12/2008 (10/01/2011)

Pour ajouter un nombre d’années à une date, utilisez les fonctions DATE,ANNÉE,MOISet JOUR.

Colonne1

Colonne2

Formule

Description (résultat)

6/9/2007

3

=DATE(ANNÉE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 3 ans au 09/06/2007 (09/06/2010)

12/10/2008

25

=DATE(ANNÉE([Colonne1])+[Colonne2],MOIS([Colonne1]),JOUR([Colonne1]))

Ajoute 25 ans au 10/12/2008 (10/12/2033)

Pour ajouter une combinaison de jours, de mois et d’années à une date, utilisez les fonctions DATE,ANNÉE,MOIS et JOUR.

Colonne1

Formule

Description (résultat)

6/9/2007

=DATE(ANNÉE([Colonne1])+3,MOIS([Colonne1])+1,JOUR([Colonne1])+5)

Ajoute 3 ans, 1 mois et 5 jours au 09/06/2007 (14/07/2010)

12/10/2008

=DATE(ANNÉE([Colonne1])+1,MOIS([Colonne1])+7,JOUR([Colonne1])+5)

Ajoute 1 an, 7 mois et 5 jours au 10/12/2008 (15/07/2010)

Calculer la différence entre deux dates

Utilisez la fonction DATEDIF pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"d »)

Renvoie le nombre de jours entre les deux dates (1626)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"ym »)

Renvoie le nombre de mois entre les dates, en ignorant la partie Année (5)

01-janv.-1995

15-juin-1999

=DATEDIF([Colonne1], [Colonne2],"yd »)

Renvoie le nombre de jours entre les dates, en ignorant la partie Année (165)

Calculer la différence entre deux heures

Pour présenter le résultat au format d’heure standard (heures:minutes:secondes), utilisez l’opérateur de soustraction (-) et la fonction TEXTE. Pour que cette méthode fonctionne, les heures ne doivent pas dépasser 24, et les minutes et les secondes ne doivent pas dépasser 60.

Colonne1

Colonne2

Formule

Description (résultat)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h »)

Heures entre deux heures (4)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm »)

Heures et minutes entre deux heures (4:55)

09/06/2007 10:35

09/06/2007 15:30

=TEXTE([Colonne2]-[Colonne1],"h:mm:ss »)

Heures, minutes et secondes entre deux heures (4:55:00)

Pour présenter le résultat dans un total basé sur une unité de temps, utilisez la fonction ENT, ou la fonction HEURE,MINUTEou SECONDE.

Colonne1

Colonne2

Formule

Description (résultat)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*24)

Nombre total d’heures entre deux heures (28)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*1440)

Nombre total de minutes entre deux heures (1 735)

09/06/2007 10:35

10/06/2007 15:30

=ENT(([Colonne2]-[Colonne1])*86400)

Nombre total de secondes entre deux heures (104 100)

09/06/2007 10:35

10/06/2007 15:30

=HEURE([Colonne2]-[Colonne1])

Heures entre deux heures, lorsque la différence n’excède pas 24 (4)

09/06/2007 10:35

10/06/2007 15:30

=MINUTE([Colonne2]-[Colonne1])

Minutes entre deux heures, lorsque la différence n’excède pas 60 (55)

09/06/2007 10:35

10/06/2007 15:30

=SECONDE([Colonne2]-[Colonne1])

Secondes entre deux heures, lorsque la différence n’excède pas 60 (0)

Convertir des heures

Pour convertir des heures du format d’heure standard en nombre décimal, utilisez la fonction ENT.

Colonne1

Formule

Description (résultat)

10:35

=([Colonne1]-ENT([Colonne1]))*24

Nombre d’heures depuis 00:00 (10,583333)

12:15

=([Colonne1]-ENT([Colonne1]))*24

Nombre d’heures depuis 00:00 (12,25)

Pour convertir des heures à partir d’un nombre décimal au format horaire standard (heures:minutes:secondes), utilisez l’opérateur de division et la fonction TEXTE.

Colonne1

Formule

Description (résultat)

23:58

=TEXTE(Colonne1/24, « hh:mm:ss »)

Heures, minutes et secondes depuis 00:00 (00:59:55)

2:06

=TEXTE(Colonne1/24, « h:mm »)

Heures et minutes depuis 00:00 (0:05)

Insérer des dates au julien

Une date au format julien fait référence à un format de date qui est une combinaison de l’année en cours et du nombre de jours écoulée depuis le début de l’année. Par exemple, le 1er janvier 2007 est représenté sous la 2007001 et le 31 décembre 2007 est représenté sous la 2007365. Ce format n’est pas basé sur le calendrier julien.

Pour convertir une date en date au julien, utilisez les fonctions TEXTE et DATEVAL.

Colonne1

Formule

Description (résultat)

6/23/2007

=TEXTE([Colonne1],"yy »)&TEXTE(([Colonne1]-DATEVAL(« 01/01/"& TEXTE([Colonne1],"yy »))+1),"000 »)

Date au format julien, avec une année à deux chiffres (07174)

6/23/2007

=TEXTE([Colonne1],"yyyy »)&TEXTE(([Colonne1]-DATEVAL(« 01/01/"&TEXTE([Colonne1],"yy »))+1),"000 »)

Date au format julien, avec une année à quatre chiffres (2007174)

Pour convertir une date en une date au julian qui est utilisée en astronomie, utilisez la constante 2415018,50. Cette formule ne fonctionne que pour les dates ultérieures au 03/01/1901 et si vous utilisez le calendrier depuis 1900.

Colonne1

Formule

Description (résultat)

6/23/2007

=[Colonne1]+2415018,50

Date au format julien, utilisée en astronomie (2454274,50)

Afficher les dates en tant que jour de la semaine

Pour convertir les dates en texte pour le jour de la semaine, utilisez les fonctions TEXTE et JOURS WEEKDAY.

Colonne1

Formule

Description (résultat possible)

19 février 2007

=TEXTE(JOURS OUVRABLE([Colonne1]), « dddd »)

Calcule le jour de la semaine pour la date et renvoie le nom complet du jour (lundi)

3-janv.-2008

=TEXTE(JOURS OUVRABLE([Colonne1]), « ddd »)

Calcule le jour de la semaine pour la date et renvoie le nom abrégé du jour (Lue)

Vous pouvez utiliser les formules suivantes pour effectuer diverses calculs mathématiques, tels que l’addition, la soustraction, la multiplication et la division de nombres, le calcul de la moyenne ou de la médiane des nombres, l’arrondi d’un nombre et le comptage de valeurs.

Ajouter des nombres

Pour additioner des nombres dans plusieurs colonnes d’une ligne, utilisez l’opérateur d’addition (+) ou la fonction SOMME.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

6

5

4

=[Colonne1]+[Colonne2]+[Colonne3]

Additione les valeurs des trois premières colonnes (15)

6

5

4

=SOMME([Colonne1],[Colonne2],[Colonne3])

Additione les valeurs des trois premières colonnes (15)

6

5

4

=SOMME(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si Colonne1 est supérieure à Colonne2, additione la différence et Colonne3. Sinon ajoute 10 et Colonne3 (5)

Soustraire des nombres

Pour soustraire des nombres dans plusieurs colonnes d’une ligne, utilisez l’opérateur de soustraction (-) ou la fonction SOMME avec des nombres négatifs.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

15000

9 000

-8000

=[Colonne1]-[Colonne2]

Soustrait 9 000 de 15 000 (6 000)

15000

9 000

-8000

=SOMME([Colonne1], [Colonne2], [Colonne3])

Additione les nombres des trois premières colonnes, y compris les valeurs négatives (16000)

Calculer la différence entre deux nombres sous la mesure d’un pourcentage

Utilisez les opérateurs de soustraction (-) et de division (/) et la fonction ABS.

Colonne1

Colonne2

Formule

Description (résultat)

2342

2500

=([Colonne2]-[Colonne1])/ABS([Colonne1])

Variation en pourcentage (6,75 % ou 0,06746)

Multiplier des nombres

Pour multiplier les nombres de plusieurs colonnes d’une ligne, utilisez l’opérateur de multiplication (*) ou la fonction PRODUIT.

Colonne1

Colonne2

Formule

Description (résultat)

5

2

=[Colonne1]*[Colonne2]

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1], [Colonne2])

Multiplie les nombres des deux premières colonnes (10)

5

2

=PRODUIT([Colonne1],[Colonne2],2)

Multiplie les nombres des deux premières colonnes et le nombre 2 (20)

Diviser des nombres

Pour diviser des nombres dans plusieurs colonnes d’une ligne, utilisez l’opérateur de division (/).

Colonne1

Colonne2

Formule

Description (résultat)

15000

12

=[Colonne1]/[Colonne2]

Divise 15 000 par 12 (1250)

15000

12

=([Colonne1]+10000)/[Colonne2]

Ajoute 15000 et 10000, puis divise le total par 12 (2083)

Calculer la moyenne des nombres

La moyenne est également appelée moyenne. Pour calculer la moyenne des nombres de plusieurs colonnes d’une ligne, utilisez la fonction MOYENNE.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

6

5

4

=MOYENNE([Colonne1], [Colonne2],[Colonne3])

Moyenne des nombres des trois premières colonnes (5)

6

5

4

=MOYENNE(SI([Colonne1]>[Colonne2], [Colonne1]-[Colonne2], 10), [Colonne3])

Si Colonne1 est supérieure à Colonne2, calcule la moyenne de la différence et Colonne3. Sinon calcule la moyenne de la valeur 10 et Colonne3 (2,5).

Calculer la médiane de nombres

La médiane est la valeur au centre d’une plage de nombres ordonné. Utilisez la fonction MEDIAN pour calculer la médiane d’un groupe de nombres.

A

B

C

D

E

F

Formule

Description (résultat)

10

7

9

27

0

4

=MÉDIANE(A, B, C, D, E, F)

Médiane des nombres des 6 premières colonnes (8)

Calculer le plus petit ou le plus grand nombre d’une plage

Pour calculer le plus petit ou le plus grand nombre de deux colonnes ou plus d’une ligne, utilisez les fonctions MIN et MAX.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

10

7

9

=MIN([Colonne1], [Colonne2], [Colonne3])

Plus petit nombre (7)

10

7

9

=MAX([Colonne1], [Colonne2], [Colonne3])

Plus grand nombre (10)

Compter des valeurs

Pour compter des valeurs numériques, utilisez la fonction COMPTE.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

Pomme

12/12/2007

=COMPTE([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques. Exclut les valeurs de date et heure, texte et Null (0).

12 $

#DIV/0!

1.01

=COMPTE([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes qui contiennent des valeurs numériques, mais exclut les valeurs d’erreur et les valeurs logiques (2).

Augmenter ou diminuer un nombre selon un pourcentage

Utilisez l’opérateur de pourcentage (%) pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat)

23

3%

=[Colonne1]*(1+5 %)

Augmente le nombre dans Colonne1 de 5 % (24,15)

23

3%

=[Colonne1]*(1+[Colonne2])

Augmente le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3 % (23,69)

23

3%

=[Colonne1]*(1-[Colonne2])

Diminue le nombre dans Colonne1 de la valeur en pour cent dans Colonne2 : 3 % (22,31)

Élever un nombre à une puissance

Utilisez l’opérateur d’exposant (^) ou la fonction PUISSANCE pour effectuer ce calcul.

Colonne1

Colonne2

Formule

Description (résultat)

5

2

=[Colonne1]^[Colonne2]

Calcule cinq au carré (25)

5

3

=PUISSANCE([Colonne1], [Colonne2])

Calcule cinq au cube (125)

Arrondir un nombre

Pour arrondir un nombre, utilisez la fonction ARRONDI.UP,IMPAIRou PAIR.

Colonne1

Formule

Description (résultat)

20.3

=ARRONDI.UP([Colonne1],0)

Arrondit 20,3 au nombre entier le plus proche (21)

-5.9

=ARRONDI.UP([Colonne1],0)

Arrondit -5,9 au nombre entier le plus proche (-5)

12.5493

=ARRONDI.UP([Colonne1],2)

Arrondit 12,5493 au centième le plus proche, à deux décimales (12,55)

20.3

=EVEN([Colonne1])

Arrondit 20,3 au nombre even le plus proche (22)

20.3

=IMPAIR([Colonne1])

Arrondit 20,3 au nombre impair le plus proche (21)

Pour arrondir un nombre à la base, utilisez la fonction ARRONDI.INT.INT.

Colonne1

Formule

Description (résultat)

20.3

=ARRONDI.INT.INS([Colonne1],0)

Arrondit 20,3 au nombre entier le plus proche (20)

-5.9

=ARRONDI.INT.INS([Colonne1],0)

Arrondit -5,9 au nombre entier le plus proche (-6)

12.5493

=ARRONDI.INT.INS([Colonne1],2)

Arrondit 12,5493 au centième le plus proche, à deux décimales (12,54)

Pour arrondir un nombre au nombre ou à la fraction le plus proche, utilisez la fonction ARRONDI.

Colonne1

Formule

Description (résultat)

20.3

=ARRONDI([Colonne1],0)

Arrondit 20,3 au nombre inférieur, car la partie fractionnaire est inférieure à 0,5 (20)

5.9

=ARRONDI([Colonne1],0)

Arrondit 5,9 au nombre supérieur, car la partie fractionnaire est supérieure à 0,5 (6).

-5.9

=ARRONDI([Colonne1],0)

Arrondit -5,9 au nombre inférieur, car la partie fractionnaire est inférieure à -0,5 (-6)

1.25

=ARRONDI([Colonne1], 1)

Arrondit le nombre au dixième le plus proche (une décimale). Étant donné que la partie à arrondir est supérieure ou égale à 0,05, le nombre est arrondi au nombre supérieur (résultat : 1,3)

30.452

=ARRONDI([Colonne1], 2)

Arrondit le nombre au centième le plus proche (deux décimales). Étant donné que la partie à arrondir, 0,002, est inférieure à 0,005, le nombre est arrondi au nombre inférieur (résultat : 30,45)

Pour arrondir un nombre au chiffre significatif supérieur à 0, utilisez les fonctions ARRONDI,ARRONDI.INT, INTet LEN.

Colonne1

Formule

Description (résultat)

5492820

=ARRONDI([Colonne1],3-LEN(ENT([Colonne1])))

Arrondit le nombre à 3 chiffres significatifs (5490000)

22230

=ARRONDI.INT([Colonne1],3-LEN(ENT([Colonne1])))

Arrondit au nombre inférieur à 3 chiffres significatifs (22200)

5492820

=ARRONDI.UP([Colonne1], 5-LEN(ENT([Colonne1])))

Arrondit au nombre supérieur à 5 chiffres significatifs (5492900)

Vous pouvez utiliser les formules suivantes pour manipuler le texte, notamment combiner ou concatener les valeurs de plusieurs colonnes, comparer le contenu de colonnes, supprimer des caractères ou des espaces et des caractères extenseurs.

Modifier la case du texte

Pour modifier la cas du texte, utilisez les fonctionsUPPER, LOWERou PROPER.

Colonne1

Formule

Description (résultat)

nina Vietzen

=UPPER([Colonne1])

Change le texte en minuscules (NINA VIETZEN)

nina Vietzen

=LOWER([Colonne1])

Change le texte en minuscules (nina vietzen)

nina Vietzen

=PROPER([Colonne1])

Change le texte en cas de titre (Nina Vietzen)

Combiner les prénoms et les noms

Pour combiner le prénom et le nom, utilisez l’opérateur « etande » (&) ou la fonction CONCATENER.

Colonne1

Colonne2

Formule

Description (résultat)

Carlos

Carvallo

=[Colonne1]&[Colonne2]

Combine les deux chaînes (CarlosCarvallo)

Carlos

Carvallo

=[Colonne1]& » « &[Colonne2]

Combine les deux chaînes, séparées par un espace (Carvallo Carlos)

Carlos

Carvallo

=[Colonne2]& », « &[Colonne1]

Combine les deux chaînes, séparées par une virgule et un espace (Carvallo, Carlos)

Carlos

Carvallo

=CONCATENER([Colonne2], « , », [Colonne1])

Combine les deux chaînes, séparées par une virgule (Carvallo,Carlos)

Combiner du texte et des nombres de différentes colonnes

Pour combiner du texte et des nombres, utilisez la fonction CONCATENER, l’opérateur « etande » (&), ou la fonction TEXTE et l’opérateur « et ».

Colonne1

Colonne2

Formule

Description (résultat)

Yang

28

=[Colonne1]& » a vendu « &[Colonne2]& » unités. »

Combine le contenu en une phrase (Yang a vendu 28 unités.)

Dubois

40%

=[Colonne1]& » a vendu « &TEXTE([Colonne2],"0% »)& » des ventes totales. »

Combine le contenu en une phrase (Dubois a vendu 40 % des ventes totales.)

Remarque : La fonction TEXTE ajoute la valeur mise en forme de Colonne2 au lieu de la valeur sous-jacente, 0,4.

Yang

28

=CONCATENER([Colonne1], » a vendu « ,[Colonne2], » unités. »)

Combine le contenu en une phrase (Yang a vendu 28 unités.)

Combiner du texte avec une date ou une heure

Pour combiner du texte avec une date ou une heure, utilisez la fonction TEXTE et l’opérateur « etande » (&).

Colonne1

Colonne2

Formule

Description (résultat)

Date de facturation

5-juin-2007

="Date déclaration : « &TEXTE([Colonne2], « d-mmm-yyyy »)

Combine du texte avec une date (date déclaration : 5-juin-2007)

Date de facturation

5-juin-2007

=[Colonne1]& » « &TEXTE([Colonne2], « mmm-dd-yyyy »)

Combine le texte et la date de différentes colonnes en une seule colonne (Date de facturation 5-juin-2007)

Comparer le contenu des colonnes

Pour comparer une colonne à une autre colonne ou une liste de valeurs, utilisez les fonctions EXACTet OU.

Colonne1

Colonne2

Formule

Description (résultat possible)

BD122

BD123

=EXACT([Colonne1],[Colonne2])

Compare le contenu des deux premières colonnes (Non)

BD122

BD123

=EXACT([Colonne1], « BD122 »)

Compare le contenu de Colonne1 et la chaîne « BD122 » (Oui)

Vérifier si une valeur de colonne ou une partie de cette dernière correspond à un texte spécifique

Pour vérifier si une valeur de colonne ou une partie de cette valeur correspond à un texte spécifique, utilisez les fonctions SI,TROUVE,CHERCHE et ESTNUMBER.

Colonne1

Formule

Description (résultat possible)

Vietzen

=SI([Colonne1]="Vietzen », « OK », « Pas OK »)

Vérifie si Colonne1 est Vietzen (OK)

Vietzen

=SI(ESTNOMBRE(TROUVE(« v »,[Colonne1])), « OK », « Pas OK »)

Vérifie si Colonne1 contient la lettre v (OK)

BD123

=ESTNOMBRE(TROUVE(« BD »,[Colonne1]))

Vérifie si Colonne1 contient BD (Oui)

Compter les colonnes non blanches

Pour compter les colonnes non blanches, utilisez la fonction COUNTA.

Colonne1

Colonne2

Colonne3

Formule

Description (résultat)

Ventes

19

=COUNTA([Colonne1], [Colonne2])

Compte le nombre de colonnes non blanches (2).

Ventes

19

=COUNTA([Colonne1], [Colonne2], [Colonne3])

Compte le nombre de colonnes non blanches (2).

Supprimer des caractères du texte

Pour supprimer des caractères du texte, utilisez les fonctions LEN,GAUCHEet DROITE.

Colonne1

Formule

Description (résultat)

Vitamine A

=GAUCHE([Colonne1],LEN([Colonne1])-2)

Renvoie 7 caractères (9-2), en commençant par la gauche (Vitamine)

Vitamine B1

=DROITE([Colonne1], LEN([Colonne1])-8)

Renvoie 2 caractères (10-8), en commençant par la droite (B1)

Supprimer les espaces au début et à la fin d’une colonne

Pour supprimer les espaces d’une colonne, utilisez la fonction TRIM.

Colonne1

Formule

Description (résultat)

 Bonjour!

=TRIM([Colonne1])

Supprime les espaces de début et de fin (Bonjour !)

Répéter un caractère dans une colonne

Pour répéter un caractère dans une colonne, utilisez la fonction REPT.

Formule

Description (résultat)

=REPT(« . »;3)

Répète un point 3 fois (...)

=REPT(« -« ;10)

Répète un tiret 10 fois (----------)

Liste alphabétique des fonctions

Voici une liste alphabétique des liens vers les fonctions disponibles pour SharePoint utilisateurs. Il inclut des fonctions trigonométriques, statistiques et financières, ainsi que des formules conditionnelles, mathématiques, de date et de texte.

ABS

ACOS

ACOSH

ET (ET, fonction)

ASIN

ASINH

ATAN

ATAN2

MOYENNE

AVERAGEA

BETA.N

TAINV

SI.BINOMI PEUT ÊTRE

PLAFOND

CAR

FONCTION.CHID

CHOISIR

CODE

FONCTION CONCATENER

CONFIDENCE

COS (COS, fonction)

COUNT

FONCTION.COUNTA

CRITBINOMIE

DATE

Fonction DATEDIF

DATEVAL (DATEVAL, fonction)

JOUR (JOUR, fonction)

JOURS360

DDB

DED (DED, fonction)

DEVISE (DEVISE, fonction)

EVEN

EXACT

FONCTION.EXPO.N

FACT

F.F

TROUVE

FONCTION.FIN.N

FISHER

CTXT (CTX

FONCTION.GAMMA

GAMMA.V (GAMMA.V, fonction)

L GAMMA.LN (L GAMMA,N, fonction)

GEOMEAN (GEOMEAN, fonction)

HARMEAN

HEURE (HEURE, fonction)

LA FONCTIONGEOMEOMENE

Fonction SI

ENT

IPmt, fonction

EST

GAUCHE

FONCTION.NEN

LN

Log, fonction

LOG10

LOGINV

FONCTION.LOGNORNORME

LOWER

MAX

Me, fonction

MEDIAN

MID

MIN

MINA

MINUTE

MOD

MOIS

NEGINOGIST

FONCTION.NORMALE

FONCTION.NORMALE.STANDARD

NORMAL.STANDARD.STANDARD.N

FONCTION NON

NPER

VAN

IMPAIR

OU (OU, fonction)

PMT

PUISSANCE

PPMT

PRODUIT (PRODUIT, fonction)

PROPER

VA (VA, fonction)

RADIANS

REMPLACER

REPT

DROITE

ARRONDI

ARRONDI.INT.INT.

ARRONDI.UP

CHERCHE

SECONDE

SIGNE

SIN

SINH

RT

NORMALISER

STDEVA

STDEVP

STDEVPA

Fonction SUM

SOMME.SOMME.Q

SYD (SYD, fonction)

TANH

EST.N

TEXTE (TEXTE, fonction)

TEMPS (TEMPS, fonction)

TINV

AUJOURD’HUI (AUJOURD’HUI,

TRIM

VRAI (VRAI, fonction)

UPPER

USDO CE(S)

C VALUE

VAR

VARA

VAR.P

VARPA

Fonction Weekday

WEIBULL

ANNÉE (ANNÉE, fonction)

Autres ressources

Si vous ne voyez pas ce que vous essayez de faire ici, essayez de le faire dans Excel. Voici quelques autres sources. Certains d’entre eux peuvent couvrir des versions antérieures, il peut donc y avoir des différences dans l’interface utilisateur affichée. Par exemple, les éléments du menu Actions du siteSharePoint sont désormais dans le menu Paramètres Office 365 de setttings - ressemble à un engrenage en regard de votre nom site.

Besoin d’aide ?

Développez vos compétences

Découvrez des formations >

Accédez aux nouvelles fonctionnalités en avant-première

Rejoindre Microsoft Insider >

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?

Nous vous remercions de vos commentaires.

×