VALEURCHAMP (fonction)

Vous pouvez utiliser la fonction VALEUR CHAMP pour extraire des données de champs à partir de types de données liés tels que les types de données Titres boursiers ou Géographie. Il existe des méthodes plus faciles pour écrire des formulesqui font référence à des types de données. Par ailleurs, la fonction VALEUR CHAMP DOIT être utilisée principalement pour créer des calculs conditionnels basés sur des types de données liés.

Remarque : 28 mars 2019 : Les types de données ont été publiés pour tous les abonnés à Windows Microsoft 365. Si vous êtes abonné à Microsoft 365, vérifiez que vous utilisez la dernière version d’Office.

Détails techniques

Syntaxe

=VALEURCHAMP(valeur, nom_champ)

La syntaxe de la fonction VALEURCHAMP contient les arguments suivants :

Argument

Description

valeur

La fonction renvoie tous les champs correspondants à partir du type de données lié spécifié dans l’argument valeur.

nom_champ

Nom du ou des champs que vous voulez extraire du type de données lié.

Description

Exemples

Dans l’exemple de base suivant, la formule =VALEURCHAMP(A2,"Prix") extrait le champ Prix à partir du type de données Titres boursiers pour JM Smucker Co.

Récupérer le prix de l’action d’une société avec =VALEURCHAMP(A2,"Prix")

L’exemple suivant est un exemple plus classique de la fonction VALEUR CHAMP. Nous utilisons la fonction SIERREUR pour vérifier la recherche d’erreurs. Si la cellule A2 ne contient pas de nom de société, la formule VALEUR CHAMP renvoie une erreur et, dans ce cas, nous voulons ne rien afficher («  »). En cas de nom de société, vous souhaitez récupérer le Prix à partir du type de données dans A2 avec =SIERREUR(VALEUR CHAMP($A 2;B$1);" »).

Récupérer le prix de l’action d’une société et ignorer les erreurs avec =SIERREUR(VALEURCHAMP($A2,B$1),"")

Notez que la fonction VALEURCHAMP vous permet de faire référence à des cellules de feuille de calcul pour l’argument nom_champ. La formule ci-dessus fait ainsi référence à la cellule B1 pour le prix, ce qui évite d’entrer manuellement « Prix » dans la formule.  

Remarques

Si vous essayez d’extraire des données à partir d’un champ de type de données inexistant, la fonction VALEURVAL retourne l’erreur #FIELD!. Par exemple, vous avez peut-être entré « Prix », lorsque le champ du type de données réel est nommé « Prix ». Vérifiez que votre formule utilise un nom de champ valide. Si vous voulez afficher une liste de noms de champs pour un enregistrement, sélectionnez la cellule de l’enregistrement, puis appuyez sur Alt+Shift+F10.

Vous avez besoin d’une aide supplémentaire ?

Vous pouvez toujours consulter un expert de la communauté technique Excel, obtenir une assistance dans la communauté Answers ou suggérer une nouvelle fonctionnalité ou une amélioration sur le forum Excel User Voice.

Voir aussi

Types de données Titres boursiers et Géographie

Rédaction de formules faisant référence à des types de données

Erreur #CHAMP! erreur

Besoin d’aide ?

Développez vos compétences dans Office
Découvrez des formations
Accédez aux nouvelles fonctionnalités en avant-première
Rejoignez le programme Office Insider

Ces informations vous ont-elles été utiles ?

Nous vous remercions pour vos commentaires.

Merci pour vos commentaires. Il serait vraisemblablement utile pour vous de contacter l’un de nos agents du support Office.

×