KB2645648 - CORRECTIF : échec de la procédure d’exportation lors de l’exportation d’un rapport SSRS 2008 R2 64 bits, d’un rapport SSRS 2012 ou d’un rapport SSRS 2008 qui contient plusieurs niveaux d’une correspondance de document au format PDF

S’applique à
SQL Server 2012 Developer SQL Server 2012 Enterprise SQL Server 2012 Express SQL Server 2012 Standard SQL Server 2012 Web SQL Server 2012 Enterprise Core

Microsoft distribue les correctifs Microsoft SQL Server 2008 R2 Service Pack 1 (SP1) ou Microsoft SQL Server 2008 dans un fichier téléchargeable. Étant donné que les correctifs sont cumulatifs, chaque nouvelle version contient tous les correctifs logiciels et toutes les mises à jour de sécurité inclus dans la précédente mise à jour de SQL Server 2008 R2 Service Pack 1 (SP1) ou SQL Server 2008.

Symptômes

Prenons le scénario suivant :

  • Vous avez un rapport dans une instance 64 bits de Microsoft SQL Server 2008 R2 Reporting Services (SSRS 2008 R2), dans une instance de Microsoft SQL Server 2008 Reporting Services (SSRS 2008) ou dans une instance de Microsoft SQL Server 2012 Reporting Services (SSRS 2012) : instance.
  • Le rapport contient plusieurs niveaux d’un explorateur de documents.
  • Vous essayez d’exporter le rapport au format PDF.

Dans ce scénario, la procédure d’exportation échoue et vous recevez le message d’erreur suivant :

Remarque

Le serveur distant a renvoyé une erreur : (500) Erreur de serveur interne.

En outre, l’erreur suivante est consignée dans le fichier journal SSRS :

Remarque

rshost !rshost !bb8 !<Date><Heure> :: e ERREUR : Échec du traitement de la demande 0x80131014, pipeline=0x0000000002B99080.
Interface utilisateur ! ReportManager_0-84 !ee8 !<Date><et heure> :: Non géré Exception : Microsoft.Reporting.WebForms.ReportServerException : Le serveur distant a retourné une erreur : (500) Erreur interne au serveur. >--- System.Net.WebException : Le serveur distant a retourné une erreur : (500) Erreur de serveur interne.

        
Notes

  • Vous pouvez toujours restituer le rapport au format HTML avec succès.
  • Ce problème ne se produit pas si SSRS 2008 R2 est installé sur un ordinateur qui exécute un système d’exploitation 32 bits.

Cause

Ce problème est dû à une limitation du moteur de rendu PDF SSRS.

Résolution

Informations sur les mises à jour cumulatives

Package de mise à jour cumulative 1 pour SQL Server 2012 Service Pack 1

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 1. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2012 Service Pack 1, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2765331 Package de mise à jour cumulative 1 pour SQL Server 2012 Service Pack 1Remarque Comme les versions sont cumulatives, chaque nouvelle version contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2772858 Builds de SQL Server 2012 publiées après SQL Server 2012 Service Pack 1

SQL Server 2012

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 3 pour SQL Server 2012. Pour plus d’informations sur ce package de mise à jour cumulative, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2723749 Package de mise à jour cumulative 3 pour SQL Server 2012Remarque Étant donné que les builds sont cumulatives, chaque nouvelle version de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2012. Microsoft vous recommande d’envisager d’appliquer la publication de correctif la plus récente qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2692828 Les builds SQL Server 2012 publiées après la sortie de SQL Server 2012 Vous devez appliquer un correctif SQL Server 2012 à une installation de SQL Server 2012.

SQL Server 2008 Service Pack 3

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 6 pour SQL Server 2008 Service Pack 3. Pour plus d’informations sur ce package de mise à jour cumulative, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2715953 Package de mise à jour cumulative 6 pour SQL Server 2008 Service Pack 3Note Comme les builds sont cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2008. Microsoft vous recommande d’envisager d’appliquer la publication de correctif la plus récente qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2629969 Les versions de SQL Server 2008 publiées après SQL Server Service Pack 3 de Microsoft SQL Server 2008 sont créées pour des Service Packs SQL Server spécifiques. Vous devez appliquer un correctif logiciel de SQL Server 2008 Service Pack 3 à une installation de SQL Server 2008 Service Pack 3. Par défaut, tout correctif logiciel fourni dans un Service Pack SQL Server est inclus dans le Service Pack SQL Server suivant.

SQL Server 2008 Service Pack 2

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 8 pour SQL Server 2008 Service Pack 2. Pour plus d’informations sur ce package de mise à jour cumulative, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2648096 Package de mise à jour cumulative 8 pour SQL Server 2008 Service Pack 2Note Comme les builds sont cumulatives, chaque nouvelle version de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2008. Microsoft vous recommande d’envisager d’appliquer la publication de correctif la plus récente qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2402659 Les versions de SQL Server 2008 publiées après SQL Server Service Pack 2 de Microsoft SQL Server 2008 ont été créées pour des Service Packs spécifiques SQL Server. Vous devez appliquer un correctif logiciel de SQL Server 2008 Service Pack 2 à une installation de SQL Server 2008 Service Pack 2. Par défaut, tout correctif logiciel fourni dans un Service Pack SQL Server est inclus dans le Service Pack SQL Server suivant.

Package de mise à jour cumulative 4 pour SQL Server 2008 R2 SP1

Le correctif pour résoudre ce problème a été publié pour la première fois dans la mise à jour cumulative 4. Pour plus d’informations sur la procédure d’obtention de ce package de mise à jour cumulative pour SQL Server 2008 R2 SP1, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.

2633146 Package de mise à jour cumulative 4 pour SQL Server 2008 R2 SP1Remarque : les builds étant cumulatives, chaque nouvelle publication de correctif contient tous les correctifs logiciels et tous les correctifs de sécurité inclus dans la version précédente du correctif SQL Server 2008 R2 SP1. Nous vous recommandons d’envisager d’appliquer la version la plus récente du correctif qui contient ce correctif. Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :

2567616 Builds SQL Server 2008 R2 publiées après la publication de SQL Server 2008 R2 SP1

Solution de contournement

Pour contourner ce problème, utilisez moins de niveaux d’explorateurs de documents.

État

Microsoft a confirmé qu’il s’agissait d’un problème dans les produits Microsoft répertoriés dans la section « S’applique à ».