INTRODUCTION
Cet article décrit le package de mise à jour cumulative 4 pour Microsoft SQL Server 2008 R2 Service Pack 1 (SP1). Cette mise à jour contient des correctifs logiciels pour des problèmes résolus après la publication de SQL Server 2008 R2 SP1.
Remarque La version de ce package de mise à jour cumulative est appelée build 10.50.2796.0.
Nous vous recommandons de tester les correctifs logiciels avant de les déployer dans un environnement de production. Étant donné que les builds sont cumulatives, chaque nouvelle publication de mise à jour contient tous les correctifs logiciels et toutes les mises à jour de sécurité qui ont été inclus dans la version précédente de la mise à jour de SQL Server 2008 R2. Nous vous recommandons d’envisager d’appliquer la mise à jour la plus récente qui contient ce correctif.
Pour plus d’informations, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
2567616 Builds de SQL Server 2008 R2 publiées après SQL Server 2008 R2 Service Pack 1
Remarques importantes sur ce package de mise à jour cumulative
- Les correctifs logiciels contenus dans ce package de mise à jour cumulative sont inclus dans SQL Server 2008 R2 Service Pack 2 (SP2).
- Les correctifs logiciels de SQL Server 2008 sont désormais multilingues. Par conséquent, le package de mise à jour cumulative ne s’applique pas à une seule langue et s’applique à toutes les langues prises en charge.
- Un package de mise à jour cumulative contient tous les packages des composants. Toutefois, le package de mise à jour cumulative ne met à jour que les composants installés sur le système.
Informations supplémentaires
Comment obtenir ce package de mise à jour cumulative
Un package de mise à jour cumulative pris en charge est désormais disponible auprès de Microsoft. Toutefois, elle est destinée à corriger uniquement les problèmes décrits dans cet article. Appliquez-le uniquement aux systèmes qui rencontrent ces problèmes spécifiques. Ce package de mise à jour cumulative peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par l’un de ces problèmes, nous vous recommandons d’attendre le prochain Service Pack SQL Server 2008 R2 qui contiendra les correctifs logiciels contenus dans ce package de mise à jour cumulative.
Si la mise à jour cumulative est disponible en téléchargement, une section « Téléchargement de correctif logiciel disponible » figure en haut du présent article de la Base de connaissances. Si cette section est absente, procurez-vous le package de mise à jour cumulative auprès des services de Support technique Microsoft.
Remarque Si des problèmes supplémentaires surviennent ou si des procédures de dépannage sont nécessaires, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes non directement liés à ce package de mise à jour cumulative. Pour obtenir la liste complète des numéros de téléphone des services d’assistance technique Microsoft ou pour créer une demande de service distincte, reportez-vous au site web de Microsoft à l’adresse suivante :
Correctifs logiciels inclus dans ce package de mise à jour cumulative
Les articles de la Base de connaissances Microsoft qui traitent de ces correctifs logiciels seront publiés dès qu’ils seront disponibles.
Pour plus d’informations sur les problèmes liés à SQL Server, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
| Numéro de bogue VSTS | Numéro d’article de la Base de connaissances | Description |
|---|---|---|
| 834628 | 955850 | Message d’erreur lorsque vous essayez d’utiliser les fichiers binaires du package SQL Server System CLR Types (SQLSysClrTypes.msi) : « Impossible de charger la DLL 'SqlServerSpatial.dll' : Cette application n’a pas pu démarrer car la configuration de l’application est incorrecte » |
| 765507 | 970198 | CORRECTIF : Vous recevez un résultat incorrect lorsque vous exécutez une requête qui utilise la fonction row_number dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 843693 | 2159286 | CORRECTIF : le service de Registre distant se bloque lorsqu’une application essaie de récupérer des données de compteur de performances à partir d’une instance de SQL Server sur un autre ordinateur |
| 826730 | 2445812 | CORRECTIF : une colonne qui utilise le type de données DATETIME ne se réplique pas sur un abonné Oracle à l’aide d’une réplication transactionnelle dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 783498 | 2510788 | CORRECTIF : Un message de réussite est incorrectement enregistré lors de l’abandon d’une transaction distribuée d’un package SSIS 2005, SSIS 2008 ou SSIS 2008 R2. |
| 799308 | 2515286 | CORRECTIF : « Il n’existe aucune fonction '{urn :schemas-microsoft-com :xml-sql} :variable() » pour une requête XQuery qui met à jour la valeur d’une colonne XML dans SQL Server 2005, dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 818397 | 2550375 | CORRECTIF : Un blocage peut se produire dans sys.dm_database_encryption_keys DMV dans SQL Server 2008 R2 lorsque vous exécutez la copie des journaux de transaction à partir de nombreuses bases de données vers un serveur secondaire |
| 738050 | 2562753 | CORRECTIF : Performances ralenties lorsqu’une requête MDX utilise des opérateurs unaires sur les membres de la hiérarchie parent/enfant dans SSAS 2008 R2 si vous définissez un calcul d’étendue sur ces membres et si la requête accède à plusieurs dates dans une dimension temporelle |
| 818842 | 2567366 | CORRECTIF : Performances ralenties lors de la restauration d’une base de données dans SQL Server 2008 R2 si CDC est activé |
| 818849 | 2580224 | CORRECTIF : résultats incorrects lorsque vous validez la transformation Unpivot dans un package SSIS dans SSIS 2008 ou dans SSIS 2008 R2 |
| 799296 | 2583994 | CORRECTIF : le point de contrôle SSIS restaure une valeur de variable incorrecte pour un élément de tâche Execute SQL d’un élément de conteneur For Loop dans SSIS 2008 ou SSIS 2008 R2 si un package SSIS s’exécute à nouveau après son échec ou son arrêt |
| 818843 | 2588506 | CORRECTIF : la fonction SQLGetDiagRec ne renvoie pas d’erreurs dans SQL Server 2008 ou SQL Server 2008 R2 si plus de 2 100 paramètres de requête sont envoyés |
| 799325 | 2588970 | CORRECTIF : erreur « Serveur : Msg 7359 » lorsque vous exécutez une requête distribuée dans SQL Server 2008 ou dans SQL Server 2008 R2 si une version du schéma est mise à jour plus de cinq fois |
| 799293 | 2591461 | CORRECTIF : erreur « Erreur inattendue de l’interface SE OLEDB » lors de l’exécution d’une requête de recherche en texte intégral dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 818848 | 2597229 | CORRECTIF : Report Builder 3.0 cesse de répondre si SSRS 2008 R2 utilise l’authentification par formulaires |
| 799305 | 2598903 | CORRECTIF : la tâche de l’SQL Server Agent s’arrête de façon aléatoire lorsque vous planifiez l’exécution de la tâche après minuit à certains jours dans SQL Server 2005, dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 829282 | 2603910 | CORRECTIF : la sauvegarde échoue dans SQL Server 2008 ou dans SQL Server 2008 R2 si vous activez le suivi des modifications sur la base de données |
| 799312 | 2606301 | CORRECTIF : utilisation élevée de la mémoire lors de l’exécution de l’agent d’instantané de réplication dans SQL Server 2008 ou SQL Server 2008 R2 |
| 791492 | 2606918 | CORRECTIF : valeur NULL dans la colonne Rétention de la table sysmergepublications et effets sur le processus de nettoyage des métadonnées lorsque vous configurez un environnement de réplication de fusion dans une topologie de republication dans SQL Server 2008 R2 |
| 818853 | 2616117 | CORRECTIF : un profil de courrier incorrect s’affiche dans la page Système d’alerte dans SQL Server 2008 R2 |
| 798464 | 2616718 | CORRECTIF : Performances médiocres lorsque vous synchronisez les données d’un éditeur SQL Server 2008 R2 vers un abonné SQL Server compact 3.5 |
| 834621 | 2618676 | CORRECTIF : la sauvegarde du journal des transactions est créée même si la sauvegarde complète est annulée dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 834618 | 2618680 | CORRECTIF : erreur « Non enregistré correctement » lorsque vous utilisez un abonnement par extraction et le résolveur de conflits interactif de réplication |
| 805159 | 2620762 | CORRECTIF : les messages d’accusé de réception ne sont pas envoyés par une cible Service Broker SQL Server 2008 R2 |
| 807413 | 2622668 | CORRECTION : Message d’erreur lors de la suppression de certains enregistrements d’une table sur l’éditeur si le nom de schéma de la table n’est pas [dbo] |
| 818851, 818852 | 2622823 | CORRECTIF : ghost_record_count valeurs continuent d’augmenter dans SQL Server 2008 R2 |
| 809033 | 2624272 | CORRECTIF : Erreur 9013 lorsque vous essayez de démarrer les services SQL Server après avoir appliqué SQL Server 2008 R2 SP1 pour SQL Server 2008 R2 |
| 818844 | 2624527 | CORRECTIF : l’index cluster n’est pas utilisé dans le plan d’exécution dans SQL Server 2008 R2 si une requête utilise deux partitions ou plus |
| 812723 | 2626637 | CORRECTIF : l’instruction DRILLTHROUGH ne fonctionne pas si elle est exécutée sur certains membres d’attribut dont les valeurs contiennent un ou plusieurs guillemets doubles dans SSAS 2008 R2 |
| 834637 | 2628126 | CORRECTIF : erreur « Erreur d’index de texte intégral pendant la compression ou la décompression » lors de la création d’un index de recherche en texte intégral dans SQL Server 2008 ou dans SQL Server 2008 R2 si la clé primaire est définie sur une colonne BIGINT |
| 815917 | 2628712 | CORRECTIF : une boucle infinie se produit dans une hiérarchie qui contient une relation circulaire dans SQL Server 2008 R2 |
| 804578 | 2629168 | CORRECTIF : erreur interne lors de la mise à jour d’un jeu de cellules renvoyé après l’exécution d’une requête sur une perspective dans SSAS 2008 R2 |
| 817160 | 2629456 | CORRECTIF : violation d’accès lorsque vous insérez un enregistrement dans une nouvelle partition vide dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 816667 | 2632021 | CORRECTIF : Un rapport SSRS 2008 R2 contenant des éléments bascules n’est pas paginé |
| 821110 | 2633271 | CORRECTIF : Impossible d’arrêter les services SQL Server sur un ordinateur sur lequel SQL Server 2008 R2 Express Edition est installé |
| 822390 | 2634571 | Les améliorations apportées à la commande DBCC CHECKDB peuvent entraîner des performances plus rapides lorsque vous utilisez l’option PHYSICAL_ONLY |
| 834649 | 2635827 | CORRECTIF : violation d’accès lorsque vous exécutez une commande DBCC CHECKDB sur une base de données qui contient une table contenant un index spatial dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 827315 | 2638216 | CORRECTIF : Message d’erreur lors de l’exécution d’une requête qui utilise un mot clé réservé MDX comme nom de paramètre dans SSAS 2008 R2 |
| 834640 | 2638448 | CORRECTIF : violation d’accès lorsqu’une requête est compilée ou recompilée dans SQL Server 2008 ou dans SQL Server 2008 R2 |
| 828867 | 2639301 | CORRECTIF : Message d’erreur lorsque vous examinez un rapport SSRS 2008 R2 qui a une région de données de tableau matriciel si la région contient des éléments de graphique, de jauge ou de carte |
| 831931 | 2641923 | CORRECTIF : distribution personnalisée des couleurs incorrecte lorsque vous utilisez des valeurs numériques pour les valeurs de début et de fin des compartiments de distribution de couleurs personnalisés dans SSRS 2008 R2 |
| 832040 | 2641971 | CORRECTIF : erreur « Erreur : Échec de la conversion des données » lorsque vous utilisez plusieurs caractères comme délimiteur de colonne dans le Gestionnaire des connexions de fichier plat dans SSIS 2008 R2 |
| 834705 | 2643340 | CORRECTIF : la propriété d’action ne fonctionne pas lorsque vous affichez un rapport SSRS 2008 R2 dans le Gestionnaire de rapports |
| 836483 | 2644396 | CORRECTIF : les modifications de réplication de fusion sont manquantes sur un abonné SQL Server Compact lorsqu’il s’abonne à une partition dans SQL Server 2008 R2 |
| 835438 | 2645648 | CORRECTIF : Échec de la procédure d’exportation lors de l’exportation d’un rapport SSRS 2008 R2 64 bits qui contient plusieurs niveaux de mappage de document au format PDF |
| 822171 | 2646224 | CORRECTIF : le plan de requête s’affiche en tant que document XML de manière incorrecte lorsque vous définissez l’option SHOWPLAN_XML sur ACTIVÉ dans SQL Server 2008 R2 SP1 |
| 842206 | 2647120 | CORRECTIF : Des numéros de page incorrects s’affichent lors de l’exportation d’un rapport SSRS 2008 R2 au format PDF |
| 844587 | 2648158 | CORRECTIF : message d’erreur « Le processus n’a pas pu s’exécuter » lors de la définition d’une valeur différente de zéro dans le paramètre MaxCmdsInTran de l’agent de lecture du journal dans SQL Server 2008 R2 |
| 845530 | 2649359 | CORRECTIF : Une violation d’accès se produit dans l’erreur « sqlservr ! CSbMsgDispatcher ::CSbReceivedDialog ::AppendMsg » dans SQL Server 2008 R2 |
| 836497 | 2651629 | CORRECTIF : message d’erreur lors de l’utilisation de DTA pour comparer une ou plusieurs requêtes à une base de données qui contient de nombreux objets dans SQL Server 2008 R2 |
| 834224 | 2652582 | CORRECTIF : Message d’erreur « Spécification d’autorisation non valide » lorsque vous exécutez l’Assistant Déploiement d’Analysis Services SQL Server 2008 R2 à l’aide du mode d’authentification SQL Server |
| 837758 | 2653893 | CORRECTIF : la restauration d’une base de données dans SQL Server 2008 R2 est très longue |
| 831388 | 2633151 | Le fichier du journal des transactions de la base de données SQL Server n’augmente pas de la valeur de croissance du fichier configuré |
Informations sur le package de mise à jour cumulative
Informations sur le redémarrage
Vous devrez peut-être redémarrer votre ordinateur après avoir appliqué ce package de mise à jour cumulative.
Informations sur le Registre
Pour utiliser l’un des correctifs logiciels contenus dans ce package, il n’est pas nécessaire de modifier le Registre.
Comment désinstaller ce package de mise à jour cumulative
Pour désinstaller ce package de mise à jour cumulative, procédez comme suit :
Dans le Panneau de configuration, ouvrez le
Ajouter ou supprimer des programmes
l’objet.Cliquez sur
Modifier ou supprimer des programmes.Pour afficher toutes les mises à jour de l’installation de SQL Server 2008 R2, activez la case à cocher Afficher les mises à jour de la case activée.
Trouvez et désinstallez l’entrée de ce package de mise à jour cumulative.
Références
Pour plus d’informations sur le modèle de maintenance incrémentielle pour SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft.
935897
Un modèle de service incrémentiel est disponible auprès de l’équipe SQL Server pour proposer des correctifs logiciels pour les problèmes signalés
Pour plus d’informations sur le schéma d’appellation pour les mises à jour de SQL Server, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
822499
Nouveau schéma d’appellation pour les packages de mise à jour logicielle Microsoft SQL Server
Pour plus d’informations sur la terminologie de mise à jour logicielle, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
824684
Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft