Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Symptômes

Considérez le scénario suivant :

  • Vous disposez de Microsoft Commerce Server 2007 ou Microsoft Commerce Server 2009 est installé sur un ordinateur. L’ordinateur est configuré pour utiliser un symbole autre qu’un point (.) comme séparateur décimal. Par exemple, l’ordinateur est configuré pour utiliser une virgule (,) comme séparateur décimal.

    Remarque Sur un ordinateur fonctionnant sous Windows, vous pouvez modifier le paramètre de séparateur décimal dans l’élément Options régionales et linguistiques de
    Le panneau de configuration.

  • Vous spécifiez un type décimal dans la zone de Propriété de composant affecté d’une définition de produit.

  • Dans le Gestionnaire de catalogue, vous essayez de modifier la valeur de la propriété de composant d’un produit qui est basé sur la définition de produit.

Dans ce scénario, la valeur de la propriété de composant est enregistrée correctement. Plus précisément, le séparateur décimal est supprimé lorsque la valeur de la propriété de composant est enregistrée.

Par exemple, vous utilisez une virgule (,) pour le séparateur. Puis, si vous indiquez 1,5 comme valeur de la propriété de type variant, la valeur est enregistrée sous la forme 15.

Cause

Le problème se produit car le Gestionnaire de catalogues utilise toujours « en-us » comme les paramètres régionaux lorsque le Gestionnaire de catalogues enregistre les valeurs de propriété de type variant. Étant donné que le « en-nous « paramètres régionaux utilisent un point (.) comme séparateur décimal, d’autres symboles sont supprimés lorsque la valeur est enregistrée.

Résolution

Informations sur le correctif

Un correctif pris en charge est désormais disponible auprès de Microsoft. Toutefois, il est conçu pour résoudre uniquement le problème décrit dans cet article. Il s’applique uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n’êtes pas sérieusement concerné par ce problème, nous vous recommandons d’attendre le prochain service pack qui comprendra ce correctif.

Pour résoudre ce problème immédiatement, contactez les Services de Support technique Microsoft pour obtenir le correctif. Pour obtenir une liste complète des numéros de téléphone des Services de Support technique Microsoft et des informations sur les coûts de support, visitez le site Web de Microsoft à l’adresse suivante :

http://support.microsoft.com/contactus/?ws=supportRemarque Dans des cas particuliers, des frais généralement encourus pour les appels au support technique peuvent être annulés si un technicien du support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les coûts habituels du support technique s’appliqueront aux autres questions et problèmes qui ne relèvent pas de la mise à jour spécifique en question.

Conditions préalables

Vous devez disposer de Microsoft Commerce Server 2007 Service Pack 2 (SP2) ou Microsoft Commerce Server 2009 installé pour appliquer ce correctif.

Nécessite un redémarrage

Vous n’êtes pas obligé de redémarrer l’ordinateur après avoir appliqué ce correctif.

Informations de remplacement du correctif

Ce correctif ne remplace aucun autre correctif.

Informations sur les fichiers

La version anglaise de ce correctif dispose des attributs de fichier (ou version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont répertoriées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, elles sont converties en heure locale. Pour trouver la différence entre l’UTC et l’heure locale, utilisez l’onglet fuseau horaire dans l’élément de Date et heure dans le panneau de configuration.

Commerce Server 2007

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Catalogmanager.exe

6.0.4109.18

1,906,528

23-Apr-2009

11:33

x86

Commerce Server 2009

Nom de fichier

Version de fichier

Taille du fichier

Date

Heure

Plateforme

Catalogmanager.exe

6.0.4171.2

1,769,472

14-May-2009

16:56

x86


État

Microsoft a confirmé l'existence de ce problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Dans Commerce Server, vous pouvez utiliser le catalogue Commerce Server et le Gestionnaire de schémas du stock pour gérer le schéma de base de données pour le système de catalogue. Pour plus d’informations sur le catalogue et Gestionnaire de schémas du stock, visitez le site Web de Microsoft à l’adresse suivante :

http://msdn.microsoft.com/en-us/library/ms962252.aspxPour plus d’informations sur la gestion de catalogue et de schéma d’inventaire, visitez le site Web de Microsoft à l’adresse suivante :

http://msdn.microsoft.com/en-us/library/ms915810.aspx

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×