PROBLÈME
Lorsque vous tentez de déplacer ou de transférer une boîte aux lettres de votre environnement Exchange local vers Exchange Online dans Office 365 dans le cadre d’un déploiement hybride Exchange, vous recevez un message d’erreur qui ressemble à l’une des situations suivantes :
-
Erreur (s) : l’appel à https://mail. <nom_domaine>. com/EWS/MRSProxy. svc a échoué car aucun service n’écoutait les détails d’erreur de point de terminaison spécifiés : il n’y a aucun point de terminaison à l’écoute sur https://mail. <nom_domaine>. com/EWS/MRSProxy. svc qui peut accepter le message. C’est souvent dû à une adresse ou une action SOAP incorrecte. Le serveur distant a renvoyé une erreur 404 introuvable.
-
Erreur : MigrationTransientException : l’appel à’https://mail. <nom_domaine>. com/EWS/MRSProxy. svc’a expiré. Détails de l’erreur : délai du canal de requête écoulé en attendant une réponse après 00:00:00.0020000. Augmentez la valeur de temporisation transmise à l’appel pour demander ou augmentez la valeur SendTimeout sur la liaison. Le temps maximal alloué à cette opération a pu être une portion d’un délai d’expiration plus long. --> la requête HTTP « https://mail. <nom_domaine>. com/EWS/MRSProxy. svc » a dépassé le délai imparti de 00:00:00.0020000.
-
Erreur : MigrationTransientException : échec de l’appel vers’https://mail.contoso.com/EWS/mrsproxy.svc', car aucun service n’a été en écoute sur le point de terminaison spécifié. Détails de l’erreur : il n’y a aucun point de terminaison à l’écoute sur https://mail.contoso.com/EWS/mrsproxy.svc qui peut accepter le message. C’est souvent dû à une adresse ou une action SOAP incorrecte. Pour plus d’informations, voir InnerException, le cas échéant. Le serveur distant a renvoyé une erreur : (404) introuvable. --> échec de l’appel vers’https://mail.contoso.com/EWS/mrsproxy.svc', car aucun service n’écoute sur le point de terminaison spécifié.
Toutefois, vous pouvez toujours être en mesure de déplacer d’autres boîtes aux lettres avec succès.
CAUSE
Ce problème peut se produire si la propriété ExchangeGUID de l’objet MailUser Exchange Online ne correspond pas à la propriété ExchangeGUID de la boîte aux lettres locale. Pour réussir le déplacement d’une boîte aux lettres, la valeur de la propriété ExchangeGUID dans la boîte aux lettres Exchange Online et dans la boîte aux lettres locale distante associée doit correspondre.
SOLUTION
Définissez la propriété ExchangeGUID de l’utilisateur à extension messagerie dans Exchange Online de sorte qu’elle corresponde à la propriété ExchangeGUID de la boîte aux lettres locale correspondante, puis relancez le déplacement. Pour cela, procédez comme suit :
-
Récupérez la valeur de la propriété ExchangeGUID de la boîte aux lettres locale que vous voulez déplacer. Pour cela, ouvrez Exchange Management Shell sur le serveur local, puis exécutez la commande suivante :
Get-Mailbox <MailboxName> | Format-List ExchangeGUID
Notez la valeur. Vous en aurez besoin plus tard dans l’étape 2B.
-
Connectez-vous à Exchange Online à l’aide du PowerShell à distance. Pour plus d’informations, voir se connecter à Exchange Online à l’aide de Remote PowerShell. Procédez ensuite comme suit :
-
Déterminez la valeur de la propriété ExchangeGUID de l’utilisateur à extension messagerie dans Exchange Online. Pour cela, exécutez la commande suivante :
Get-MailUser -Identity <UserName> | fl displayname,ExchangeGuid
-
Définissez la valeur de la propriété ExchangeGUID de l’utilisateur à extension messagerie dans Exchange Online pour qu’elle corresponde à la propriété ExchangeGUID de la boîte aux lettres locale. Pour cela, exécutez la commande suivante :
Set-MailUser -Identity <UserName> -ExchangeGUID <Value Retrieved From Step 1>
-
-
Relancez le déplacement.
INFORMATIONS SUPPLÉMENTAIRES
Encore besoin d’aide ? Rendez-vous sur la communauté Microsoft ou dans les Forums TechNet sur Exchange.