Se connecter avec Microsoft
S'identifier ou créer un compte.
Bonjour,
Sélectionnez un autre compte.
Vous avez plusieurs comptes
Choisissez le compte avec lequel vous voulez vous connecter.

Résumé

Cet article décrit un problème dans lequel vous ne peut pas trouver les fichiers lorsque vous recherchez un ordinateur Windows Vista, même si les fichiers existent sur l’ordinateur. Cet article répertorie les méthodes que vous pouvez utiliser pour résoudre ce problème lorsque vous recherchez n’importe quel emplacement et lorsque vous recherchez dans l’index.

Pour obtenir l’aide sur des problèmes de recherche de Windows dans Windows Vista et suivez les étapes de cet Assistant automatiquement, cliquez sur Exécuter maintenant le bouton de la page des Services automatisés de résolution des problèmes :

Résoudre les problèmes dans lesquels Windows Search ne fonctionne pas ou les recherches sont plus lentes

Symptômes

Vous rencontrez des problèmes lorsque vous essayez de rechercher des fichiers sur un ordinateur qui exécute Windows Vista. Par exemple, lorsque vous recherchez des fichiers à l’aide d’un terme de recherche, vous ne peut pas trouver les fichiers que vous vouliez rechercher. Les éléments n’apparaissent pas dans les résultats de recherche. Vous rencontrez ce problème même si les fichiers existent sur l’ordinateur.

Cause

Ce problème peut se produire dans un des scénarios suivants.

  • Lorsque vous recherchez n’importe quel emplacement, vous rencontrez les problèmes décrits dans la section « Symptômes » si l’une des conditions suivantes est remplie :

    • Le fichier n’est pas à l’emplacement que vous recherchez

    • Le fichier se trouve dans un dossier système.

    • Le fichier est un fichier caché.

    • Le fichier n’apparaît pas dans les premier de cinq mille éléments répertoriés dans les résultats de recherche

    • Le fichier contient le terme de recherche dans une de ses propriétés et pas le nom de fichier

  • Lorsque vous recherchez dans l’index, vous rencontrez les problèmes décrits dans la section « Symptômes » si l’une des conditions suivantes est remplie :

    • Le fichier n’est pas dans un emplacement indexé.

    • Le type de fichier du fichier n’est pas indexé.

    • Le fichier possède des propriétés qui empêchent son en cours d’indexation.

    • L’indexeur n’a pas encore inséré le fichier dans l’index.

    • L’indexeur est surplombant le fichier.

    • Les éléments dans les résultats de recherche ne correspondent pas le fichier que vous recherchez.

Windows Vista inclut de nouvelles méthodes qui permettent une recherche rapide de fichiers. Toutefois, ces nouvelles méthodes peuvent ne les connaissent pas et provoquer une certaine confusion pour les utilisateurs qui ne sont pas familiarisés avec eux.

Résolution

Pour résoudre ce problème, utilisez une ou plusieurs des méthodes suivantes, en fonction de votre situation.

Lorsque vous recherchez n’importe quel endroit

Cette section répertorie les méthodes que vous pouvez utiliser pour vous aider à résoudre ce problème lorsque vous recherchez n’importe quel emplacement d’un fichier. Chaque méthode correspond à un élément qui est répertorié dans la section « Cause ».

Cause 1 : Le fichier n’est pas à l’emplacement que vous recherchez

Assurez-vous que le fichier que vous souhaitez rechercher est dans la portée de l’emplacement que vous recherchez. Pour déterminer l’emplacement de votre recherche, procédez comme suit :

  1. Sous avez-vous trouvé ce que vous recherchiez ? au bas de la fenêtre de résultats de recherche, cliquez sur Recherche avancée.

  2. Dans la zone de Recherche avancée , notez l’emplacement que vous recherchez.

L’emplacement que vous recherchez doit contenir le fichier que vous recherchez.

Rechercher partout sur l’ordinateur

Pour rechercher partout sur l’ordinateur, cliquez sur partout dans la zone emplacement , puis cliquez sur pour sélectionner la case à cocher inclure non indexés, masqué et les fichiers système (plus lent) .

Rechercher uniquement les emplacements indexés

Pour rechercher uniquement les emplacements indexés, cliquez sur Emplacements indexés dans la zone emplacement .

Cause 2 : Le fichier se trouve dans un dossier système

Par défaut, lorsque vous essayez de trouver un fichier qui se trouve sur votre ordinateur, Windows Vista ne recherche pas les dossiers système. Dossiers système incluent le dossier Program Files et le dossier Windows. Pour rechercher un dossier système, utilisez une des méthodes suivantes.

Méthode 1

Effectuer une recherche dans le dossier système qui contient le fichier. Par exemple, si vous recherchez le fichier Shell32.dll , ne pas rechercher à l’aide de l’option partout . Au lieu de cela, recherchez le lecteur: dossier \Windows et recherchez le fichier Shell32.dll .

Méthode 2

Cliquez sur Organiser, puis cliquez sur Options de recherche et de dossier. Dans la boîte de dialogue Options des dossiers , cliquez sur l’onglet Rechercher , puis sous lors de la recherche des emplacements non indexés, activez la case à cocher inclure les répertoires de système .

Méthode 3

Dans la zone de Recherche avancée , cliquez pour sélectionner la case à cocher inclure non indexés, masqué et les fichiers système (plus lent) .

Cause 3 : Le fichier est un fichier caché

Pour afficher les fichiers cachés dans les résultats de la recherche, utilisez une des méthodes suivantes.

Méthode 1

Cliquez sur Organiser, puis cliquez sur Options de recherche et de dossier. Dans la boîte de dialogue Options des dossiers , cliquez sur l’onglet affichage , puis, sous fichiers et dossiers cachés, cliquez sur Afficher les fichiers et dossiers cachés.

Méthode 2

Dans la zone de Recherche avancée , cliquez pour sélectionner la case à cocher inclure non indexés, masqué et les fichiers système (plus lent) .

Cause 4 : Le fichier n’apparaît pas dans les premier de cinq mille éléments répertoriés dans les résultats de recherche

Si Windows Vista détecte plus de cinq mille résultats de la recherche, le message d’erreur suivant s’affiche :

Il y a des résultats qui n'apparaissent pas dans cette vue. Affiner les résultats de la zone de recherche, ou cliquez sur pour afficher tous les résultats...Vous pouvez afficher tous les résultats de la recherche. Pour ce faire, cliquez sur le message. Ou bien, vous pouvez réduire le nombre d’éléments qui apparaissent dans les résultats de recherche. Pour ce faire, ajoutez plusieurs termes de recherche. Par exemple, ajoutez le type de fichier comme un terme de recherche. Pour utiliser des méthodes plus évoluées pour filtrer les résultats de la recherche, utilisez les options qui sont disponibles dans la zone de Recherche avancée .

Cause 5 : Le fichier contient le terme de recherche dans une de ses propriétés et pas le nom de fichier

Lorsque vous tapez un terme dans la zone de recherche , Windows Vista recherche toujours les noms de fichiers. Si le fichier se trouve dans l’index, Windows Vista recherche également dans les propriétés du fichier. Propriétés de fichier comprennent le type de fichier, l’auteur, le contenu tel que des mots et des expressions dans le fichier et les commentaires qui ont été ajoutés aux images. Pour rechercher du contenu dans un fichier si le fichier n’est pas dans l’index, utilisez une des méthodes suivantes.

Méthode 1

Cliquez sur Organiser, puis cliquez sur Options de recherche et de dossier. Dans la boîte de dialogue Options des dossiers , cliquez sur l’onglet Rechercher , puis cliquez sur pour sélectionner la case à cocher toujours rechercher les noms de fichiers et de contenu (plus lent) .

Méthode 2

Si vous recherchez un emplacement qui n’est pas dans l’index, sous avez-vous trouvé ce que vous recherchiez ? au bas de la fenêtre de résultats de recherche, cliquez sur Rechercher dans le contenu du fichier.

Lorsque vous recherchez dans l’index

Cette section répertorie les méthodes que vous pouvez utiliser pour vous aider à résoudre ce problème lorsque vous recherchez l’index d’un fichier. Chaque méthode correspond à un élément qui est répertorié dans la section « Cause ».

Cause 1 : Le fichier n’est pas dans un emplacement indexé

Si vous cliquez sur Emplacements indexés pour rechercher les emplacements indexés, l’emplacement de l’élément que vous recherchez doit figurer dans l’index. Pour déterminer si les fichiers et les dossiers que vous prévoyez d’apparaître dans les résultats de recherche sont situés dans l’index, procédez comme suit :

  1. Cliquez sur Démarrer Start button et cliquez sur Panneau de configuration, puis cliquez sur système et Maintenance.

  2. Cliquez sur les Options d’indexation. Les dossiers sont indexés sont répertoriés sous Des emplacements inclus dans la boîte de dialogue Options d’indexation .

  3. Pour afficher le chemin d’accès des dossiers qui se trouvent dans l’index, cliquez sur Modifier et puis cliquez sur Afficher tous les emplacements. Sous Résumé des emplacements sélectionnés, cliquez sur l’élément que vous souhaitez afficher.

Pour ajouter un emplacement pour l’index, utilisez une des procédures suivantes :

  • Utilisez les options de la boîte de dialogue Options d’indexation à ajouter, à supprimer ou à exclure des emplacements de l’index.

  • Dans les scénarios où vous recherchez un emplacement qui n’est pas dans l’index, le message suivant s’affiche :

    Les recherches peuvent être lentes dans les emplacements non indexés : emplacement. Cliquez pour ajouter à l’index...Pour ajouter cet emplacement à l’index, cliquez sur le message.

Vous pouvez uniquement ajouter des emplacements sur l’ordinateur local à l’index. Si vous recherchez un ordinateur sur le réseau qui exécute Windows Vista, les emplacements indexés qui sont configurés sur l’ordinateur Windows Vista à distance sont utilisés dans la recherche.

Vous pouvez ajouter un dossier à partir d’un ordinateur sur le réseau qui n’exécute pas Windows Vista pour l’index. Avant d’ajouter le dossier à l’index, vous devez utiliser la boîte de dialogue Propriétés de NomDossier pour rendre le dossier disponible hors connexion sur l’ordinateur distant.

Cause 2 : Le type de fichier du fichier n’est pas indexé.

Certains types de fichiers ne sont pas inclus dans l’index. Pour afficher les types de fichiers qui sont inclus dans l’index, procédez comme suit :

  1. Cliquez sur Démarrer Start button et cliquez sur Panneau de configuration, puis cliquez sur système et Maintenance.

  2. Cliquez sur les Options d’indexation, puis cliquez sur Avancé.

     User Account Control permission  Si vous êtes invité à entrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe ou cliquez sur Continuer.

  3. Cliquez sur l’onglet Types de fichiers et affichez la liste des types de fichiers. Si la case à cocher en regard de l’extension de nom de fichier, le type de fichier est inclus dans l’index. Si la case à cocher en regard de l’extension de nom de fichier n’est pas activée, le type de fichier n’est pas inclus dans l’index.

Remarque Vous pouvez également configurer si vous souhaitez n'indexer que les propriétés des types de fichiers spécifiques ou si vous voulez indexer les propriétés et le contenu des types de fichiers spécifiques. Pour indexer dans les propriétés d’un type de fichier, cliquez sur Propriétés de l’Index uniquement. Pour indexer les propriétés et le contenu d’un type de fichier spécifique, cliquez sur indexer les propriétés et le contenu du fichier.

Cause 3 : Le fichier possède des propriétés qui empêchent son en cours d’indexation

Les fichiers peuvent avoir des propriétés qui empêchent que les fichiers en cours d’indexation. Un fichier n’est pas ajouté à l’index si l’une des conditions suivantes est remplie :

  • La case à cocher Index ce fichier pour la recherche rapide n’est pas sélectionnée. (Pour trouver cette case à cocher, cliquez sur le fichier et cliquez sur Propriétés, puis cliquez sur Avancé.)

  • Le fichier est configuré pour utiliser l’attribut masqué et l’attribut système. Très peu de fichiers utilisent ces attributs. Le fichier Desktop.ini est un exemple d’un fichier qui utilise les deux attributs.

Pour trouver ces fichiers, utilisez une des méthodes suivantes.

Méthode 1

Supprimer les propriétés ou les attributs qui empêchent que le fichier en cours d’indexation.

Méthode 2

Dans la zone de Recherche avancée , cliquez pour sélectionner la case à cocher inclure non indexés, masqué et les fichiers système (plus lent) .

Méthode 3

Cliquez sur Organiser, puis cliquez sur Options de recherche et de dossier. Dans la boîte de dialogue Options des dossiers , cliquez sur l’onglet de recherche et puis sous la recherche, activez la case à cocher ne pas utiliser l’Index lors de la recherche du système de fichiers (plus lent) .

Cause 4 : L’indexeur n'a pas encore inséré le fichier dans l’index

Les fichiers ne sont pas immédiatement insérées dans l’index par l’indexeur. Lorsqu’il n’existe aucune activité de l’utilisateur, l’indexeur utilise des ressources pour le traitement de la file d’attente des fichiers qui n’ont pas encore été indexés. Par exemple, vous ouvrez la boîte de dialogue Options d’indexation , et que vous n’utilisez pas la souris ou le clavier pendant 45 secondes. Dans la boîte de dialogue Options d’indexation , vous verrez que l’indexeur augmente la vitesse d’indexation pour indexer les éléments. La boîte de dialogue Options d’indexation indique également si l’indexation est terminée. Dans les scénarios où vous ajoutez beaucoup de nouveaux fichiers sur l’ordinateur, assurez-vous que l’indexation est terminée.

Cause 5 : L’indexeur est surplombant le fichier

Si vous pensez qu’il existe un problème dans lequel l’indexeur ne contient-elle pas un ou plusieurs fichiers qu’elle doit contenir, reconstruisez l’index. Afin que nous puissions reconstruire l’index pour vous, consultez la section «Aidez-moi». Si vous préférez la reconstruction de l’index, consultez la section «Je résous le problème moi-même».

Aidez-moi



Pour reconstruire l’index automatiquement, cliquez sur le
Lien de résoudre ce problème. Cliquez sur
Exécuterdans le
Boîte de dialogue Téléchargement de fichier dezone, puis suivez les étapes décrites dans le correctif il Assistant.




Remarque Cet Assistant peut exister en anglais uniquement. Toutefois, la résolution automatique fonctionne aussi pour d'autres versions linguistiques de Windows.

Remarque Si vous n'êtes pas sur l'ordinateur qui rencontre le problème, vous pouvez enregistrer la résolution automatique sur un lecteur flash ou sur un CD-ROM afin de pouvoir l'exécuter sur l'ordinateur qui rencontre le problème.


Merci à MVP Anand Khanse pour sa contribution à cette solution de réparation.

Ensuite, passez à le «le problème est-il résolu ?» section.



Je résous le problème moi-même



Pour reconstruire l’index, procédez comme suit :

  1. Cliquez sur Démarrer Start button et cliquez sur Panneau de configuration, puis cliquez sur système et Maintenance.

  2. Cliquez sur les Options d’indexation, puis cliquez sur Avancé.

     User Account Control permission  Si vous êtes invité à entrer un mot de passe administrateur ou une confirmation, tapez votre mot de passe ou cliquez sur Continuer.

  3. Cliquez sur Reconstruire. Lorsque vous êtes invité à confirmer que vous souhaitez reconstruire l’index, cliquez sur OK.

  4. Une fois la reconstruction terminée, redémarrez votre ordinateur.

Reconstruction d’un index peut prendre un certain temps pour terminer. Au cours de l’opération de reconstruction, l’indexeur essaie réinsérez tous les éléments dans l’index.

Le problème est-il résolu ?

Vérifiez si le problème est résolu. Si le problème est résolu, vous avez terminé avec cette section. Si le problème n’est pas résolu, vous pouvez contacter le support technique.

Cause 6 : Les éléments dans les résultats de recherche ne correspondent pas le fichier que vous recherchez

Lorsque vous utilisez la zone Rechercher pour rechercher l’index, la recherche inclut les propriétés telles que l’auteur, artiste, balises et le contenu du fichier. Utilisez la zone de Recherche avancée pour spécifier ce que vous recherchez.

Pour plus d’informations sur la façon de rechercher des fichiers à l’aide de la syntaxe de requête avancée, consultez l’aide de Windows Vista.

Besoin d’aide ?

Vous voulez plus d’options ?

Explorez les avantages de l’abonnement, parcourez les cours de formation, découvrez comment sécuriser votre appareil, etc.

Les communautés vous permettent de poser des questions et d'y répondre, de donner vos commentaires et de bénéficier de l'avis d'experts aux connaissances approfondies.

Ces informations vous ont-elles été utiles ?

Dans quelle mesure êtes-vous satisfait(e) de la qualité de la langue ?
Qu’est-ce qui a affecté votre expérience ?
En cliquant sur Envoyer, vos commentaires seront utilisés pour améliorer les produits et services de Microsoft. Votre administrateur informatique sera en mesure de collecter ces données. Déclaration de confidentialité.

Nous vous remercions de vos commentaires.

×