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Symptômes

Si vous utilisez un ordinateur client qui exécute Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows 98 Second Edition pour effectuer une impression sur une imprimante réseau installée en tant que composant d’un cluster Microsoft ou d’un serveur autonome, le message d’erreur suivant peut apparaître :

La page de test ne s’imprime pas. Voulez-vous voir le problème d’impression pour obtenir de l’aide ? Accès refusé.

Cause

Ce problème peut se produire si le logiciel de vérification antivirus McAfee est configuré pour effectuer une analyse en temps réel des fichiers sur le client exécutant Windows 95, Windows 98 ou Windows 98 Second Edition ou sur le serveur exécutant Windows NT Server 4,0. McAfee Anti-virus analyse les fichiers mis en file d’attente lors du traitement de l’impression. Windows ne peut pas fermer les fichiers, car ils sont ouverts par McAfee Anti-virus. Ces fichiers sont conservés dans le dossier systemroot\System32\Spool\Printers. Les fichiers. SHD et. SPL sont conservés dans le dossier une fois le travail d’impression terminé.

Résolution

Pour résoudre ce problème, utilisez l’une des méthodes décrites dans cette section.

Le message d’erreur s’affiche sur le serveur d’impression

Si vous recevez le message d’erreur sur le serveur d’impression exécutant Windows NT Server 4,0 :

  1. Supprimez les fichiers endommagés dans le dossier spool :

    1. Cliquez sur Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur services, sélectionnez Spooler, puis cliquez sur Stop.

    3. Lorsque le message suivant s'affiche, cliquez sur Oui :

      Êtes-vous sûr de vouloir arrêter le service de spouleur ?

    4. Cliquez sur Démarrer, pointez sur programmes, puis cliquez sur Explorateur Windows NT.

    5. Développez le dossier winnt , développez le dossier system32 , puis développez le dossier spool .

    6. Cliquez sur le dossier imprimantes , cliquez sur tous les fichiers répertoriés dans le volet droit, puis cliquez sur supprimer.

    7. Lorsque le message suivant s'affiche, cliquez sur Oui :

      Êtes-vous sûr de vouloir envoyer ces x éléments dans la corbeille ?

    8. Répétez les étapes A et B pour redémarrer le service de spouleur, puis cliquez sur Démarrer.

  2. Configurer l’imprimante qui rencontre le problème pour lancer l’impression après le spoulage de la dernière page :

    1. Cliquez sur Démarrer, pointez sur paramètres, puis cliquez sur imprimantes.

    2. Cliquez avec le bouton droit sur l’imprimante qui rencontre le problème, puis cliquez sur Propriétés.

    3. Cliquez sur l’onglet planification , puis sur Spouler l’impression pour que le programme finisse l’impression.

    4. Cliquez sur Démarrer l’impression après la dernière page est spoulée, puis cliquez sur OK.

  3. Configurez l’imprimante dont le problème est lié à l’impression directe sur l’imprimante :

    1. Cliquez sur Démarrer, pointez sur paramètres, puis cliquez sur imprimantes.

    2. Cliquez avec le bouton droit sur l’imprimante qui rencontre le problème, puis cliquez sur Propriétés.

    3. Cliquez sur l’onglet planification , sur imprimer directement sur l’imprimante, puis sur OK.

  4. Mettez à niveau le programme antivirus McAfee vers la version 4,5 ou une version ultérieure.

  5. Vérifiez que le dossier Spool dispose des autorisations appropriées.Pour plus d’informations sur les autorisations appropriées pour le dossier Spool, cliquez sur le numéro ci-dessous pour consulter l’article de la base de connaissances Microsoft :

    137503 Répertoire de spoule Windows et autorisations par défaut

Vous recevez le message d’erreur sur le client

Si vous recevez le message d’erreur sur le client exécutant Windows 95, Windows 98 ou Windows 98 Deuxième édition :

  1. Supprimez les fichiers endommagés dans le dossier spool :

    1. Cliquez sur Démarrer, pointez sur Programmes, puis cliquez sur l’Explorateur Windows.

    2. Développez le dossier Windows , développez le dossier spool , puis cliquez sur le dossier imprimantes .

    3. Cliquez sur tous les fichiers répertoriés dans le volet droit, puis cliquez sur supprimer.

    4. Lorsque le message suivant s'affiche, cliquez sur Oui :

      Êtes-vous sûr de vouloir envoyer ces x éléments dans la corbeille ?

  2. Configurer l’imprimante qui rencontre le problème pour lancer l’impression après le spouleur de la dernière page :

    1. Cliquez sur Démarrer, pointez sur paramètres, puis cliquez sur imprimantes.

    2. Cliquez avec le bouton droit sur l’imprimante qui rencontre le problème, puis cliquez sur Propriétés.

    3. Cliquez sur l’onglet Détails , sur paramètres du spouleur, puis sur Spouler l’impression pour terminer l’impression.

    4. Cliquez sur Démarrer l’impression après la dernière page est spoulée, puis cliquez sur OK.

  3. Configurez l’imprimante dont le problème est lié à l’impression directe sur l’imprimante :

    1. Cliquez sur Démarrer, pointez sur paramètres, puis cliquez sur imprimantes.

    2. Cliquez avec le bouton droit sur l’imprimante qui rencontre le problème, puis cliquez sur Propriétés.

    3. Cliquez sur l’onglet Détails , sur paramètres du spouleur, sur imprimer directement sur l’imprimante, puis sur OK.

  4. Mettez à niveau le programme antivirus McAfee vers la version 4,5 ou une version ultérieure.

Informations supplémentaires

Si vous utilisez un programme de débogage pour déboguer le service de spouleur, les données suivantes peuvent être enregistrées dans le journal de débogage :

LSPL : SplGetPrinter échec ERROR_INSUFFICIENT_BUFFER de l'; cbBuf est égal à 0 et pcbNeeded est 78.

Références

Pour plus d’informations sur les problèmes d’impression liés, cliquez sur les numéros ci-dessous pour consulter les Articles de la base de connaissances Microsoft :

180892 Message d’erreur : erreur d’écriture sur LPT1 : accès refusé

142370 L’impression sur une imprimante HP LaserJet génère une requête d’événement 2004

179156 Options d’impression TCP/IP mises à jour pour Windows NT 4,0 SP3 et version ultérieure

188878 L’impression sur le port local risque d’échouer avec l’erreur Accès refuséLes produits tiers mentionnés dans cet article sont développés par des sociétés indépendantes de Microsoft. Microsoft ne fournit aucune garantie, implicite ou autre, relative aux performances et à la fiabilité de ces produits.

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